Jump to content
dazhbog

BattlEye service implementation

Recommended Posts

Hello,

we have released a major upgrade of our BattlEye integration in a dev branch today. This new version of BattlEye uses a windows service that is started before the game and provides additional security. The service is started and stopped automatically and it's also shared among all our games that support it (currently Arma 3, Operation Arrowhead and DayZ) so the impact on your systems should be minimal.

If you want to use BattlEye in an Arma 3 client (there's no change for servers) you have basically three options:

Use Arma 3 Launcher

  • Start the launcher, enable BattlEye in the options and start the game

-or-


  • If you're using a -noLauncher parameter to skip the Arma 3 Launcher in the game Launch Options, in a shortcut or an URL, you can also add a -useBE parameter.

arma3launcher.exe -noLauncher -useBE <params>

steam://rungameid/107410// -noLauncher -useBE

Let Arma 3 start BE

  • You can simply start the game and join a BE enabled server
  • Arma 3 will show a dialog requesting a game restart
  • If you will confirm it the game will be restarted with BattlEye enabled (restart is required in order to start the BattlEye service)

Manual start of BattlEye

  • Start the game by running the BattlEye launcher directly
    arma3battleye.exe 2 1 <params>


  • The first parameter - 2 means BE should check for updates and then run the game
  • <params> stands for command line parameters that are forwarded to the game

Please use this thread to share your feedback and report any issues you may have to our feedback tracker. Thanks!

EDIT: A3 launcher option extended with the -useBE parameter

EDIT: The first parameter for arma3battleye.exe changed from 0 to 2

Edited by dazhbog

Share this post


Link to post
Share on other sites

Great so you cannot start the game and join a BE enabled server without restarting the game, using the (not liked) launcher or manually starting BE?

Why doesn't this BE service automaticly start when the game is started? This seems like a step back for people who use self created launchers.

Share this post


Link to post
Share on other sites
Great so you cannot start the game and join a BE enabled server without restarting the game, using the (not liked) launcher or manually starting BE?

Why doesn't this BE service automaticly start when the game is started? This seems like a step back for people who use self created launchers.

Actually I think all you need to do is just change the what file the launcher executes (from arma3.exe) to (arma3battleye.exe)

Share this post


Link to post
Share on other sites
Actually I think all you need to do is just change the what file the launcher executes (from arma3.exe) to (arma3battleye.exe)

I was so blinded with dissapointment that a totally missed the last option. But why add the 0 and 1 in the start up line?

Share this post


Link to post
Share on other sites

I'm wondering if it's safe to use Reshade (a post-processing injector) after this BE update? Will it get detected as an hack and get me banned?

Share this post


Link to post
Share on other sites
Actually I think all you need to do is just change the what file the launcher executes (from arma3.exe) to (arma3battleye.exe)

I do not believe all launchers let you control this, since it's been executing arma3.exe since alpha.?

Share this post


Link to post
Share on other sites
Actually I think all you need to do is just change the what file the launcher executes (from arma3.exe) to (arma3battleye.exe)

That doesn't seem to work with Arma 3 Sync, at least not for me.

Would it be possible to create a new startup parameter ?

enableBattleeye = 1

Something along these lines?

Share this post


Link to post
Share on other sites

Would it be possible to create a new startup parameter ?

enableBattleeye = 1

Something along these lines?

Yes:

* we will provide a parameter to start Arma 3 with battlEye enabled when -noLauncher is present. Expect -useBE to be out soon. User will need to agree to BattlEye license to be able to continue. Relevant only for Arma 3 Launcher. Example: -nolauncher -useBE will result in Arma 3 starting with BE enabled.

http://feedback.arma3.com/view.php?id=23435#c90099

Share this post


Link to post
Share on other sites
Dorph;2915399']-useBE - arghh my shortcuts targetline runs out of characters

Use .BAT files instead of shortcuts.

Share this post


Link to post
Share on other sites

launch by arma3battleye.exe dont request battleye license !! and dont launch a3 exe.... client must run arma3launcher 1 time before launch by arma3battleye... boring

Share this post


Link to post
Share on other sites

I use Play with Six, and Arma 3 Sync launcher !

What hell !! who is that which had this brilliant idea to launch 2 times the game? :mad:

why not make the opposite rather : ask to restart game without BE when you join a server without BE activated :j:

Then like this, it is those which would have something to be reproached which would be quiet: the world with back :j:

Share this post


Link to post
Share on other sites

I was able to get Arma 3 to launch using ArmaSync (no Battleye prompt for restart) without issues with Battleye with the following settings:

launcher.jpg

I hope this helps someone.

Edited by 2old2bagamer

Share this post


Link to post
Share on other sites
I was able to get Arma 3 to launch using ArmaSync (no Battleye prompt for restart) without issues with Battleye with the following settings:

I hope this helps someone.

Thanks for sharing this screenshot with the community!

Share this post


Link to post
Share on other sites

The game doesn't start with arma3battleye.exe.

Tried:

1. arma3battleye.exe 0 1 -window

2. join BE enabled server and restart the game

3. run game through the BIS Launcher (arma3launcher.exe)

nothing works

arma3battleye.exe just appears in the Task Manager process list and disappears instantly with no error message displayed.

Windows 7 x64 SP1

It's not possible to play BE protected servers now. Also I e-mailed Bastian about Color Clutch injector issue and he didn't respond me few months ago. It looks like the new BE launcher is in pre pre alpha stage.

Edited by Prodavec

Share this post


Link to post
Share on other sites

We found that you have to load the game at least once via the vanilla Launcher for it to work. In one case, one of our players even had to connect to a public server once for this method to work.

Share this post


Link to post
Share on other sites

Your launcher poor, bring it to mind, I used to run the game in one click. ONE CLICK

Share this post


Link to post
Share on other sites

arma3battleye.exe just appears in the Task Manager process list and disappears instantly with no error message displayed.

Windows 7 x64 SP1

It's not possible to play BE protected servers now. Also I e-mailed Bastian about Color Clutch injector issue and he didn't respond me few months ago. It looks like the new BE launcher is in pre pre alpha stage.

Pro,

Try this, for clues to why the battleeye exe is not starting properly, maybe us in the community can figure this out:

Winkey + R (brings up "Run" box)

Type in:

compmgmt.msc (hit enter)

On the left hand panel, expand the following:

Event Viewer, then Windows Logs.

Single-click on the "Application" section, and scroll through there slowly, looking for anything named Arma3Battleye.exe

If you find something, paste it here. Just highlight the text, hit CTRL + C, then paste it in a reply on this thread with CTRL + V.

I know this isn't the optimal solution, but while we wait for an official fix, it doesn't hurt to work together to come up with a workaround.

Share this post


Link to post
Share on other sites
We found that you have to load the game at least once via the vanilla Launcher for it to work. In one case, one of our players even had to connect to a public server once for this method to work.

You don't have to use vanilla Launcher, not even once. If the vanilla Launcher have 'Use BattlEye' enabled, it will simply execute "arma3battleye.exe 0 1 <params>" insted of "arma3.exe <params>" when you click on the PLAY button, exactly the same way as if you run the BattlEye manually.

Share this post


Link to post
Share on other sites

I forget about Event Log :). Well. I've just checked the log and didn't find anything related to BE (using CTRL+F). There are few notifications related to other products/applications but not BattlEye / Arma.

I have cleared logs (Application, Security, Setup, System, Forwarded Events), restarted PC, tried to run A3 few times using BE launcher and checked the windows logs again - nothing.

F:\Games\Steam\SteamApps\common\Arma 3>arma3battleye.exe

F:\Games\Steam\SteamApps\common\Arma 3>

F:\Games\Steam\SteamApps\common\Arma 3>arma3battleye.exe 0 1

F:\Games\Steam\SteamApps\common\Arma 3>

F:\Games\Steam\SteamApps\common\Arma 3>arma3battleye.exe 1
:)IMPORTANT: Please launch game via Steam or command line "arma3battleye.exe 0 1 [parameters]" from now on.
F:\Games\Steam\SteamApps\common\Arma 3>

I have suspended arma3battleye.exe by Process Explorer and found Current directory: C:\Windows\. Is it ok?

Edited by Prodavec

Share this post


Link to post
Share on other sites
Actually I think all you need to do is just change the what file the launcher executes (from arma3.exe) to (arma3battleye.exe)

Ëny body knows if this is poseble with pw6

Share this post


Link to post
Share on other sites

Starting the game and connecting to a server takes really long for me. I'm currently starting the arma3battleeye.exe with the startup parameter 0 1.

Has anyone else got this issue?

Share this post


Link to post
Share on other sites
I forget about Event Log :). Well. I've just checked the log and didn't find anything related to BE (using CTRL+F). There are few notifications related to other products/applications but not BattlEye / Arma.

I have cleared logs (Application, Security, Setup, System, Forwarded Events), restarted PC, tried to run A3 few times using BE launcher and checked the windows logs again - nothing.

F:\Games\Steam\SteamApps\common\Arma 3>arma3battleye.exe

F:\Games\Steam\SteamApps\common\Arma 3>

F:\Games\Steam\SteamApps\common\Arma 3>arma3battleye.exe 0 1

F:\Games\Steam\SteamApps\common\Arma 3>

F:\Games\Steam\SteamApps\common\Arma 3>arma3battleye.exe 1
:)IMPORTANT: Please launch game via Steam or command line "arma3battleye.exe 0 1 [parameters]" from now on.
F:\Games\Steam\SteamApps\common\Arma 3>

I have suspended arma3battleye.exe by Process Explorer and found Current directory: C:\Windows\. Is it ok?

Hmm.. I hate when programs are not coded to write errors into the event viewer logs. :|

I'm running out of ideas, but I have two:

First one, I see you're launching arma3battleye.exe from a command prompt (or a batch file maybe?)

Have you tried first opening a command prompt by using "Run as administrator" ? Or if you're using a batch file, right-click and run as administrator? You might have tried that already but I figured it's worth asking.

The other thing I would try (and this is probably way out on a limb) but try turning off "DEP" or data execution prevention on arma3battleye.exe ? If you don't know how, there's plenty of walkthroughs on google..

I hope it helps!

---------- Post added at 23:01 ---------- Previous post was at 22:30 ----------

maybe one more idea? (a dangerous one but possibly worth checking):

(this is not the dangerous part) First, do a verify cache on arma 3 in steam (right click on arma 3 in steam, go to properties, then go to the local files tab and hit verify integrity of game cache)

(this is the dangerous part) Since you're running arma on your F: drive and not your C: drive, check to make sure your paths are correct in the registry. A quick search showed me that there are Arma 3 paths in the registry. Maybe the last update messed up your paths or something? Check the keys under this one (this is on my 64 bit system)

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\bohemia interactive\arma 3 (there's a DWORD value in there that has the arma 3 path in it, make sure it's right)

Also, search for this string and make sure they're right (it appears in more than one place) :

"C:\Program Files (x86)\Steam\steam.exe" "%1"

Back up your registry first, and don't mess with this stuff if there's a chance you might break it! Remember the changes you made in case you have to revert back. :)

Do you have steam installed on your F: drive too?

It's just a suggestion, but like I said be really careful. If you break something, I can't be held liable!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×