Jump to content
Sign in to follow this  
thenobleone

Headless Client crashing every 20 minutes

Recommended Posts

Hello,

I host two Arma 2 CO Warfare CTI (Benny Edition) servers that use Headless Clients. I noticed a few days ago that both headless clients on both servers started crashing after about 20 minutes after they were started.

I did not change any settings, they just started crashing on their own. Over the last few days I spent many hours trying to fix this. I tried various start-up parameters as well as different other settings.

I even went as far reinstalling everything from scratch on three different version of Windows operating system and every time with same result, crash after about 20 minutes.

Also I do not believe that the problem is caused by faulty hardware, I have tried running the headless clients on three different physical computers with same result.

Windows error message after the crash:

ArmA2OA.exe - Application Error

The instruction at 0x130b6ef8 referenced memory at 0xffffffff.

The memory could not be read.

Click on OK to terminate the program

From ArmA2OA.RPT:

Mods: Expansion

Distribution: 0

Version 1.63.125548

Fault address: 130B6EF8 BE3400:0000000C Unknown module

file: ofpswarfare (__CUR_MP)

world: takistan

Prev. code bytes: 75 49 8B 90 92 A3 35 00 8B 02 8B 88 80 18 00 00

Fault code bytes: 8B 11 8B 72 44 8B BD A8 FE FF FF 8D 85 AC FE FF

Registers:

EAX:0EDC0D00 EBX:00000000

ECX:FFFFFFFF EDX:00DA0564

ESI:00000000 EDI:769F3E93

CS:EIP:0023:130B6EF8

SS:ESP:002B:13A8CFE8 EBP:13A8EF30

DS:002B ES:002B FS:0053 GS:002B

Flags:00010246

=======================================================

note: Minidump has been generated into the file Warfare\ArmA2OA.mdmp

Client: Network message d2aa (update info 1b3a4110) is pending

Client: Network message d2aa (update info 1b3a4168) is pending

Client: Network message d2aa (update info 1b3a4218) is pending

Client: Network message d2aa (update info 1b3a44d8) is pending

Client: Network message d2aa (update info 1b3a4530) is pending

Client: Network message d2ab (update info 1b3a4230) is pending

Hope someone out there knows how to fix this. Thanks.

Share this post


Link to post
Share on other sites

I have exactly the same problem. The crashes started out of nothing at around 10 p.m. CET / 10th March.

I noticed there was an Arma 2 OA update on queue in steam, but after installing it, the HC keept crashing.

Like thenobleone I tried several things:

- Rolled back our serverfiles

- Reinstalled Arma 2 / 2 OA for the HC

- Disabled the HC scripts and let him connect as a regular player

- Outsorced the HC to my local pc

- Created VMs with different OS ( Win 7 / 2008) and fresh HC installations

- Created a fresh, vanilla DayZ server and let the freshly installed HC connect

- tried different mallocs for the HC

All of it with no positive results - the HC keeps crashing, so it more or less leaves me with the thought that the dedicated client has to be faulty.

Mods: @DayZ_Epoch

Distribution: 0

Version 1.63.125548

Fault address: 129BCDB8 BE3400:0000000C Unknown module

file: DE_1000_B (__CUR_MP)

world: Chernarus

Prev. code bytes: 75 49 8B 90 92 A3 35 00 8B 02 8B 88 80 18 00 00

Fault code bytes: 8B 11 8B 72 44 8B BD A8 FE FF FF 8D 85 AC FE FF

Registers:

EAX:0FB35900 EBX:00000000

ECX:FFFFFFFF EDX:00DA0564

ESI:00000000 EDI:76519C76

CS:EIP:001B:129BCDB8

SS:ESP:0023:13D9CFE8 EBP:13D9EF30

DS:0023 ES:0023 FS:003B GS:0000

Flags:00010246

Share this post


Link to post
Share on other sites

Here's what I found after looking into the mini dump that Arma2 created, it may be an issue with the BEClient.dll

BI seriously guys this is a big bug, can you please look into it for us, it's not hard to recreate!

---------------------------------------------------------------

Microsoft ® Windows Debugger Version 6.3.9600.17298 X86

Copyright © Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\UHAX\Desktop\ArmA2OA.mdmp]

User Mini Dump File: Only registers, stack and portions of memory are available

************* Symbol Path validation summary **************

Response Time (ms) Location

Deferred SRV*C:\Symbols*

Symbol search path is: SRV*C:\Symbols*

Executable search path is:

Windows 8 Version 9200 UP Free x86 compatible

Product: WinNt, suite: SingleUserTS

Machine Name:

Debug session time: Sun Mar 22 00:25:58.000 2015 (UTC + 13:00)

System Uptime: not available

Process Uptime: 0 days 0:18:01.000

................................................................

.......................

This dump file has an exception of interest stored in it.

The stored exception information can be accessed via .ecxr.

(26b4.2318): Access violation - code c0000005 (first/second chance not available)

eax=00000000 ebx=00000001 ecx=00000000 edx=00000000 esi=00cbfcb2 edi=137fc677

eip=77c2d44c esp=137fbc30 ebp=137fbc3c iopl=0 nv up ei pl nz ac pe nc

cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00000216

ntdll!NtGetContextThread+0xc:

77c2d44c c20800 ret 8

0:004> .ecxr

*** ERROR: Symbol file could not be found. Defaulted to export symbols for BEClient.dll -

eax=0c9f5930 ebx=00000000 ecx=74746168 edx=00da0564 esi=00000000 edi=76e38c00

eip=0575ae70 esp=137fcfe0 ebp=137fef28 iopl=0 nv up ei pl zr na pe nc

cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010246

0575ae70 8b11 mov edx,dword ptr [ecx] ds:002b:74746168=????????

---------- Post added at 14:34 ---------- Previous post was at 14:33 ----------

I can confirm this is a BattlEye issue, if I set BattlEye = 0; in the server.cfg the problem no longer occurs.

I have emailed BattlEye support.

Share this post


Link to post
Share on other sites
Guest

Are you guys also having the sudenly rise of player upload consume reaching, sometimes, like 300 Kb/s upload rate per player?

Share this post


Link to post
Share on other sites

I got a reply back from BattlEye.

However if you are looking for a temp fix in the mean time try deleting the Profile folder each time before you start the HC!

----------------------------------

Hi,

I'm sorry for this, it will be corrected shortly.

Regards,

Bastian Suter

BattlEye Innovations

Share this post


Link to post
Share on other sites

This issue should be fixed now, please confirm.

I'm sorry for any inconvenience caused.

Share this post


Link to post
Share on other sites

It is still crashing for me and I didn´t notice any changes to the BE files. Which ones underwent changes?

Share this post


Link to post
Share on other sites
It is still crashing for me and I didn´t notice any changes to the BE files. Which ones underwent changes?

No file updates. Could you confirm that the issue is fixed now?

Share this post


Link to post
Share on other sites

Looks good for the past couple of restarts, I´ll keep you posted if something goes wrong. Thanks for the fix!

Share this post


Link to post
Share on other sites
Guest

It's crashing to me.

The problem have back again?

Share this post


Link to post
Share on other sites

Crashing for me again too, seems like the problem is back.

Have also had the lag problems you linked. Our headless client is running a very small amount of code with no intense or taxing loops, under 10 A.I. units, and still having problems...

We tried placing our HeadlessClient in a fresh WinXP machine, and still it has continued crashing...So we tried making it only 1 AI unit with nothing extra, and STILL it is crashing at seemingly random intervals!

Share this post


Link to post
Share on other sites
Guest

I send a e-mail to BE but they not answered it. May be you have more luck. Why don't you send a e-mail to BE?

I'm with BE off on my server and its all working ok, but this is really bad because i can't use Dart to comunicate with my players.

You don't need hackers breaking your server, BE auto-hacker tool do it for then, so hackers will not need to attack your server. Best protection ever!

Edited by Guest

Share this post


Link to post
Share on other sites

I have the same problems again - anybody else?

 

Yes.

 

I have the same problems. it started Aug. 6, a month before it worked without a glitch. crashing every 17-20 minutes on all my servers(3)

there is some sort of fix?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×