Jump to content
CUP

Community Upgrade Project - CUP

Recommended Posts

18 hours ago, TitleMax said:

Anzac Class Frigate Deck Broken.

Well all I have to say is that when your on the Helicopter Deck of the ship, You fall through. I Doubt it'll ever get fixed because it's been like that for years and yeah.


Haven't tried this myself, but you could "patch" that spot with the invisible wall object from the editor?

Share this post


Link to post
Share on other sites
4 minutes ago, JD Wang said:


Haven't tried this myself, but you could "patch" that spot with the invisible wall object from the editor?

Idk, when the shop sways or move it'll just be apart from the ship

Share this post


Link to post
Share on other sites
On 5/14/2020 at 4:24 AM, TitleMax said:

Anzac Class Frigate Deck Broken.

Well all I have to say is that when your on the Helicopter Deck of the ship, You fall through. I Doubt it'll ever get fixed because it's been like that for years and yeah.

 

Simple when the frigate is stopped. Add an invisible helipad and:

<yourHelipad> attachTo [<yourFrigate>,[0,-50,2.2]];

 

Problem with swell. Try to add something like:

["stab","onEachFrame",{<yourHelipad> setVectorDirAndUp [vectorDirVisual <yourFrigate>,vectorUpVisual <yourFrigate>]}] call bis_fnc_addStackedEventHandler;

Not really nice.

 

Problem with speed (waypoint): the player (not the helo) slides to the stern.

 

My 2 cent contrib for a deck landing (without getting out), just for replenishment/repair, Anzac sailing...

 

In Anzac init field:

if (isServer) then {

  myTrigger attachTo [this];

   this setVelocityModelSpace [0,10,0];   // just to make the anzac starts moving without inertia

};

in myTrigger  ( size 150,150,50, BLUFOR present, repeatable, server only), myAnzac is supposed to be AI controled, then located on server:

condition:             this && {_x isKindOf "helicopter"} count thislist > 0
onActivation:       {myAnzac setVariable ["heloLanding",_x]; [_x,false] remoteExec ["allowDamage",_x]} forEach thislist; myAnzac allowDamage false;
onDeactivation:   [myAnzac getVariable ["heloLanding",objNull], true] remoteExec ["allowDamage",(myAnzac getVariable ["heloLanding",objNull])]; myAnzac allowDamage true";

 

See this video at 0:40

 

Share this post


Link to post
Share on other sites
31 minutes ago, starlord1214 said:

Question dose this mod have the British battle tank called challenger 2?


Yes.
It can be found in CUP Vehicles.

Share this post


Link to post
Share on other sites

Whata update! Love the new stuffs! Thank you very much for the many Hilux! This particular Hilux of a thing even had a freaking bmp turret on the back of it! I lmao upon seeing it for the first time , bundled with fun. And the armored ones 😄, the armored ones are epic! It's like how they set up over there in middle east. Now a motor carrier is available for the suppose rebels too!

So many things to be thx for indeed. I thanks also for the guns the like of SKS and long mosin(short mosin is rare in reallife which is not good in imagining my suppose rebels). And that square shaped holo sight, which look like the one i had once proposed on add-on request thread(if that is the one Israelis have been using lately, then that's what i proposed for. Not sure the one you just included in the CUP is my intended one though. But it indeed look like it).

So seem like the CUP weapons are almost filled. Now let's get goings-on to Romanian PSL  Must have for every suppose rebels ever (and CFP)!

Share this post


Link to post
Share on other sites

anyone help with this I trying to load cup addons to sever and keep getting '@CUPWeapons\addons\cup_baseconfigs.pbo' not found. is there a fix for this..thank you.

Share this post


Link to post
Share on other sites

 

On 5/23/2020 at 11:59 AM, delta1uk said:

anyone help with this I trying to load cup addons to sever and keep getting '@CUPWeapons\addons\cup_baseconfigs.pbo' not found. is there a fix for this..thank you.

corrupt download most likely, go in a3 launcher > mods > cup weapons > repair

  • Like 5
  • Haha 1

Share this post


Link to post
Share on other sites

hey i have a question are you guys planning on making new static navy ships? for example: USS Arleigh Burke-class Destroyer or any other ship?

Share this post


Link to post
Share on other sites
6 hours ago, starlord1214 said:

hey i have a question are you guys planning on making new static navy ships? for example: USS Arleigh Burke-class Destroyer or any other ship?

not for the time being

Share this post


Link to post
Share on other sites

Splendid work indeed Chairborne. 😎 

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, Chairborne said:

 

 

That looks so much like the "Real Thing"!!!

 

Well done, such talent!

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

It would be nice to have it for the weekend beach sunbathing.
 

 
 
 
 
Spoiler

 orig


@Chairborne fantastic job man!

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for the alpenflage addition in Dev branch don't know if it's in stable yet but it looks really good. 

Share this post


Link to post
Share on other sites

Beautiful, now you just need a deuce or a M939, or both...

Share this post


Link to post
Share on other sites

Will the M151A2 MUTT be able to fit inside the CH-47 VIV or the V-22 VIV?

Share this post


Link to post
Share on other sites

I have an odd stutter with any of the Chernarus Maps. If I place any type of AI-based turret or Drone (Such as the Falcon), I get a stutter during game play. When placing turrets on the destroyer, the stutter was pretty pronounced. Anyone else have this or seen this?

Share this post


Link to post
Share on other sites
On 6/8/2020 at 9:21 PM, D.Tac said:

Will the M151A2 MUTT be able to fit inside the CH-47 VIV or the V-22 VIV?

can definitely fit inside a chinook, havent tried the mv22, but something tells me the MG variant is too tall

On 6/8/2020 at 10:45 PM, Rich_R said:

I have an odd stutter with any of the Chernarus Maps. If I place any type of AI-based turret or Drone (Such as the Falcon), I get a stutter during game play. When placing turrets on the destroyer, the stutter was pretty pronounced. Anyone else have this or seen this?

has this been happening for long?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×