Jump to content
CUP

Community Upgrade Project - CUP

Recommended Posts

11 hours ago, NutzMcKracken said:

1/ Also is there a special way to disable the defense weapon systems. We are trying to set up a mission where you raid the carrier which has OPFOR Ai that have taken over.

2/ I tried searching tickets to see if there was one open issue on this, never submitted a ticket, would that be Open a Task?

1/ There is an 3DEN attribute which is broken in current stable but should be fixed in next update (soon).

2/ Yes or "create a task" something like that. You can also check for already existing ticket before submiting a new one.

Share this post


Link to post
Share on other sites
15 hours ago, ranger_24 said:

Hi.

 

Apologies if someone has already notified this...

 

While building a mission for my clan I wanted to use CUP's LHD for an amphibious operations, but due to clipping issues on the ship's decks that eventually you clip right under the sea, out of frustration I changed the mission's assault plan.

 

Is this something fixable?

 

12 hours ago, NutzMcKracken said:

I came here for the same reason as above for the LHD.

 

Seems the Below Deck area (all floor surface areas), the contact surface is inconsistent and you either get stuck floating in mid air at times or die instantly.

This wasn't a problem before until recently. 

Noticed that the guns on the LHD act up as well, the top fore rocket and Sea Wiz emplacements bounce around while in 3DEN after spawning in.

Also is there a special way to disable the defense weapon systems. We are trying to set up a mission where you raid the carrier which has OPFOR Ai that have taken over.

I tried searching tickets to see if there was one open issue on this, never submitted a ticket, would that be Open a Task?

It happens when the ship is placed on certain positions because of uneven ground below. Try moving it around slightly, it should fix it, otherwise if you can put up a video or screenshots where this is happening we can take a look.

Just to be clear though, the LHD always had issues in certain spots since the A2 days, especially the front section used to spawn incorrectly very often to me.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Chairborne said:

 

It happens when the ship is placed on certain positions because of uneven ground below. Try moving it around slightly, it should fix it, otherwise if you can put up a video or screenshots where this is happening we can take a look.

Just to be clear though, the LHD always had issues in certain spots since the A2 days, especially the front section used to spawn incorrectly very often to me.

Thanks. Will check it out.

Share this post


Link to post
Share on other sites

We'll check that out, however tracking down broken animations is going to be a problem.

  • Like 1

Share this post


Link to post
Share on other sites

Gday CUP team. I've been happily using CUP stuff for ages now, so up front please accept my thanks for the incredible amount of work and dedication you've put into these absolutely essential addons .

 

I run A3 dev branch exclusively, and run CUP terrains core + maps (both from the workshop) and a bunch of 3rd party CUP requiring maps. Until a few weeks ago these ran flawlessly. And then I started experience a total black screen crash to desktop when trying to load A3 once the mods had initialised.  If I just loaded CUP core everything was fine, but as soon as I loaded CUP maps and/or other CUP requiring maps the CTD bit me. After a lot of swearing and fiddling with parameters, I found that the only way to get the game to actually load and run with CUP Terrains was to use the 32 bit A3 exe. I figured since CUP terrains hadn't recently updated, the behaviour was due to one of the dev branch updates, but it seems no-one else has experienced it, just me. If I disable CUP terrains the game runs without issues in 64 bit (Windows 7).

 

I realise I'm probably an edge case with some system quirk, but any insight would be appreciated.

Share this post


Link to post
Share on other sites

Only thing that comes to mind is that your download might be corrupt.

If its a steam workshop download you can repair it from the A3 launcher.

Other than that, nothing really comes to mind. Is it the regular exe or the diagnostics exe? Because diag exe has been crashing a lot lately to me and a few others, even trying to open a waypoint panel makes the game crash.

Share this post


Link to post
Share on other sites
41 minutes ago, Chairborne said:

Only thing that comes to mind is that your download might be corrupt.

If its a steam workshop download you can repair it from the A3 launcher.

Other than that, nothing really comes to mind. Is it the regular exe or the diagnostics exe? Because diag exe has been crashing a lot lately to me and a few others, even trying to open a waypoint panel makes the game crash.

Cheers for the reply Chairbone, greatly appreciated. I get the crash if I use the downloaded version or the steam workshop version. Validating the install does nothing. I guess it’s just a vagary of my system, I’ll just have to put up with the reduced 32bit performance and hope that a future release of either A3 or Cup terrains gets things to come to their senses! I’m only using the regular exe by the way.

Share this post


Link to post
Share on other sites

If it happens from two different sources and you're sure it's not corrupted then i wouldn't know, does it throw any error like memory could not be read or anything similar in RPT maybe?

Share this post


Link to post
Share on other sites
2 hours ago, Chairborne said:

If it happens from two different sources and you're sure it's not corrupted then i wouldn't know, does it throw any error like memory could not be read or anything similar in RPT maybe?

 

The usual rpt looks like this:

 

Version 1.77.143248
Fault time: 2017/10/11 17:28:09
Fault address:  77620944 8EDC00:000000B1 Unknown module
file:     
world:    
Prev. code bytes: 00 00 00 00 00 00 00 00 00 00 00 00 48 83 EC 28
Fault code bytes: F0 0F BA 2D 77 99 04 00 00 E9 5B 6A 5C 93 FF 25
=======================================================
note: Minidump has been generated into the file C:\Users\tpw\AppData\Local\Arma 3\Arma3_x64_2017-10-11_17-27-43.mdmp
=======================================================
-------------------------------------------------------
Exception code: C0000005 ACCESS_VIOLATION at 77620944

Not sure of the significance of any of this to be honest!

Share this post


Link to post
Share on other sites

That's just memory dump information - not much to be had of it unless you have debugger tools and checked builds.  Which no one but BIS will have.

  • Like 1

Share this post


Link to post
Share on other sites

I recently had the 'pleasure' to debug some problems with the Unsung maps from arma 2. What helped was to run the dev branch diag exe and check for any popups. They are a bit mysterious, those popups, but they helped me to identify a faulty object through bisecting the pbo's that were loaded. 


I think the memory dump can help if the fault / prev code information stays roughly the same. If so, I would open a feedback ticket and attach the crash dumps and hope that some kind BI developer with a love for CUP will spend some hour to take a look ...

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks very much for the replies gents, all really appreciated. Given that I seem to be the only person in the universe experiencing this, I doubt it will get much attention. Maybe I'll just put it in the "too hard basket" for the time being and hope that an A3 or CUP update fixes it. 

Share this post


Link to post
Share on other sites
6 hours ago, tpw said:

Thanks very much for the replies gents, all really appreciated. Given that I seem to be the only person in the universe experiencing this, I doubt it will get much attention. Maybe I'll just put it in the "too hard basket" for the time being and hope that an A3 or CUP update fixes it. 

 

What you describe sounds like a hardware failure that only comes into play, when a program taps more RAM than usual (64bit + Terrains). You can test this with Memtest.exe or something like this. You could also try running A3 64bit with -maxmem=2047 (or lower).

 

Just an idea

Share this post


Link to post
Share on other sites

CUPREP #0007: GOING DYNAMIC

 

sK6kYX7.jpg

 

The CUP Team is happy to announce the release of a fresh new patch for all our content.

 

You can find the downloads on our Download page and Steam Workshop.

 

After months of heavy work the integration of the dynamic loadouts is finally complete. All our compatible vehicles now feature proper sensor and dynamic loadout setup.

Granted some tweaks might still happen here and there, the bulk of the work has finally been completed.

But what else is new? The M60A3 Patton MBT is new! The Uparmored Humvees are new! The Takistani Civilians are new! Guess we'll have to find another excuse to delay our patches now huh... sahrani civilians are still missing

Also coming along with this patch there are a few more civilian vehicles, bringing the number of vehicles left to port over and upgrade just down to 14 and making the Army of the Czech Republic the last missing piece of our units.

 

Once again we would like to remind you that if you wish to get involved in testing we have a special DEV branch that updates weekly from our internal version, giving you access to the latest additions, upgrades and fixes.

Because of how Steam works and how we want to keep more control on who has access to this separate version, you need to befriend the CUP Team Steam account to see it.

Drop us a message on our Discord Chat server to let us know who you are and we'll make sure to give you access.

 

This being said, we're still chasing after many other technical upgrades BI has been implementing lately and we're looking forward to the Tanks DLC for an overhaul of our armored vehicles.

If you're a modder and want to get actively involved in CUP development come by our discord to have a chat with us.

 

Thank you for your continuous support, bye for now!

 

Changelogs:

CUP Weapons 1.10.0 Changelog

CUP Units 1.10.0 Changelog

CUP Vehicles 1.10.0 Changelog

CUP ACE Compats 1.10.0 Changelog

CUP Terrains Core 1.4.0 Changelog

CUP Terrains Maps 1.4.0 Changelog

CUP Terrains CWA 1.4.0 Changelog

Edited by CUP
  • Like 26
  • Thanks 11

Share this post


Link to post
Share on other sites

It's inbound. Wait a few hours, it'll go up

Thanks in advance, guys :)

Share this post


Link to post
Share on other sites

Workshop is going up right now

Share this post


Link to post
Share on other sites

CUP Vehicles key in the workshop build after update is cup_vehicles-1.9.1.bikey. Others are 1.10.0. Not bothered so long as the server and client match for BattlEye

Cheers,

Grahame.

Share this post


Link to post
Share on other sites

That would be because CUP vehicles hasn't actually updated yet....

 

EDIT: Of course it does the second after I post that XD

Kill your Arma 3 and let it update

  • Like 1

Share this post


Link to post
Share on other sites

Steam said the update date of the mod was today...

{Edited) Fuck Steam... yep... none of the new PBOs... They updated the update date before actually updating.... 

 

And I'm doing updates for three persistent A3/Epoch servers so killing ARMA3 and letting it update is not an option :dontgetit:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×