Jump to content
CUP

Community Upgrade Project - CUP

Recommended Posts

Not very much, if they're smart about it. It doesn't have to be done manually, there are many programs that can batch-rename files with many different options. Even my antiquated Windows Commander 5.0 could be used for that. Unless, this would also involve adjusting something else (like those "signing" files for multiplayer, or references inside the config files) to match, it's a trivial operation if you have the right tool.

 

TBH, this shouldn't even be needed, but Linux happens to be case-sensitive (another reason I don't like it very much) and it'd probably be easier to do that way than having BIS implement a workaround.

 

Simply run a script over your files once you have installed them on the server, problem solved.

 

 

i love the new bren rifle sounds but please enable it to be able to use custom suppressors. the standard BIS ones just really get to me these days. 

 

Where do you suppose would these custom suppressors come from? It's not enough to "enable" them, you actually have to have them in the game.

Share this post


Link to post
Share on other sites

Simply run a script over your files once you have installed them on the server, problem solved.

 

 

 

Where do you suppose would these custom suppressors come from? It's not enough to "enable" them, you actually have to have them in the game.

what i meant was make them compatible with other user made suppressors. Like every some other weapons pack out there. BIS suppressor are just too big. 

  • Like 1

Share this post


Link to post
Share on other sites

I really enjoyed having all 4 maps that I was ready to release on the Workshop suddenly become broken because of the update.  Bravo

 

"You cannot play this mission. It is dependant on downloadable content that has been deleted. CUP_Air_Vechiles_Merlin"

 

The mod as a whole is awesome, I'm just really incensed about how this has turned out.

Share this post


Link to post
Share on other sites

I really enjoyed having all 4 maps that I was ready to release on the Workshop suddenly become broken because of the update.  Bravo

 

"You cannot play this mission. It is dependant on downloadable content that has been deleted. CUP_Air_Vechiles_Merlin"

 

The mod as a whole is awesome, I'm just really incensed about how this has turned out.

"Incensed" huh.  I think you should re-examine your life priorities :D

 

This incredibly common mission error can be fixed by removing those references within the mission SQM file.  When you remove those references the mission no longer "checks" for those addons.  So if something in CUP was moved from one PBO to another, the class name of that vehicle will be the only thing it will reference. 

  • Like 1

Share this post


Link to post
Share on other sites

When using createvehicle, the Coyote spawns damaged on Tanoa, but fine on Altis. :(

Share this post


Link to post
Share on other sites

Apparently I do have a life, because this coding stuff is nothing but a pain in the ass, and I took this time today to l do what I can, I've looked around the web; didnt find it and I dont actually have time to learn the intricancies of coding .Your suggestion doesnt work. It still asks for it. Erasing it just made the file crash more quickly. ButThanks.

Share this post


Link to post
Share on other sites

Is there any known incompatibility that makes sounds for RPGs disappear? All firing sounds for them are gone for me, in the current version.

Share this post


Link to post
Share on other sites

Apparently I do have a life, because this coding stuff is nothing but a pain in the ass, and I took this time today to l do what I can, I've looked around the web; didnt find it and I dont actually have time to learn the intricancies of coding .Your suggestion doesnt work. It still asks for it. Erasing it just made the file crash more quickly. ButThanks.

Pook's advice was spot on... Sounds like you didn't follow it properly, as you're obviously a busy chap I'll try and help. It could be simply that the class name has changed so the mission cannot load the specific helicopter you referenced. Make sure you've not encrypted the mission file then open it in ARMA Edit, or Notepad++. Do a find replace on that class name with another vanilla helicopter - I.e. The wildcat or hummingbird etc. Save and try again in the editor.

Profit....

  • Like 1

Share this post


Link to post
Share on other sites

Is there any known incompatibility that makes sounds for RPGs disappear? All firing sounds for them are gone for me, in the current version.

 

Hotfix is inbounce. The RPG-7 as well as a few other weapons (Abrams, Cobra etc) have lost their voice, there should be a fix for that soon (probably today/tormorrow)

Share this post


Link to post
Share on other sites

I really enjoyed having all 4 maps that I was ready to release on the Workshop suddenly become broken because of the update.  Bravo

 

"You cannot play this mission. It is dependant on downloadable content that has been deleted. CUP_Air_Vechiles_Merlin"

 

The mod as a whole is awesome, I'm just really incensed about how this has turned out.

 

1) No need to write everything in bold.

2) Cool down your incense.

3) Once you have done that, we can talk.

  • Like 1

Share this post


Link to post
Share on other sites

 It could be simply that the class name has changed so the mission cannot load the specific helicopter you referenced.

 

The original CfgPatches name had a typo, which was corrected but subsequently forgotten to add a compatibility patch. The hotfix should cure that problem.

 

As a rule we never make changes that break missions, if it happens then it was a bug. I would have told that to Mr. Beerbellygod as well, but I didn't like the bold font.

  • Like 4

Share this post


Link to post
Share on other sites

Nice update as usual. Did not know this was a thing tho... maybe I am wrong about what I think it is..

 

 CUP_Weapons_C7 - removed package pending review. 

 

c7a1_a2.jpg

 

Our Canadian Group would love these :)

Share this post


Link to post
Share on other sites

Hello i run a dedicated server with CUP but there is a problem which makes the server unable to launch:

 

16:08:32 Warning Message: Addon 'CUP_Terrains_Abel' requires addon 'CUP_CWA_Signs'

 

ive tried to search for both those files but none of them exist either in my arma 3 mods folder nor on the server can someone help?

 

this is the command line: @CUP_Terrains_Maps;@ace3;@task_force_radio;@CUP_Terrains_Core;@CUP_Vehicles;@CUP_Weapons;@CUP_Units;@ares;@CBA_A3

Share this post


Link to post
Share on other sites

Our Canadian Group would love these :)

Oh they would, eh? 

 

:D

Share this post


Link to post
Share on other sites

Hello i run a dedicated server with CUP but there is a problem which makes the server unable to launch:

 

16:08:32 Warning Message: Addon 'CUP_Terrains_Abel' requires addon 'CUP_CWA_Signs'

 

ive tried to search for both those files but none of them exist either in my arma 3 mods folder nor on the server can someone help?

 

this is the command line: @CUP_Terrains_Maps;@ace3;@task_force_radio;@CUP_Terrains_Core;@CUP_Vehicles;@CUP_Weapons;@CUP_Units;@ares;@CBA_A3

Tried loading Core before Maps?

Share this post


Link to post
Share on other sites

Tried loading Core before Maps?

yes i was editing in it and trying to fix it while waiting for a response this is how the commandline looks now: 

 

@CBA_A3;@CUP_Terrains_Core;@ace3;@task_force_radio;@CUP_Vehicles;@CUP_Weapons;@CUP_Units;@ares;@CUP_Terrains_Maps

 

i still get the same error

Share this post


Link to post
Share on other sites

Just a heads-up, I noticed that the An-12 is missing a ViV variant. C-130 works great, but its Russian counterpart doesn't seem to have ViV.

Share this post


Link to post
Share on other sites

That damn pookie released the AN12 :p

 

And before you ask, no I don't plan to.

  • Like 3

Share this post


Link to post
Share on other sites

In that case it's yours. I wonder, why isn't there a forum thread for it? All your other releases have one.

 

TBH, it'd be nice to have it, especially if you're not planning on a transport version of Il-76. The US have C-130, but the Russians don't quite have any counterpart to it. An-12, well, is just that, fitting perfectly into the lineup.

Share this post


Link to post
Share on other sites

 

Apex update added a separate keybind for "vectoring" versus "autohover", but as far as I know the Harrier automatically vectors (it did in Arma 2 as well, IIRC).  I haven't had a chance to test it out myself yet, though, so I'll edit with my own complaints if necessary. =)

 

Ok, I found the keybind and got it fixed. Works great now.

 

 

Thank you very much.

Share this post


Link to post
Share on other sites

CUPREP #0003: APEX Update Part Deux

 

This is a hotfix for a few errors that slipped in the latest patch.

As usual, if you find any more issues with the mod please report them in our feedback tracker below:

 

http://dev.cup-arma3.org/

 

Sorry for the inconvenience!

 

Bye for now!

 

Weapons changelog:

Version 1.7.1 (16|Jul|2016)

ADDED:
Added soundshaders to AWM, CZ750, M24, KSVK, VSS, AA12, Saiga12K, EVO, M60E4, MP5. Updated soundshaders for Hunting Rifle and Lee Enfield.
Added proper silencer model to L85.

EDITED:
CUP_Weapons_East_Attachments - Made PSO-1's ironsight-mode usable.

FIXED:
CUP_Weapons_L85 - UGL Launcher sight now flips down correctly. Fixed UGL eye offset causing grenades to miss.
CUP_Weapons_RPG7 - Fixed missing shot sound for RPG-7.
CUP_Weapons_VehicleWeapons - fixed missing shot sounds for Zu-23, Stryker MGS, M1 Abrams, Apache, Super Cobra.

 

Vehicles changelog:

Version 1.7.1 (16|Jul|2016)

FIXED:
CUP_AirVehicles_Merlin - Typo in Merlin CfgPatches and added legacy version, should fix T1580

 

Download links:

  • Like 5

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×