Jump to content
cervantes

WW2 warships release on arma3 engine

Recommended Posts

@cervantes ... is this topredoes bug something new or just the old one we talked about ?

Share this post


Link to post
Share on other sites

its alway a same bug Aplion the torpedoes move corectly on target position (last fix)  but a velocity is alway afected.

 

more i add a ships targets and night afecting more a velocity of torpedoes.

 

my last observation is a arma3 deffaut ships d'ont have this bug this bug appear only when i launch multiple torpedoes.

 

im not sure but its possible a geo lods or land contact create this probs.

 

i have follow a arma3 ships tutorial and boat sample for trying to working same models...

 

size of models perhaps :/

Share this post


Link to post
Share on other sites

You are talking about torpedo velocity (I assume that you mean the torpedo speed by this term). And this speed is getting worst when you are placing more of your ships on the map. If this is true ... can you tell me how many polygons your ships are (each one, not in total) ? I'm thinking that in case of to much polygons maybe the game performance is affected and gives you the impression of velocity change. Just a silly thought ...

Share this post


Link to post
Share on other sites

damned i not known this and how count each Polys ^^

 

but a ships models is always same models used in A2OA.

 

i have only enhancing a uboats models for the moment.

 

4443 faces for the escort ship is a good number of faces for a low poly models generaly used for a games.

 

less faces on the cargo ships also ;)

 

and this bug do not apear on A2 engine :)

Share this post


Link to post
Share on other sites

damned i not known this and how count each Polys ^^

 

Just open your p3d with Object Builder and have a look on your lower left corner ... must have a number for points (vertices) and another one for faces (polygons).

Share this post


Link to post
Share on other sites

xd :P ty for this info 

 

 

12838 points

 

14463 faces

 

123 sections

 

:)

 

i just instaled a swedish mod and trying testing a submarine.

 

a submarine just sink and not working not sure but its possible i have one some physx arma3 bug

Share this post


Link to post
Share on other sites

xd :P ty for this info 

 

 

12838 points

 

14463 faces

 

123 sections

 

:)

 

i just instaled a swedish mod and trying testing a submarine.

 

a submarine just sink and not working not sure but its possible i have one some physx arma3 bug

 

Your sections are to many and must be reduced ... usually sections must be close to 20 (more or less). Your vertices and faces numbers are fine.

 

Another question ... the torpedo is practically a vehicle ... do you use PhysX on that ?

Share this post


Link to post
Share on other sites

no i d'ont use physx on torpedoes only a basic geo lod and land contact

  • Like 1

Share this post


Link to post
Share on other sites

i just tested with a large ship target with

 

26402 points

 

15739 faces

 

1 section

 

the bug is same ;)

  • Like 2

Share this post


Link to post
Share on other sites

ok i have trying one other test same mission but i have replace a cargos and escort ships with fishing boats only.

 

the torpedoes moves is also affected but working very better i think a size of ships affect also a velocity of torpedoes.

 

but im not really sure because our torpedoes working with large ships without troubles.

Share this post


Link to post
Share on other sites

I'm sure that the issue is not caused by ships size (remember that I've tested on my ships before and their size is really big). Must be something else that causes that. I believe that there are some big ship addons you can try for testing purposes (as targets) ...

Share this post


Link to post
Share on other sites

i have also tested LCS 2 Technological Demonstrator

 

by mankyle is one really good addon for testing and i encountering same prob.

 

after trying to modifiate p3d and config, disable scripts and use minimal addons of my mod i have same bug.

 

its possible i have one troubls with arma3 engine or physx but after full réinstal of arma3 a bug is alway present.

 

this bug affect my all scripts using setvelocity comand.

 

by exemple my old convoys script using setvelocity for a ship move alway on forward direction.

Share this post


Link to post
Share on other sites

I just registered to say that I've been following this project for a while, Cervantes your work is amazing.

I know you're, as far as I've seen, very perfectionist with your work and you want every minor detail to be there for the release, but, have you considered releasing a beta version? and working on top of that with new patches? It will sure help to get your addons more known and used by players and communities alike. I mean, damn, at my community we're so hyped for this mod that we cannot wait to try it. We're playing Becti style missions for WW2 content and this would be the best addition ever.

Just that, I think the whole community out there will appreciate even a partial release, and also probably more modders would be able to help you out with bugs or testing. I myself would offer to help you with MP testing if you want.

Finally, also thank Altion for your interest in this project, following it from outside one can notice that you have pushed it forward helping cervantes and vice versa. Also looking with a lot of interest into your greek army mod, particularly the submarine and ship. That video with the new Harpoon missiles reticle is just dope.

I hope I didn't sound rude at any point, just wanted to show that there's a fair amount of people interested in this project and so far we find it amazing, it's probably the most ambitious naval mod I've seen so far, but don't let it die out of over ambition or trying it to be perfect from the start haha,  keep it up!

  • Like 2

Share this post


Link to post
Share on other sites

I just registered to say that I've been following this project for a while, Cervantes your work is amazing.

I know you're, as far as I've seen, very perfectionist with your work and you want every minor detail to be there for the release, but, have you considered releasing a beta version? and working on top of that with new patches? It will sure help to get your addons more known and used by players and communities alike. I mean, damn, at my community we're so hyped for this mod that we cannot wait to try it. We're playing Becti style missions for WW2 content and this would be the best addition ever.

Just that, I think the whole community out there will appreciate even a partial release, and also probably more modders would be able to help you out with bugs or testing. I myself would offer to help you with MP testing if you want.

Finally, also thank Altion for your interest in this project, following it from outside one can notice that you have pushed it forward helping cervantes and vice versa. Also looking with a lot of interest into your greek army mod, particularly the submarine and ship. That video with the new Harpoon missiles reticle is just dope.

I hope I didn't sound rude at any point, just wanted to show that there's a fair amount of people interested in this project and so far we find it amazing, it's probably the most ambitious naval mod I've seen so far, but don't let it die out of over ambition or trying it to be perfect from the start haha,  keep it up!

I totally agree with you!

Share this post


Link to post
Share on other sites

damned im unmasked :D

 

yes im very perfectionist ^^!

 

 

for the moment im so busy with real life and not work on the release.

 

when i can restart my works corectly i think share the last version of mod in my drop box with others moders followed this project.

 

im really so happy to see Caring proposed for help me ;)

 

im also so busy to working on one other project this is actualy the confidential submarine :D

 

i worked also on the red october submarine for modern submarine project :)

 

but in standby also ;)

 

  • Like 2

Share this post


Link to post
Share on other sites

hi guys following proposal for help me to solved a bugs i have today choose my beta testers and send a beta to this beta testers.

 

i have choose  nikiforos,Aplion,Rakad, and thirtennluiz of reality team mod for a beta testing of actual contents on the project

 

sorry for others but i can send a beta at all ^^

 

thank you for your help and hope your enjoying on this beta test :)

 

 

if i can foward actualy i find is a good moment for beta testing and hope fix a last bugs fastly ;)

Share this post


Link to post
Share on other sites

with pleasure Rakad :)

 

aplion report me a turret bug with escort ship i have repack a warship.pbo if you encoutering same bug ;)

Share this post


Link to post
Share on other sites

Yes I have the turret bug aswell. I send you some other bugs via PM. And how does it work with updates, will you tell us when you updated your mod, so we can download it again?

Share this post


Link to post
Share on other sites

yes i have add one readme in drop box you can check when you want if i add update i write this in readme ;)

Share this post


Link to post
Share on other sites

Please tell me the projects not dead, this is so fucking awesome to see in a game with such a huge gap in naval support, if its been abandoned is there any way at all to get hands on any kind of copy, broken or not Id love to check it out!

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×