Jump to content
Sign in to follow this  
djbordie

x99 system testing

Recommended Posts

Hello folks,

thought id post some testing ive done with the x99 architecture. Unfortunately only the 6 core 5820k.

Hopefully you pro's can help me or confirm im getting as good as it can be, and why i cant seem to get any more fps or see differences with the settings.

arma 3 all up to date

x99 - 5820k @ 4.3ghz stable

gtx 970

ssd

8gb 2400 ddr4

(clean OS, clean fresh ssd, eliminated as many variables as possible)

ALL power savings off, turbo, eist, nvidia profiles max, windows profiles max.

findings: all testing with arma3Mark altis (for consistency)

DayZero graphics config, most ultra, 2700/1800 draw distances, 2x AA, fxaa ultra,

.cfg

max frames 1

detected frames 1

basic launch params through steam

-cpuCount=12 -exThreads=7 -high -noPause -maxMem=6144 -maxVRAM=4096 -skip intro -noSplash -nologs -window

Hyper Threading ON

(multiple passes on everything)

no launch params -- 50 fps

-cpuCOunt=12 -- 50 fps

-cpuCount=6 -- 50 fps

-malloc 3,4, custom github -- no changes

-exThread 1,4,7 -- no diff

core 1 75-85 %

core 2-3 ~30% and rest minimal ~0-20%

gpu ~%20

Cant believe all the setting changes, launch commands, etc dont show much variation in fps.

HyperThreading off (6 cores only)

56 fps across the board, same tests (no launch params, cpuCount=6, etc,etc,etc)

Core 1 90%

core 2-6 - 65-70%

gpu ~22%

AND for fun i put cpuCount=1,2,4 and it still used all 12 threads with HT on and when off all 6 cores...same fps.

do these settings every do anything anymore?

damn gpu gets up to 40% in the menus!!! but in game, 22%....arg

so am i bottlenecked anywhere? am i maxing things out?

this tirade started when upgrading from x58 i7 930 @ 4.0ghz HT off and seemingly had better performance on that rig...

now its about on par with what I had on that x58 rig, except when away from AI and stuff happening. where the x58 would stick around 30-50 fps

the x99 rig goes crazy high 100+fps outside of towns/ai/etc.

but single core performance is +300mhz on this new rig and way more efficient im sure than the i7-930...so why the similar fps?

why does it look like HT off is soo amazing, using lots of core power, but only +6 fps??? hardly worth it. I dont mind running with HT off though.

thoughts?

---------- Post added at 20:56 ---------- Previous post was at 20:36 ----------

just did 2 passes without ANY launch options (HT off)

cpu core 1- ~90%

core 2-6 - ~65%

fps = 54!!!!

so wtf?

Edited by djbordie

Share this post


Link to post
Share on other sites

Increase 3D Resolution in game to 150%/133% and you will get better pictures and higher GPU usage. FSAA 2x or 4X Max

Dont use nothing like max frames, detected frames, cpuCount, exThreads, maxMem, maxVRAM, etc. None of these works

Use Just: -skipintro -nosplash -nologs -enableHT

Your Aim to play ArmA should be around 30-40 FPS. Keed changing settings in game. This ins´t COD or BF fast paced to need 60 Fps. If you got 54 you are good to go.

Share this post


Link to post
Share on other sites
Increase 3D Resolution in game to 150%/133% and you will get better pictures and higher GPU usage. FSAA 2x or 4X Max

Dont use nothing like max frames, detected frames, cpuCount, exThreads, maxMem, maxVRAM, etc. None of these works

Use Just: -skipintro -nosplash -nologs -enableHT

Your Aim to play ArmA should be around 30-40 FPS. Keed changing settings in game. This ins´t COD or BF fast paced to need 60 Fps. If you got 54 you are good to go.

wow so none of that works anymore eh, i even think enableHT is pretty useless as it is working with all 6 cores natively.

I will compare HT on and OFF with enableHT on and off.

arma 3 used all 12 threads when HT was on and no launch param was used...

so you think my rig wont achieve any more fps than 54??

i play one scenario bad holiday, tons of ai, etc.

30 fps...flop

i am excited to render higher, hopefully use more gpu! amazing tip.

on that COD note, im not a cod or bf player. been working with arma2 since 2010.

i am simply trying to understand the limits of the launch params and what is happening relative to the x99 architecture.

is it better now a days to use 12 thread or just leave it at 6 physical cores?

______________

no launch params except what you said

test 1: HT off, -enableHT, render 150% === core1=90%, 2-6=65-75%, GPU usag=~40%, FPS=50

test 2: HT off, render 150% === core1=90%, 2-6=65-75%, GPU usag=~40%, FPS=51

test 3: HT off, render 200% === core1=90%, 2-6=65-85%, GPU usag=~40-60%, FPS=49

test 4: HT off, render 133% === core1=90%, 2-6=65-80%, GPU usag=~20-30%, FPS=50

HyperThreading ON

tested enableHT on and off launch param, no diffy

results identical, except core usage spread over 12. so much lower "usage" per core, but more cores working.

ill leave HT on

but i cant get any higher than 52 fps...

again, my x58 could get 50 fps...so this is still insanity.

each of my 6 cores are more efficient, and more overclocked than the x58 4 cores.

but i guess thats irrelivant...

Edited by djbordie

Share this post


Link to post
Share on other sites

haha!

overclocked a measily 300mhz (to 4.6ghz) and turned out 71fps on same test.

can you believe 300mhz = 20fps???

wowow

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×