Jump to content
Sign in to follow this  

Problems With Battleye

Recommended Posts

Hello evreyone,

When i am trying to start my game i get the same error over and over again.

I have managed to fix it about 4 times but each day the error shows up again. So my quastion is can somone help me please. I do know it has to do somting with battleye. But i deleted evreything from Battleye and reinstalled it. i reinstalled both the games 2 times. I did also verify the game a couple of times but it is still not working.



can not access the specified device, path, or file. You may not have access power for the file.

After that CMD comes up with this.


Does somone have any solution for this?

Share this post

Link to post
Share on other sites

I found a solution for this problem. I did look up the battleye website and found this.

When launching the game I get a "Failed to install BattlEye Service." / "Failed to start BattlEye Service." error. How can I solve this?

Something on your system prevents the installation/startup of the BE Service, which is required to play on BE-enabled servers. Please ensure that any security software (anti-virus, etc.) running on your system doesn't block the BE Service (both BEService.exe/BEService_x64.exe in your game's "BattlEye" directory as well as BEService.exe in the BE Service directory, which is usually "C:\Program Files (x86)\Common Files\BattlEye") in any way. You might have to add it to your security software's exception list. If that doesn't help or you don't use any sort of security software there might be a permission issue with your BE Service directory or the files within it. To solve this delete the BE Service directory (usually "C:\Program Files (x86)\Common Files\BattlEye") and then try to launch your game again. If you still get the same error at this point please try to manually set the BE Launcher (for ArmA 2: Operation Arrowhead: "ArmA2OA_BE.exe" in your game directory) to run with administrative privileges (normally this should happen automatically). To do so right-click on the BE Launcher executable, choose "Properties", go to the "Compatibility" tab, check the "Run this program as an administrator" option and click OK to apply your changes.

Share this post

Link to post
Share on other sites

Loads of us have the same problem at the moment - started maybe saturday 1 november?

start OA1.63 in steam and it tries to run

D:\Steam\steamapps\common\Arma 2 Operation Arrowhead\ArmA2OA_BE.exe

and comes up with this error (not seen before) "D:\Steam\steamapps\common\Arma 2 Operation Arrowhead\ArmA2OA.exe: windows cannot access the specified device, path, or file. you may not have the appropriate permissions to access the item."

when the error comes up as above (citing arma2oa.exe) it then opens a window arma2oa_be.exe and says "failed to launch game"

image copied from another thread reporting same problem (not my install path)


I am in steam as administrator and can launch the OA exe directly, or by selecting launch w/o battleeye

just cannot launch with battle-eye any more since the weekend.

No changes made on my PC as i was on holiday... and it worked before i left, and loads of my buddies have been busy reinstalling their games (oops lol) thinking they had broken their installs...

Edited by eggbeast

Share this post

Link to post
Share on other sites

ok dwarden helped me fix this today - it appears to have been a change in the way BattleEye works last week, which some antivirus programs do not allow by default.

in F-secure, it says under DeepGuard

Use the compatibility mode (lowers security)

For maximum protection, DeepGuard temporarily modifies running programs. Some programs check that they are not corrupted or modified and may not be compatible with this feature. For example, online games with anti-cheating tools check that they have not been modified in any way when they are run. In these cases, you can turn on the compatibility mode.

turning on compatibility mode fixed my problem completely

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this