Jump to content
Mattaustt

My Whale doesn't want to swim, [Animations work in debug]

Recommended Posts

Hello all,

I'm successful in getting my animations to work on my whale, but when I place it down in the editor, it only does the Whale_stop/idle animation where it just moves it's fins, it refuses to swim! The animations work fine under Debug Animations button, All 3 animations work flawlessly.

The only time it swims is for about 1-2 seconds when I click preview then it decided to do the Whale_Stop animation.

Any ideas? Here is the config.

http://pastebin.com/v3Smw5hE [My config with alterations to suit the whale]

Here is the config, that I have altered for my whale, This is the FISH Config.

http://pastebin.com/g6fgb0Vd [Pretty much the template]

Any ideas? Cheers.

Share this post


Link to post
Share on other sites
sadly i cannot help u , but i loved your title actually :cool:

Haha thanks, I'm still up for suggestions if anyone has them.

Share this post


Link to post
Share on other sites

@Mattaustt any luck yet? I got the same problem with my GreatWhite.

If we got one good working config, we could populate the Arma3 sea's, i'm not really a config writer.

---------- Post added at 10:03 ---------- Previous post was at 09:52 ----------

Here my Great White ingame, swimidle animation works. I got the turn and attack animations also working, but no movement. Any help or tips where to look for in the config would be welcome.

ScreenShot_THA_GreatWhite2.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Oh god yes! This looks great! Please keep going with this guys. I love it. Would love to see a lot more work in the water environment. Hope both of you guys get to release this stuff. I would love to get into animal stuff, but I feel I'd struggle even worse than you guys. A tad out of my depth right now. Keep it up. Excited...

Share this post


Link to post
Share on other sites

Don't give up! You can do it! Other motivational sayings! (I really want this to happen)

Share this post


Link to post
Share on other sites

Guys I will be releasing my Whale by Christmas, really busy plus I want to possibly make a whole fish pack.

  • Like 1

Share this post


Link to post
Share on other sites

I always wanted a whale for Christmas. This is good news! Been waiting since last winter.

Share this post


Link to post
Share on other sites

well obviously you can't use a fish config for a mammal...hurr hurr hurr. sorry i know i'm a retard :lol:

 

i can only give some general pointers.

 

first of you should check if you have all memory points that a fish has. and in general try to copy all the non visual lods too as best as you can. you can use eliteness to analyse the binarized vanilla fish models without opening them in o2 (which under normal conditions you can't).

 

is there maybe a fish sample in the samples_F folder? if so, then i'm too out of the loop already.

 

when it comes to these kind of things arma is like a house of cards. so it's always good to be as close to a working example as possible. same goes for the configs of course.

 

i know i'm stating the obvious but i wouldn't be able to spot anything in the files you posted. it's all guessing without real time hands on involvement.

 

so a good excercise could be making a clone of an existing fish that uses the same model and all but has a config with all the same paths but different classnames in terms of animations and CfgMoves name.

 

i hope some of this vague stuff made you come up with something. :lol:

Share this post


Link to post
Share on other sites

Will do, I'm going to have a crack at it again with this 2 week break that I've got up comming.

Share this post


Link to post
Share on other sites

In your move animation, have you set step and xstep ? Because i remember some guy who had a female model with custom skeleton (not quite a fish... but still) and it would only walk on the spot. That's because his animation was lacking step and xstep information in the move anim keyframe list

Share this post


Link to post
Share on other sites

Hey x3kj, thx for this point on the x step. I will have a look at this!

 

 

I had a look, these x and xstep are precent, only one thing there both have a value of o.oo  is that ok?

Share this post


Link to post
Share on other sites

that sounds like some default value, but idk for sure.

If animals technically work the same way as humans i do not think that's right. step is basically the frame when the left or right foot of a humanoid touches the ground. xstep is when the opposite foot touches the ground. The game as far as i understand it derives from this the distance travelled for each animation loop. If that's not present, 0 distance is travelled.

Not an expert in this matter, just trying to help by giving some food for thought.

  • Like 1

Share this post


Link to post
Share on other sites

Thx, x3kj, this is a plausible explanation. I shall have to find out what the proper distance should be.

Share this post


Link to post
Share on other sites

Will do, I'm going to have a crack at it again with this 2 week break that I've got up comming.

Did you ever get another crack at this Matt?

Share this post


Link to post
Share on other sites

20160427130920_1.jpg

 

Model update, no succes yet with animal behavior, but i'll keep trying. Any help still welcome ;)

  • Like 3

Share this post


Link to post
Share on other sites

I was able to get the shark from A2 working in the water as a vehicle. Not sure if that would help you but its definitely an option if you want it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×