Jump to content
Sign in to follow this  
noubernou

ACRE2 Public Beta Release

Recommended Posts

Great job on this mods guys but I am having an issue with the mod. I have it perfectly installed so it is working just fine but I am not hearing the radio clicks when sending and receiving radio transmissions over any radio. Is there a way to fix this or will I have to wait for the next update?

Make sure you connect to a game with the ACRE plugin already running at least once. It most likely did not transfer the click files over.

Share this post


Link to post
Share on other sites

Heads up, acre_api_fnc_isSpectator has a script error in the latest public version of ACRE2.

Line 10 is using exitWith followed by an else statement.

Share this post


Link to post
Share on other sites

Do you have more information on that (How did you call it)? Checked the function myself and it is fine for me.

Share this post


Link to post
Share on other sites

I'm calling it with

isSpect = [player] call acre_api_fnc_isSpectator;

Arma was saying there's a generic script error in the function on line 10.

However now that I look at my rpt file it's more specific than the in-game error, but I'm not sure which error is the one associated with the function:

16:17:13 Error position: <exitWith {

_spectVariable

} else {

if( _>

16:17:13 Error exitwith: Type Array, expected code

16:17:13 File idi\clients\acre\addons\api\fnc_isSpectator.sqf, line 10

16:17:13 Error in expression < = _this select 0;

Share this post


Link to post
Share on other sites

Any plans to support resolutions above 1920x1080? I'm on 2560x1080 and the actual button elements are not in the proper places on the textured radio interfaces. It's not a super big deal because they are still usable by finding the invisible buttons on the screen and still using them, but it is still improper and relatively annoying.

So Nouber, as a fellow washingtonian, I demand you smoke a blunt and add 2560x1080 support. Thanks doge.

Share this post


Link to post
Share on other sites

Hi , after the last few days some of my members report me that they have a strange bug. When they use the radio everything work correctly but when they configure their radio just after they can't hear anyone BUT the other can hear them ! Tonight after few month of using ACRE 2 i got that bug. Do you have any idea of what can cause that ?

Thank you

Share this post


Link to post
Share on other sites

ACRE Update 2.1.0.786 - STABLE Release

Hello everyone! We have worked to make sure to release in tandem with CBA for the latest Marksman release! Included below is ACRE2 STABLE Build 2.1.0. This build is compatible with the newest version of CBA, as well as the new Marksman DLC.

Pending any issues, this issue is being flagged as ACRE 2.1 STABLE

Additionally, we have included the below final bug fixes:

- Clipping issue eliminated

- Phasing from occlusion has been reduced, but still present when running through buildings

- Multiple SQF script error fixes

- The babel module would sometimes not initialize for JIPs

- The 343 no longer breaks when you remove the handle

- The ACRE2 Volume control options have been improved

- An issue which possibly caused AI to stutter has been removed

Thanks everyone!

Download Link: http://acre.idi-systems.com/archive/acre2_2.1.0.786.zip

Share this post


Link to post
Share on other sites

Awesome! The clipping fix alone brings ACRE2 up a few notches and I would say whoever was afraid of it before, should worry no longer!

In my experience phasing from occlusion is still pretty terrible but can be disabled entirely with this in the init.sqf or the Debug console:

ACRE_TEST_OCCLUSION = false

Share this post


Link to post
Share on other sites

New version frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites
New version frontpaged

Thanks, just was on armaholic and when my eyes saw "Advanced" and "Combat" and "Environment" I nearly took a dump in my pants.

Share this post


Link to post
Share on other sites

Does anyone have experienced very often happening desync when using ACRE2? We have played small mission on VTS recently with new version and all of us (9 ppl) had desync every now and then, not happening with TFAR which we are using atm (we want to switch to ACRE2 but we have many many problems with it). If anyone got a method to get rid of that desync then please contact me!

Share this post


Link to post
Share on other sites

Was all the API documentation moved? The links in OP no longer work.

Share this post


Link to post
Share on other sites

Don't know if this was ever answered but will there be in vehicle radios or a Vehicle Mount System where you'll be able say place a AN/PRC-152 and make it a AN/VRC-110?

Share this post


Link to post
Share on other sites

Yes, that is being worked on. It is part of a much larger attachment system that will let you build your own radio racks with external antennas and other devices.

Share this post


Link to post
Share on other sites

Hi,

We gave another try to ACRE2 tonight and I noticed that after dying and being in spectator mod (vanilla one), I was unable to speak with other dead players (also in spectator mod) in my channel because I wasn't able to unmute myself.

Is it supposed to behave this way ?

We were using AGM, maybe that's the reason.

Is there a way to solve that issue other than unpluging the ACRE plugin in teamspeak ?

Second question : Some time ago I asked about your plans concerning underwater simulation but got no answer, could you tell us more about it ?

I really like ACRE2 and I'm eager to use it in every game session. :)

Edited by Sparfell_19

Share this post


Link to post
Share on other sites

My teamspeak server keeps crashing for no apparent reason.

Now we bought a new slot server from gameservers, and the problem is still persistent.

The only thing in common is that it usually happens when we're in game with ACRE.

On the previous one, crashes occured randomly during the day, more often while in game.

On the new one it happens only when we're in game after a random amount of time.

Everything is up to date, cba, acre, and ts3.

Has anybody ever experienced this?

Edited by Chairborne

Share this post


Link to post
Share on other sites

Not sure what it could be since we do not run anything on the TS server. Maybe a bug in their message handling when too many messages are sent? But yea, not heard of anyone getting TS server crashes.

Share this post


Link to post
Share on other sites

I have no clue either, it started just a few weeks ago doing random crashes. :confused:

Share this post


Link to post
Share on other sites

Any news ? The radio stutter on buildings is still there. Likewise, radio messages do not arrive partially .

Share this post


Link to post
Share on other sites

There's a lot of progress in the background. Test build 2.1.0.811 is the latest and it has TONS of fixes as well as a couple of new features.

Unfortunately, stutter on buildings isn't fixed and might never be - There's no engine support for it so it's basically an improvisation. If it really bothers you, you can disable it with this line: ACRE_TEST_OCCLUSION = false

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×