Jump to content
Sign in to follow this  
zeedesertfox

Arma 3 crash to desktop

Recommended Posts

I can't start a new topic so i shall bung my issue onto this one, as mine is crashing to desktop also.

I brought this game last week

Single player = perfect, no issues atall

Multiplayer = haven't had a game yet, it crashes on role selection 99% of the time with a windows error msg, or if i'm very lucky i can get into the game for about 2mins and then it crashes. windows task manager struggles to end the process, and when it dose i cant use any internet browser or steam for a good 10mins due to end process not closing them down (i normally just reboot PC) it happens on any server. i have latest nvidea drivers and direct x, disabled firewall and anti-virus. verified game files.

its doing my nut here, all i want to do is play

Share this post


Link to post
Share on other sites

don't worry my man. it aint your computer its an arma 3 thing.

most people cant play because of the constant crashing in multiplayer mode.

Share this post


Link to post
Share on other sites

well i got that fustrated i formated my hdd, just put everything back on and it connected to the first server i tryed. maybe i had some conflicting software or some residue settings it didnt like.

fingers crossed this fix's it.

Share this post


Link to post
Share on other sites
well i got that fustrated i formated my hdd, just put everything back on and it connected to the first server i tryed. maybe i had some conflicting software or some residue settings it didnt like.

fingers crossed this fix's it.

i did the same thing till i joined the teamspeak on the servers i like to play on and verified that the game is pretty unplayable as it is constant crashing.

Share this post


Link to post
Share on other sites

Hey there, hoping someone could me out with the issues I've been having with A3 and crashing...I couldn't post a new thread so I thought I'd try my luck here since no one on the steam forums seem to reply very much...

Ok so here's some background on my PC and where I'm at:

Well I had ONE crash a month ago and haven't been able to get ARMA 3 running right since, it started while crashing when trying to connect to the a MP Server, it basically went all Display Driver Error crazy with lines and boxes jumping on the screen then went into complete crash mode, after trying all of the Display Driver Error methods of fixing (ReInstall Drivers/Beta, launch parameters, etc. none seemed to help) ran IOLO software scan and fixed the problem for a week or so then it was the same old problems once again...of course *sigh...(I heard that is a big mistake to install software like IOLO or Registry Cleaner?...not sure)

Then, I did a complete system Restart where I fully cleaned my files and PC, re installed Windows 8.1 and all that, now after I reinstall Steam/ARMA 3, all is running good on my PC, no Display Driver Errors or any BS, but then I start up ARMA 3 (After new Re-Install), tweaked some of video settings to LOW-NORMAL and went to Exit the game and it all crashed and burned and went back to Display Driver problems again!!!??? Also wondering if my ACER model PC Monitor could have anything to do with the crashes? (its about 6-7 years old but still has a 60 or 75hz Refresh Rate option dunno if that can cause Disp Driv Errors?)

Well anyway here is the PC I'm working with...I know AMD is a nightmare with ARMA 3 but for the first 3-4 months this game was running perfectly fine so idk if new Windows/Steam updates are causing my issues or what the hell is going on (hopefully I didn't blow my Graphics Card out already :( ....), been driving me nutty lately since I just bought this PC *Brand NEW less than a year ago...I

AMD FX-Series FX-6300 (3.50GHz)

8GB DDR3 500GB HDD

Windows 8.1 64Bit

AMD Radeon R7 250 2GB

*Or if anyone there are certain ways I need to set up my ARMA 3 GPU/CPU in the notepad or startup parameters to help rid me of this problem? Been surfing the net and forums for different solutions but not sure what exactly would apply to my situation?

Greatly Appreciate Any Feedback

Share this post


Link to post
Share on other sites

Just my own anecdotal experience, but my crashing turned out to be due to different custommissions, not Arma. After the main culprit was patched by the dev, I have ceased to have crashing issues. My point I guess is that if you are crashing in KotH or something else like that, it might not be BI Studios' fault.

Share this post


Link to post
Share on other sites

I got a similar problem, in singleplayer game works fine, if I host a multiplayer session i can play, but when i try to connect to a multyplayer server game close without errors, i got no strange errors in .rtp and i got no .mdmp .bidmp in my profile folder. I got no mod loaded.

Share this post


Link to post
Share on other sites

Although having no issues myself with the game, I'd like to know why no dump files are created when a crash is created, is it some requirement that needs to be met?

Share this post


Link to post
Share on other sites

I had issues in MP a while back. People were warping all around, ammo boxes floating in the air etc. I could join servers just fine, could play SP all day...

Turns out I had some corrupt or missing files. When verifying files, Steam downloaded 1 or 2 gigs of data. That would be my first stop-suggestion.

Strange that I could join servers just fine.

Share this post


Link to post
Share on other sites

Glad you got it sorta, wish it was that simple for some members here.

OP did the verification, see his first post and some his following posts of his issues, guy buys Arma3 beginning of Summer and still cant play beyond 3-5 mins in the game without it crashing.

As I told him in our recent conversation on steam chat that I still think its his graphics card as he has a Radeon, but then he says he plays Planetside and other games without issues

and at max settings, so then i think its something related to the engine and how his hardware or something is setup, cant say if he is missing anything as we did the verification, I

got him a program that can scan for registry errors, and defrag his hard drive, and we checked for latest versions of drivers, and many other things and to no avail, wtf is wrong?

I feel sorry for the guy as he really wants to play but I have the slightest idea of whats going on, only thing for feedback he can give for the

game is the RPT which he posted but the dump files do not get created and I personally would like to know why it does that.

If he had those files created then I think possibly he could have the chance of solving his issue if he were to submit them and get them looked at by

someone who has an idea about the engine and game files.

Share this post


Link to post
Share on other sites
I got a similar problem, in singleplayer game works fine, if I host a multiplayer session i can play, but when i try to connect to a multyplayer server game close without errors, i got no strange errors in .rtp and i got no .mdmp .bidmp in my profile folder. I got no mod loaded.

Today is working, or i got a possible solution. Meanwhile i tryed to go in "developer version" so i downloaded 1GB of updates, but I got the same problem, today I did a rollback to the official version, i got the same problem but now I got a hint, just before closing, i got a game message in chat about "updating Battleye" and "game close now" (or something similar). So i get to the Battleye download page i downloaded the ArmA 3 .dll inside the zip, and uncompress it inside the Battleye folder in ArmA 3. Now the game is working.

Hope this could help someone, I think Battleye try to close ArmA 3 to update itself, but something don't work and so it is not reopening ArmA 3.

Share this post


Link to post
Share on other sites

After 5 days without playng ArmA 3, again game close to desktop 10sec after I connect to a server , I tryed again the .dll trick, but I got no luck..

Edit, I needed to close beservice.exe and the game runs fine in multyplayer, I don't know if I need to close beservice.exe every time.. :confused:

Edited by DuM3D0
Find fix, maybe

Share this post


Link to post
Share on other sites

No luck with any recommendations so far. Its been 4 months I think. I've lost faith in the arma series.

Share this post


Link to post
Share on other sites

As we chatted on steam zeedesertfox if Bis can reply to you and tell you whats wrong then we can go from there, if not and you wasted your time, as I suggested on steam chat

try an Nvidia GPU over radeon, as your current specs exceed mine but im running 2 nvidias and have no crashing issues.

Share this post


Link to post
Share on other sites

Hey

I have a crash to desktop error too

My system i7 980 3.33ghz

12gb ram

nvidia gforce gtx 770

i have average 50 fps no lags no problems ingame

After the last patch i have this Arma 3 stopped working errors randomly after 15min 2h or 4h completly random allways same text in windows protokoll says:

Name der fehlerhaften Anwendung: arma3.exe, Version: 1.32.127.785, Zeitstempel: 0x543e7ada

Name des fehlerhaften Moduls: D3DCOMPILER_43.dll, Version: 9.29.952.3111, Zeitstempel: 0x4bf73239

Ausnahmecode: 0xc0000005

Fehleroffset: 0x001e5516

ID des fehlerhaften Prozesses: 0x1578

Startzeit der fehlerhaften Anwendung: 0x01cfee171848da98

Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Steam\steamapps\common\Arma 3\arma3.exe

Pfad des fehlerhaften Moduls: C:\Windows\system32\D3DCOMPILER_43.dll

Berichtskennung: 42bf5b4e-5a25-11e4-9cec-bd1cf12dd682

I tried repair arma reinstall directx deleted D3DCOMPILER_43.dll reinstalled directx updated my other drivers grafic etc. nothing seems to work any advice???

greez

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×