Jump to content
Sign in to follow this  

Missions not working on server

Recommended Posts

Guys, I really need some help over here. It's a nightmare, I just don't get this!

We rented a ArmA Gameserver a few months ago. Played some ArmA 2, especially user made missions from my friends. Worked all pretty good. A few weeks ago I switched the Server to ArmA 3.

Not a single Mission works properly!

- I't not possibly to switch waypoints via trigger. (I tried anything, isServer - isDedicate ...). Nothing. If it is a "hold" waypoint, you can't pass it. Nothing i tried made the waypoint disappear and the next waypoint appear.

- Choppers don't give a sh** about their task to pick up our squad. If I order a squad to enter a flying chopper without any waypoint, the chopper just waits there for god knows what. He's not coming down to us.

I have never encountered such a crap in ArmA 2, so I am overcharged with this one. I have no idea whats wrong. Those bugs just appear, wenn I upload my mission onto the server. In SP, everything works well.

Thanks in advance for any help.

Share this post

Link to post
Share on other sites

Dude you should check the version of the ArmA3 that is running on that server cause it sounds like it's a frikkin pre-alpha one...

Share this post

Link to post
Share on other sites

1.24 ... =(

1. Problem solved, I didn't know about the Multiplayer-Editor.

But choppers didn't respond to any transport orders.

Share this post

Link to post
Share on other sites

No, as I said: the choppers don't work properly: if you synchronise your own "GET IN" Waypoint with a "LOAD" Waypoint of an AI-Chopper, it doesn't work. The Chopper ignores this completly and simply flies ahead to this next waypoint. Even when I gave the GET IN CHOPPER Order via Menue to my AI-Soldiers , the Pilot simply ignores us. Like he just don't give a f*** :D

Works enverything fine in single player or local multiplayer. As soon as I upload this little testmission on my server, the AI becomes SKYNET und does whatever the hell it want to.

This crap is happening on two seperate ArmA 3 gameservers.


-> Affects all units, not only choppers, also cars and tanks.

-> BUT only the player! If my leader is AI, everything goes well. If I am the leader, the described problem occurs.

Edited by GAanimal

Share this post

Link to post
Share on other sites

Not to sound patronising, but this sounds to me like a mission design issue and not understanding the concept of locality in an MP scenario.

From what you have stated, you have come from a Single player environment

Mission design/coding is much more complex in the MP environment than it is in the SP environment.

You have the following nodes to think about

  • Server
  • Client
  • JIP client
  • Headless client (possibly)

You have timing issues in certain environments, for example Description.ext paramsarray is defined at a different time on the server than it is on the clients

Certain commands have to be run on the node where the object is local too.

Some commands should only be run on 1 machine and therefore the use of switches should be utlilised

  • IsServer
  • HasInterface
  • Isdedicated

Rather than rip into Arma3 with vague issues, it may be more prudent to take 1 issue at a time , get as much information as you can about the issue, eg by debugging your code and then accurately report the issue you are having, and ask for help with these issues in the relevant forums, eg the Mission editing forums

This forum is more to do with actual server issues and your problem doesnt sound like it is.

If you need help in debugging techniques, try this thread, it may help


Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this