Jump to content
Sign in to follow this  
haleks

Massi's Weapons Pack Audio Fix

Recommended Posts

Hey Pepe,

Thank you kindly for providing the sound-fix update.

Signing it for use on dedicated servers will be great as our community has to cancel nearly all of our current missions and loadouts otherwise and start over.

We have PM'd you with details.

Kind regards,

D

ExpBG

Share this post


Link to post
Share on other sites

I haven't got this to work, I overwrote everything fine but I still get the unsilenced guns sounding suppressed, but at least suppressed guns sound suppressed and aren't silent now (that i've noticed)

Share this post


Link to post
Share on other sites
I haven't got this to work, I overwrote everything fine but I still get the unsilenced guns sounding suppressed, but at least suppressed guns sound suppressed and aren't silent now (that i've noticed)

o_O Are you sure to be on 1.24? It should be the other way around...

Do you use any other mods?

About the keysigned, I'll most likely do those this week-end (maybe this afternoon).

Share this post


Link to post
Share on other sites

Nice work man, reckon you could take a stab at getting suddens' East vs West mod updated?

Share this post


Link to post
Share on other sites

Hey Pepe,

Regarding signing and server key.

If you did that this afternoon that would be fantastic.

Myself, and many others would be very grateful.

:)

D

ExpBG

Share this post


Link to post
Share on other sites
o_O Are you sure to be on 1.24? It should be the other way around...

Do you use any other mods?

About the keysigned, I'll most likely do those this week-end (maybe this afternoon).

Positive. The suppressed and unsuppressed guns i've tested have the same sound now.

Share this post


Link to post
Share on other sites
Positive. The suppressed and unsuppressed guns i've tested have the same sound now.

Could you post your RPT file next time you experience this?

@TheDee : Didn't had time to make them yet. :/

---------- Post added at 19:23 ---------- Previous post was at 19:21 ----------

Nice work man, reckon you could take a stab at getting suddens' East vs West mod updated?

Probably not ^^'

I have my hands full with various projects, and fixing configs isn't the funnier aspect of modding.

Sorry :(

Share this post


Link to post
Share on other sites
I'm still having an issue with the African Conflict mod.

My arms are a tad weird.

http://i.imgur.com/yFWZJOR.jpg (591 kB)

Looking at your screen, it seems that you are using more than one mod.

I doubt that just adding new config entries to weapons could cause such an issue - have you tried to run your mods one by one to isolate the cause?

Share this post


Link to post
Share on other sites

Hello! My English is not good so ...

I fix the 1.2 sound but still no soundne to isolate the cause?

Edited by TWRoach
error

Share this post


Link to post
Share on other sites
Could you post your RPT file next time you experience this?

@TheDee : Didn't had time to make them yet. :/

---------- Post added at 19:23 ---------- Previous post was at 19:21 ----------

Probably not ^^'

I have my hands full with various projects, and fixing configs isn't the funnier aspect of modding.

Sorry :(

No worries mate, if anybody wanted to have a go heres what i found... I wouldn't know what to do :/

File d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\config.cpp, line 86: .G_40mm_HE_M203: Undefined base class 'GrenadeBase'

Config : some input after EndOfFile.

Error reading binary file 'd:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\config.cpp'

Cannot register unknown string STR_STATE_HEALSOLDIER

Cannot register unknown string STR_STATE_FIRST_AID

Cannot register unknown string STR_UI_RADARRANGE

Cannot register unknown string STR_ACTION_LAUNCHCM

Cannot register unknown string STR_ACTION_NEXTCM

Cannot register unknown string STR_USRACT_ACTION_CONTEXT

Cannot register unknown string STR_USRACT_OPTICS_MODE

Cannot register unknown string STR_USRACT_ZEROING_UP

Cannot register unknown string STR_USRACT_ZEROING_DOWN

Cannot register unknown string STR_USRACT_NETWORK_DS_INTERFACE

Cannot register unknown string STR_USRACT_BULD_TERRAIN_RAISE_10CM

Cannot register unknown string STR_USRACT_BULD_TERRAIN_LOWER_10CM

Cannot register unknown string STR_USRACT_BULD_TERRAIN_RAISE_50CM

Cannot register unknown string STR_USRACT_BULD_TERRAIN_LOWER_50CM

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_0

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_1

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_2

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_3

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_4

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_5

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_6

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_7

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_8

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_9

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_10

Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_11

Cannot register unknown string STR_DISP_LEFT

Cannot register unknown string STR_DIFF_CAMERA_SHAKE

Cannot register unknown string STR_FREETRACK

Cannot register unknown string STR_ADDON_ACTIONS_INSTALL_CORE

Cannot register unknown string STR_ADDON_ACTIONS_INSTALL_MOD

Cannot register unknown string STR_ADDON_ACTIONS_PLAY_MISSION

Cannot register unknown string STR_ADDON_ACTIONS_TRY_ENTITY

Cannot register unknown string STR_ADDON_ACTIONS_TRY_WEAPON

Cannot register unknown string STR_MSG_ADDON_NOT_FOUND

Cannot register unknown string STR_MSG_ADDON_CANNOT_OPEN

Cannot register unknown string STR_MSG_ADDON_UNKNOWN_PRODUCT

Cannot register unknown string STR_INCOMPATIBLE_LOAD_GAME_ATTEMPT

Warning: CfgVehicles missing in PreloadConfig - may slow down vehicle creation

Warning: CfgAmmo missing in PreloadConfig - may slow down vehicle creation

Warning: CfgNonAIVehicles missing in PreloadConfig - may slow down vehicle creation

File d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\config.cpp, line 38: '/cfgAmmo/G_40mm_HE_GP25.multiSoundHit': Missing ';' prior '}'

File d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\config.cpp, line 86: .G_40mm_HE_M203: Undefined base class 'GrenadeBase'

Config : some input after EndOfFile.

Error 3 while parsing

Error in config d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\config.cpp

File d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\config.cpp, line 38: '/cfgAmmo/G_40mm_HE_GP25.multiSoundHit': Missing ';' prior '}'

File d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\config.cpp, line 86: .G_40mm_HE_M203: Undefined base class 'GrenadeBase'

Config : some input after EndOfFile.

Error 3 while parsing

Error in config d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\config.cpp

Cannot load font core\data\fonts\lucidaconsoleb8

Fonts file \core\data\fonts\lucidaConsoleB8 not found

Cannot load font core\data\fonts\lucidaconsoleb11

Fonts file \core\data\fonts\lucidaConsoleB11 not found

<anim = "d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\AK.rtm">

Obsolete CfgSkeletons for OFP2_ManSkeleton, move to model.cfg

No entry 'D:\Program Files (x86)\Bohemia Interactive\Tools\BinMake\Binarize\bin\config.cpp.CfgSkeletons'.

No entry '.OFP2_ManSkeleton'.

No entry '.skeletonInherit'.

'/' is not a value

No entry '.skeletonBones'.

Size: '/' not an array

Size: '/' not an array

Size: '/' not an array

No entry '.isDiscrete'.

'/' is not a value

</anim>

<anim = "d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\AK_GL.rtm">

</anim>

<anim = "d:\steam\steamapps\Convert animation d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\AK.rtm -> C:\Users\petey\AppData\Local\Temp\ARMAaddons\sud_gw_wpn\data\anim\AK.rtm

Convert animation d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\AK_GL.rtm -> C:\Users\petey\AppData\Local\Temp\ARMAaddons\sud_gw_wpn\data\anim\AK_GL.rtm

Convert animation d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\CarlGustaf.rtm -> C:\Users\petey\AppData\Local\Temp\ARMAaddons\sud_gw_wpn\data\anim\CarlGustaf.rtm

Convert animation d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\M16_GL.rtm -> C:\Users\petey\AppData\Local\Temp\ARMAaddons\sud_gw_wpn\data\anim\M16_GL.rtm

Convert animation d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\PK.rtm -> C:\Users\petey\AppData\Local\Temp\ARMAaddons\sud_gw_wpn\data\anim\PK.rtm

Convert animation d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\RPG7.rtm -> C:\Users\petey\AppData\Local\Temp\ARMAaddons\sud_gw_wpn\data\anim\RPG7.rtm

common\arma 3\@evw\addons\sud_gw_wpn\data\anim\CarlGustaf.rtm">

</anim>

<anim = "d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\M16_GL.rtm">

</anim>

<anim = "d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\PK.rtm">

</anim>

<anim = "d:\steam\steamapps\common\arma 3\@evw\addons\sud_gw_wpn\data\anim\RPG7.rtm">

</anim>

Creating texture headers file...

90 texture headers saved to file "C:\Users\petey\AppData\Local\Temp\ARMAaddons\sud_gw_wpn\texHeaders.bin"

w:\C_branch\Poseidon\Arrowhead\El\FileServer\fileServer.cpp(2513) : Assertion failed 'req->RefCounter()==1'

Share this post


Link to post
Share on other sites

wrong thread

sorry

Edited by maquez

Share this post


Link to post
Share on other sites

The audio fix has been signed for MP! :)

Don't forget to remove Massi' signature file for the configuration file only (mas_us_rifle_c.pbo.mas.bisign)!

Share this post


Link to post
Share on other sites
The audio fix has been signed for MP! :)

Don't forget to remove Massi' signature file for the configuration file only (mas_us_rifle_c.pbo.mas.bisign)!

I am still getting session lost when I do your update...

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

I have added this fix to the NATO SF and Russian Spetsnaz Weapons downloadpage, I figured people might like to see it together :)

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites
Hello. I tested the HK416 and the M4 and offers silent when we hear the sound of closure. In this configuration for example it doesn't work. http://i.imgur.com/klOZaPl.jpg

Yes, as stated in the OP, silenced weapons currently don't work; I'll have to fix the silencers whenever I can.

---------- Post added at 14:05 ---------- Previous post was at 14:03 ----------

We have also "connected" these pages to your account on Armaholic.

Thank you Fox!

Share this post


Link to post
Share on other sites

Anyone else seeing this?

Wrong signature for file c:\users\xx\documents\arma 3\@nato_russian_sf_weapons\addons\mas_us_rifle_c.pbo

Share this post


Link to post
Share on other sites
I'm still having an issue with the African Conflict mod.

My arms are a tad weird.

http://i.imgur.com/yFWZJOR.jpg (591 kB)

I am also getting this weird arm contortion. Does anyone have any ideas what has caused this?

Share this post


Link to post
Share on other sites

@Pepe Hal . For this error, try to put silencer's config in your weapons's config (example mas_us_rifle_c>m4> full item us. ) with soundTypeIndex = 1;

In all cases, it is preferable that you have your own silencor sounds.

I hope to have helped you. Bye. :)

Share this post


Link to post
Share on other sites

Did you put "mas_us_rifle_fhq_c.pbo" into "@mas/addon" folder?

Try it if you didn't. sorry for my bad English

Share this post


Link to post
Share on other sites

Thanks RaZorLegend! ;)

Someone on Massi's thread gave me the same solution; I just have to find some time to do it (right now I'm struggling with some performance issues >_<').

Share this post


Link to post
Share on other sites

here is tip for silencer fix

class ItemInfo: InventoryMuzzleItem_Base_F
{	
	mass=7;
	class MagazineCoef
	{
		initSpeed = 0.8;
	};

	class AmmoCoef
	{
		hit=0.8;
		visibleFire=0.2;
		audibleFire=0.4;
		visibleFireTime=0.5;
		audibleFireTime=1.0;
		cost = 1.0;
		typicalSpeed= 0.8;
		airFriction = 1.0;      
	}; [b]
	class MuzzleCoef
	{
		dispersionCoef="0.8f";
		artilleryDispersionCoef="1.0f";
		fireLightCoef="0.1f";
		recoilCoef="1.0f";
		recoilProneCoef="1.0f";
		minRangeCoef="1.0f";
		minRangeProbabCoef="1.0f";
		midRangeCoef="1.0f";
		midRangeProbabCoef="1.0f";
		maxRangeCoef="1.0f";
		maxRangeProbabCoef="1.0f";
	};[/b]//added in 1.24 - without it sound doesnt work

	muzzleEnd = "zaslehPoint"; // memory point in muzzle supressor's model
	alternativeFire = "Zasleh2";  // class in cfgWeapons with model of muzzle flash

	[b]soundTypeIndex = 1;[/b] - added in 1.24
	inertia=0.2;
};

Share this post


Link to post
Share on other sites

Thanks a ton Reyhard! This is gonna make things easier for me!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×