Jump to content
silola

DAC V3.1 (Dynamic-AI-Creator) released

Recommended Posts

will Dac work on Tanoa? I can make it work on Altis and Stratis, but no go for tanoa.

 

Should works properly. I only supose that in some places where is a lot of objects DAC could have problems with spawn WP, but it can be fixed in DAC_Config_Waypoints. ;)

  • Like 2

Share this post


Link to post
Share on other sites

I have a problem with giving custom Waypoints - you said "give a Logic Waypoints in a Zone.." - but I cannot give Waypoints to a Logic Module 

Share this post


Link to post
Share on other sites

I have a problem with giving custom Waypoints - you said "give a Logic Waypoints in a Zone.." - but I cannot give Waypoints to a Logic Module 

 

This functionality is no longer supported in the 3D editor. BI removed it.

Share this post


Link to post
Share on other sites

Guys, I am too stupid for triggers. I am trying to set up a zone which builds up only if player enters the trigger area. Whatever I do, it will not work.

 

Without the player condition:

None, Anybody, Present, Repeatable - Condition: time>1

Works

 

With player condition:

None, Anybody, Present, Repeatable - Condition: ((time>1)&&(player in thisList))

Code starts, but no spawning

 

Activation code: fun = ["z1",[1,0,0],[20,1,200,50],[],[],[],[0,0,0,0]] spawn DAC_Zone

After entering the trigger zone, a hint appears! "Dac 3.1b initializing"... but DAC does not spawn any units. It does not display a hint afterwards, which it does normally do after having done the job.

 

 

I would start by have the DAC-zone disabled at game start. Then have a trigger zone which players activate and in that trigger you call "DAC_Enable" (can't remember the call exactly) on that DAC-zone.

 

I had my zones setup like that. 1/3 of the DAC-zones would be enabled at start and the other 2 would get enabled later by 2 different timers. So it seemed like AI got reinforcements. Worked well.

  • Like 2

Share this post


Link to post
Share on other sites

To me it is useful to permanently move heli waypoint zones more or less on top of the SP player.

I mostly use this in Ravage+DAC missions I like to create.

 

In case anyone is interested. Can be put into a game logic and saved as custom composition for later use.
 
Explanation for below call:
- Waypoint zone (ellipse of min. 800m, max. 2500m) moves every 150 seconds- ish. Not sure if it's a useful value for DAC
   - 80% chance that it moves at all at any test
   - 70% chance that it is offcenter to the player object (i.e. 30% that it exactly on players head)
   - If offcenter, 45% chance of being at a total random place (but center of zone is on land)
 

comment "zoneName, [sizemin, sizemax], changeAfterAbout, [probDoChange, probOffPlayerCentre, probWayOff(ifOff)]";

0 = [z4, [800,2500], 150, [0.8, 0.7, 0.45]] spawn 
{ 
   private ["_pos","_dir","_dist","_overland", "_min", "_max", "_size1", "_size2", "_sleep"]; 
   _sleep = _this select 2; 
   sleep random[0.75 * _sleep, _sleep, _sleep]; 
   _min = _this select 1 select 0; _max = _this select 1 select 1; 
   if (_min == 0) then {_min = 0.05 * worldsize}; 
   if (_max == 0) then {_max = 0.1 * worldsize}; 
   while{true} do 
   { 
      _overland=false; _pos = position player; 
      if((random 1)<(_this select 3 select 0)) then 
      { 
         _size1 = _min + random(_max - _min); 
         _size2 = _min + random(_max - _min); 
         if((random 1)<(_this select 3 select 1)) then 
         { 
            if((random 1)>(_this select 3 select 2)) then 
            { 
               _dir = random 360; 
               _dist = 0.5 * (_size1 min _size2) + random (0.5 * (_size1 min _size2)); 
               _pos = [(_pos select 0) + cos _dir * _dist, (_pos select 1) - sin _dir * _dist, 0]; 
            } 
            else 
            { 
               while {!_overland} do { 
                  _pos = [random worldsize, random worldsize, 0]; 
                  _overland = !(_pos isFlatEmpty [-1, -1, -1, -1, 0, false] isEqualTo []); 
                  sleep 0.02; 
               }; 
            }; 
         } 
         else 
         { 
            _pos = position player; 
         }; 
         [_this select 0, _pos, [_size1, _size2, random 360],0,0,0] call DAC_fChangeZone; 
      }; 
   _sleep = _this select 2; 
   sleep random[0.75 * _sleep, _sleep, 1.5 * _sleep]; 
   }; 
};

Share this post


Link to post
Share on other sites

Can someone help with DAC_Res_Side cause I'm not sure what it really does.

So the docs says it sets the relation between guer and other forces but isn't that already manager by the mission editor alliance thing?

Second is that after i changed it to 2 all kind of strange things started to happen and only on the dedicated server.

First is groups stopped building-up. Second we started to hear some radio chatter of the ai which is DAC sounds afaik.

I'm not sure how that can be caused by DAC_Res_Side but after I switched it back to 0 dac returned back to normal.

Share this post


Link to post
Share on other sites

Can someone help with DAC_Res_Side cause I'm not sure what it really does.

So the docs says it sets the relation between guer and other forces but isn't that already manager by the mission editor alliance thing?

Indfor friendly to

0-Opfor

1-Bluefor

2-Nobody

Did you change also a relation between guer and others in Eden Editor Attributes?

Share this post


Link to post
Share on other sites

Indfor friendly to

0-Opfor

1-Bluefor

2-Nobody

Did you change also a relation between guer and others in Eden Editor Attributes?

I always have indi relation to nobody in my framework and didn't have any problems before even when using DAC_Res_Side = 0. But after changing DAC_Res_Side to 2 dac started to act weird (that's why I even changed it to 2, cause i noticed that docs say that if you have indi relation to nobody this should be 2). I wound understand if units stopped attacking someone or used the same waypoints or stuff like that, but groups stopped building-up when you get close to them and we started to hear ai radio chatter, I'm not sure that's related.

Share this post


Link to post
Share on other sites

is this compatible with mods that modify AI tactics? like VCOM ai? it lets the AI plant mines and etc. , drive better, act smarter, be able to breach and clear buildings, etc.

Share this post


Link to post
Share on other sites

Second is that after i changed it to 2 all kind of strange things started to happen and only on the dedicated server.

First is groups stopped building-up. Second we started to hear some radio chatter of the ai which is DAC sounds afaik.

 

 

I tested it on dedicated serwer by using Nationalist Troops from RHS with DAC_Res_Side = 2 and everything was ok. All grups bulid-up and i didn't hear any radio chatter, so it could be local problem. Maybe is it confict with any other script in your mission?    

Share this post


Link to post
Share on other sites

I tested it on dedicated serwer by using Nationalist Troops from RHS with DAC_Res_Side = 2 and everything was ok. All grups bulid-up and i didn't hear any radio chatter, so it could be local problem. Maybe is it confict with any other script in your mission?    

Did you play as INDI and enemies were WEST? Cause it worked fine before when I was playing WEST and enemies were EAST. I probably should've mentioned this before.

Share this post


Link to post
Share on other sites

Did you play as INDI and enemies were WEST?

I was WEST vs INDI.

 

 

Here you have a part of my DAC_Config_Creator.

        if(isNil "DAC_STRPlayers")	        then {          DAC_STRPlayers		= ["s0","s1","s2","s3","s4","s5","s6","s7","s8","s9","s10","s11","s12","s13","s14","s15","s16","s17","s18","s19","s20","s21","s22","s23","s24","s25","s26","s27","s28","s29","s30","s31","s32"]};   
	if(isNil "DAC_AI_Count_Level")	        then {		DAC_AI_Count_Level      = [[2,3],[2,2],[3,3],[4,5],[6,7],[6,6]]		                                }; 
	if(isNil "DAC_Dyn_Weather") 	        then {		DAC_Dyn_Weather		= [0,0,0,[0, 0, 0],0]						                }; 
	if(isNil "DAC_Reduce_Value") 	        then {		DAC_Reduce_Value	= [900,1000,0.3]							        }; 
	if(isNil "DAC_AI_Spawn") 		then {		DAC_AI_Spawn		= [[10,5,5],[10,5,15],0,120,250,0]			                        }; 
	if(isNil "DAC_Delete_Value") 	        then {		DAC_Delete_Value	= [[1000,1000],[1000,1000],6000]		 	                        }; 
	if(isNil "DAC_Del_PlayerBody") 	        then {		DAC_Del_PlayerBody	= [0,0]										}; 
	if(isNil "DAC_Com_Values") 		then {		DAC_Com_Values		= [0,1,0,0]									}; 
	if(isNil "DAC_AI_AddOn") 		then {		DAC_AI_AddOn		= 1										}; 
	if(isNil "DAC_AI_Level") 		then {		DAC_AI_Level		= 4		    								}; 
	if(isNil "DAC_Res_Side") 		then {		DAC_Res_Side		= 2										};  
	if(isNil "DAC_Marker") 			then {		DAC_Marker		= 0										};  
	if(isNil "DAC_WP_Speed") 		then {		DAC_WP_Speed		= 0.01										};  
	if(isNil "DAC_Join_Action")		then {		DAC_Join_Action		= false										}; 
	if(isNil "DAC_Fast_Init") 		then {		DAC_Fast_Init		= false										}; 
	if(isNil "DAC_Player_Marker")	        then {		DAC_Player_Marker	= false										}; 
	if(isNil "DAC_Direct_Start")	        then {		DAC_Direct_Start	= false										}; 
	if(isNil "DAC_Activate_Sound")	        then {		DAC_Activate_Sound	= false										}; 
	if(isNil "DAC_Auto_UnitCount")	        then {		DAC_Auto_UnitCount	= [0,0]										};   
	if(isNil "DAC_Player_Support")	        then {		DAC_Player_Support	= [10,[4,2000,3,1000]]						                }; 
	if(isNil "DAC_SaveDistance")	        then {		DAC_SaveDistance	= [100,["DAC_Save_Pos"]]					                };    
	if(isNil "DAC_Radio_Max")		then {		DAC_Radio_Max		= DAC_AI_Level								        };  
		

Share this post


Link to post
Share on other sites

My config is fairly similar. I'm not sure why that bug happened, but after I changed DAC_Res_Side back to 0 it was fixed.

I'll do some more tests later and record a video and try to create a repro mission, just DAC and vanilla arma. And try to look through the dac source code.

Share this post


Link to post
Share on other sites

Hi Folks,

RE: Arty Configs...

So if I understand the instructions correctly - I can define real in game artillery pieces that can be called on by both player and AI troops ? I'll see them fire if adjacent to their position ?

So then the range of a given artillery piece is relative to the placement in the editor ?

Would anyone know the approximate respective ranges for 81mm and 105mm mortars... Same for a 155mm Howitzer ?

How exactly does the player initiate an artillery strike ? I've read the manual and there is a script call defined - but what do you use to run that script ?

Thanks...

Regards,

Scott

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

Hi Folks,

Found this chart - might be helpful to anyone messing with mortars in the arty conf files...

One more question - is there an easy way to setup this file to almost guarantee firing - for testing or perhaps night illumination ?

56dc2f096ce4659df7135a453fa0812a.jpg

Regards,

Scott

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

The DAC mod throws an error message at mission start, in latest DEV build... something like "[] - config.bin\cfgpatches\dacSource: Not an array"...

Not exactly sure if it's solved, but I think so. I removed

name = "DAC_Source.pbo";
mail = "silola@freenet.de";
from dac_source.pbo\config.cpp and now the error is gone... Maybe some attribute is not working any more...
  • Like 1

Share this post


Link to post
Share on other sites

Is it possible to have helis respawn on camps?

Really great addon, wish this was updated with new features and optimizations from new script commands.

Share this post


Link to post
Share on other sites

could somebody pls help me on how to use  dac_config_weapons.sqf I looked everywhere but can't find anything...
thx in advance

Share this post


Link to post
Share on other sites

could somebody pls help me on how to use  dac_config_weapons.sqf I looked everywhere but can't find anything...

thx in advance

I am not sure if it works in Arma 3 - I might be wrong but I think it was just copied from A2 version and not ported to A3.

  • Like 1

Share this post


Link to post
Share on other sites

Did you play as INDI and enemies were WEST? Cause it worked fine before when I was playing WEST and enemies were EAST. I probably should've mentioned this before.

 

 

I've been experiencing an interesting issue as of late. (DISCLAIMER: Firstly just to say i haven't used DAC for a couple of A3 builds so im not 100% when this has taken effect. I am also using various pubic and private mods, however nothing of note that should effect the issue.)

 

It would seem since one of the latest A3 updates something has triggered an issue with our DAC configs similar to what your getting.

 

I setup a mission using the same DAC config we use internally and have done since 3.1 was released. For simplicity this config comes with "DAC_Res_Side = 2" as (from my understanding) unless you want IndFor to be friendly to one side this should just make them enemy to anyone. In the mission I use some scripts to generate new DAC zones after the mission has started. When these zones are generated, the OpFor AI would refuse to engage the BluFor players.......

Some further testing proved that i could generate DAC zones at the start of the mission, and the AI would engage OpFor. But, as soon as the new zones are generated all OpFor AI (new zones and current) would suddenly act as if they are friendly to BluFor...

 

I have tried replacing our custom configs with the default DAC 3.1 configs and still get the same issue as soon as the DAC zone has generated. 

The only things i haven't tested yet (and will do at some point) are using DAC on its own without mods, or loading an old mission with our internal configs that i know works.

Would be interesting if anyone else is getting similar issues?

The fix i found was just to set "DAC_Res_Side" to a different value.

 

Share this post


Link to post
Share on other sites

i cannot seem to figure out how to get all spawned dac groups to converge on one spot?  here is my master zone:              

 

 fun=["z1",[1,0,0],[2,2,10,1],[],[],[],[0,0,0,0,1]] spawn DAC_Zone  

 

and here are my other zones for an example:  

 

 fun=["z5",[1,0,0],[2,2,10,1],[],[],[],[0,0,0,1,1]] spawn DAC_Zone

 

what do i have to change to get all my zones to attack my position on the map?  this is a wave attack mission on a base.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×