Jump to content
Αplion

[Tutoria] - Importing ArmA2 vehicles to ArmA3

Recommended Posts

On 30/1/2017 at 6:01 AM, DayZ Addict said:

When I repath things in mass texture rename it still is red even thought it is 100% correct.  Fixes anyone? @LCpl Baev @logan83

I don't know if you got this sorted but I had the same problem. What I did to fix it was to go into File->Options->Path for textures and in the Value box bellow added P:\

Share this post


Link to post
Share on other sites

When I try to edit the .rvmat files with Notepad++ they look like i would try to edit a DLL with notepad. Lots of different symbols only.
 

Spoiler

 raP              ambient                @diffuse               €?forcedDiffuse
×£;
×£;
×£;    emmisive    ?   ?   ?  €?specular                 specularPower     renderFlags NoZWrite  AddBlend PixelShaderID Normal VertexShaderID Basic      


I'm a total newbie to addons but I really want the armored SUV and some cars from Arma 2. Is it any easier way? It's for a small faction and I rather not use any dependencies.
Thanks for this tutorial!

Share this post


Link to post
Share on other sites

So I've been trying to import the F-35B from Arma 2. I haven't fully followed the tutorial here (as its for cars), but I suspect the physx stuff is what I need to do to make the wheels work. Right now its basically restricted to VTOL operation...

That's not my main concern now, my main question is how I get the animations on the vehicle to work... Right now the gear don't move, control surfaces don't move, the nozzle doesn't move when its in VTOL mode, etc.

Do you have any guidance on what I need to do to make those animations work?

 

pics of the "port" so far (I've tweaked the model a bit, plan to do a more extensive tweak if I can get the rest working):

Spoiler

0B41663824060C46478C83AEFB6C1DE468EAE212

 

FAA7A7479DCCB36F72B9DB059821313FAF017A3D

 

C7A7F3399B038471347060D305EC18C465F01FB5

 

B03348BB0C0E4CBC18EC6C72DF1042AA60489A87

 

14BFE5CC83F386D5D8C14FE08C6F05A3BF752CB8

 

3C269EF554531299216DCA916EE0825F0D3F4EEB

 

 

 

Share this post


Link to post
Share on other sites

Firstly look here you need to make sure you have named selections of the things you want to move.  As in Flap_R, Flap_L, Rudder_L etc.. you then need to create the animations.  If you have these already in your model.cfg as you say this is a port then you need to check that your named selections have been created in object builder and are present on All your LODs also include view-pilot so you can see them when flying.

Share this post


Link to post
Share on other sites

I'm pretty sure that the LODs have the same named selections... might it be a problem of inheritances... since I assume the plane and vehicle configs that it inherits from are different between arma 2 and 3?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×