Jump to content
Sign in to follow this  
reyhard

East Static Weapons Pack

Recommended Posts

Hey Reyhard. Love the details in your work. I've noticed one issue/feature with your tracked models though; turning while moving with the tracked vehicles almost stop the vehicle, drops the speed down to 10km/h, unlike in any other tracked vehicles (arma 3 vanilla and other mods). Is this intended behaviour?

Cheers, Peg

Edited by Peguus

Share this post


Link to post
Share on other sites
I meant if BIS tanks has same issue. Now it's quite hard for me hunt down that bug as I'm not experiencing such tank behaviour :/

Thanks for your efforts, Ok so what about T-72 behavior? as they won't still fire on other enemy tanks? and also other mentioned bugs, anyway you did fantastic job on sounds such as sounds of movement, sabot load and etc, so fixing these issues make your mod best tank pack release for ArmA 3, also @peguus mentioned one the other current issues thanks to him for report I was wonder that maybe it's not an issue and is only because of old tanks mechanics!

Share this post


Link to post
Share on other sites

Yeah, I'd think that kind of behaviour would be accurate to T-55 family, and maybe early T-72's. From T-72B's and BM's I'd expect to steer and turn properly

Share this post


Link to post
Share on other sites

Your static weapon addon is great! Do you think you would be able to add an M224 60mm mortar similar to the one used in Arma 2 ACE mod? You wouldn't have to add all the range tables and firing solutions, just put an artillery computer on it and use a beafed up grenade launcher explosion value for it.

Share this post


Link to post
Share on other sites

hey man im enjoying your addons.

But i have found a small issue though with the Arty guns (d30 and M119). When ever i use Ai to fire the guns, with the command {Gun1 DoArtilleryFire [getmarkerpos "mrk10", "RDS_30Rnd_122mmHE_D30", 3];}. they start shooting off the 3 rounds im asking for but, they sighting of the gun is completly wrong. Instead of pivoting the gun up 60 degrees they only do 3 or 4 degrees making it look that they are just shooting straight forward. So they do sight the gun but not correctly (in an extreme way). This is just with AI though if i jump in the gun and use the arty computer it does what it is supposed 2. Also I red a few pages back that the mortars are suffering from the same bug aswell (but i havent personaly tested them out yet) :)

@Reyhard: First off, love the mod!

Secondly, after the most recent A3 patch I've noticed something strange happening when an AI controlled D-30 tries to fire via a script. Before the patch I used something along the lines of:

d30 commandArtilleryFire [ markerPos "someMarker", getArtilleryAmmo [d30] select 0,1];

..and this worked perfectly. But after the patch it seems that the AI no longer compensates for distance and doesn't adjust the bore. Instead it just shoots straight ahead. Also the Podnos 2B14 doesn't seem to want to fire at anything via a script. I tried a few of BIS' artillery units and they seemed to work.

So either I'm being a dummy and not doing it right, or something in the patch changed something. If it is the former and anyone knows a good solution I'd appriciate any help I could get. If it's the latter I thought I'd let you know at least.

Thx for a great mod

Share this post


Link to post
Share on other sites

I will take a look into that.

btw guys, I've done same thing twice...

...once again I uploaded old rar package :D so agm&fcs fixes are not in that rar

https://mega.co.nz/#!9pM00DrQ!R3-19huqS-747kE4nYMtD0P893VJE0KS42IljuO9aWY hopefully this should be correct one now

please report if t72 laser bug is gone

Share this post


Link to post
Share on other sites

Fixed version frontpaged on the Armaholic homepage.

==================================================

You are not registered on Armaholic, or at least not that we are aware of. In the future we offer the possibility to authors to maintain their own pages.

If you wish to be able to do this as well please register on Armaholic and let me know about it.

This is not mandatory at all! Only if you wish to control your own content you are welcome to join, otherwise we will continue to follow your work like we have always done ;)

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

For the M119 and the D30 artillery guns, is it possible for you to put the Solution and Elevation Control readouts that are on the vanilla artillery pieces? Currently the M119 and D30 only display the crosshairs, which means you can basically only fire artillery through the BI Point-and-Click system, or use AI. If we could somehow get the readouts enabled on them then people could actually run the guns a bit more realistically.

Picture for reference of the readouts

Share this post


Link to post
Share on other sites

I can't seem to do any damage with these tanks to any of the armored vehicles of vanilla A3. Why is ammunition so weak?

Share this post


Link to post
Share on other sites
I will take a look into that.

please report if t72 laser bug is gone

text from imtranslator.net/compare/russian/to-english/translation/

Hello. Yes, Т-72 now attacks other tanks, - BIS-fantastic-model tanks, - “Slammer†and other. But

AI all BMP – bugs. AI ПТУР (Malutka, Konkurs) – bugs. AI BMP ПТУР does not attack armor. I did

not see, that AI BMP, using ПТУР, attacked armor. Thanks.

Share this post


Link to post
Share on other sites

I can't seem to get AI tanks to load, only empty. All the add-on load but if I try try to start/preview with an actively loaded AI tank, I get:

Cannot open object caf_wp_weapons\ak_74.p36

And when I try to add, even an empty tank such as a BMP2 I get:

No entry bin\config.bin/cfgWeapons/caf_AK74/FullAuto.StandardSound

I went though each add-ons page at Armaholic and grabbed the required addons shown at the bottom of each page as far as I'm aware. What I downloaded and added to my Mod folder is shown in bold below.

I'm also running CBA Release Candidate 4.

This add-on pack looks great, I'm dying to get it to work.

tanki_v125a

Kae_SZ_0.4.1

RDS_Tank_SZ_Extension

RDS_StaticW_CAG

statyczne_v111

RDS_Tank_CAG_Extension

Patch1

Patch2

Sound-Hotfix

Edited by starstreams

Share this post


Link to post
Share on other sites
I can't seem to get AI tanks to load, only empty. All the add-on load but if I try try to start/preview with an actively loaded AI tank, I get:

Cannot open object caf_wp_weapons\ak_74.p36

And when I try to add, even an empty tank such as a BMP2 I get:

No entry bin\config.bin/cfgWeapons/caf_AK74/FullAuto.StandardSound

I went though each add-ons page at Armaholic and grabbed the required addons shown at the bottom of each page as far as I'm aware. What I downloaded and added to my Mod folder is shown in bold below.

I'm also running CBA Release Candidate 4.

This add-on pack looks great, I'm dying to get it to work.

tanki_v125a

Kae_SZ_0.4.1

RDS_Tank_SZ_Extension

RDS_StaticW_CAG

statyczne_v111

RDS_Tank_CAG_Extension

Patch1

Patch2

Sound-Hotfix

Are you actually running aggressor mod? because it's complaining about not finding classes from that mod

Share this post


Link to post
Share on other sites
Are you actually running aggressor mod? because it's complaining about not finding classes from that mod

Yes,

EDIT: Sorry, double posted.

Edited by starstreams

Share this post


Link to post
Share on other sites

Still not working, I'm getting No entry bin\config.bin/cfgWeapons/caf_AK74/FullAuto.StandardSound

I've been installing add-ons for over 10 years, I'm not new to it. The Armaholic pages are either not listing the complete list of needed files, or wrong versions. Later, after the fact, I went to this page and grabbed all the files and put them in my @RDS mod folder, and I'm still getting the error. Some of the versions at the BIS link above were older then the ones at Armaholic so I left the newer files, Did NOT overwrite. Also, there were missing files that got added when I extracted the BIS hosted filesto my folder, that were not included at in the zip/rar files at Armaholic. I just wanted the tanks, but there's all these dependency's. What am I doing wrong? Should I just drop on bomb on my computer and start over? lol :icon_mrgreen: Maybe grab the files from here? My gosh.

Here is a screenshot of my RDS add-ons folder and all the files in it.

www.pyramid-of-wisdom.com/addons.jpg

Edited by starstreams

Share this post


Link to post
Share on other sites

The question is: have you added the CAF_Aggressors sound fix patch? This error message is due to A3 patch 1.24 and post bootcamp DLC... indeed armaholic should link that as well, but you only need CAF_Aggressors, and its fix, if you use RDS East Weapons & Tanks with the caf-aggressors optional pbo, if you take it out, dependancy will end =)

Share this post


Link to post
Share on other sites
;2793704']The question is: have you added the CAF_Aggressors sound fix patch?

Thank you for your support on this Corporal_Lib' date=' and to Kerc Kasha as well.

It looks you're right, I was missing CAF_Aggressors sound fix patch. Thank you so much!

What confused me was that I had grabbed another sound fix thinking it was the same thing, probably because I was rushing.

Turns out it was for the South Zagorian Army. See bottom left of page here

However, This BIS Page should have all needed fixes since the OP took the time to list these two patches: 1 2 Why is the sound fix not there?

Another question just for my own knowledge: How is Aggressors titled as a mod when there are no factory files being overwritten, or separate game loaders to launch the mod? Wouldn't this just be called an add-on? I'm only questioning this because perhaps there are other files to get the full use of this title? Everything is loading great now.

Thanks again! So happy to have BMP tanks, and US solders again!

On a side note: Another few must have add-ons

F18 Nato Hellcats ATI A-10 ..or the A10-C, can't remember which one I tested.

Edited by starstreams

Share this post


Link to post
Share on other sites

Issues:

Most of available tanks rotate their turret very slowly.

Also, T-72 doesn't use main cannon at all.

BMPs tend to flip over.

Share this post


Link to post
Share on other sites

This is a great pack, however, the vehicles are only available for the independents :( Is there anyway you have the same tanks but in the Opfor category as well? I say this because I made a mission where Opfor soldiers were using empty BMP-2's and T-55's but whenever myself (an independent soldier) destroyed them, my own teammates turned and killed me because I destroyed an Independent tank.

---------- Post added at 03:23 ---------- Previous post was at 03:21 ----------

The old T-72A's and B's as well as the T-55's have hand cranked turrets I beleive, so the turret rotation should be quite slow.

Share this post


Link to post
Share on other sites

Just posting to confirm earlier reports that AI-controlled mortars will not fire at all using scripting commands such as commandArtilleryFire.

Share this post


Link to post
Share on other sites

The static weapons pack has a conflict between it and AiATP. When play Sahrani or Takistan, it'll cause dedicated servers to crash, but clients won't.

Share this post


Link to post
Share on other sites

It seems I was wrong in relation to Sahrani crashing. RDS static weapons is not the cause, it's just a catalyst that makes crashes happen more frequently when those objects are in the mission.

Edited by Tinter

Share this post


Link to post
Share on other sites

The D30 isn't compatible with the artillery module of the MCC when used by AI. The guns will fire in a straight line instead of using the fire solution.

Any idea why?

Also, could you add a manual elevation and direction HUD ?

Share this post


Link to post
Share on other sites

Hey just went back to play in arma 2 a bit and was wondering if you could port the T-72M4 CZ from the Czech Republic DLC and put it in Blufor/NATO. It is a high tech T-72 which I personaly would like in the game. If possible. Also there is the T-90 from the Russians. You could put that in Redfor/CSAT. Just some feedback. I have been playing with a Czech Republic mod and its missing a tank to go with it :P Great work with the mod, keep it up.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×