Jump to content
Sign in to follow this  
theebu

C-130J Port Release

Recommended Posts

So after much thought I have decided to release the port of the C-130J from Arma 2. This was originally just for the @CAF pack, but I have received a lot of requests for it.

Features:

  • 2 variants- One for transporting soldiers (36) one for transporting cargo using scripts (empty)
  • Fully functional incoming missile warning and chaff/flare counter-measure (300rd)
  • Walk-able interior and working ramp
  • Working HUD

http://www.theebu.com/ebu_c130/2014-02-19_00003.jpg (180 kB)

http://www.theebu.com/ebu_c130/2014-02-19_00004.jpg (275 kB)

http://www.theebu.com/ebu_c130/2014-02-19_00005.jpg (113 kB)

http://www.theebu.com/ebu_c130/2014-02-19_00006.jpg (156 kB)

http://www.theebu.com/ebu_c130/2014-02-19_00007.jpg (272 kB)

2014-02-19_00008.jpg

2014-02-19_00009.jpg

2014-02-19_00010.jpg

http://www.theebu.com/ebu_c130/2014-02-19_00011.jpg (129 kB)

Planned updates:

Fix gear issue

Known Issues:

Gear sometimes won't go up

Credits:

BIS for the original model, textures and config.

Change log:

Changelog v 1.2

  • HUD applied to copilot seat, HUD is now on pilot's helmet visor.
  • Transport: added 12 more seats to fit 36 passengers
  • Transport: changed the get-in positions. Crew door, Bottom of ramp, top of ramp, rear side doors.
  • Tweaked viewpilot settings.
  • Added options to control each door. (Front, Left & right)
  • Ramp should be 100% walk-upable now.

Changelog v 1.1

  • Added: Copilot seat with access to controls
  • Added: Collision/ nav and landing lights
  • Server Key
  • Fixed: Cargo ejecting in flight - for now enter / exit cargo is at rear of aircraft
  • Fixed: Cargo ramp open/close speed - Now takes longer
  • Fixed: Rvmat errors
  • Fixed: Cargo seats getting into cockpit - now only cargo seats in rear
  • Now in standard @folder setup for standalone mod

Edited by theebu

Share this post


Link to post
Share on other sites

What did you add into the IgiLoad script so that we can use this with supplies and such?

And thank you so much for this! We have been needing this for a while now.

Edited by HitmanTwoActual

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

==================================================

You are not registered on Armaholic, or at least not that we are aware of. In the future we offer the possibility to authors to maintain their own pages.

If you wish to be able to do this as well please register on Armaholic and let me know about it.

This is not mandatory at all! Only if you wish to control your own content you are welcome to join, otherwise we will continue to follow your work like we have always done ;)

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Really nice, thanks Theebu. :)

One video and one error.

Cannot load surface info ebu_c130\DATA\rvmat\armor_30mm_plate.bisurf
Warning Message: Cannot load texture ca\data\env_land_co.paa.

Share this post


Link to post
Share on other sites

Hi there, great port. I was wondering if any of you guys had any issues with the lights not working? (Landing lights and collision lights)

Share this post


Link to post
Share on other sites

New mod available at withSIX. Download now by clicking:

@ebu_c130.png

@ theebu:

Soon you will be able to manage the promo pages of your content on our web platform and publish new content yourself.

To do so, please hit 'this is me' button on the page while logged in and you will get connected to your work.

For now you can send new content or releases our way through withsix.wetransfer.com or add your notification at getsatisfaction.withsix.com.

Share this post


Link to post
Share on other sites

Nice to see a transport plane in arma again.:)

The cargo version seems to have throttle issues. Can't get the plane to move when placed on ground.

Engines start up but the throttle won't work.

When placed as 'flying' in the editor everything works fine.

Share this post


Link to post
Share on other sites

Hi !

At first, we thank you for releasing this awesome airplane that I really missed.

We tried to practice airborne operations and we encountered the following problem : every paratrooper is dying when he's jumping because he strikes the rear part of the airplane.

The freefly trooper appears inside the airplane, and even if the ramp is open, he dies.

On the other hand, the pilot doesn't encounter this problem.

I think that one way to fix that could be to define the same "jumping place" for every passenger exactly where the pilot's "jumping place" is.

Share this post


Link to post
Share on other sites
Nice to see a transport plane in arma again.:)

The cargo version seems to have throttle issues. Can't get the plane to move when placed on ground.

Engines start up but the throttle won't work.

When placed as 'flying' in the editor everything works fine.

Well....i've been thinking that you might accidentaly used the wrong C-130 mod....there are two of them and the oldest has that throttle problem. I've tried this particular mod and had no problems of taking off what so ever.:)

Share this post


Link to post
Share on other sites
Nice to see a transport plane in arma again.:)

The cargo version seems to have throttle issues. Can't get the plane to move when placed on ground.

Engines start up but the throttle won't work.

When placed as 'flying' in the editor everything works fine.

Works fine for me, if you have a joystick plugged in check your throttle and brake controls something might be conflicting.

Share this post


Link to post
Share on other sites

OK I did a few tests. I was able to drive an offroad and a Hunter (OK maybe the Hunter isn't very practical since it is too big and hard to get out) right into the open c-130! Unfortunately, I couldn't get the quadbike and a hatchback on to the ramp

Edited by RecondoGamer

Share this post


Link to post
Share on other sites
Works fine for me, if you have a joystick plugged in check your throttle and brake controls something might be conflicting.

The transport version works just fine, so it should not be an issue with the controls. You have tested both versions?

I place c-130j cargo and C-130j transport down as empty in the editor at the airport tarmac.

The transport version has no problems.

With the cargo version I can start the engines but increasing throttle have no effect.

Lowering flaps or use tail rudder seems broken as well, at least no visual movement when I lower flaps or move rudder.

No other mods, running the dev branch.

Share this post


Link to post
Share on other sites

Awesome!

BUT,... Has anyone ever figure out how to get these to FLY and STAY FLYING at 30,000ft for a "True" HALO Jump???

I've been messing with this project for months and months now, and EVERY Aircraft wants to fall back down and

fly TOO LOW for what I'm looking for. I've given up hope and am thinking we have to do a 'trick' of sorts to fake it...

It seems the max height we can get is about 2-3k meters or so, then do a script to plop us up 11K meters somewhere.

Might have to do a script anyways because it seems you always hit the craft on exit which kills ya. :crazy_o:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×