Jump to content

Recommended Posts

Hi ! Thank you for your work. I've a kind of visual effect like if color balance was changed, can I disable it ?

Share this post


Link to post
Share on other sites

To disable it, you'd have to edit some scripts (InitPlayerLocal.sqf and fn_impactEffects.sqf)

InitPlayerLocal.sqf:

Delete these lines

"colorCorrections" ppEffectEnable true;
"colorCorrections" ppEffectAdjust[0.9,1,0,[0.1,0.1,0.1,-0.1],[1,1,0.8,0.528],[1,0.2,0,0]];
"colorCorrections" ppEffectCommit 0;

 

common\client\ais_injury\func\fn_impactEffects.sqf:

Edit these lines

"colorCorrections" ppEffectAdjust[1.0,1.0,0.0,[1.0,1.0,1.0,0.0],[1.0,1.0,0.9,_color],[0.3,0.3,0.3,-0.1]];

"colorCorrections" ppEffectAdjust[0.9,1,0,[0.1,0.1,0.1,-0.1],[1,1,0.8,0.528],[1,0.2,0,0]];

To look like this

"colorCorrections" ppEffectAdjust [1,1,0, [1,1,1,0.0], [1,1,1,_color],[1,1,1,0.0]];

"colorCorrections" ppEffectAdjust [1,1,0,[1,1,1,0.0],[1,1,1,1],[1,1,1,0.0]];

 

I might include an easier way to disable the color correction in the future.

  • Like 1

Share this post


Link to post
Share on other sites

[Development News]

Thanks to everyone who gave feedback on the mission, I've been able to fix most of the bugs that were reported!
I've gotten several reports of players joining or respawning as seagulls, but I've been unable to reproduce that issue, so cannot promise a fix for it.  Many others report the mission works fine and experience little-to-no issues.

Aside from bug fixes, also expect more optimizations and small content additions to the mission as well.  There's much more to come and I'll be updating the change-log frequently.
Expect an update around Christmas or early January.

Crash Issue: "I and other users connecting to the mission keep getting a memory crash error!"
Temporary Workaround: For now, the only way around this is to set verifySignatures=2 on your dedicated server and perhaps also disable BattlEye.  The actual cause of the memory crashes are unknown.  It seems to occur sometimes when CUP Weapons, Units, and Vehicles are loaded.

Share this post


Link to post
Share on other sites

Hi, at first. Great work.

We have played tonight 14.12 at your serwer and we have some problem with enemy AI. It doesn't spawn at all. After entering the zone it automatically changed to blue. They appeared only CIV and IED. We do not know whether it is server error or mission. In first 4 zones it was all good but later AI didn't want to appear. 

Share this post


Link to post
Share on other sites

On my server?  That's very odd.  I'll look into it, thanks.

Share this post


Link to post
Share on other sites

Booting the mission up and game freezes at Insurgency screen. When you go to back out, you see the characters as seagulls. Any idea as to what may be causing it? 


Server is running CUP Core/Terrain, ACE3.

Share this post


Link to post
Share on other sites

This is a common bug report and it may be related to ACE3.  I'll work on figuring out a fix immediately.

 

[EDIT]

To clarify, you were running both CUP Terrains: Core AND CUP: Terrains: Maps, correct? (BOTH are required)

Share this post


Link to post
Share on other sites

I have absolutely no clue why that bug is occurring.  Never experienced it, even with the same addons loaded.  I think someone reported that CUP: Terrains - Complete is broken, so it may be a good idea to use CUP: Terrains - Core and CUP: Terrains - Maps instead.  I'll be releasing a new version of the mission most likely on Friday or earlier, which should fix many bugs and miscellaneous issues, as well as add more valuable content.

Do you have any specific errors?  Knowing the files referenced that are causing errors helps a lot.

  • Like 1

Share this post


Link to post
Share on other sites

how do i change units and replace them with units from other mods?

 

when i use cup mods, i've noticed, that the vanilla units/vehicles, are replaced by cup units.

 

where can i alter this behaviour, and change it to third party mods' units?

Share this post


Link to post
Share on other sites

It's located in the following scripts:
"eos\unitPools.sqf"
"eos\fn.sqf"
 

I think that's it.  I'll most likely be doing a slight rewrite of how it detects mods and selects the correct content, to make the script more efficient by using a "switch" instead of if(then)else{}; statements.

[EDIT]

I'm rewriting it now.  Should be considered an optimization and improve efficiency.

Share this post


Link to post
Share on other sites

i didn't mean the randomly spawned units.

 

i ment the units, that are placed inside the base.

 

the vanilla units have variable names like "ah0" or "MRAP1". i think your scripts change that unit if @cup is detected. 

 

can i just delete the variable name, or do i destroy something with that? like delete the name and the vehicle won't respawn. 

 

and how long does it take for a vehicle to respawn, anyway?

Share this post


Link to post
Share on other sites

The vehicles in base should be left as vanilla units;

Instead, edit the "common\server\veh.sqf" script.  I should also turn that into a switch as well, which I might do.  Maybe I'll just add RHS:USAF as yet another compatible mod for the mission, so that vehicles at base will be US military vehicles and respawn as such.  As for making the RHS: Russian pack compatible, for starters, maybe I'll just have it so that the vehicles and weapons are used by insurgents and if you have Taliban Fighters enabled alongside it, they'll wear the arab garbs.

  • Like 1

Share this post


Link to post
Share on other sites

oh, no please stay with @cup.

 

they have the ch53 of the german forces, while rhs only got the us-marines variant. as well as the german dingo. but it's your choice anyway. 

 

thank you for this realy cool mission and for your help.

 

thumbs up.

Share this post


Link to post
Share on other sites

by the way,

how about the playable infantry units. how do i change them, in the best way? 

Share this post


Link to post
Share on other sites

The mission will still support CUP, Taliban Fighters, etc. but will ALSO support RHS, if RHS was enabled by the host.  It'd be one step forward in improving ease of access in my mission, which is already at a higher standard than what I've seen in most other missions.

 

I recommend you watch the Ease of Access video linked in the first post to understand how the compatibility works in my mission.  No lobby parameters are required, it's all automatically detected based on the mods (if the mission supports them) running.

 

[EDIT]

To change the playable units, just change them as you would any other placed unit in the 3DEN editor.  They're inside the barracks buildings in the base, just before the warehouse.

Share this post


Link to post
Share on other sites

The base vehicles typically respawn after 2 minutes.  5 minutes for air assets.  Maybe I'll add a parameter to adjust respawn times, if the admin deems it necessary.

 

I believe for a vehicle to actually respawn, players mustn't be within a couple kilometers of the vehicle for a certain amount of time and the vehicle needs to be pretty damaged.

Share this post


Link to post
Share on other sites

I got the seagull issue too, running RHS, with CUP Terrains and Maps. Strange thing is - if I load the mission on a local server from the game, it runs fine. Its only when I host as dedicated it goes seagull.

Share this post


Link to post
Share on other sites

Also getting this recurring error in my server log : 

Spoiler

13:17:47 File mpmissions\__cur_mp.Takistan\Civs\fn\getRoadPos.sqf, line 8

13:17:47 Error in expression <_roadList)==0)}do{

_roadList=_searchPos nearRoads _radius;

if((count _roadlist)>>

13:17:47 Error position: <nearRoads _radius;

if((count _roadlist)>>

13:17:47 Error Type Number,Not a Number, expected Number

 

Share this post


Link to post
Share on other sites

@callmesargeOthers who have given the same report confirmed it was an error on their end; it's either a corrupt mod file such as CUP:Terrains (Need to redownload/install on dedicated server, if that's the case) or there was some kind of typo.  Try adding these commands to the init of your server: -noLogs -autoInit

@r4mp4g3_re4p3rThat's related to LAxemann's L_Civs script added to the mission.  The script will activate if both CBA is running on the host's end AND the civilian parameter is enabled in the lobby parameters.  It will flood the RPT, so I'd recommend adding -noLogs to your server's init to avoid it from causing major issues for now until I figure out how to fix it.

  • Like 1

Share this post


Link to post
Share on other sites

I'd like to update the mission with the radio script you just released. Can you tell me where the old one is located so I can replace it?

Don't worry, I won't re-release, I just want to use it asap because it's damn badass

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×