Jump to content
igi_pl

IgiLoad script - logistical support

Recommended Posts

Hi Igi and thanks for such a brilliant mod.

I have a question about IgiLoad and MCC, whenever i try to load items that were placed via MCC the load scripts don't recognise them, is there something i need to put in the Init of the item to get them to work with the load scripts. I have been testing with Ammo and Supply boxes and they only seem to work when placed in the editor and are present when the mission starts, anything placed after the mission start is invisible to the load script.

Thanks again for the brilliant mod and i hope there is a solution to this little problem.

EDIT: just noticed i cant load the supply boxes into the Hermit transporter even when place in the editor, is that something that is deliberate and can it be changed it the parameters?

EDIT 2: Forget it all, just found your post about the supply boxes and have tested with a different box i.e. the vehicle ammo box and it works like a dream.

Ian-C - This is good information. Have Fun :)

Share this post


Link to post
Share on other sites

I have a question related to this bugreport http://feedback.arma3.com/view.php?id=17310 (various crates damage the helicopters when loaded).

Now that the supplyboxes stopped working due to the cursorTarget bug, which items that allow inventory can I safely use?

edit:

I believe to have found one to replace the supplyboxes temporarily: "R3F_WeaponBox" You need to add it to the IL_Supported_Supply_Crate array in igiload.sqf first.

Edited by DavidZi

Share this post


Link to post
Share on other sites
I have a question related to this bugreport http://feedback.arma3.com/view.php?id=17310 (various crates damage the helicopters when loaded).

Now that the supplyboxes stopped working due to the cursorTarget bug, which items that allow inventory can I safely use?

edit:

I believe to have found one to replace the supplyboxes temporarily: "R3F_WeaponBox" You need to add it to the IL_Supported_Supply_Crate array in igiload.sqf first.

DavidZi - This can work if you are using "R3F_WeaponBox". I have not test this, but it is good that you solve your problem and give hint to all :)

Info to all

1. During the holidays I have limited access to the internet, so do not be upset if I do not wrote back for long time.

2. Few people ask me how to allow loading SUV/OFFROAD into Mohawk. Just add "IL_Supported_OFFROAD" and/or "IL_Supported_SUV" to "IL_Supported_Cargo_Veh_Mohawk".

Edited by Igi_PL

Share this post


Link to post
Share on other sites

Hi Igi

Been using the load script for a couple of days now and i must say it's a brilliant addition to Arma, i can now have proper logistics crews working to keep the troops supplied.

Don't know if this has been mentioned before but i have noticed is when a truck carrying a load gets destroyed, basically the cargo is left floating in the space it occupied in the truck. is there a way to detect if the vehicle destroyed and remove the cargo or drop it to the floor or something along those lines.

I did try to destroy the cargo box but 16 explosive and 4 satchel charges all at the same time failed, it was handy that the target was a Virtual Ammo Box so no shortage of charges.

Share this post


Link to post
Share on other sites

Hi Ian, Igi is on vacation at this moment, he has little to none internet acces during this time as he mentiont in the post above yours.

He will be back around after the 21st of this month.

Share this post


Link to post
Share on other sites
Hi Ian, Igi is on vacation at this moment, he has little to none internet acces during this time as he mentiont in the post above yours.

He will be back around after the 21st of this month.

Thanks for reply and i was aware he is on vacation but if i left it till he got back i would probably forget, it's not a major issue just something he can look at when he has time.

Share this post


Link to post
Share on other sites

Hallo

I have a problem that I can't solve alone, my problem is that I can't load the "I_supplyCrate_F" Ammunitionbox to any vehicles or choppers. I looked in the script "igiliad.sqf" and can't find anything wrong speled.

I'm geting nowhere when I look at it, so please help me here out :confused:

regards from switzerland

Share this post


Link to post
Share on other sites
Hallo

I have a problem that I can't solve alone, my problem is that I can't load the "I_supplyCrate_F" Ammunitionbox to any vehicles or choppers. I looked in the script "igiliad.sqf" and can't find anything wrong speled.

I'm geting nowhere when I look at it, so please help me here out :confused:

regards from switzerland

If you went back a few pages and looked you would see that the latest arma patch broke them and until bohemia fix them you have to use something else instead.

Share this post


Link to post
Share on other sites
If you went back a few pages and looked you would see that the latest arma patch broke them and until bohemia fix them you have to use something else instead.

Thank you very much, i've mist that somehow. Have a nice day :)

Share this post


Link to post
Share on other sites

Hi,

is there now a way to load objects via a script server side? because Im trying

0=[_vehicle, [(typeOf _cargoObj)], "B", true, _cargoObj] spawn IL_Do_Load;

and it doesn't work. _vehicle is my object i want to attach to and _cargoObj is my cargo.

witch great regards

z0Kng

Edited by z0Kng

Share this post


Link to post
Share on other sites

So, is this script basically ineffective if there is no human pilot? I am making a COOP mission. I can load the boat into the Heli, however, since an AI is our pilot, we, human players, cannot unload the boat whilst in the air. Is there a way to do this so that this script can be used in the absence of a human pilot?

Share this post


Link to post
Share on other sites

Best read the topic before asking questions :D

Edited by neonlazer

Share this post


Link to post
Share on other sites

hello guys

i was reading a lot here but didn't find an answer... i set up igi for my mission (added some vehicles) and in the editor it's working absolutely flawlessly. all the mods, vehicles and scripts are working juuust fine (loading and unloading c-130 and hmett). igi is correct loading and is confirming "igi has loaded - have fun" (or so) i can load unload with igi and even arrange stuff with the R3F-Logistics and then load it... everything fine until here. i save the mission as "mp-mission", create the .pbo and paste it in the game folder... all as usual until here too... i start the game and host a mission on my lan to see how it would work for the others in my clan and everything is working fine except igi-load... i dont get the message that igi is initializing...

does anybody had this fault too? i think i did all right cause in the editor everything works fine... and i can't choose to create the pbo differently (working with pbo manager), can i?

line in my ini.sqf is: execVM "IgiLoad\IgiLoadInit.sqf"; (i took this line cause it looks similar to the others already there and yeah... i didn't know which to take from the following options...)

in the donwload file the line is: _igiload = execVM "IgiLoad\IgiLoadInit.sqf";

and on igi's page is this line: 0 = execVM "IgiLoad\IgiLoadInit.sqf";

why is it all working in the editor and not in a hosted mission? looking forward for any hint!!!

cheers

matth

i did point 1 (no unit has something like point 2 in it). what means point 3 and 4 exactly? i didn't add 3 a), b) c) nor 4 to any of my vehicles.

USE:

1. In mission "init.sqf" add line: "0 = execVM "IgiLoad\IgiLoadInit.sqf";".

2. In vehicles "INITIALIZATION" field type: "0 = [this] execVM "IgiLoad\IgiLoad.sqf";"

3. Unload from script or trigger:

a) Unloading cargo from script. Force unload: "0 = [Car, true, "L"] spawn IL_Do_Unload;"

b) Unloading cargo from script. Force unload: "0 = [Car, true] spawn IL_Do_Unload;"

c) Unloading cargo from script. Force unload: "0 = [Car] spawn IL_Do_Unload;"

4. Loading cargo from script. Force load: "0 = [Car, [typeOf Box], "B", true, Box] spawn IL_Do_Load;"

Ways from points 1 and 2 can not be used simultaneously!!!

Edited by Matth

Share this post


Link to post
Share on other sites

Hey there! Is this beautiful script compatible with the Boeing MH-47E from konyo? And if not..is there somehow a possibility that you/we can make it compatible?

Greetz, Don

Edit: Answered myself with studying the script. It should be supported! :yay:

Edited by ItsDonJon

Share this post


Link to post
Share on other sites
Hi Igi

Been using the load script for a couple of days now and i must say it's a brilliant addition to Arma, i can now have proper logistics crews working to keep the troops supplied.

Don't know if this has been mentioned before but i have noticed is when a truck carrying a load gets destroyed, basically the cargo is left floating in the space it occupied in the truck. is there a way to detect if the vehicle destroyed and remove the cargo or drop it to the floor or something along those lines.

I did try to destroy the cargo box but 16 explosive and 4 satchel charges all at the same time failed, it was handy that the target was a Virtual Ammo Box so no shortage of charges.

Ian-C - There may be several reasons for this behavior. Most likely it is that this box has already been destroyed, but do not hide properly, because it was attached to the vehicle. Check whether it is possible to supplement ammunition in the vehicle with such a crate. If no - the crate damage = 1.

Hi Ian, Igi is on vacation at this moment, he has little to none internet acces during this time as he mentiont in the post above yours.

He will be back around after the 21st of this month.

-1PARA-Melle - Thank you for watching thread :)

Hallo

I have a problem that I can't solve alone, my problem is that I can't load the "I_supplyCrate_F" Ammunitionbox to any vehicles or choppers. I looked in the script "igiliad.sqf" and can't find anything wrong speled.

I'm geting nowhere when I look at it, so please help me here out :confused:

regards from switzerland

Thank you very much, i've mist that somehow. Have a nice day :)

ROOB1984 - We have to wait for BI. Regards from Poland ;)

If you went back a few pages and looked you would see that the latest arma patch broke them and until bohemia fix them you have to use something else instead.

Nemiuk - Thank you for your help :)

Hi,

is there now a way to load objects via a script server side? because Im trying

0=[_vehicle, [(typeOf _cargoObj)], "B", true, _cargoObj] spawn IL_Do_Load;

and it doesn't work. _vehicle is my object i want to attach to and _cargoObj is my cargo.

witch great regards

z0Kng

z0Kng - I need more information. What vehicle, what box and how exactly are you doing this. Do you have any error messages in Arma log?

So, is this script basically ineffective if there is no human pilot? I am making a COOP mission. I can load the boat into the Heli, however, since an AI is our pilot, we, human players, cannot unload the boat whilst in the air. Is there a way to do this so that this script can be used in the absence of a human pilot?

chondo999 - It is possible.

1. Make sure that the script is running on the server side.

2. Probably best to use a trigger.

Best read the topic before asking questions :D

neonlazer - Thank you for your help :) Please remember that the thread is long - People will ask about the topics already discussed in the thread ;)

hello guys

i was reading a lot here but didn't find an answer... i set up igi for my mission (added some vehicles) and in the editor it's working absolutely flawlessly. all the mods, vehicles and scripts are working juuust fine (loading and unloading c-130 and hmett). igi is correct loading and is confirming "igi has loaded - have fun" (or so) i can load unload with igi and even arrange stuff with the R3F-Logistics and then load it... everything fine until here. i save the mission as "mp-mission", create the .pbo and paste it in the game folder... all as usual until here too... i start the game and host a mission on my lan to see how it would work for the others in my clan and everything is working fine except igi-load... i dont get the message that igi is initializing...

does anybody had this fault too? i think i did all right cause in the editor everything works fine... and i can't choose to create the pbo differently (working with pbo manager), can i?

line in my ini.sqf is: execVM "IgiLoad\IgiLoadInit.sqf"; (i took this line cause it looks similar to the others already there and yeah... i didn't know which to take from the following options...)

in the donwload file the line is: _igiload = execVM "IgiLoad\IgiLoadInit.sqf";

and on igi's page is this line: 0 = execVM "IgiLoad\IgiLoadInit.sqf";

why is it all working in the editor and not in a hosted mission? looking forward for any hint!!!

cheers

matth

i did point 1 (no unit has something like point 2 in it). what means point 3 and 4 exactly? i didn't add 3 a), b) c) nor 4 to any of my vehicles.

USE:

1. In mission "init.sqf" add line: "0 = execVM "IgiLoad\IgiLoadInit.sqf";".

2. In vehicles "INITIALIZATION" field type: "0 = [this] execVM "IgiLoad\IgiLoad.sqf";"

3. Unload from script or trigger:

a) Unloading cargo from script. Force unload: "0 = [Car, true, "L"] spawn IL_Do_Unload;"

b) Unloading cargo from script. Force unload: "0 = [Car, true] spawn IL_Do_Unload;"

c) Unloading cargo from script. Force unload: "0 = [Car] spawn IL_Do_Unload;"

4. Loading cargo from script. Force load: "0 = [Car, [typeOf Box], "B", true, Box] spawn IL_Do_Load;"

Ways from points 1 and 2 can not be used simultaneously!!!

Matth - _igiload and 0 are just variables. Check yours init.sqf and open .pbo to see if IgiLoad files are in it.

Hey there! Is this beautiful script compatible with the Boeing MH-47E from konyo? And if not..is there somehow a possibility that you/we can make it compatible?

Greetz, Don

Edit: Answered myself with studying the script. It should be supported! :yay:

ItsDonJon - I am glad that you have found the answer to your question :)

Share this post


Link to post
Share on other sites

Bugs (19324 and 19339) associated with Supply Crate currently are in status resolved :)

Unfortunately we have to wait for version 1.26 :(

Share this post


Link to post
Share on other sites

For the C130 Cargo it only has 0/3 slots available, yet the HEMETT has 0/120 slots. I'd prefer it if the C130 was higher than the HEMETT. What do I need to modify to put the C130 at about 200 or so?

I see the following variables that I can modify. Yet the Hemett is -6

IL_Num_Slots_C130J = -12;
Edited by locknlol

Share this post


Link to post
Share on other sites
For the C130 Cargo it only has 0/3 slots available, yet the HEMETT has 0/120 slots. I'd prefer it if the C130 was higher than the HEMETT. What do I need to modify to put the C130 at about 200 or so?

locknlol - Do you modify something in IgiLoad? There is no vehicle with 120 slots :confused: Check lines 66 and 68

66:	IL_Num_Slots_HEMTT = -6;
67:	IL_Num_Slots_MH9 = -1;
68:	IL_Num_Slots_C130J = -12;

Share this post


Link to post
Share on other sites
locknlol - Do you modify something in IgiLoad? There is no vehicle with 120 slots :confused: Check lines 66 and 68

66:	IL_Num_Slots_HEMTT = -6;
67:	IL_Num_Slots_MH9 = -1;
68:	IL_Num_Slots_C130J = -12;

Same as you, yet hemett holds 120.

http://i.imgur.com/xVTwSFn.jpg (115 kB)

Share this post


Link to post
Share on other sites
This is not IgiLoad :D This looks like "[R3F] Logistics" menu - read under "UNLOAD" button ;)

IgiLoad do not use dialogs.

Well then, I'm retarded. Have a great day!

Share this post


Link to post
Share on other sites

I want to start a mission with a Hunter inside a C130 cargo that is sitting on a tarmac. I put the force load into a trigger. I just go not understand how the force load script works. How to I use it, where do I put it etc?

Thanks. This script is excellent. Wish I understood it better!

Share this post


Link to post
Share on other sites
I want to start a mission with a Hunter inside a C130 cargo that is sitting on a tarmac. I put the force load into a trigger. I just go not understand how the force load script works. How to I use it, where do I put it etc?

Thanks. This script is excellent. Wish I understood it better!

ValhallanGuines - I prepared a simple mission demonstrated the use of IgiLoad with triggers and how to load cargo at the start of the mission by using a script. Mission is available in the download section.

Share this post


Link to post
Share on other sites

nvm, looked at your example mission. Helped me out greatly.

Edited by silentghoust

Share this post


Link to post
Share on other sites

IGI, a few months back I asked if you could script in the ability for any players/ai in ANY aircraft to have the parachute option (like the mohawk does). Any chance you could employ that on your next update?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×