Jump to content
sickboy

Discover, Play, Promote missions and mods withSIX

Recommended Posts

PWS the last few months been very unstable, seems to be crashing around near the end of completion of a download or updating a mod. Not sure if you guys look at your error logs but there be a massive amount coming from me :( do they get looked at?

Share this post


Link to post
Share on other sites

@ deVilspaWn

Please create a support request in our system, provide details and the log files.

You are the first to report such issue as far as I am aware.

It sounds more like something specific to your system or your location in Australia has an influence.

Let's see what what your info will unveal.

Share this post


Link to post
Share on other sites

Almost every addon (around 40) I tried to update came with an error:

"Collection was modified, enumeration operation may not execute." or "Index was out of range must be non-negative and less than the size of the collection in C#"

I spammed :) some bug reports to you yesterday and tried reinstalling after deleting everything PWS related (.exe, everything in user profiles) besides addon and synq folders but it didn't help.

Especially the @ags addon for Arma 2 brings a different error, "Exception, no source found with @ags":

Type: System.Exception
Message:
   No source found with @ags
Source: withSIX-Play
TargetSite: Void ()
StackTrace:
      at ...()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
      at ...()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ...()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ...()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ..–.()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ‡...()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ‡...()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ..Â.()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ..Â.()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ..Š.()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
      at ..‰.()
   --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
      at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
      at ‡...()

And a cosmetic bug, when I start to download an update for a brief moment the percentage bottom left is displayed as "NaN%".

Edited by TonyGrunt

Share this post


Link to post
Share on other sites

Thanks for the reports guys.

We're addressing the @ags issue shortly.

As to the collection enumeration errors; will dig into them shortly as well, gotto love threading issues ;-)

Share this post


Link to post
Share on other sites

here is my log files :) someone else in PWS chat channel was having the same issues.

https://www.dropbox.com/s/1m05l0272wh3mm8/crash%20reports.7z

;2736015']@ deVilspaWn

Please create a support request in our system' date=' provide details and the log files.

You are the first to report such issue as far as I am aware.

It sounds more like something specific to your system or your location in Australia has an influence.

Let's see what what your info will unveal.[/quote']

Edited by deVilspaWn

Share this post


Link to post
Share on other sites

The CTD issues should be resolved now since 1.51 BETA 750.1

Still looking into other possible sources, but the main ones should be sorted.

Enjoy :)

@TonyGrunt; the AGS issue should be sorted tomorrow.

Share this post


Link to post
Share on other sites

Our latest blog post is up!

We're talking about what we've achieved these past 2 years and how big we currently are while also looking a at our costs and previewing some of our next goals when we Level UP! http://withsix.com/blog/level-up

Level UP
Wouldn't it be great if you could easily find, download and keep all your mods up to date - especially as a multiplayer community?
Two years ago as a small group of dedicated ARMA players and modders, we set out to create a tool and platform to fulfill these needs. Our goal is to take away all the hassle around accessing fan made content, for both single players as for entire communities playing together.

Providing over 1300 mods to more than 30.000 users daily, we will share a bit more on the size of the current project and talk about our financial situation. This post will also preview some of our ideas to improve it and plans to move further improving the services.

Read the rest on our blog...

Share this post


Link to post
Share on other sites

Hey guys, I'm trying to sort out a custom repo for my group, as we use some addons that are modular in the way of deleting .pbos and a few of our own addons not for public.

These are the things that I've done or tried so far:

  • Downloaded the Six Updater
  • Used the repo manager to create and set up a repo
  • Created repo is on my local webserver (Tried with admittedly version of Apache higher than recommended, also tried with NGINX)
  • Entered the path to config.yml into PWS
  • The mods configured show up in the PWS repo (should mean it can read the .yml fine)
  • Mods fail to download, when clicking install on the mod itself the button turns gray for a millisecond and then it's back to the green "Launch" button.
  • Found no relevant information in the logs
  • Scoured the documentation
  • Added YAML MIME types

I need some help here figuring out what I'm doing wrong, if anyone is willing to lend a hand. PWS not supporting HTTP only as the documentation seems to be old? Latest NGINX also not compatible? PM's or Skype (my username) if that's better than this thread.

Share this post


Link to post
Share on other sites

How does the latest version of Play withSIX supposed to be installed? It doesn't seem to install everything? I tried using an old version (which was working on my old windows installation), but it isn't working either (getting errors while trying to update mods).

Currently, trying to run the executable I downloaded opens up a crash report window which then instantly closes.

Where does Play withSIX save its data so that I can try to delete it and start over?

Thanks.

Share this post


Link to post
Share on other sites

@ Sniperwolf572

I have asked Sickboy to come back to you a few days ago. Unfortunately he is extremely busy..

@ galzohar

The "new" version is a standalone exe. You can "install to PC" for desktop link, start menu entry, etc

via "options - check for updates".

To delete the data go to C:\Users\XXX\AppData\Local\SIX Networks\Play withSIX

Please create a support request and attach the logs from that folder, if the issue persists.

Share this post


Link to post
Share on other sites
;2753702']@ Sniperwolf572

I have asked Sickboy to come back to you a few days ago. Unfortunately he is extremely busy..

I understand, thanks. :)

Share this post


Link to post
Share on other sites

Just finished a fresh install on my new SSD last night. Been trying to get Pw6 installed all night, but not had any luck.

Fresh install of Windows 7 (updated, obviously)

Just installed .net 4.5

UAC is disabled (And tried running as admin, for good measure)

No relevant files are in the appdata (and none are created when attempting to run)

Any time I try to install from the exe downloaded from http://withsix.com/download, it hangs after the first splash screen shows.

It doesn't create any logs in appdata, so the only error reporting comes directly from windows:

Description:

A problem caused this program to stop interacting with Windows.

Problem signature:

Problem Event Name: AppHangB1

Application Name: withSIX-Play.exe

Application Version: 1.52.767.4

Application Timestamp: 53e3d120

Hang Signature: 13a5

Hang Type: 0

OS Version: 6.1.7601.2.1.0.256.48

Locale ID: 1033

Additional Hang Signature 1: 13a5ddcdae98d5914e79b36102f99083

Additional Hang Signature 2: d97a

Additional Hang Signature 3: d97ab3ca7f3cb9ea4372d2238a9c3bdf

Additional Hang Signature 4: 13a5

Additional Hang Signature 5: 13a5ddcdae98d5914e79b36102f99083

Additional Hang Signature 6: d97a

Additional Hang Signature 7: d97ab3ca7f3cb9ea4372d2238a9c3bdf

Share this post


Link to post
Share on other sites

What do you mean Acoustic - please elaborate.

Share this post


Link to post
Share on other sites
Hey guys, I'm trying to sort out a custom repo for my group, as we use some addons that are modular in the way of deleting .pbos and a few of our own addons not for public.

These are the things that I've done or tried so far:

  • Downloaded the Six Updater
  • Used the repo manager to create and set up a repo
  • Created repo is on my local webserver (Tried with admittedly version of Apache higher than recommended, also tried with NGINX)
  • Entered the path to config.yml into PWS
  • The mods configured show up in the PWS repo (should mean it can read the .yml fine)
  • Mods fail to download, when clicking install on the mod itself the button turns gray for a millisecond and then it's back to the green "Launch" button.
  • Found no relevant information in the logs
  • Scoured the documentation
  • Added YAML MIME types

I need some help here figuring out what I'm doing wrong, if anyone is willing to lend a hand. PWS not supporting HTTP only as the documentation seems to be old? Latest NGINX also not compatible? PM's or Skype (my username) if that's better than this thread.

Hey Sniper! Sorry for the long wait. If you could send us your repo details to support (at) withsix (dot) com, then i'll take a quick peek to see what's going on and get back to you asap.
Just finished a fresh install on my new SSD last night. Been trying to get Pw6 installed all night, but not had any luck.

Fresh install of Windows 7 (updated, obviously)

Just installed .net 4.5

UAC is disabled (And tried running as admin, for good measure)

No relevant files are in the appdata (and none are created when attempting to run)

Any time I try to install from the exe downloaded from http://withsix.com/download, it hangs after the first splash screen shows.

It doesn't create any logs in appdata, so the only error reporting comes directly from windows:

Description:

A problem caused this program to stop interacting with Windows.

Problem signature:

Problem Event Name: AppHangB1

Application Name: withSIX-Play.exe

Application Version: 1.52.767.4

Application Timestamp: 53e3d120

Hang Signature: 13a5

Hang Type: 0

OS Version: 6.1.7601.2.1.0.256.48

Locale ID: 1033

Additional Hang Signature 1: 13a5ddcdae98d5914e79b36102f99083

Additional Hang Signature 2: d97a

Additional Hang Signature 3: d97ab3ca7f3cb9ea4372d2238a9c3bdf

Additional Hang Signature 4: 13a5

Additional Hang Signature 5: 13a5ddcdae98d5914e79b36102f99083

Additional Hang Signature 6: d97a

Additional Hang Signature 7: d97ab3ca7f3cb9ea4372d2238a9c3bdf

Hmm, is it at installing pre-requisites, or even before that happens?

Often the cause is third party software incompatibility, like some graphics related utility (tweaker/booster/etc), are you running any of that?

Why does PWS take so long to update or install mods?
any mods in particular? official network or custom repository?

Share this post


Link to post
Share on other sites

Hmm, is it at installing pre-requisites, or even before that happens?

Often the cause is third party software incompatibility, like some graphics related utility (tweaker/booster/etc), are you running any of that?

I'm not sure what happened, but it started working later. (Should have mentioned this before now, probably.) I wish I could tell you what it was, but outside of windows updates, nothing at all changed between it not working and installing correctly. I can confirm though that it wasn't installing any pre-requisites, and outside of steam, .net, vb libraries, and some windows updates, nothing else had been installed yet. Sorry I don't have more info for you. Sucks to have found a bug without having any clue how to reproduce it for you. :/

Share this post


Link to post
Share on other sites

Hi, I've a problem. When I put PlayWithSix in tray icon (by clicking on close button) I can no longer maximize window, by clicking twice on the trayicon nothing happens, I have to completely exit and restart it. Everytime.

It happens after the last (non beta) update. Anyone?

I've another question, can I clear .synq folder (28,3 Gb)?

Thanks.

Share this post


Link to post
Share on other sites

I'm using withSix now (sickboy, that UI :-!?!) and I need it exclusively for keeping mods up to date. I don't want it to keep a copy of mods at another place (for the repair option), because, if mods are broken, I can handle this.

Can I turn the caching system off? Also, this makes it very time consuming migrating to withsix, because it would take ages for it to pack 100s of GBs of already downloaded mods.

Edited by tortuosit

Share this post


Link to post
Share on other sites

Is there anything I can do about the ever-growing size of the ".synq" folder? Currently, it stands at around 32 GB; for comparison the actual mod folders are around 10 GB. So three times the size. Almost all of this size is taken up by the "objects" folder. Will any serious damage be done by simply deleting the objects folder? Am I missing some option to clean up that folder?

I've tried searching the thread, but couldn't find an answer; sorry if this has been answered already.

Share this post


Link to post
Share on other sites
Is there anything I can do about the ever-growing size of the ".synq" folder? Currently, it stands at around 32 GB; for comparison the actual mod folders are around 10 GB. So three times the size. Almost all of this size is taken up by the "objects" folder. Will any serious damage be done by simply deleting the objects folder? Am I missing some option to clean up that folder?

I've tried searching the thread, but couldn't find an answer; sorry if this has been answered already.

I'm interested too!!

Share this post


Link to post
Share on other sites

314rz8i.jpg

Read the full post at: withsix.com/blog/improve-your-experience-with-premium

We're pleased to announce the release of our additional, premium services,

which on top of all the free services and benefits you have become acustomed to from us for years,

adds additional benefits, performance and features, and most importantly; helps us to sustain our service.

As announced in our earlier blog posts; the-sonic-barrier, and level-up, cost has been an issue for us for quite some time;

Bandwidth, servers, staff, and a lot of engineering, development, research and management;

Alot of time, effort and investment went, and goes, into the platform.

Our team, nearly 10 strong, has been tirelessly at work to give you easy and fast access to the latest and greatest of content,

created by many great authors, while removing the hassle and cost involved for authors, communities and players alike.

347ac8w.png

We want to expand and improve on our services, and of course to keep doing what we're doing;

Provide the easiest and fastest access to large collections of mods in both Multiplayer and Singleplayer,

for free, and therefore we need your help.

Some of the things brewing in our dev-labs include giving authors full access and control to manage their content,

and especially the metadata related to the mods.

For players we are working hard on improving the usability, user experience, stability and performance of the platform.

And these are but the tip of the iceberg in terms of what we have in store for you.

We hope for your understanding and we are open to feedback and suggestions, as always.

Yours faithfully

Edited by Sickboy

Share this post


Link to post
Share on other sites

Happy to support the Six team! Interested to see what new features you come up with.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×