Jump to content
Feint

RQ-11B RAVEN for Arma 3 - RELEASED!

Recommended Posts

Back on topic...

I've had an update for this addon almost ready to go for some time now. Just finishing up a few of the features and trying to get an unnamed feature working before I release it. New (announced) features:

  • Easier way to pick up Raven and GCS
  • Improved dropping of GCS and Raven
  • Improved carrying animation of Raven (follows body position)
  • Improved assembly animation (removed workarounds to Arma bugs with attachTo and improved a few other things)
  • Some new sounds
  • Fixed the "too loud sound" problem when using Zeus or MCC
  • Code cleaning

Edited by Feint

Share this post


Link to post
Share on other sites

hello I hope u huys gonna fix, its sound problem.

if Im in the zeus, Raven keep make sound while its flyin

*too noizy!*

Share this post


Link to post
Share on other sites

Thanks for the update on the update, Feint!

I do also hope you find that annoying Raven flying sound when you use MCC or Zeus and mute it.

Share this post


Link to post
Share on other sites
hello I hope u huys gonna fix, its sound problem.

if Im in the zeus, Raven keep make sound while its flyin

*too noizy!*

Forgot to mention, I think I found a fix for that too. Once I post the update, I'm hoping one of you can report back that the fix worked.

Share this post


Link to post
Share on other sites
Forgot to mention, I think I found a fix for that too. Once I post the update, I'm hoping one of you can report back that the fix worked.

really thx for ur reply.

will wait for it :)

Share this post


Link to post
Share on other sites

Hey Guys

**This questions is for anyone that may have any insight regarding technical issues with the mod**

First HUGE thanks to Feint for all of his hard work and his contribution to Arma. Game changer is an understatement.

I'm absolutely sure the issue is something on my end, perhaps a compatibility problem. Everything about the mod works fine. I can test the strobe/battery; assembly animation works, and I can carry the Raven on my back. However when I select the launch RQ-11B option, nothing happens. Nothing. No animation glitch, not anything. I guess I'm trying to see if anyone else has reported anything similar (found nothing along this thread), if there's a procedural order to launching (read through the instructions on Feint's site), or if I haven't loaded something properly (all other aspects work fine in game). Apologies in advance b/c I know its something staring me in the face. Thanks for the forum.

Raven3

Share this post


Link to post
Share on other sites

Thanks Raven3. Very nice of you to say.

I would suggest that there's another addon that's taking over the keystroke of the Raven addon. Usually that would completely block the execution of the launch script. Try uninstalling other mods you are using, then re-enabling them one at a time to see which one is interfering.

You could also take a look at your .rpt file to see if there are any errors. Or turn on the switch "-showScriptErrors" which is a good way to track down any errors you might be getting in real time.

---------- Post added at 01:17 ---------- Previous post was at 01:07 ----------

There are some new changes coming to the RQ-11B Raven addon for Arma 3. New animations, new display, sound fixes, new sounds and more efficient coding. The 2.5 update will be out in a few days after I tweak a few more thing.

Share this post


Link to post
Share on other sites

There are some new changes coming to the RQ-11B Raven addon for Arma 3. New animations, new display, sound fixes, new sounds and more efficient coding. The 2.5 update will be out in a few days after I tweak a few more thing.

Glad to hear that!

Share this post


Link to post
Share on other sites

Will 2.5 still be going live? Really looking forward to the Zeus fixes, plus everything else. :)

Edited by Skord

Share this post


Link to post
Share on other sites

I'm also awaiting an update for this mod. :) Even just an update to fix the Zeus sound issue.

Share this post


Link to post
Share on other sites
This is awesome.

A weaponized version of this would also be awesome.

Like this UAV

http://i.imgur.com/Rkw6rqc.jpg (204 kB)

First of all, let Feint finish his awesome work (he should get a price for best addon maker)

Second, there are other better drones to be made:

- MQ9 Reaper or Predator

- Battle drones

- Switchblade (Compatible with Raven GCU)

- RQ-8

Edited by Lt_Ryan

Share this post


Link to post
Share on other sites

We have a bug where people walking around the guy with the raven get wounded. That is, when you carry it in your hand (not backpack ofc).

Using CSE for medical system (but since nothing else causes this weird bug I blame you).

Also, it should be destroyable :P

Edited by janus0104

Share this post


Link to post
Share on other sites
First of all, let Feint finish his awesome work (he should get a price for best addon maker)

Second, there are other better drones to be made:

- MQ9 Reaper or Predator

- Battle drones

- Switchblade (Compatible with Raven GCU)

- RQ-8

+1

MQ9 Reaper for sure, Feint must consider making it , i also would love to say that this Raven mod is defiantly among best of the best modes i played around here .

keep it up feint :)

Share this post


Link to post
Share on other sites

Brilliant mod, absolutely amazing. However, it's generating repeating error messages in the rpt files as follows:

Arma 3 v1.30.127372 (main build)

@cba_a3 (1.0.9.140907)

@rq-11_raven_ab_a3 (2.1.0.1)

Unknown attribute shadowcolor

spams rpt file thousands of times

"shadowcolor" appears in your \scripts\ .sqf

Presumably there's a line in one of them with something missing, as shadowcolor seems to be an acceptable string formatting command.

Apollo

3 Commando Brigade

Share this post


Link to post
Share on other sites

Feint has been quiet for a while now.. I hope everything's ok!

Share this post


Link to post
Share on other sites

Whenever i attempt to access the Raven's main Camera my game crashes with this error "userconfig\RQ11RAVEN\raven_keys.hpp not found." I checked this specific directory and the file is there so im not sure what the issue could be. I would appreciate your assistance regarding this matter.

Share this post


Link to post
Share on other sites

I'm sorry for asking this, but how exactly can I fix the raven_keys is not found. I've tried different ways to let it know my keybindings, but I just don't know how it want it. Anyone able to copy paste their keybindings or something, I',m lost and there is literally little to no help to gain from the thread :(

Share this post


Link to post
Share on other sites

Not sure if you already got this fixed. But check the path that is says that it can't find the raven_keys, and compare with the path you actually have in userconfig.

The path is supposed to be: ...Arma 3\userconfig\RQ11RAVEN\raven_keys.hpp

Share this post


Link to post
Share on other sites
We have a bug where people walking around the guy with the raven get wounded. That is, when you carry it in your hand (not backpack ofc).

Using CSE for medical system (but since nothing else causes this weird bug I blame you).

Also, it should be destroyable :P

If you "run into it", i.e. if you are running and you decide to drop it and then you collide with it, you get injured. That's true of any object in Arma. The raven looks light, but it actually isn't. The workaround for this is that I've added an animation that stops your character when you drop the Raven or GCS. That way, it's almost impossible to run into the Raven when dropping it.

---------- Post added at 08:51 ---------- Previous post was at 08:48 ----------

I'm sorry for asking this, but how exactly can I fix the raven_keys is not found. I've tried different ways to let it know my keybindings, but I just don't know how it want it. Anyone able to copy paste their keybindings or something, I',m lost and there is literally little to no help to gain from the thread :(

The instructions say to place the userconfig folder into your root Arma 3 directory. Hope this helps. A lot of people have trouble with this for some reason. The install instructions are here:

http://feintgames.com/rq-11b-raven-welcome/raven-addon-info/

---------- Post added at 08:51 ---------- Previous post was at 08:51 ----------

Whenever i attempt to access the Raven's main Camera my game crashes with this error "userconfig\RQ11RAVEN\raven_keys.hpp not found." I checked this specific directory and the file is there so im not sure what the issue could be. I would appreciate your assistance regarding this matter.

Please see above comment. You have to install the userconfig folder into the root directory of Arma 3.

---------- Post added at 08:52 ---------- Previous post was at 08:51 ----------

where can i find the server key?

https://www.dropbox.com/s/95rctquo2eqoo61/FEINT.bikey?dl=0

---------- Post added at 09:04 ---------- Previous post was at 08:52 ----------

Brilliant mod, absolutely amazing. However, it's generating repeating error messages in the rpt files as follows:

Arma 3 v1.30.127372 (main build)

@cba_a3 (1.0.9.140907)

@rq-11_raven_ab_a3 (2.1.0.1)

Unknown attribute shadowcolor

spams rpt file thousands of times

"shadowcolor" appears in your \scripts\ .sqf

Presumably there's a line in one of them with something missing, as shadowcolor seems to be an acceptable string formatting command.

Apollo

3 Commando Brigade

Thanks for the heads up. I just looked into it and yeah, wow. I'll fix this.

+1

MQ9 Reaper for sure, Feint must consider making it , i also would love to say that this Raven mod is defiantly among best of the best modes i played around here .

keep it up feint :)

Thanks very much!

Can you not implement this: http://dev.withsix.com/projects/cca/wiki/Keybinding

To separate from the Userconfig? It would be nice.

I've just implemented this into my Paddle Mod and wanted to finish that and get some understanding of it before I applied it to any of my other addons. The keybinding system is somewhat limited in that you can't turn OFF the bound keys when you aren't using them, as far as I know. So I have to be very careful with how I write the functions connected to the keys. Ideally, I would use this system, or come up with my own user interface for changing keys from within the game. But that's very difficult for me. But rest assured, it is something I'm trying to do. I just have to figure out how to implement it with my special case Raven addon.

I'm also awaiting an update for this mod. :) Even just an update to fix the Zeus sound issue.

I might release early in order to fix this known problem.

Not sure if you already got this fixed. But check the path that is says that it can't find the raven_keys, and compare with the path you actually have in userconfig.

The path is supposed to be: ...Arma 3\userconfig\RQ11RAVEN\raven_keys.hpp

I looked into it and the path is correct. People just tend to install that file into the wrong place.

A lot of times, the game engine will throw an inaccurate code because it doesn't know any better. This is the path to my raven_keys.hpp file that I have installed on my computer:

H:\SteamLibrary\SteamApps\common\Arma 3\userconfig\RQ11RAVEN

This is the path that is called for in the code (the path the keys file looks for):

#include "\userconfig\RQ11RAVEN\raven_keys.hpp"

So as long as you follow the install instructions, there should be no problems (relating to that file).

Edited by Feint

Share this post


Link to post
Share on other sites

The raven sound have a problem with the localation of sound for Zeus and if the player are at arsenal box. You hear the sound permanently with maximum volume. I think it's a problem with the localization of the sound. Please check mavSoundOn.sqf and cba_fnc_globalSay2D.

Note: CBA has an update.

Could you fix it?

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×