Jump to content
cool=azroul13

UPSMON Updated to ArmaIII

Recommended Posts

It's the basically the beta version of Arma for future versions of Arma. So any new commands/functions/features that the BI developers have put together for an update get tested and critiqued first in the dev branch version of Arma, to then be evaluated for placement in the updated release.

http://forums.bistudio.com/forumdisplay.php?186-ARMA-3-DEVELOPMENT-BRANCH

So sometimes people on the dev branch have different functionality of certain commands/functions because the dev branch version has them altered, which can cause issues when using scripts/mods made in standard Arma.

How can i tell if im a dev branch user or not? i bought this game like a month ago. So im not really sure if im a dev branch user.

Share this post


Link to post
Share on other sites
How can i tell if im a dev branch user or not? i bought this game like a month ago. So im not really sure if im a dev branch user.

Seeing how you didn't know about it in the first place, the odds are you aren't on it, there are a few hoops you have to jump through to get on it, I don't even know those steps because I've never been interested in it.

Share this post


Link to post
Share on other sites

Question:

If i wanted to start the mission where all groups are added outside the marker area....and have they wait till a trigger is activated...can i do it by the following? I've tested and seems to be working on a small example but not sure what impacts it might have on a full scale mission. My idea is:

1. Create marker in AO area

2. Create groups outside of marker with correct INIT codes

3. No code in mission INIT.sqf file

4. Trigger INIT code in Trigger activation to cause units to run to AO Marker and st

Share this post


Link to post
Share on other sites

Well you can let the UPSMON_Init in your init.sqf file and just add when you want to your other group the UPSMON init code.

What is your goal behind it ?

Share this post


Link to post
Share on other sites

Missions is about units showing up to a certain location, and then defending. I will have the UPSMON scripts only begin once player reaches the AO location, and then have the AI units run up to marker and respawn as they die per UPSMON.

Share this post


Link to post
Share on other sites

It's for the moment mainly for the civilian part, as it is explained in the pdf it is meant to simulate civilian life.

Share this post


Link to post
Share on other sites

hey I am messing around with upmon for the first time for ARMA3. I am a little lost with the this

You can create group dynamically with the “UPSMON_CreateGroup†function:

_grp = [position,side,[unitsarray],[min units,max units per group],3,["markername","SAFE","COLUMN"]] call UPSMON_CreateGroup;

<- _position Position where the group will spawn

<- side Side of the group (EAST,WEST,GUER,CIVILIAN)

<- [unitsarray] Array with classnames of unit you want to spawn (classname will be choose

randomly), the classname can be unit or vehicles. If the classname is a vehicle, it will be filled with units of the

same side than the vehicle.

<- [min,max] Minimum and maximun units you want to spawn in the group [1,4]

<- 3 amount of mandatory units

<- ["markername"] UPSMON parameters for the group

how do I use this to spawn the units without placing units down via editor? do you need to place units down via editor first then how is this dynamically. Avibird

Share this post


Link to post
Share on other sites
How can i tell if im a dev branch user or not? i bought this game like a month ago. So im not really sure if im a dev branch user.

Just so you know to sign up to devbranch you have to click on ARMA III in steam, select properties and then opt into it, so odds are your not. If you are on devbranch you'll also notice daily updates.

Share this post


Link to post
Share on other sites

Hi guys, I downloaded UPSMON from armaholic but I saw there are no sample missions inside, do you have a link with all UPSMON sample/showcase editor missions ?

This would help a lot

cheers

Edited by HaZZarD

Share this post


Link to post
Share on other sites

@AVIBIRD-1

You can place the function anywhere to activate: trigger or via the init.sqf.

example:

_grp = [getmarkerpos "SPAWN",WEST,[b_Soldier_03_f,B_Soldier_04_f,B_soldier_AT_F,B_Soldier_03_f,B_Soldier_03_f,B_APC_Tracked_01_rcws_F],[4,6],0,["markername","SAFE","COLUMN"]] call UPSMON_CreateGroup;

It will spawn a group of 4 to 6 soldiers (pick from the array) at the marker "SPAWN".

@Hazzard

Sorry I remove all the demos missions a long time ago :/ .

There are a pdf to explain the basic with UPSMON in the infos folder.

Share this post


Link to post
Share on other sites

@ cool=Azroul13 thank you for your reply. I am having another issue with the respawn during my testing of your script.

if I put this nul = [this,"upmonz1","RESPAWN:",2] execVM "scripts\UPSMON.sqf"; If I am a blufor unit and I kill the two blufor units that are using the above code the units spawn back no issues however if I am a opfor unit and kill the two blufor units they never spawn back even if I move far away from the spawn location.

I know you gave this info The group will not respawn if there are any enemies at their point of origin (The first position of the leader).

So I tried this nul = [this,"upmonz1","RESPAWN:",2,"RESPAWNPOS:",getmarkerpos “respawnâ€] execVM

"scripts\UPSMON.sqf"; no luck.

I aslo tried this nul = [this,"upmonz1","RESPAWNDELAY:",60,"RESPAWN:",2] execVM "scripts\UPSMON.sqf"; no luck nothing respawns back.

I know I am doing something wrong with the codes but have no clue what it is lol.

Share this post


Link to post
Share on other sites

Are you sure that the enemy are at minimum 800m from your respawn position ?

(I will add a variable in the Init_UPSMON.sqf for the mission maker)

Share this post


Link to post
Share on other sites

I got the same problem, however the problem comes from the minimum distance, I would like it to be much more low. About 100m or so...

Making a mission "Black Hawk Down"-ish and want them to respawn even if close to ennemy troops.

Also, when using "call UPSMON_CreateGroup", how do I make them spawn at random places in the zone? Still haven't figured it out even with the info pdf.

Edited by ElectroEsper

Share this post


Link to post
Share on other sites

1-

I will add a variable for this, for the moment you will have to change the line 73 of the UPSMON_RESPAWN.sqf (UPSMON\MODULES):

_mensnear = _orgpos nearentities [["CAManBase","TANK","CAR"],800];

Change the number to 0 or 10.

2-

The "UPSMON_Creategroup" function doesn't randomly spawn the group but you can add to the UPSMON parameters this one: "RANDOM", it will randomly spawn the group inside his marker zone.

If you want to spawn at some preplaced markers for example you can do something like that:

	_markers = ["spawn1","spawn2","spawn3","spawn4"];

_marker = _markers select (floor (random (count _markers)));
_grp = [getmarkerpos _marker,Resistance,["I_Soldier_SL_F","I_soldier_F","I_soldier_F","I_Soldier_GL_F","I_soldier_F","I_soldier_F","I_Soldier_AR_F"],[6,8],1,["mk2","FULL"]] call UPSMON_CreateGroup;	
_grp setvariable ["UPSMON_Attackpos",getmarkerpos "mk2"];

The last line is to forced group to attack a position.

Share this post


Link to post
Share on other sites

Hello!

I have a question about UPSMON unit surrendering/ retreating. I´ve set UPSMON_SURRENDER = true, but even with UPSMON_WEST_SURRENDER = 100 and UPSMON_WEST_RETREAT = 100 not one unit will surrender or retreat. Tested it against enemy AI without UPSMON, and all UPSMON units are spawned on HC. Is there a chance to make units surrender?

Share this post


Link to post
Share on other sites

Ok, while faffing around I managed to make the random respawn, using a method I found somewhere else on the forum.

createCenter east;

_position = [(getMarkerPos "north_zone" select 0) + ((random 200)+(random -200)), (getMarkerPos "north_zone" select 1) + ((random 200)+(random -200)), 0];  
_grp = [_position,EAST,["«lots of random unit»"],[1,10],5,["markername","COMBAT","COLUMN"]] call UPSMON_CreateGroup;

Now, I still can't use the respawn, even with the edit.

Here's the line I use (kind-of the continuation of the previous lines of script):

_grp [this,"north_zone","RANDOM","RESPAWN:",10] execVM "scripts\UPSMON.sqf";

All it says is "1 exiting mainloop", and nothing happens. :(

Edit1 : Found a way to combine SHK Pos, UPSMON and a repeating trigger to make it work. That should do.

Edited by ElectroEsper

Share this post


Link to post
Share on other sites

@oddie2

You should use the TPWCAS script with UPSMON for this part.

@ElectroEsper

You use two UPSMON parameters lines for the group ?

What exactly your second line do ?

You don't need to wrote this line: _grp = [this,"marker"] exevm "UPSMON.sqf" ; if you use the UPSMON_creategroup function.

the first parameter of the array should be the leader of the group so it can be :

-->this // if you add the UPSMON code in the init of the leader (in the editor).

-->leader _grp // If you add the group via script.

Share this post


Link to post
Share on other sites

hey,

i get an errormessage in my server.rpt "Error in expression <

if (_spawn) then

{

{

_pos2 = _unitpos findEmptyPosition [1,25];

_x setposATL _>"

anybody knows what it meens???

Share this post


Link to post
Share on other sites

jep using ambush2. heres a part of the rpt.:

2014/12/14, 1:28:20 File mpmissions\__cur_mp.Zargabad\Scripts\UPSMON\COMMON\Cover\fnc\UPSMON_fnc_find_cover.sqf, line 34

2014/12/14, 1:28:20 Error in expression <

if (_spawn) then

{

{

_pos2 = _unitpos findEmptyPosition [1,25];

_x setposATL _>

2014/12/14, 1:28:20 Error position: <findEmptyPosition [1,25];

_x setposATL _>

2014/12/14, 1:28:20 Error Type Any, expected Number

2014/12/14, 1:28:20 File mpmissions\__cur_mp.Zargabad\Scripts\UPSMON\COMMON\Cover\fnc\UPSMON_fnc_find_cover.sqf, line 33

2014/12/14, 1:28:20 Error in expression <= _unitpos findEmptyPosition [1,25];

_x setposATL _pos2;

}foreach _units;

};

_m>

2014/12/14, 1:28:20 Error position: <setposATL _pos2;

}foreach _units;

};

_m>

2014/12/14, 1:28:20 Error 0 elements provided, 3 expected

2014/12/14, 1:28:20 File mpmissions\__cur_mp.Zargabad\Scripts\UPSMON\COMMON\Cover\fnc\UPSMON_fnc_find_cover.sqf, line 34

2014/12/14, 1:28:20 Error in expression <

if (_spawn) then

{

{

_pos2 = _unitpos findEmptyPosition [1,25];

_x setposATL _>

2014/12/14, 1:28:20 Error position: <findEmptyPosition [1,25];

_x setposATL _>

2014/12/14, 1:28:20 Error Type Any, expected Number

2014/12/14, 1:28:20 File mpmissions\__cur_mp.Zargabad\Scripts\UPSMON\COMMON\Cover\fnc\UPSMON_fnc_find_cover.sqf, line 33

2014/12/14, 1:28:20 Error in expression <= _unitpos findEmptyPosition [1,25];

_x setposATL _pos2;

}foreach _units;

};

_m>

2014/12/14, 1:28:20 Error position: <setposATL _pos2;

}foreach _units;

};

_m>

2014/12/14, 1:28:20 Error 0 elements provided, 3 expected

2014/12/14, 1:28:20 File mpmissions\__cur_mp.Zargabad\Scripts\UPSMON\COMMON\Cover\fnc\UPSMON_fnc_find_cover.sqf, line 34

2014/12/14, 1:28:21 Unsupported language English in stringtable

2014/12/14, 1:28:21 Unsupported language English in stringtable

2014/12/14, 1:28:21 Mission Urugal_Valley2.fata: Number of roles (3) is different from 'description.ext::Header::maxPlayer' (4)

2014/12/14, 1:28:21 No owner

im using bcombat, could it be a problem between bcombat and upsmon?

all in all nice script. use it in every mission i build. keep up ur great work!

Share this post


Link to post
Share on other sites

hey,

checked upsmon with bcombat on my server. looks really cool, for the test a cant see any problems. really nice work mate!

cya

Share this post


Link to post
Share on other sites

I was having the same problem as Coolinator a few pages back, i.e. everything installed correctly and the correct script put into the unit's init field but the guys would just stand still. Turns out the problem was that I copy/pasted the script directly from the pdf into the editor. For whatever reason, Arma 3 didn't like that. Once I typed the script out in the unit's init field within the editor, everything worked perfectly. Thought I would post this in case someone else has the same problem.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×