Jump to content
cool=azroul13

UPSMON Updated to ArmaIII

Recommended Posts

Hi Guys,

are there any "AI-Mods" AI-improvement Addons how work good with Upsmon like TPWCAS in Arma3?

Cheers

Sc0rc3d

Share this post


Link to post
Share on other sites

you can try bcombat, it should work well.

Version 6.0.8 is out:

http://www.fileconvoy.com/dfl.php?id=gc62a42087ec0e31599951762634655252d24fd78f

special thanks to Barbolani and Shuko for this version.

changelog:

=== 6.0.8 ========================================================================

Added: -Speedmode parameter (FULL,LIMITED,NORMAL)

-You can change the respawn position via ["RESPAWNPOS:",[0,0,0]]

-you can add delay for the respawn ["RESPAWNDELAY",50]

-You can remove a group from UPSMON control via _grp setvariable ["UPSMON_Remove",true];

-("RANDOMUP" or "RANDOMDN" or "RANDOMA")+"NOWP3" = "FORTIFY"

Modified: -Artillery is now detected by UPSMON, just add nul = [this,"area0"] execvm "Scripts\UPSMON.sqf";

the old method is always available.

Corrected: -AI patrol can't find their way in marker area less then 100*100

-AI try to mount autonomous static weapons

-AI Patrol in building

Share this post


Link to post
Share on other sites

This version has error reporting on by default. It's spamming to the .rpt file. For example

"UPSMON INITIALIZED"
"UPSMON_Arti: [[]]"
"UPSMON_REINFORCEMENT_WEST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_EAST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_GUER_UNITS: [[]]"
Ref to nonnetwork object 172e4100# 164027: snake_f.p3d
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
Ref to nonnetwork object 47ac0100# 164031: snake_f.p3d
"Min: 245.252 Max: 224.999"
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
"UPSMON_Arti: [[]]"
"UPSMON_REINFORCEMENT_WEST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_EAST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_GUER_UNITS: [[]]"
"[b Alpha 1-1:2,B Alpha 1-1:3,B Alpha 1-1:4]"
"[b Alpha 1-1:1]"
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
"[b Alpha 1-1:2,B Alpha 1-1:3,B Alpha 1-1:4]"
"[b Alpha 1-1:1]"
"UPSMON_Arti: [[]]"
"UPSMON_REINFORCEMENT_WEST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_EAST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_GUER_UNITS: [[]]"
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
"[b Alpha 1-1:2,B Alpha 1-1:3,B Alpha 1-1:4]"
"[b Alpha 1-1:1]"
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
"[b Alpha 1-1:2,B Alpha 1-1:3,B Alpha 1-1:4]"
"[b Alpha 1-1:1]"
"UPSMON_Arti: [[]]"
"UPSMON_REINFORCEMENT_WEST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_EAST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_GUER_UNITS: [[]]"
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
"[b Alpha 1-1:2,B Alpha 1-1:3,B Alpha 1-1:4]"
"[b Alpha 1-1:1]"
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
"[b Alpha 1-1:2,B Alpha 1-1:3,B Alpha 1-1:4]"
"[b Alpha 1-1:1]"
soldier[b_G_Soldier_AR_F]:Some of magazines weren't stored in soldier Vest or Uniform?
soldier[b_G_Soldier_LAT_F]:Some of magazines weren't stored in soldier Vest or Uniform?
soldier[b_G_Soldier_LAT_F]:Some of magazines weren't stored in soldier Vest or Uniform?
"UPSMON_Arti: [[]]"
"UPSMON_REINFORCEMENT_WEST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_EAST_UNITS: [[]]"
"UPSMON_REINFORCEMENT_GUER_UNITS: [[]]"
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
"[b Alpha 1-1:2,B Alpha 1-1:3,B Alpha 1-1:4]"
"[b Alpha 1-1:1]"
"[b Alpha 1-2:2,B Alpha 1-2:4]"
"[b Alpha 1-2:1,B Alpha 1-2:3]"
"[b Alpha 1-1:2,B Alpha 1-1:3,B Alpha 1-1:4]"
"[b Alpha 1-1:1]"
"UPSMON_Arti: [[]]"

---------- Post added at 01:44 PM ---------- Previous post was at 01:13 PM ----------

Note even though Init_UPSMON.sqf has UPSMON_Debug = 0;

Share this post


Link to post
Share on other sites
-You can change the respawn position via ["RESPAWNPOS:",[0,0,0]]

Does this mean we can't use a "getpos" or a "getmarkerpos" command? Was hoping for something a little less manual than having to find a grid point on each map.

Share this post


Link to post
Share on other sites

New version frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Would it be possible to implement an easy spawn on HC script? Just a config value somewhere that makes all the UPSMON units spawn and run on the HC.

Share this post


Link to post
Share on other sites
Does this mean we can't use a "getpos" or a "getmarkerpos" command? Was hoping for something a little less manual than having to find a grid point on each map.

What I mean is that you need the coordinates of the position so it can be like this:

["RESPAWNPOS:",getpos obj1] or ["RESPAWNPOS:",getmarkerpos "pos1"] but not ["RESPAWNPOS:", "pos1"] or ["RESPAWNPOS:",obj1]

Would it be possible to implement an easy spawn on HC script? Just a config value somewhere that makes all the UPSMON units spawn and run on the HC.

i don't know what you mean, could you be more specific ?

Share this post


Link to post
Share on other sites
Would it be possible to implement an easy spawn on HC script? Just a config value somewhere that makes all the UPSMON units spawn and run on the HC.

Never tested it, but maybe "NOWP3" to that will be enough to control an UPSMon group with High Command module....

Share this post


Link to post
Share on other sites

hi guys im getting an error in the RPT

Error in expression <= _unitpos findEmptyPosition [0,10];
_x setposATL _pos2;
}foreach _units;
};

_c>
 Error position: <setposATL _pos2;
}foreach _units;
};

_c>
 Error 0 elements provided, 3 expected
File C:\Users\Hellstorm77\Documents\Arma 3\missions\Co20_Lazy_Sunday_Part_1_vA1.Altis\scripts\UPSMON\COMMON\func_getcover.sqf, line 17
Error in expression <= _unitpos findEmptyPosition [0,10];
_x setposATL _pos2;
}foreach _units;
};

Share this post


Link to post
Share on other sites

Hey is it possible to ask if this is still up to date with the command lines? In a few posts prior I was informed

6 // nomove = Unit will stay at start position until enemy is spotted, then they get a defensive role.

is no longer and to use

17 // fortify = makes leader order to take positions on nearly buildings at distance 200 meters, squad fortified moves less than "nomove".

http://dev.withsix.com/projects/upsmon/wiki/UPSMONsqf

just wondering if this list is not up to date, is there a better site to find what commands are currently good?

Thanks in advance.

Share this post


Link to post
Share on other sites
What I mean is that you need the coordinates of the position so it can be like this:

["RESPAWNPOS:",getpos obj1] or ["RESPAWNPOS:",getmarkerpos "pos1"] but not ["RESPAWNPOS:", "pos1"] or ["RESPAWNPOS:",obj1]

Fantastic, sir! Thanks.

One more dumb question...I'm downloading now, but figured I'd ask...where in the init array should we put the "RESPAWNPOS:" switch? At the end?

Share this post


Link to post
Share on other sites
hi guys im getting an error in the RPT

_c>
 Error 0 elements provided, 3 expected
File C:\Users\Hellstorm77\Documents\Arma 3\missions\Co20_Lazy_Sunday_Part_1_vA1.Altis\scripts\UPSMON\COMMON\func_getcover.sqf, line 17
Error in expression <= _unitpos findEmptyPosition [0,10];
_x setposATL _pos2;
}foreach _units;
};

I'm getting the same error. Are you spawning units?

I changed this

_unitpos findEmptyPosition [0,10];

to this

_unitpos findEmptyPosition [0,25];

and the error happens less often, but I still get it.

Share this post


Link to post
Share on other sites
Has anyone tried this with VcomAI?

Yes and it works well, from what I have been told, xgensisx made it to work with UPSMON.

Share this post


Link to post
Share on other sites

One more dumb question...I'm downloading now, but figured I'd ask...where in the init array should we put the "RESPAWNPOS:" switch? At the end?

So I've played with a few different ways and I'm sure I must be doing something wrong, but if I replace the "RESPAWN:" with the "RESPAWNPOS:", like this:

nul=[this,"area99", "SAFE", "RESPAWNPOS:", getmarkerpos "spawn1", 2, "CUSTOM"] execVM "scripts\upsmon.sqf"; 

I'm getting an error about line 214 in the /scripts/UPSMON.sqf file. If I try to run it with the 6.0.7 code which was working fine before (in 6.0.7), I don't get anything to respawn at all.

Like I said, I'm sure I have something out of order, but any help?

Share this post


Link to post
Share on other sites

@gatordev

you need the "RESPAWN" parameter.

The orders doesn't have any importance, only the group leader name and the area can't be moved in the array.

nul=[this,"area99", "SAFE", "RESPAWNPOS:", getmarkerpos "spawn1","RESPAWN:",2, "CUSTOM"] execVM "scripts\upsmon.sqf";

Share this post


Link to post
Share on other sites
I'm getting the same error. Are you spawning units?

I changed this

_unitpos findEmptyPosition [0,10];

to this

_unitpos findEmptyPosition [0,25];

and the error happens less often, but I still get it.

No all the AI are on the map at the start but i am using random

---------- Post added at 17:04 ---------- Previous post was at 15:55 ----------

also i have just found yellow dots on the map i dont have debug on http://i.imgur.com/YCeMlxB.png the 2 groups are on ambush2

Share this post


Link to post
Share on other sites
No all the AI are on the map at the start but i am using random
Then the common denominator is "RANDOM" as I am using that too.

Share this post


Link to post
Share on other sites

Hi !

I have a issue , what is the default speed ? because when i just put : nul = [this,"ups5","SAFE","COLUMN"] execvm "Scripts\UPSMON.sqf";

The patrol Run.

And when i put : nul = [this,"ups5","SAFE","COLUMN","LIMITED"] execvm "Scripts\UPSMON.sqf";

I record a video with this line.

https://www.youtube.com/watch?v=BBM_WHTthYs

The patrol still running. Any solution ?

Edited by pokertour

Share this post


Link to post
Share on other sites

@hellstorm77

You were only using "Random" ? the error seems related to Ambush or Fortify.

@pokertour

there were no enemies near ? Can you try outside the village, you create just before it happens,

Does it happens all the time ?

Share this post


Link to post
Share on other sites

No enemies near, it's a Coop mission for my Team, only my team in Blufor.

Same issue in field without houses.

Yes all time, with each squad.

Share this post


Link to post
Share on other sites
@gatordev

you need the "RESPAWN" parameter.

The orders doesn't have any importance, only the group leader name and the area can't be moved in the array.

nul=[this,"area99", "SAFE", "RESPAWNPOS:", getmarkerpos "spawn1","RESPAWN:",2, "CUSTOM"] execVM "scripts\upsmon.sqf";

Thank you! Works great now. Just didn't understand the syntax initially. Thanks again for continuing to work on this. It's so much nicer to make missions with this.

Share this post


Link to post
Share on other sites
@hellstorm77

You were only using "Random" ? the error seems related to Ambush or Fortify.

I was using ambush2 on 2 groups also. I did see some yellow dots on the map even though there was no debug on

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×