Jump to content
cool=azroul13

UPSMON Updated to ArmaIII

Recommended Posts

I am getting debug markers drawn even with UPSMON_Debug set to 0. These are the enemy knows about markers (little dots that follow me around on the map).

I was flying my helicopter testing out AA spawning, sometimes when flying over the squad I would get red dots drawn on the map that followed my last position. I'm assuming these are for debugging purposes only, but they are not being turned off with the above switch.

Share this post


Link to post
Share on other sites
I am getting debug markers drawn even with UPSMON_Debug set to 0. These are the enemy knows about markers (little dots that follow me around on the map).

I was flying my helicopter testing out AA spawning, sometimes when flying over the squad I would get red dots drawn on the map that followed my last position. I'm assuming these are for debugging purposes only, but they are not being turned off with the above switch.

it is a known issue that will be fixed in the next version, for now you can find the fix a few pages back in this thread.

Share this post


Link to post
Share on other sites
you could always create the triggers (or the units themselves with the 'nowp' UPSMON directive so that they wait until you are detected to move) by script at runtime if it really bothers you. you'd just need to go around and get all the coords first..

Nah, I'm just as happy leaving it to trigger radius and adding parameters thanks. If I really want to make things interesting, I'll make an array of the possible parameters and add a random series of them in.

Since I'm going to be playing it as well as designing it, it means I'm not always one step ahead of the mission when it comes to play with the group. Thanks though.

Share this post


Link to post
Share on other sites

I can finally share the last version of UPSMON:

http://www.fileconvoy.com/dfl.php?id=gc296cbd9361428d4999482956e39c781f45139929

I must thanks Grumpy old man, Gienkov and kord for this release.

changelog:

=== 6.0.7.2 ==================================================================================

Added: -All artillery units are supported in UPSMON.

-Battery support an artillery group can have multiple artillery units of same type.

Modified: -Ambush are now spawn to their ambush position (More usefull when you want to spawn quickly an ambush squad).

-With fortify parameter, the unit will search for cover if there are no buildings near.

Corrected: -Debug message that can be shown without Debug on (i hope it's the last).

-delete UPSMON group should be faster ({_x setvariable ["UPSMON_Deletegroup",true];} foreach units _UPSMONgroup).

-"init:" parameter (for sp at least)

-Template module (there weren't spawning the template)

-Paradrop units.

Share this post


Link to post
Share on other sites

Thanks for informing us about the updated release :)

New version frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

I'm busy testing a mission I made and noticed that 3 patrols I got in a 'town' to patrol along the roads will leave the marker area to attack me, despite using "NOFOLLOW". They never return and later when I get to the town it's almost empty except for patrols and units not using upsmon.

All 3 groups are running this >> nul = [this,"area0","NOVEH2","NOFOLLOW","ONROAD","SAFE"] execVM "scripts\UPSMON.sqf";

Share this post


Link to post
Share on other sites

Hi!

I got an error popping up all the time:

UPSMON_getArg =

{...'

Error Zero divisor

File C:\blah\blah\blah\scripts\UPSMON\COMMON\UPSMON_KRON_FNC.sqf,

line 73

Not using any fancy stuff, just FORTIFY and NOWP. Happens when the AI starts to engage...

Share this post


Link to post
Share on other sites
Can you try wit this version:

http://www.fileconvoy.com/dfl.php?id=g69d2be2d31aacdc39994838382ee76e8a1310a945

Try to reduce the UPSMON_sharedistance in the UPSMON_init.

Did the "NOFOLLOW" group see you or was it an other that see you the first time ?

I'll try it out and post back. I had the share distance set at 400 and it was in range of another group and my position when this happens. It was another group that would have seen me. I tested by placing myself in the town by these groups as an OpFor and had an invincible BluFor placed at the objective. The patrols end up reacting to the distant gunfire or bullets flying over and then make their way to the position, way outside of the rectangular marker area.

Share this post


Link to post
Share on other sites

wondering if someone could help me? Im using this code to spawn AI but how would i do x amount ie spawn 100 AI or 20 depending on the mission im making

if (!isServer) exitWith {};
_spawnPoint = _this select 0;
_patrolArea = _this select 1;
_side = EAST;

_spawngrp = [getMarkerPos "area0", EAST, (configfile >> "CfgGroups" >> "East" >> "OPF_F" >> "Infantry" >> "OIA_InfSquad")] call BIS_fnc_spawnGroup; 
sleep 3;
[_spawngrp,"area0","NOWAIT","patrol","SPAWNED","DELETE:",100] execVM "scripts\upsmon.sqf"; 

Share this post


Link to post
Share on other sites

I have tried clone parameter but not sure if im doing it right

if (!isServer) exitWith {};
_spawnPoint = _this select 0;
_patrolArea = _this select 1;
_side = EAST;
_spawngrp = [getMarkerPos "area6", EAST, (configfile >> "CfgGroups" >> "East" >> "OPF_F" >> "Infantry" >> "OIA_InfSquad")] call BIS_fnc_spawnGroup; 
sleep 3;
[_spawngrp,"area6","NOWAIT","RANDOMDN","SPAWNED","DELETE:",300,"MIN:",2,"MAX:",4] execVM "scripts\upsmon.sqf"; 

Share this post


Link to post
Share on other sites
I have tried clone parameter but not sure if im doing it right

if (!isServer) exitWith {};
_spawnPoint = _this select 0;
_patrolArea = _this select 1;
_side = EAST;
_spawngrp = [getMarkerPos "area6", EAST, (configfile >> "CfgGroups" >> "East" >> "OPF_F" >> "Infantry" >> "OIA_InfSquad")] call BIS_fnc_spawnGroup; 
sleep 3;
[_spawngrp,"area6","NOWAIT","RANDOMDN","SPAWNED","DELETE:",300,"MIN:",2,"MAX:",4] execVM "scripts\upsmon.sqf"; 

I would use: [leader _spawngrp,"area6","NOWAIT","RANDOMDN","SPAWNED","DELETE:",300,"MIN:",2,"MAX:",4] execVM "scripts\upsmon.sqf";

Share this post


Link to post
Share on other sites

i have placed an area marker 20 x 20 i set a spawn script to spawn in AI with AMBUSH2. they spawn into the area just fine then they disappear and get moved outside the area i wanted them to be in any ideas how to fix this problem?

Share this post


Link to post
Share on other sites

Ambush doesn't use the marker for setting up their ambush. You need to place the group where you want them to put the mine. If there's a road near them they will take it has an objective and they will find a position in cover where they can see the road or the position you place them at the beginning.

Share this post


Link to post
Share on other sites

This version is completly useless for me atm. im using the standard sample from the manual, tried FATA, Clafghan with it and the units get new WP´s assigned 1 meter in front of them. They circle on the same spot all the time. Is this a map problem?

Share this post


Link to post
Share on other sites

Cool, another issue I found. The artillery clases are not well defined for INDEPENDENT mortars, I changed it for the correct ones and Works perfectly.

Share this post


Link to post
Share on other sites
.... units get new WP´s assigned 1 meter in front of them. They circle on the same spot all the time. Is this a map problem?
Nope, not the map.

See suggestion from barbolani

I would use: [leader _spawngrp,"area6","NOWAIT","RANDOMDN","SPAWNED","DELETE:",300,"MIN:",2,"MAX:",4] execVM "scripts\upsmon.sqf";

i.e. Add leader.

However the RandomDN feature doesn't seem to be working. I'd also add "SAFE" to the above so units patrol with Combat status of SAFE i.e.

[leader _spawngrp,"area6","NOWAIT","RANDOMDN","SAFE","SPAWNED","DELETE:",300,"MIN:",2,"MAX:",4] execVM "scripts\upsmon.sqf";

I'd also like to add that the ambush routine works better in an old version of UPSMON I use from August last year.

Units actually place the mines on the road where the patrolarea marker is placed, then go and hide, instead of the mines autospawning and the units just hiding. The older way was more logical.

Edited by Beerkan

Share this post


Link to post
Share on other sites

KingoftheSandbox, Beerkan :

It would probably be helpful to include the parameters you are using for your group when you see the unit circling around like that. I haven't yet seen this behavior (although I am still using a test version from a few days before the current release.)

Share this post


Link to post
Share on other sites

I create an Empty Icon marker and call it "spawnOF1". Usually on the outskirts of a town.

Then I create a solid Rectangle patrol area and name it "area0" with a size between 150-300m in size, and place it over the town or area I want the "spawnOF1" group to patrol.

I then place a size 5 x 250 trigger on the map where BLUFOR units are likely to approach the town from.

Activation BLUFOR.

Once

Present

With this as the ON ACT:

_nul = ["spawnOF1", "area0"] execVM "Spawn_OFGrp1.sqf";

Spawn_OFGrp1.sqf with 10 individually defined units and skills.

if (!isServer) exitWith {};
_spawnPoint = _this select 0;
_patrolArea = _this select 1;

_side = EAST;
_skill = [0.2, 0.6];
_units = ["O_Soldier_SL_F","O_Soldier_F","O_Soldier_AAR_F","O_Soldier_TL_F","O_soldier_AR_F","O_soldier_GL_F","O_soldier_F","O_medic_F","O_soldier_exp_F","O_Soldier_LAT_F"];
_pos = getMarkerPos _spawnPoint;
_grp = [_pos, _side, _units, [], [], _skill] call BIS_fnc_spawnGroup;

{	_x setskill ["aimingAccuracy",(random 0.4)];
	_x setskill ["spotDistance",(random 0.6)];
	_x setskill ["spotTime",(random 0.8)];
	_x setskill ["courage",(random 0.5)];
	_x setskill ["commanding",(random 0.5)];
	_x setskill ["aimingShake",(random 0.4)];
	_x setskill ["aimingSpeed",(random 0.4)];
	_x setskill ["endurance",(random 0.6)];
	_x setskill ["reloadSpeed",(random 0.6)];
	_x setskill ["general",(random 0.6)];
} foreach units _grp;

sleep 3;
_leader = leader _grp;
null = [_leader,_patrolArea,"NOWAIT","RANDOM","SAFE","SPAWNED","DELETE:",300] execVM "scripts\upsmon.sqf";

Edited by Beerkan
So beginners can use my example

Share this post


Link to post
Share on other sites

@Barbolani

thanks,I will check that.

@Beerkan

What was the result, Do they stay at the spot or do they patrol ?

For UPSMON the marker is only use for the group with patrol or NoFollow parameter and now with Random parameter. Most of the time the marker is not taken in account by the script. For Fortify and Ambush parameter it only check the leader position.

The mines are spawned now because AI seems to love moving on mine even if they know about them :/

Share this post


Link to post
Share on other sites
@Beerkan

What was the result, Do they stay at the spot or do they patrol?/

Using leader will make them patrol ok, ie. if you use this as the call in a script
[leader _grp,_patrolArea,"NOWAIT","RANDOMDN","SAFE","SPAWNED","DELETE:",300] execVM "scripts\upsmon.sqf";

but if you include "RANDOMDN", it doesn't randomly respawn units safely on the ground inside the marker. They just respawn at their spawn marker and move to the centre of their patrol area.

This works just fine in the August 2013 UPSMON version

Edited by Beerkan

Share this post


Link to post
Share on other sites

Has anyone else had this problem, and if so, does it relate to UPSMON?

My AI running UPSMON will keep indefinitely "rearming" at crates or vehicles containing any sort of ammunition. And they'll forget about the war in the process. Any suggestions?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×