Jump to content
Sign in to follow this  
Yashamalu

Name and chat not showing

Recommended Posts

I've been playing Wasteland for a while and recently all the in-game text chat and killing notification are not showing, so I dont know whats going on in the map, whether I killed someone or not, and worst of all, no way to avoid team killers. Anyone coming across such issue?

Share this post


Link to post
Share on other sites

It may depend on the server and/or mission. I know for a fact that you can turn off the killing notifications, but I'm not sure about the chat. I believe you can disable the chat with scripting though, so maybe the server updated the mission or turned off these features?

Share this post


Link to post
Share on other sites

Sometimes when i play coop with a friend, one of us can't see the chat at all. Maybe it is related. It is a bug.

It doesn't happen every mission.

Share this post


Link to post
Share on other sites

I haven't played multiplayer since the latest patch, but there was a bug where alt-tabbing or hitting escape would cause all of the chat, player names, and VOIP identifications to disappear. Going back to the server lobby and then rejoining would fix it. I have no idea if this has been fixed, though.

Share this post


Link to post
Share on other sites

try looking in the SETTINGS under stream friendly Ui - I had this issue and realised that this setting had "reverted" back - I re-enabled it and all good again

Share this post


Link to post
Share on other sites

I've encountered that on multiple servers/missions. It's a bug. The visibility may change during one session.

Share this post


Link to post
Share on other sites

The AiA mod causes this. It changes some of the fonts for some reason. AiA is a great mod but thats one of the bugs I noticed.

Share this post


Link to post
Share on other sites

It's an Arma 3 bug.

It's also happening with no mods running at all. Very randomly, some people see chat, others don't.

We tested it specifically and played around with showChat. I've added this to our server side addon (client injection) to fix it:

// Chat fix
[] spawn {
player addMPEventHandler ["MPRespawn", { [] spawn { sleep 2; showChat true; }; }];
showChat true;
sleep 1;
showChat true;
sleep 5;
showChat true;
};

The list of such workaround fixes is getting longer and longer :(

Share this post


Link to post
Share on other sites
try looking in the SETTINGS under stream friendly Ui - I had this issue and realised that this setting had "reverted" back - I re-enabled it and all good again

Worked for me. Chat shows up now, but i'm not sure if i like it :D

"I need EXFIL at coordinates x/y ASAP!" - "You're on an ACRE server, use the radio to call it in and not the side chat." - "OK, but can i have EXFIL? And bring some AT, explosives and MedKits!" - "-.- really? What did i just say?"

  • Like 1

Share this post


Link to post
Share on other sites

OK the problem is solved, but in a rather strange way. I played another server and chats/kill notification are showing, and when I entered the old server I used to play and have problems the chats/kill notification are there again. Of course that could also be that I created a new character. No idea...

Anyway, thx for the help guys.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×