Jump to content
alduric

@A3MP - ArmA 3 Map Pack

Recommended Posts

Hey Alduric!

Great job man!

Sorry to ask this again but, is in your plans to make the "save game" possible?

Better saying, the "reload" of a saved mission.

Anyway, thanks a lot for your effort!

Share this post


Link to post
Share on other sites

Dunno if these have been reported, the thread is pretty large:

- Trees, walls, fences, and the like offer next to no resistance if you drive over them.

- There seem to be a lot of broken categories in the editor under "Empty". Looks like e.g. warfare buildings and stuff.

- Reloading a saved mission will always fail with an error about missing addons, all of them being Arma 2 files (ca_air and the like)

Especially the first and last are deal breakers IMO.

Share this post


Link to post
Share on other sites

Howdy-

Has anyone had any experience hosting this mod on a dedicated server?

I've enabled the mod @A3MP; on my server start.bat file.

It seems that while all the files are on the @A3MP mod folder on my dedicated server and the mod is supposedly enabled- it would not actually let anyone join in. I am running a mission based on proving grounds which is also on the dedicated server's mpmissions folder and the server keeps kicking me and everyone else off.

does anyone here know of a reason this is happening?? Or any way for me to fix this issue?

Thanks for reading.

Share this post


Link to post
Share on other sites
Dunno if these have been reported, the thread is pretty large:

- Trees, walls, fences, and the like offer next to no resistance if you drive over them.

- There seem to be a lot of broken categories in the editor under "Empty". Looks like e.g. warfare buildings and stuff.

- Reloading a saved mission will always fail with an error about missing addons, all of them being Arma 2 files (ca_air and the like)

Especially the first and last are deal breakers IMO.

Our very own Rund reported the 1st one on the 1st couple of pages & the 3rd has been mentioned a few times :cool:

Share this post


Link to post
Share on other sites

@Garmagor

cant offer a solution to your problem, but can confirm that this mod can be hosted fine on a dedicated server. Our servers are hosting a couple using Tadst that required no extra configuration.

Share this post


Link to post
Share on other sites

Hey zach. Could you please tell me your setup for the mod on your dedicated server? Please send me a private message, or accept my steam friend request?

I think that I am setting something up wrong.

Share this post


Link to post
Share on other sites
Howdy-

Has anyone had any experience hosting this mod on a dedicated server?

I've enabled the mod @A3MP; on my server start.bat file.

It seems that while all the files are on the @A3MP mod folder on my dedicated server and the mod is supposedly enabled- it would not actually let anyone join in. I am running a mission based on proving grounds which is also on the dedicated server's mpmissions folder and the server keeps kicking me and everyone else off.

does anyone here know of a reason this is happening?? Or any way for me to fix this issue?

Thanks for reading.

Missing .p3d files in @a3mp on first mission load can cause the server to kick back to the lobby. A reload of the mission after the kick back will let you in but if you restart the server it will kick you back again on first load.

Adding -nologs to the server's startup will prevent the kick back to lobby on first load.

Incidentally adding -nologs to your client startup will also significantly increase clientside performance since the addon produces a flood of rpt warnings which slow clientside performance during the rpt write process.

Also if you have verifysignatures enabled make sure that you have copied the @a3mp bikey the the server's keys folder. There was an issue with the bisign files not working in the first version of this addon so i resigned them specifically for our server but I believe that Alduric has since updated and fixed the bisigns?

Edited by [KH]Jman

Share this post


Link to post
Share on other sites

Good response, Jman. I'm gonna make sure all my servers/clients do that 'cos of the errors from @a3mp.

Share this post


Link to post
Share on other sites

Thanks for the reply and the help guys,

As of this moment the layout I have on the server is as thus:

@A3MP folder completely uploaded onto the main server folder.

Keys including a copy of the key that came with the mod which is called 'Alduric.bikey".

Here is my server A3server.cfg:

// FPSPLAYERS.COM
// server.cfg
//
// comments are written with "//" in front of them.

// STEAM

steamport		=8792;
steamqueryport        	=27062;

// GLOBAL SETTINGS

hostName = "[PBG] Home Server - (SThud/TMR Optional) - RECRUITING!";
//password = "6173565";
passwordAdmin = "278432";
reportingIP = "arma3pc.master.gamespy.com";
logFile = "";

motd[] = {
"Welcome to Point Blank Gaming.",
"WE ARE RECRUITING!",
"Please join us on teamspeak at:",
"23.29.125.6:10004 or pbgarma.enjinvoice.com",
"Or visit our website to find out more about us:",
"http://www.pbgarma.enjin.com"
};
motdInterval = 5;

// JOINING RULES
maxPlayers		= 50;		// Maximum amount of players. Civilians and watchers, beholder, bystanders and so on also count as player.
voteMissionPlayers	= 1;        	// Tells the server how many people must connect so that it displays the mission selection screen.
voteThreshold		= 0.33;     	// 33% or more players need to vote for something, for example an admin or a new map, to become effective
//voteMissionPlayers	= 0;

// INGAME SETTINGS
disableVoN = 0;
vonCodecQuality = 10;
persistent = 0;
persistent		= 1;        	// If 1, missions still run on even after the last player disconnected.

// MISSIONS CYCLE (Remove // below this line to make active)
class Missions
{
         class Mission1
        {
             template="PBG-PVP.ProvingGrounds_PMC";
             difficulty="veteran";
         };
};

kickDuplicate = 1;
equalModRequired = 0;
requiredSecureId = 2;
timeStampFormat = "short";

// SCRIPTING ISSUES
onUserConnected = "";					//
onUserDisconnected = "";				//
doubleIdDetected = "";					//

// SIGNATURE VERIFICATION
onUnsignedData = "kick (_this select 0)";		// unsigned data detected
onHackedData = 	"kick (_this select 0)";	//"ban (_this select 0)";			// tampering of the signature detected
onDifferentData = "";

The start.bat file is configued with this code:

start "" /wait "arma3server.exe" -config=servercfg\A3server.cfg -cfg=servercfg\Users\Administrator\Arma3Alpha.cfg -profiles=servercfg -port=2372 -cpuCount=2 -maxMem=2047 -noSound -exThreads=1 -nosplash server=server netlog=true -mod=@A3MP;@CBA_A3;@sthud;@tmr

I have to add also, which is stupid of me not to have done so before, that i am using FPSplayers' console to access the server, and thus have to enter everything manually.

The issue I am experiencing is that I log into the server, I see the 'group channel' pop up which generally from my experience means that I am logged into the server- but then instead of getting to the slot menu I get kicked by the server.

The console log reads as follows:

 7:37:24 Player Moses disconnected.
7:37:24 BattlEye Server: Player #0 Moses disconnected
7:42:38 Moses uses modified data file
7:42:38 BattlEye Server: Player #0 Moses (79.183.68.23:2304) connected
7:42:38 Player Moses connecting.
7:42:38 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:39 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:40 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:40 Mission PBG-PVP.ProvingGrounds_PMC read from bank.
7:42:40 BattlEye Server: Player #0 Moses - GUID: ee2414b9d397ace389c8223142fd09c5 (unverified)
7:42:40 Mission PBG-PVP.ProvingGrounds_PMC read from 

What can I do to fix this?

Thanks for reading again, and for the help.

Share this post


Link to post
Share on other sites

class Missions

{

class Mission1

{

template="PBG-PVP.ProvingGrounds_PMC";

difficulty="veteran";

};

};

Delete this and run mission manualy from list.

Share this post


Link to post
Share on other sites

Im not sure what you mean. The server is hosted on FPSplayers, its not a locally launched arma > multiplayer > host. The only thing I have access to are the config files and a 'start' and 'stop' button via a web console.

Share this post


Link to post
Share on other sites

I have been tampering with this for the past 7 hours trying to get it to work.

I have not really dealt with hosting servers and managing their files before so this is all very new for me. I apologize in advance if I missed something crucial here or do not understand how things work. Please tell me if im missing anything? We have been using this list to set which mission is going to be loaded on the server so far and so I dont see the logic of removing that batch from the configuration?

Share this post


Link to post
Share on other sites

Delete :

class Missions

{

class Mission1

{

template="PBG-PVP.ProvingGrounds_PMC";

difficulty="veteran";

};

};

From you server A3server.cfg

Share this post


Link to post
Share on other sites

Ive managed to get the mod to work now on our server.

The class missions had nothing to do with it actually- it was the mission itself which is for some reason not responding. Im gonna take that to a different forum.

Major kudos to Zach though for actually taking the time to explain some server hosting issues to me and introducing me to TADST. And to Jman for his tip about the -nolog.

Share this post


Link to post
Share on other sites

Glad you sorted it Garmagor.

If you'd like a mission to test on Proving Grounds here is a mission from our server

It requires: British Infantry, ALiVE, CBA and A3MP

Co10_ALiVE_BNeedle_1_2.ProvingGrounds_PMC.7z

Remove @sthud from the server startup it's a clientside addon and therefore not required serverside.

server cfg

You have two 'persistent' vars defined. Remove one and keep the one that's relevent.

Here's our A3 server guide

Edited by [KH]Jman

Share this post


Link to post
Share on other sites

So how do I install this? It keeps telling me something about volume when i try to extract all 3 files in the same folder.

Share this post


Link to post
Share on other sites

It's a split archive. Only extract part one to the folder.

The rest at extract themselves. As long as all three are in the same folder

Edited by KevsnoTrev

Share this post


Link to post
Share on other sites

So if one wishes to load 3rd party Arma2 islands, no need to use AiA? This should speed up the loading process.

Share this post


Link to post
Share on other sites

if it's normal then I'll leave it, but I don't think it looked like that in Arma 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×