Jump to content
Dwarden

Arma 3 STABLE server 2.10 "performance binary" feedback

Recommended Posts

Got something new with the 788 build:

https://www.dropbox.com/s/8y5sis4pdrbn2y7/arma3chernarus_2015-12-19_00-02-21.7z?dl=0

 

But this time i think i was to fast and stoppt + rebooted the server before he could throw a dump file out there...

But the RPT shows some interesting things.

Also the mem jumpt from 1gb to 1,3 at 1:03:01. together with the:

 1:03:01 Terminator (-1088386898) reached on (258,195)
rpt entry.
For the hole time with 788 (1 hour) there were 3 people online.


Hope this helps.

Share this post


Link to post
Share on other sites

@onefox I really wish you let the server crash ... that would dumps be more of use

Share this post


Link to post
Share on other sites

@onefox I really wish you let the server crash ... that would dumps be more of use

:D i will do but i cant tell when since its goning in a strange freeze state :/ most of the time the dump file is there.

Share this post


Link to post
Share on other sites

I understood, checking your RPT anyway  , maybe the debug trap catched something before the eof error

  • Like 1

Share this post


Link to post
Share on other sites

System

- Windows Server 2012/x64

- Malloc = system
- extDB Version = extDB(69)
- Game Mode/Version = Altis Life
- using life_fnc_MP

 

 

Version: 1.54.133741

 

13H uptime no Crash

 

asm-17-12-15-17-23-U13h.JPG

 

 

 

Version: 1.54.133788 perfor,amce binary V6

13H uptime No Crash

 

asm-19-12-15-17-01-U13h.JPG

Share this post


Link to post
Share on other sites

I have still having the same access_violation crashes, until I removed @TRYK. I have gone 20 hours with no crashes...

Share this post


Link to post
Share on other sites

Tryk and ryan crashing servers

The question is why since 1.54. What function do they use that BI changed and where a mem leak is now build in.

We could list all the functions of both mods and check the functions that both mods use for leaks.

Share this post


Link to post
Share on other sites

Running with the latest performance files now since release - No crash yet! And 70-80+ players the most time - 5 hours uptime cycle! 

Share this post


Link to post
Share on other sites

Server was up for four hours before crash, 64/64, it crashes right after reboot.

Logs pm'd to Dwarden

Share this post


Link to post
Share on other sites

I don't know if this is in anyway helpful or the correct logs, but here's a rpt from TADST.

Someone familiar with reading these rpts says ACE is likely causing my server to drop, probably due to a conflict with another mod (possibly some 3CB mod). I just don't get it because everything is up-to-date and was working fine until a couple days ago (when I updated to the new binaries).

TADST server rpt: http://pastebin.com/LWZAGNc8

Share this post


Link to post
Share on other sites

Our server is still having the out of memory crash, and our log folder isnt creating any new rpt files to post here. Where should I look to fix the problem of no new log files created?

Share this post


Link to post
Share on other sites

No crashes yet with V7, been using it for the last 12 hours

 

Edit*: Just crashed

 

2015/12/22,  1:48:59 Error: can't resize AutoArray to negative size!
=======================================================
-------------------------------------------------------
Exception code: C0000005 ACCESS_VIOLATION at 00A26E0B
 
I'll PM logs.

Share this post


Link to post
Share on other sites

System

- Windows Server 2012/x64

- Malloc = tbb4malloc_bi
- extDB Version = extDB(69)
- Game Mode/Version = Altis Life
- using life_fnc_MP

 

 

Version: 1.54.133792 performance v7

 

13H uptime no crash no restart

 

asm-24-12-15-17-13-U13h.JPG

 

Share this post


Link to post
Share on other sites

Here is another crash, at least i got some memory leaks away with using pushBack instead of the + operator when adding values to a array.

https://www.dropbox.com/s/zmhnuq29ht0v03c/crash_v7.7z?dl=0

Its a Error: can't resize AutoArray to negative size! Error.

 

You guys did something with the array itself right? (https://community.bistudio.com/wiki/Array) Could that be related?

 
From Arma 3 v1.53.132890 arrays are limited to maximum of 999999 (sometimes 1000000) elements

I am now able to fully reproduce it locally. (can take ~20 Minutes but than it crashes every time with only me on the server)

Share this post


Link to post
Share on other sites

hello please help me when im do this new update i have problem you were kicked from this game please help 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×