Jump to content
Dwarden

Arma 3 STABLE server 2.08 "performance binary" feedback

Recommended Posts

Hi Dwarden,

Can we get Linux bugs fixed?

 

1. Headless client wont stay connected with signature check enabled. 

2. Kneel action spam some times crashed the server generating 4gb rtp files.

3. Crash files doesn't get generated. "maybe my error"

 

 

Linux version of arma runs better than windows, there should be more love given to it :)

Share this post


Link to post
Share on other sites

1. Headless client wont stay connected with signature check enabled.

Would be awesome, also some clients have the signature timeout after a long time.

Share this post


Link to post
Share on other sites
serverFPS: 9.39518

That was probably the cause of your crash ;-)

Anyone wanna explain what's the different between SS2 and withoutSS2 ? 

 

 

 

:unsure:  I am a novice at PC engineering, But I use ss2 /w  I believe its of benefit if you have a late model memory controller

It allows the game to map the memory using advanced methods..U can google your brand and model and it should say if it

uses ss2 technology.  All diligence on my part(forums) indicate that it is more beneficial to use it if your system is compatible. :unsure:

Share this post


Link to post
Share on other sites

Where can I get this SS2 thing ya'll are talking about.

 

Its in Dwardens DropBox  as well   B)

Share this post


Link to post
Share on other sites

1.54.134495 profiling & performance v18 server and client, windows/linux

+ more crash fixes

+ several new error logging to narrow crash hunt

+ extra crash-logging via new commandline -crashDiag

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

 

p.s. those of you getting still getting server/hc crashes , it would be worth to try the -crashDiag and get us the extra output diag log

p.p.s. about the SSE2 allocator, it's just same tbb4 allocator compiled with SSE2 switch not SSE1

Share this post


Link to post
Share on other sites

Its in Dwardens DropBox as well B)

Thanks for that. Anyone have experience testing the difference between that one and fred41s tbbmalloc?

Will test V18

Share this post


Link to post
Share on other sites

Linux HC still getting kicked due to signature check time out, when verify signatures enabled. :(

Share this post


Link to post
Share on other sites

1.54.134495 profiling & performance v18 server and client, windows/linux

+ more crash fixes

+ several new error logging to narrow crash hunt

+ extra crash-logging via new commandline -crashDiag

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

 

p.s. those of you getting still getting server/hc crashes , it would be worth to try the -crashDiag and get us the extra output diag log

p.p.s. about the SSE2 allocator, it's just same tbb4 allocator compiled with SSE2 switch not SSE1

 

 

Where have i to add the "-crashDiag" ?

 

To the Startup Parameters ?

Share this post


Link to post
Share on other sites

Where have i to add the "-crashDiag" ?[/size]

 

To the Startup Parameters ?[/size]

yes, to server , HC or client startup command-line ...

depends where you tracking the crash

Share this post


Link to post
Share on other sites

Hi Dwarden, v17 seems to have fixed it for us (we haven't had a crash in 2 days).

Curious though, what exactly is the timeoutDisconnect parameter used for? I'd included it in my config_server and it seemed to reduce the number of crashes, but some clients have been getting kicked to side-select screen.

Removing this command seems to have fixed that issue...?

 

Thanks for your work on this!

Share this post


Link to post
Share on other sites

server.cfg's disconnectTimeout allows you as server admin to decrease the timeout wait time

by default that always was 90 second (for cooperative gameplay hosted on client computer)

unfortunately that's too long (especially for competitive gameplay where it can be exploited)

and in era of dedicated server it's not as much needed

so we allow you to define value from 5 to 90 seconds

there is known issue where value 5 seems to be too low for some Headless Client usage,

it's tested that value of 10 seconds works fine then

note: if anyone noticed I added it some week ago to BIKI too https://community.bistudio.com/wiki?title=server.cfg&diff=93883&oldid=93882

Share this post


Link to post
Share on other sites

server.cfg's disconnectTimeout allows you as server admin to decrease the timeout wait time

by default that always was 90 second (for cooperative gameplay hosted on client computer)

unfortunately that's too long (especially for competitive gameplay where it can be exploited)

and in era of dedicated server it's not as much needed

so we allow you to define value from 5 to 90 seconds

there is known issue where value 5 seems to be too low for some Headless Client usage,

it's tested that value of 10 seconds works fine then

note: if anyone noticed I added it some week ago to BIKI too https://community.bistudio.com/wiki?title=server.cfg&diff=93883&oldid=93882

 

Thanks for the rundown.

So, we haven't had a single crash since updating to v17 perf, but where we would receive crashes previously, we now have random individuals (or sometimes groups of players) getting kicked to the side-select screen. Nothing is reported in RPT logs of either client or server even indicating a crash or disconnect event.

The player also doesn't appear to re-initialise when they connect back into the server.

 

Raised this on feedback tracker; http://feedback.arma3.com/view.php?id=27873 as it may be an entirely separate issue (no idea to be honest as RPT not giving any useable info).

Share this post


Link to post
Share on other sites

@3lgstevo disconnectTimeout is in performance/profiling since v10 (1.54.133998)

so imho unrelated to your problems, unless you recently added it (then just increase the value to e.g. 10s)

Share this post


Link to post
Share on other sites

@dopefish please update to v19 ;)

Share this post


Link to post
Share on other sites

@3lgstevo disconnectTimeout is in performance/profiling since v10 (1.54.133998)

so imho unrelated to your problems, unless you recently added it (then just increase the value to e.g. 10s)

Added it (incorrectly) when we tested the v13 perf. Is the option required or can it be left at the default 90?

Probably a broad topic, but is there anything that could cause an abort action without it logging as a disconnect in the rpt logs?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×