Jump to content
Dwarden

Arma 3 STABLE server 2.08 "performance binary" feedback

Recommended Posts

Testing new 1.38 PERFormance v1 binaries ! ( 1.38.129079 )

(fixed physx matrix spam and overflow spam , recommended to use by clients too)

It is not solving camshake problem ? (just to know and be sure)

Ty.

Share this post


Link to post
Share on other sites

that's still wip, not fixed in this version

Share this post


Link to post
Share on other sites

Is this camshake problem only related to PERF/PROF servers or to stable too?

Didn't notice this on stable.

Share this post


Link to post
Share on other sites
that's still wip, not fixed in this version

TY for the fast answer ! :)

Dorph;2870980']Untill fixed you can try this:

http://steamcommunity.com/sharedfiles/filedetails/?id=382902027

Ty [HUD]Dorph i m applying the solution yet ! ;)

Didn't notice this on stable.

I can confirm it is occuring with stable branch server (on 2 servers with 2 differents missions : I&A and Domination) :(

Greats

Share this post


Link to post
Share on other sites
Is this camshake problem only related to PERF/PROF servers or to stable too?

Didn't notice this on stable.

camshake is still unfixed and yes it's also in stable

Share this post


Link to post
Share on other sites
TY for the fast answer ! :)

I can confirm it is occuring with stable branch server (on 2 servers with 2 differents missions : I&A and Domination) :(

Greats

Are you sure those missions are not attempting to alter the camera shake in someway and this is what's causing the shaking ?

Share this post


Link to post
Share on other sites

Blip I can. Confirm on stable we had bad camera shake issues until we implemented the init fix

Sent from my KFTHWI using Tapatalk

Edited by serjames

Share this post


Link to post
Share on other sites

@Dwarden, tested today: not real improvements on FPS front, but a lot more freeze reported by users.

Rolling back to standard 1.38 exe.

Share this post


Link to post
Share on other sites

users shall use the 1.38 perf v2 too otherwise it's not optimal ...

Share this post


Link to post
Share on other sites

Duely noted in your original post, but not really feasible with up to 100 players on the server.

In previous versions it was not necessary to update client as well to perf versions, so I think I'll have to wait for 1.40 :)

Freeze seems to be due to network messages pending so far.

Share this post


Link to post
Share on other sites

Is it correct that even if I switch to one of the perf/prof binaries that my version number doesn't change? Is there a way to check what version I'm running apart from looking at the executable?

Share this post


Link to post
Share on other sites

Ok, just found the error why my version number didn't change. You need to overwrite the original arma3.exe. I just copied the pref/prof versions it into that folder and left the original arma3.exe unchanged.

Is there a way to run those perf/prof with the -beta startup parameter as it was done in Arma2?

Share this post


Link to post
Share on other sites
Is there a way to run those perf/prof with the -beta startup parameter as it was done in Arma2?

No, as these aren't really official betas or anything. What I do is create a folder within the arma 3 directory called 'original exe', move the arma3.exe in there, rename the perf exe to 'arma3.exe' and drop it in the main directory. That way, if it turns out that one of these perf exes are buggered I can just drag the original exe out of its new folder and overwrite the new one. Same applies to the server. Not that hard is it? :P

Share this post


Link to post
Share on other sites
No, as these aren't really official betas or anything. What I do is create a folder within the arma 3 directory called 'original exe', move the arma3.exe in there, rename the perf exe to 'arma3.exe' and drop it in the main directory. That way, if it turns out that one of these perf exes are buggered I can just drag the original exe out of its new folder and overwrite the new one. Same applies to the server. Not that hard is it? :P

You don't have to explain how backups work. It's just extremly unhandy if you want to test the pref/prof with multiple people or even community, where some of them are lazy, not so techincally skilled or just not keen on touching the original files. It would be far easier if I could distribute those perf/prof via one of the community addon updaters and change the startup parameters in the launcher.

Edited by brainslush

Share this post


Link to post
Share on other sites

It is not compulsory for client to change their own .exe. They can join your server even if they are running original .exe.

My server is running with perf V3 and my own game is still with original .exe. I still can join and play without problem on it.

Share this post


Link to post
Share on other sites

those binaries/libraries are copied from PROFILING branch ... (which is available to public too(evolution, originally it wasn't))

the reason I've it on my Dropbox is to save time for those who don't want to switch inbetween branches

and in case we break something there are the predating builds so people can switch back/inbetween those

Share this post


Link to post
Share on other sites
It is not compulsory for client to change their own .exe. They can join your server even if they are running original .exe.

My server is running with perf V3 and my own game is still with original .exe. I still can join and play without problem on it.

I'm running perf v4 the same. No problems at all.

Share this post


Link to post
Share on other sites

So is this worth doing on our dedicated server if we have 25 - 30 players?

whats the go with arma3physx_windows_performance_138v4.7z, is that needed too?

---------- Post added at 10:00 ---------- Previous post was at 09:15 ----------

Is there a way to run those perf/prof with the -beta startup parameter as it was done in Arma2?

use a windows batch file like this and u can point it to whatever exe u want. have a couple different batch files and then u dont have to changed any files...

"C:\Games\Steam\steamapps\common\Arma 3\arma3.exe" -nosplash -showscripterrors -maxMem=8192 -cpucount=8 -enableHT -maxVRAM=2047 -nologs

@DWARDEN - after a few simple tests with arma3mark i have the following to report. SLI usage was lowered on the second card but there was more load on the first card. usually they will share the load evenly and sit at about 55% each during the bench, but with client performance build v4 the first card almost reached 80% while the second was 5 - 10%.

fps result was exactly the same @ 45.

specs

4970K @ 4.7

16gb ram @1600

2x 780

ssd

based on this i cant see it helping me (client side) as i would rather the gpu cards share the load evenly, especially if there is little to no gain in switching to perf.

do you think you will be able to fix the sli issue?

Edited by Azer1234

Share this post


Link to post
Share on other sites

Still getting the PhysX related error:

12:09:14 Matrix is not valid as physx transform! Object: O Alpha 2-2:1 (M.O.R) REMOTE (EAST_4), O_MBT_02_cannon_F, Remote

When this happens, it's flooding the rpt, everybody's screen gets shaking and scripts start failing/acting weird.

This NEEDS to be fixed for 1.40. It has effectively ruined every match we've tried to do in the last three weeks.

Share this post


Link to post
Share on other sites

that's caused by 1.38 stable clients on perf server

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×