Jump to content
Dwarden

Arma 3 STABLE server 2.06 "performance binary" feedback

Recommended Posts

58 minutes ago, iV - Ghost said:

 

 

Same problems on diferent servers after the 2.02 update.

But it seems that I'm the only one from our community.

(All tested servers are not hosted by Hetzner.)

 

Our community is having issues with the same and I was chasing a rumor that only other communities having the issue were on Hetzner servers.

Share this post


Link to post
Share on other sites
Posted (edited)

a friend sent me a fix for battleye kicks just add this line to your config.cfg or server.cfg it will allow you to enable battleye again on your servers

 

in the mission cycle area add this 

        autoSelectMission = true;

 

// MISSIONS CYCLE 
        forcedDifficulty = "Veteran";
        autoSelectMission = true; // add this to fix your battleye kicks when joining your servers
class Missions
  {
        class Mission1
    {
        template="msission1.takistan";
        forcedDifficulty = "Veteran";
    };    
        class Mission2
    {
        template="mission2_chernarus_A3";
        forcedDifficulty = "Veteran";
    };

  };

 

missionWhitelist[] = {
"msission1.takistan",
"mission2_chernarus_A3",
};

 

hope this helps seemingly battleye have changed their ip address and thats what is causing all the issues with kicks

 

Edited by PatPgtips
forgot something

Share this post


Link to post
Share on other sites
On 3/10/2021 at 5:56 PM, kMaN175 said:

 

Our community is having issues with the same and I was chasing a rumor that only other communities having the issue were on Hetzner servers.

Yes that also seems to be a trend with people reporting the problem to me. Something with hetzner and routing via DTAG.

I couldn't reproduce the issue on my Server.

Share this post


Link to post
Share on other sites

2.02.147419 new PROFILING branch with PERFORMANCE binaries, v4, server and client, windows 32/64-bit, linux server 32/64-bit

- Added: Config parameters to control whether a vehicle GetOut direction is opposite of its GetIn direction

- Fixed: Crash when selecting the last available audio device

- Fixed: Languages using Unicode characters were not rendering text correctly

- Fixed: Crash when placing a marker without the OK button being present - FT-T157299

 

Notes:
- Please pay attention that you are facing the correct/expected way when leaving a vehicle. Normally facing away from the vehicle, except some static turrets.

 

 

Also available for manual download (Downloads still WIP, they'll be up soon):

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

  • Like 1
  • Thanks 3

Share this post


Link to post
Share on other sites

2.02.147447 new PROFILING branch with PERFORMANCE binaries, v5, server and client, windows 32/64-bit, linux server 32/64-bit

 - Added: Audio option to configure the volume reduction on the map screen while inside vehicles

 - Added: _local parameter to all marker Event Handlers

 - Added: "affectedByWind" CfgAmmo entry for flares to let them be affected by wind speed (off by default)

 - Tweaked: Experimental FPS improvement in areas with many objects and active particle effects

 - Fixed: Player names not showing when hovering over map markers

 - Fixed: CfgFunctions not found error in Eden Editor - FT-T154708

 - Fixed: Game option changes were not always saving into the user profile

 - Fixed: When using deadzone, the aim would sometimes autocenter when zoomed - FT-T119242

 - Fixed: Units that were assigned to a custom channel would not delete properly - https://forums.bohemia.net/forums/topic/232760-ghost-objects/?tab=comments#comment-3430900

 - Fixed: Issues when trying to drag uniforms/vests from a dead body into a backpack container

 

 

Notes:

  • Please provide feedback on the map screen volume reduction. It's limited to a 25-100% range and only works while inside vehicles.
  • Please run benchmarks and compare FPS of profiling v4 to profiling v5 and see what effect this experimental improvement has.
  • You can now properly take uniforms from dead bodies and put them into your backpack. Therefore also taking uniforms out of backpacks lying on the ground and directly equipping them or putting them into your own backpack should work too.
    If you notice any problems with inventory operations, like moving uniforms/vests around, please report that immediately.

Note: This update comes with an experimental companion mod that adds new UI components for the audio settings menu and also includes SQF Bytecode for most vanilla functions.
You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036

 

Also available for manual download (Downloads still WIP, they'll be up soon):

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

  • Like 3
  • Thanks 5

Share this post


Link to post
Share on other sites

2.02.147473 new PROFILING branch with PERFORMANCE binaries, v6, server and client, windows 32/64-bit, linux server 32/64-bit

- Tweaked: Map volume reduction in vehicles minimum value changed from 25% to 0%

- Fixed: Crash caused by array insert script command

- Fixed: Map volume reduction not working in 3rd Person Perspective

- Fixed: setObjectScale on static objects (houses for example) not synchronizing properly in multiplayer

- Fixed: Potential freeze at "Initializing Addons"

- Fixed: Game crash when changing the audio output device in multiplayer with VoN being active - FT-T157418

 

Notes:

- Please provide feedback on the map screen volume reduction. It should only work while inside vehicles.
- If you notice any problems with inventory operations, like moving uniforms/vests around, please report that immediately.

 

Note: This update comes with an experimental companion mod that adds new UI components for the audio settings menu and also includes SQF Bytecode for most vanilla functions.
You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036

 

Also available for manual download (Downloads still WIP, they'll be up soon):

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

  • Like 1
  • Thanks 4

Share this post


Link to post
Share on other sites

2.02.147481 new PROFILING branch with PERFORMANCE binaries, v0, server and client, windows 32/64-bit, linux server 32/64-bit

 - Fixed: Car engine sounds not restarting when switching audio output device

 - Fixed: Possible freeze in the main menu when using single/dual core CPU

 

Notes:

- Please provide feedback on the map screen volume reduction. It should only work while inside vehicles.
- If you notice any problems with inventory operations, like moving uniforms/vests around, please report that immediately.

- This update comes with an experimental companion mod that adds new UI components for the audio settings menu and also includes SQF Bytecode for most vanilla functions.

You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036

 

Also available for manual download (Downloads still WIP, they'll be up soon):

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

  • Thanks 4

Share this post


Link to post
Share on other sites

The last Bis A3 update (09/03/21) seems to have removed waypoints, personnel markers, & mission task markers, on our Dedicated A3 Server. all the other "custom" difficulty settings still seem active & working. & if you host yourself with same settings  (waypoints=1;) they show, just not on the Dedicated??Anyone know how to fix the problem? Any help appreciated. think its something to do with  app233780 that Steam tries to download & fails

Share this post


Link to post
Share on other sites
On 3/28/2021 at 1:37 PM, jgaz-uk said:

The last Bis A3 update (09/03/21) seems to have removed waypoints, personnel markers, & mission task markers, on our Dedicated A3 Server. all the other "custom" difficulty settings still seem active & working. & if you host yourself with same settings  (waypoints=1;) they show, just not on the Dedicated??Anyone know how to fix the problem? Any help appreciated. think its something to do with  app233780 that Steam tries to download & fails

 

tries to download and fail?

The last update on 09th? Last profiling update was on 26th?

What game version are you on? should say in main menu on bottom right

Share this post


Link to post
Share on other sites

2.02.147497 new PROFILING branch with PERFORMANCE binaries, v8, server and client, windows 32/64-bit, linux server 32/64-bit

- Fixed: The language option sometimes failed to save (the changed language option would reset if the menu was accessed again before a game restart)

- Fixed: Possible freeze in the main menu when using a single/dual core CPU

- Fixed: Game options not saving properly (f.e. key bindings)

- Fixed: HideTerrainModule not working properly after loading a mission in 3DEN

- Reverted: Fix for "Issues when trying to drag uniforms/vests from a dead body into a backpack container"

Notes:

- Please provide feedback on the map screen volume reduction. It should only work while inside vehicles.

Note: This update comes with an experimental companion mod that adds new UI components for the audio settings menu and also includes SQF Bytecode for most vanilla functions.
You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036

 

Also available for manual download (Downloads still WIP, they'll be up soon):

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

  • Thanks 4

Share this post


Link to post
Share on other sites
On 3/11/2021 at 6:26 AM, PatPgtips said:

a friend sent me a fix for battleye kicks just add this line to your config.cfg or server.cfg it will allow you to enable battleye again on your servers

 

in the mission cycle area add this 

        autoSelectMission = true;

 

hope this helps seemingly battleye have changed their ip address and thats what is causing all the issues with kicks

 

 

I just added it to the server config and it worked for us.  I didn't need it in the mission cycle area.  Thank you for responding to my post and helping me fix a work around.

Share this post


Link to post
Share on other sites
On 3/28/2021 at 1:37 PM, jgaz-uk said:

The last Bis A3 update (09/03/21) seems to have removed waypoints, personnel markers, & mission task markers, on our Dedicated A3 Server. all the other "custom" difficulty settings still seem active & working. & if you host yourself with same settings  (waypoints=1;) they show, just not on the Dedicated??Anyone know how to fix the problem? Any help appreciated. think its something to do with  app233780 that Steam tries to download & fails

 

Same problem. The latest game and server version.

Changing the difficulty and server settings doesn't help.

  • Like 1

Share this post


Link to post
Share on other sites

not exactly sure when the problem started middle of March?

 

ArmA3 Version is 2.02.147359      I tried turning the 3rd person & crosshairs back on in the Users/serverARMA3PROFILE & there was no change they stayed off. Difficulty settings seems stuck somehow, its weird?

 

Seems were not the only one with the problem

On 3/31/2021 at 9:10 AM, Dedmen said:

 

tries to download and fail?

The last update on 09th? Last profiling update was on 26th?

What game version are you on? should say in main menu on bottom right

 

Share this post


Link to post
Share on other sites

2.02.147514 new PROFILING branch with PERFORMANCE binaries, v9, server and client, windows 32/64-bit, linux server 32/64-bit
 - Added: Secret Easter special
 - Fixed: RscEdit control not rendering text if a parent container is scrolled down but the control is at a Y offset - https://feedback.bistudio.com/T157448
 - Tweaked: Use CfgWorlds OutsideTerrain>>colorOutside on the map display if available

 

Notes:
 - Please provide feedback on the map screen volume reduction. It should only work while inside vehicles.
 - Pay attention to text rendering, if you see any Edit textbox control not rendering its text when you expect it to please report it. It shouldn't happen but better be safe.

Note: This update comes with an experimental companion mod that adds new UI components for the audio settings menu and also includes SQF Bytecode for most vanilla functions.
You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036

 

Also available for manual download:

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRG

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

  • Like 2
  • Thanks 2

Share this post


Link to post
Share on other sites
2 hours ago, jgaz-uk said:

not exactly sure when the problem started middle of March?

 

ArmA3 Version is 2.02.147359      I tried turning the 3rd person & crosshairs back on in the Users/serverARMA3PROFILE & there was no change they stayed off. Difficulty settings seems stuck somehow, its weird?

 

Seems were not the only one with the problem

 

Thats not profiling.

Please this thread is only about profiling branch specifics. If its not about profiling branch then make a ticket on our feedback tracker: https://feedback.bistudio.com/

Share this post


Link to post
Share on other sites

Already submitted Wed 30/02/21

 

https://feedback.bistudio.com/T157572

Share this post


Link to post
Share on other sites
On 3/10/2021 at 6:56 PM, kMaN175 said:

 

Our community is having issues with the same and I was chasing a rumor that only other communities having the issue were on Hetzner servers.

 

Usually disabling the Hetzner's own firewall implementation helps (for my server at least). It's under the Robot tab -> Servers -> Firewall (IIRC). Remember to keep your server's own firewall on in that case, though.

Share this post


Link to post
Share on other sites
On 4/9/2021 at 12:22 PM, Ezcoo said:

 

Usually disabling the Hetzner's own firewall implementation helps (for my server at least). It's under the Robot tab -> Servers -> Firewall (IIRC). Remember to keep your server's own firewall on in that case, though.

 

Thanks.  We didn't have any issues until after that Arma update so I'm not sure what changed.

Share this post


Link to post
Share on other sites

2.04.147541 new PROFILING branch with PERFORMANCE binaries, v0, server and client, windows 32/64-bit, linux server 32/64-bit

 - Sync with 2.04 main branch

  • Thanks 2

Share this post


Link to post
Share on other sites

2.04.147581 new PROFILING branch with PERFORMANCE binaries, v1, server and client, windows 32/64-bit, linux server 32/64-bit
 - Added: Warning if a server fails to bind to the BattlEye port
 - Tweaked: Performance improvement for PBO file lookups
 - Fixed: _forEachIndex variable inside forEach over HashMaps was broken
 - Fixed: Crash when saving a singleplayer game while a forEach over a HashMap was running
 - Fixed: Sound volume resetting when switching audio output device - FT-T158124
 - Fixed: Crash related to createSimpleObject

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites

2.04.147593 new PROFILING branch with PERFORMANCE binaries, v2, server and client, windows 32/64-bit, linux server 32/64-bit

- Added: Ability to configure Picture in Picture resolution

- Tweaked: Moved PiP view distance setting to a slider

- Fixed: TrackIR head rotation not synchronizing in multiplayer

- Fixed: A rare crash

 

Note: This update comes with an experimental companion mod that adds new UI components for the video settings menu and also includes SQF Bytecode for most vanilla functions.
You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036
If you don't load the companion mod you will get the message "No entry 'bin\config.bin/CfgVideoOptions.PiPVisibility'" at startup, but you can just click OK and Arma will launch and run fine.

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites

2.04.147616 new PROFILING branch with PERFORMANCE binaries, v3, server and client, windows 32/64-bit, linux server 32/64-bit

- Added: Timeout for Arma 3 Units data acquisition (default 30 seconds)

- Added: server.cfg option "armaUnitsTimeout" to configure the Arma 3 Units timeout

- Fixed: PiP quality changes not updating the Post Process resolution

- Fixed: Config entry not found error if launching without the Profiling companion mod (mod still required for the actual UI changes)

 

Note: This update comes with an experimental companion mod that adds new UI components for the video settings menu and also includes SQF Bytecode for most vanilla functions.
You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

Hi @Dedmen,

Following this release, myself and a few others were unable to load a particular map, https://steamcommunity.com/sharedfiles/filedetails/?id=2084904847, while running the performance binary while opening in editor. After disabling, we were able to load the map in editor.

This occurred when loading only the map, and it's dependency, no other mods.

 

The particular error in the .RPT was:
A3_Static_F_HMG_02 in a3\static_f\hmg_02\
A3_Structures_F_EPA_Civ_Constructions in a3\structures_f_epa\civ\constructions\
A3_Weapons_F_EPB in a3\weapons_f_epb\
A3_Weapons_F_Gamma_Rifles_MX in a3\weapons_f_gamma\rifles\mx\
Mods: A3;curator;kart;heli;mark;expansion;jets;argo;orange;tacops;tank;enoch;aow;@G.O.S. N'ziwasogo v2 APEX
Version 2.04.147615
Fault time: 2021/05/17 13:35:48
Fault address: A70C6FF4 00:A70C6FF4 Unknown module
file:
world: pja305
Prev. code bytes: 45 58 4C 8B 85 C0 00 00 00 48 8B 8D D0 00 00 00
Fault code bytes: 42 C6 04 08 00 4D 8B 80 40 04 00 00 41 8B D7 4F =======================================================

Thanks for all the work on this branch!

  • Thanks 1

Share this post


Link to post
Share on other sites

2.04.147628 new PROFILING branch with PERFORMANCE binaries, v4, server and client, windows 32/64-bit, linux server 32/64-bit
 - Fixed: Crash when trying to load a mission from a folder (not PBO)
 - Fixed: Crash when loading some terrains

 

Note: This update comes with an experimental companion mod that adds new UI components for the video settings menu and also includes SQF Bytecode for most vanilla functions.
You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

2.04.147660 new PROFILING branch with PERFORMANCE binaries, v5, server and client, windows 32/64-bit, linux server 32/64-bit

 - Tweaked: Server performance improvement

 - Fixed: Changing PiP resolution resulted in a black screen (oops)

 - Fixed: Players now cannot get in vehicles with disabled simulation via the action menu

 - Fixed: "Engine" Event Handler parameter was flipped if an engine change came in over network

 

Note: This update comes with an experimental companion mod that adds new UI components for the video settings menu and also includes SQF Bytecode for most vanilla functions.
You can download it here: https://steamcommunity.com/sharedfiles/filedetails/?id=2419451036

  • Like 2
  • Thanks 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×