Jump to content
Dwarden

Arma 3 STABLE server 2.04 "performance binary" feedback

Recommended Posts

Is it possible to tell me, what is this performance binary exactly?

I mean...what does it? Are there disadvantages? Why it is not the normal release version pp?

 

 

Best regards

Share this post


Link to post
Share on other sites

TL;DR: the perf binary adds bug fixes and performance improvements to the latest stable branch client/server, while remaining backwards compatible with the initial stable release. There should not be any disadvantages, other than the "opt in" nature of the performance binary.

Share this post


Link to post
Share on other sites

@s1k and @rasmusop I would suggest that you first update extdb.dll to latest version

  • Like 1

Share this post


Link to post
Share on other sites

@s1k and @rasmusop I would suggest that you first update extdb.dll to latest version

 

@Dwarden

 

Our version of Altis Life is not near compatible with extdb2, and our server worked awesome without any issues until 1.54. And people running extdb2 are also running into issues, been talking alot with communitys regards to this issue. Not to mention your issue tracker is full of these. Altis Life is not the only mission that has been struck, Exile and DayZ mods also has these.

 

 RPT it has a suspicious "Warning Message: Cannot open object ?縮(&e?Úž#Æ " before the crash

 

Here is the newest rpt logs with server rpt, mddmp and bidmp

 

http://game.nordicrp.net/rptnew.rar

Share this post


Link to post
Share on other sites

Tried the newest version and our server is still crashing within 30 minutes to an hour of starting it up. Until this gets patched, the game is basically unplayable on dedicated servers. Our group has shelved ARMA until BI releases an official patch to fix these constant crashes. 1.54 has really thrown a wrench in our group's weekend gaming sessions.

Share this post


Link to post
Share on other sites

Tried the newest version and our server is still crashing within 30 minutes to an hour of starting it up. Until this gets patched, the game is basically unplayable on dedicated servers. Our group has shelved ARMA until BI releases an official patch to fix these constant crashes. 1.54 has really thrown a wrench in our group's weekend gaming sessions.

 

They should revert patch, this is game breaking. So many flaming on this its ridicilous.

Share this post


Link to post
Share on other sites

Let's say that it is quite an annoying issue... We had two crashes today. Every time the server crash for being Out of Memory which is something that never happened before.

 

All see in before the server dies is this :

2015/12/13, 18:37:52 Small mapped regions: 24, size 106496 B

2015/12/13, 18:37:52 VM busy 4178153472 B (reserved 177917952 B, committed 4000235520 B, mapped 43843584 B), free 116682752 B

2015/12/13, 18:37:52 Longest free VM region: 4165632 B

2015/12/13, 18:37:52 Process page file used 3726 MB (3907805184 B)

2015/12/13, 18:37:52 Process working set 3464 MB (3632349184 B)

2015/12/13, 18:37:52 Page file free 9089 MB (9530925056 B)

2015/12/13, 18:37:52 Physical memory free 3517 MB (3688329216 B)

2015/12/13, 18:37:52 Virtual memory free 127 MB (133992448 B)

2015/12/13, 18:37:52 Virtual memory total 4095 MB (4294836224 B)

Share this post


Link to post
Share on other sites

@s1k and @rasmusop I would suggest that you first update extdb.dll to latest version

Thanks for responding dwarden.

I assume you mean the latest version of extDB2, as i thought this extDB1 build(35) is the latest/last build of extDB1. I'm definitely going to upgrade to extDB2.

I was wondering however, if you could provide any logic or insight as to why extDB versions/builds could possibly be related to this issue. ( had a "feeling" it had to do with extDB to be honest, from the beginning, but then i saw people on extDB2 having the same problem, so i figured it was unrelated and i was incorrect )

If you'd rather not say, to avoid mass confusion, i totally understand. Thanks again for everything you do.

Share this post


Link to post
Share on other sites

@greenpeanut

 

1. older version of extDB2.dll

based on your server RPT crash details

 

please, update to extDB2.dll version 66 (as per https://github.com/Torndeco/extDB2/blob/master/Changelog.txt )

2.

A. it seems you don't use Arma 3 dedicated data package on server 

B. you use Arma 3 client package install on dedicated server

C. it seems you have STEAMclient installed on dedicated server

 

please read my following tips (quoting myself to avoid retype)

 

 

 

in short, for dedicated server always use Arma 3 dedicated server data package, downloaded via STEAM cmd

no other clutter causing further issues (e.g. installing steam will cause it to start use steamworks .dll)

installing Arma 3 client data will cause server w/o -mod= to use those via registry

and more headache like ...

 

p.s. if it keep crashing after you cleanup the above, I do want the new dump/logs too ;)

We are using your performance.exe (1.54.133701)

and we downgraded to extDB2 (66). Used version 68.

Keeps crashing.

Logs

Share this post


Link to post
Share on other sites

We are using your performance.exe (1.54.133701)

and we downgraded to extDB2 (66). Used version 68.

Keeps crashing.

Logs

Same reason I keep crashing:  a3\map_altis\altis.wrp; WantedOffset: 128797953; ReadedIndex: -1123623202

Using extDB2 63.

Share this post


Link to post
Share on other sites

Hello.

 

Is there anything like a working version (memory bug gone) on the horizon before Xmass ? 

Our servers have been down since 1.54 and our community is dead because of this :(

 

Please say we will have working servers before you all go on holiday.

  • Like 1

Share this post


Link to post
Share on other sites

Hello.

Is there anything like a working version (memory bug gone) on the horizon before Xmass ?

Our servers have been down since 1.54 and our community is dead because of this :(

Please say we will have working servers before you all go on holiday.

According to the SlTREP they released yesterday, the are working very hard to find a fix before holiday. Interim solution is you can always run on 1.52 legacy build until they find a solution. In dwardens Dropbox the "previous builds" folder should also have the 1.52 v10 perf binaries you can use with 1.52 legacy.

Share this post


Link to post
Share on other sites

so as you maybe noticed we released hotfix #2 on stable branch (1.54.133741)

+

1.54.133760 profiling & performance v4 server and client, windows, linux server too

+ crash/issues/AI/UI/steam fixes, some tweaks and optimizing (for client too)

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

note: all the previous stable-fixes which were in performance v3 and hotfix #1 are now in the hotfix #2

+ all in new perf/prof was based off that but has more

  • Like 1

Share this post


Link to post
Share on other sites

so as you maybe noticed we released hotfix #2 on stable branch (1.54.133741)

+

1.54.133760 profiling & performance v4 server and client, windows, linux server too

+ crash/issues/AI/UI/steam fixes, some tweaks and optimizing (for client too)

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

Awesome dwarden, good to hear!

Share this post


Link to post
Share on other sites

13:17:54 Server: Object 2:9199 not found (message Type_91)
13:17:54 Server: Object 2:9184 not found (message Type_91)
13:17:54 Server: Object 2:9460 not found (message Type_119)
13:17:55 Server: Object 2:9455 not found (message Type_119)
13:17:55 Server: Object 2:9178 not found (message Type_119)
13:17:55 Server: Object 2:9794 not found (message Type_91)
13:17:55 Server: Object 2:9458 not found (message Type_119)
13:17:55 Server: Object 2:9199 not found (message Type_119)
13:17:55 Server: Object 2:8941 not found (message Type_91)
13:17:55 Server: Object 2:8940 not found (message Type_91)
13:17:55 Server: Object 2:9453 not found (message Type_119)
13:17:56 Server: Object 2:9144 not found (message Type_119)
13:17:56 Server: Object 2:9177 not found (message Type_119)
13:17:56 Server: Object 2:9192 not found (message Type_119)
13:17:56 Server: Object 2:9163 not found (message Type_119)
13:17:56 Server: Object 2:9184 not found (message Type_119)
13:17:56 Server: Object 2:9148 not found (message Type_119)
13:17:56 Server: Object 2:8975 not found (message Type_119)
13:17:56 Server: Object 2:9151 not found (message Type_119)
13:17:57 Server: Object 2:9469 not found (message Type_119)
13:17:57 Server: Object 2:9181 not found (message Type_119)
13:17:57 Server: Object 2:9159 not found (message Type_119)
13:17:57 Server: Object 2:9193 not found (message Type_119)
13:17:57 Server: Object 2:9145 not found (message Type_119)
13:17:57 Server: Object 2:9196 not found (message Type_119)
13:17:57 Server: Object 2:9169 not found (message Type_119)
Exception code: C0000005 ACCESS_VIOLATION at 00E5D495
 
 
extDB2 (F:\Server\@exileserver\extDB2.dll) [69.0.0.0] [69.0.0.0]
Distribution: 0
Version 1.54.133741
Fault time: 2015/12/16 13:17:58
Fault address:  00E5D495 01:0011C495 F:\Server\arma3server.exe
file:     Exile (__cur_mp)
world:    Esseker
Prev. code bytes: 01 FF 74 24 04 8B 01 FF 50 04 C3 57 8B 7C 24 08
Fault code bytes: 80 3F 00 75 04 33 C0 5F C3 8B C7 8D 50 01 8A 08
Registers:
EAX:C09480A3 EBX:00000001
ECX:01EAA200 EDX:0D8CAE30
ESI:FFFFFFFF EDI:C09480A3
CS:EIP:0023:00E5D495
SS:ESP:002B:00B2EE14  EBP:2493F4F8
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00210286
=======================================================
note: Minidump has been generated into the file SC\arma3server_2015-12-16_11-22-39.mdmp
 

Same issue as before I updated to the hotfix #2 for the server. I am testing the most recently posted binary and will post back if this also gives me access_violations for the server. What is in common with all the crashes is the object not found errors.

 

update

15 minutes into a restart the rpt is beginning to show this. I feel like it is going to crash again.

 

13:30:19 Error: Object(28 : 37) not found

13:30:27 Error: Object(27 : 47) not found

Share this post


Link to post
Share on other sites

@mintypie007 that's crash from hotfix #2 stable not 133760 performance v4 ;)

also the text is useless, what matter is whole .RPT, .MDMP and .BIDMP from moment of crash

inside archive (7zip, zip, rar) and uploaded to dropbox, google drive or similar 'usable' service and url sent to me (us)

Share this post


Link to post
Share on other sites

@mintypie007 that's crash from hotfix #2 stable not 133760 performance v4 ;)

also the text is useless, what matter is whole .RPT, .MDMP and .BIDMP from moment of crash

inside archive (7zip, zip, rar) and uploaded to dropbox, google drive or similar 'usable' service and url sent to me (us)

Messaged you the link. Crashes are more frequent since I updated to the performance binary.

Share this post


Link to post
Share on other sites

Aren't those errors something CBA said they fixed?

 

Yea I think it was in version 2.2 at least it had/has something to do with it.

ye definitely the best case scenario is ensure all your mods are on latest version, re-check known issues for those (e.g. they have already beta fixes)

same applies to callExtension libraries and custom allocators etc.

same us lot of headache while hunting phantom bugs :)

Share this post


Link to post
Share on other sites

Aren't those errors something CBA said they fixed?

 

Yea I think it was in version 2.2 at least it had/has something to do with it.

The object not found issues? I thought CBA was bad to run server side.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×