Jump to content
Dwarden

Arma 3 STABLE server 2.00 "performance binary" feedback

Recommended Posts

Hi Dwarden!

I'm getting reports from 50% of server population that their game drop to 3 fps after 4 min if playing, i was able to connect and also replicate same problem.

Seems like client sided issue. 

  • Like 1

Share this post


Link to post
Share on other sites

Here is my feedback so far:

 

I am running an Arma3 Server (1.56.135357v5) with Exile-Mod on Ubuntu 14.04 hosted on a  i7-3770 CPU @ 3.40GHz with 16 GB RAM.

 

Startparameters Server:

./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@infiSTAR_Exile;@FuMS

Startparameters HC:

./arma3servero -cpuCount=1 -client -nosound -connect=127.0.0.1 -port=2302 -mod=@exile -profiles=fumslogs

(arma3servero is the stock arma3server executable since the perfromance build does not work stable as HC).

 

basic.cfg

//
// Exile Mod basic.cfg Settings
//
// This file has been tuned for a box running only one Arma 3 server on a
// 1 GBit/s pipe with 100 slots
//
// See https://community.bistudio.com/wiki/basic.cfg
//

///////////////////////////////////////////////////////////////////////////////
// Default Options
///////////////////////////////////////////////////////////////////////////////
language = "English";
adapter = -1;
3D_Performance = 1.000000;
Resolution_W = 800;
Resolution_H = 600;
Resolution_Bpp = 32;

///////////////////////////////////////////////////////////////////////////////
// Bandwidth Tuning
//
// Be sure to adjust this to your server settings!
// This example is for 100MBit/s pipe
///////////////////////////////////////////////////////////////////////////////
// 50MB * 1024 * 1024 = 104857600
MinBandwidth = 52428800;    

// Do NOT set this too high or your Arma server will simulate ego-ddos
// 100MB * 1024 * 1024 = 629145600
MaxBandwidth = 104857600;        

///////////////////////////////////////////////////////////////////////////////
// Network Tuning
//
// Usually something we developers set. Only change these if you really know
// what you are doing. Do something wrong here and your sever will burn in hell
// and cause massive desych.
///////////////////////////////////////////////////////////////////////////////
MaxMsgSend = 256;
MaxSizeGuaranteed = 512;        
MaxSizeNonguaranteed = 256;    
MinErrorToSend = 0.004;    
MinErrorToSendNear = 0.03;        
MaxCustomFileSize = 0;

NIC is a 1 GB full duplex. Packet loss is under 2 %

 

This is a typical load when no user connected:


  1  [|||||||||||||||||||||||||||||||||||||                                                                  33.6%]     5  [|||||||||||||||||||||||||||||||||||||||||||                                                            38.4%]
  2  [|||||||||||||||||||                                                                                    16.4%]     6  [|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||99.3%]
  3  [||||||||||||||||||                                                                                     16.2%]     7  [|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||98.7%]
  4  [||||||||||||||||||||||||||||||                                                                         27.3%]     8  [||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||                                 63.8%]
  Mem[|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||10256/15771MB]     Tasks: 14, 58 thr; 4 running
  Swp[                                                                                                       0/0MB]     Load average: 4.95 4.82 4.66 
                                                                                                                        Uptime: 19 days, 05:50:44

  PID USER      PRI  NI  VIRT   RES   SHR S CPU% MEM%   TIME+  Command
    1 root       20   0 52164 14600  4164 S  0.0  0.1  3:15.06 /usr/bin/python /usr/bin/supervisord
29500 exile      20   0 1829M 1529M 30648 R 117.  9.7  1h45:02 `- ./arma3servero -cpuCount=1 -client -nosound -connect=127.0.0.1 -port=2302 -mod=@exile -profiles=fumslogs
29528 exile      20   0 1829M 1529M 30648 S  0.0  9.7  0:03.60 |  `- ./arma3servero -cpuCount=1 -client -nosound -connect=127.0.0.1 -port=2302 -mod=@exile -profiles=fumslogs
29527 exile      20   0 1829M 1529M 30648 S  3.3  9.7  1:16.07 |  `- ./arma3servero -cpuCount=1 -client -nosound -connect=127.0.0.1 -port=2302 -mod=@exile -profiles=fumslogs
29526 exile      20   0 1829M 1529M 30648 R 16.0  9.7 12:10.15 |  `- ./arma3servero -cpuCount=1 -client -nosound -connect=127.0.0.1 -port=2302 -mod=@exile -profiles=fumslogs
29502 exile      20   0 1829M 1529M 30648 S  0.0  9.7  0:00.67 |  `- ./arma3servero -cpuCount=1 -client -nosound -connect=127.0.0.1 -port=2302 -mod=@exile -profiles=fumslogs
29456 exile      20   0 2461M 2037M 49416 R 111. 12.9  2h11:04 `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@infiS
29545 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.35 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29544 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.38 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29543 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.35 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29538 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.00 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29537 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.00 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29536 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.03 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29535 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.03 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29534 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.03 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29533 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.02 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29532 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.02 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29531 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.02 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29510 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.41 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29495 exile      20   0 2461M 2037M 49416 S 25.3 12.9 38:34.55 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29494 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.00 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29490 exile      20   0 2461M 2037M 49416 S  0.7 12.9  0:07.75 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29489 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:03.58 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29488 exile      20   0 2461M 2037M 49416 S  4.0 12.9  2:07.54 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29487 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:16.66 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29486 exile      20   0 2461M 2037M 49416 S  6.0 12.9  3:47.59 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29474 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:48.02 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29473 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:49.07 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29472 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:48.42 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29471 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:48.35 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29470 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:48.57 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29469 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:48.25 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
29458 exile      20   0 2461M 2037M 49416 S  0.0 12.9  0:00.76 |  `- ./arma3server.perf -cpuCount=7 -exThreads=7 -maxMem=2047 -loadMissionToMemory -noBenchmark -nologs -port=2302 -config=config.cfg -mod=@exile -servermod=@exileserver;@in
27074 exile      20   0  5028  2688  2532 S  0.0  0.0  0:00.00 `- ./armaservermonitor -s
   18 root       20   0 24980  6616  2652 S  0.0  0.0  0:09.46 `- /usr/bin/python /usr/bin/pidproxy /var/run/mysqld/mysqld.pid /usr/sbin/mysqld
   25 mysql      20   0 2766M  626M  7656 S  0.0  4.0 10:55.97 |  `- /usr/sbin/mysqld
25881 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:06.02 |     `- /usr/sbin/mysqld
25823 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:07.87 |     `- /usr/sbin/mysqld
  765 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:12.08 |     `- /usr/sbin/mysqld
  764 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:11.55 |     `- /usr/sbin/mysqld
  205 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:13.87 |     `- /usr/sbin/mysqld
  204 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:12.82 |     `- /usr/sbin/mysqld
  203 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:11.88 |     `- /usr/sbin/mysqld
  104 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:12.51 |     `- /usr/sbin/mysqld
   46 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:00.00 |     `- /usr/sbin/mysqld
   45 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:05.36 |     `- /usr/sbin/mysqld
   44 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:02.67 |     `- /usr/sbin/mysqld
   43 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:00.00 |     `- /usr/sbin/mysqld
   42 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:38.89 |     `- /usr/sbin/mysqld
   41 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:02.10 |     `- /usr/sbin/mysqld
   40 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:34.41 |     `- /usr/sbin/mysqld
   39 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:05.13 |     `- /usr/sbin/mysqld
   38 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:48.03 |     `- /usr/sbin/mysqld
   37 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:24.35 |     `- /usr/sbin/mysqld
   35 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:41.73 |     `- /usr/sbin/mysqld
   34 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:39.77 |     `- /usr/sbin/mysqld
   33 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:40.03 |     `- /usr/sbin/mysqld
   32 mysql      20   0 2766M  626M  7656 D  0.0  4.0  0:45.14 |     `- /usr/sbin/mysqld
   31 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:38.89 |     `- /usr/sbin/mysqld
   30 mysql      20   0 2766M  626M  7656 S  0.0  4.0  0:38.99 |     `- /usr/sbin/mysqld
F1Help  F2Setup F3SearchF4FilterF5Tree  F6SortByF7Nice -F8Nice +F9Kill  F10Quit

The FPS and CPS  inDEcreases rapidly when players are coming on. Finally with between 10 and 15 players I notice constant FPS/CPS between 7 and 11.

 

What I am wondering about is that only 2 threads in the server process arma3server.perf are working while all others are bored. I have never seen the CPU load gone over 50%. Usually it is somewhere bewteen 16 and 34 %. So to me it looks like that arma3server (stock and perfromance build) is not scaling enough. There is no energy save in place and the CPU is running unthrotteled.

 

EDIT: Yes, all cores are in use, even if the above does not reflect it. I doublechecked with top -p <arma3server pid>, pressing 'f' and selecting 'P' for last CPU and 'nTH' for amount of threads used:

top - 13:52:08 up 19 days,  6:03,  1 user,  load average: 4.40, 4.71, 4.69
Tasks:   1 total,   1 running,   0 sleeping,   0 stopped,   0 zombie
%Cpu(s): 25.2 us,  0.6 sy,  0.0 ni, 43.9 id,  0.2 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem:  16150112 total, 15619308 used,   530804 free,   201776 buffers
KiB Swap:        0 total,        0 used,        0 free.  4935188 cached Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                                     nTH P 
29456 exile     20   0 2520904 1.992g  49416 R 158.4 12.9 149:07.27 arma3server.per                                              27 7

Regards

Blacksheep

 

That is nothing new bud, U lucky u get 2 threads active i get 1 and 6 others are chilling.

Share this post


Link to post
Share on other sites

My feedback on 1.58 (None Pref)

 

Memory bug still not fixed on windows 

Server still runs horrible 

Now clients get FPS drop to 3FPS slideshow after 3-5 min of playing (Windows and Linux servers tested) different missions.

 

Here is a pic from 5 hour game, CPS 0.2

Capture_6.jpg

 

Can we get actual functional updates instead of replacement skins and running while changing guns?

We need this game to be playble at least at 20 FPS not much to ask lol

Thank you, sorry Dwarden i shitted on your thread :)

  • Like 1

Share this post


Link to post
Share on other sites

first things first

if your server still has allocators I had on dropbox and got FPS or stability issues, try replace them with default new one from main stable branch

if your server still crashing and you got crashdumps, we need the RPT and MDMP and BIDMP files ASAP, upload to dropbox or googledrive as archive, send me URL via PM

if you have performance issues, can you run server with normal logging enabled, if there is anything usual, please same, PM me the RPT

then if nothing above helps, please PM me on Discord, Skype or IM so I can ask other questions

Share this post


Link to post
Share on other sites

Dwarden;

1.58 "stable" branch release

https://www.dropbox.com/s/914k1mk63kzzznl/crash.zip?dl=0

@life_server & @extDB installed

 

Also...

Is it possible for a template of the server profile configuration files to be released now that the options / classes have changed?

My server is no longer reading the "regular" difficulty settings because it's customised. I need to know what options are available now with 1.58 as I can't find a template for it anywhere.

Share this post


Link to post
Share on other sites

1.58.135689 profiling & performance v1 server and client, windows/linux

* more fixes of crashes, joining mp game and VON

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

note that above URLs for manual download might be overloaded by demand, in such case

you can always use the STEAMclient to switch to profiling branch

(performance binaries are used by default so nothing to worry about)

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for your fast response on this, Dwarden.

 

Can you provide a list or link to the location of all the new difficulty options too, please? I cannot find them anywhere (beyond the already listed ones in that other topic).

 

Something similar to this;

https://community.bistudio.com/wiki/Arma_3_Difficulty_Menu

 

EDIT: Nevermind, found this page eventually:

https://community.bistudio.com/wiki/server.armaprofile

Share this post


Link to post
Share on other sites

FYI: everyone who has sudden fps/stability issues and use 3rd party allocator / system allocator or obsolete allocators, switch to default TBB4 allocator (none defined)

  • Like 1

Share this post


Link to post
Share on other sites

nothing, profiling is debugging, analysis tracking ...

for normal use please just get performance binaries

 

Does this mean the thing on Steam isn't for normal use...? It says "Profiling" client, not performance; but it does give me better performance than vanilla stable. Now I am confused.

Share this post


Link to post
Share on other sites

profiling branch contains both performance and profiling binaries

when you switch to profiling branch the default binaries used are performance

when you use manual download you need to download just performance binaries

Share this post


Link to post
Share on other sites

Great new performance results (Fixes the 1fps LOD degradation bug) from this new v1 binary.

 

I have the details of how to install the new client performance binary in this thead.

Share this post


Link to post
Share on other sites

profiling branch contains both performance and profiling binaries

when you switch to profiling branch the default binaries used are performance

when you use manual download you need to download just performance binaries

 

With no .dlls enabled in my arma3/dll folder, massive slowdown and LOD loss after 10 minutes of gameplay.  Received this WinDbg analysis after I re-enabled tbb4malloc_bi.dll in my Arma 3 folder with no command line arguments, crashed with 1.58.135689 v1 'arma3client_performance_158_135689.7z' .exe, about 20 minutes into SP gameplay.:

FAULTING_IP: 
+4871a
00000000 ??              ???

EXCEPTION_RECORD:  ffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 00000000
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 00000008
   Parameter[1]: 00000000
Attempt to execute non-executable address 00000000

PROCESS_NAME:  arma3.exe

ADDITIONAL_DEBUG_TEXT:  
Use '!findthebuild' command to search for the target build information.
If the build information is available, run '!findthebuild -s ; .reload' to set symbol path and load symbols.

FAULTING_MODULE: 77590000 kernel32

DEBUG_FLR_IMAGE_TIMESTAMP:  5719dd3f

MODULE_NAME: arma3

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_PARAMETER1:  00000008

EXCEPTION_PARAMETER2:  00000000

WRITE_ADDRESS:  00000000 

FOLLOWUP_IP: 
arma3!simul::clouds::CloudGeometryHelper::SetDetailFadeStrength+4871a
01b0127a 84c0            test    al,al

FAILED_INSTRUCTION_ADDRESS: 
+4871a
00000000 ??              ???

MOD_LIST: <ANALYSIS/>

FAULTING_THREAD:  00001d5c

BUGCHECK_STR:  APPLICATION_FAULT_SOFTWARE_NX_FAULT_NULL_WRONG_SYMBOLS

PRIMARY_PROBLEM_CLASS:  SOFTWARE_NX_FAULT_NULL

DEFAULT_BUCKET_ID:  SOFTWARE_NX_FAULT_NULL

LAST_CONTROL_TRANSFER:  from 01b0127a to 00000000

STACK_TEXT:  
WARNING: Frame IP not in any known module. Following frames may be wrong.
00a6edf4 01b0127a 00a6ee30 00000000 729a39e0 0x0
00a6ee48 01af5106 729a39e0 00000001 00000000 arma3!simul::clouds::CloudGeometryHelper::SetDetailFadeStrength+0x4871a
00a6eedc 1000a5bd 33333333 33333333 7bf23000 arma3!simul::clouds::CloudGeometryHelper::SetDetailFadeStrength+0x3c5a6
00a6eef4 01b18871 3f800000 7bf23040 87f40800 tbb4malloc_bi!MemAllocA+0x46ad
00a6ef1c 10005df1 5d2d3b60 87f40800 5d2d3b60 arma3!simul::clouds::CloudGeometryHelper::SetDetailFadeStrength+0x5fd11
00a6ef2c 01c409f8 5d2d3b60 00000007 01b511f7 tbb4malloc_bi!MemSize+0x51
00a6ef38 01b511f7 0000001c 4488d47b 43aef5c2 arma3!simul::clouds::BaseCloudRenderer::FillIlluminationBlock+0x135a8
00a6ef60 01b18c79 5d2d3b60 3f800000 02206564 arma3!simul::clouds::CloudGeometryHelper::SetDetailFadeStrength+0x98697
00a6ef70 01a9a3dc 5d2d3b60 3f800000 0220310c arma3!simul::clouds::CloudGeometryHelper::SetDetailFadeStrength+0x60119
00a6efac 01a6b87e 3f800000 3f800000 87f42b00 arma3!simul::clouds::CellularCloudGrid::GetNoiseResolution+0x113cac
00a6efd4 10005e8d 9519b430 024e0388 024dc2b0 arma3!simul::clouds::CellularCloudGrid::GetNoiseResolution+0xe514e
00a6eff0 01771269 00000000 000000ab 00a6f024 tbb4malloc_bi!MemFreeA+0x4d
00a6f094 1000a5bd 1000a5ff 00a6f128 00000039 arma3!simul::clouds::CellularCloudNode::GetNoisePeriod+0x228f9
00a6f098 1000a5ff 00a6f128 00000039 00a6f0c8 tbb4malloc_bi!MemAllocA+0x46ad
00a6f0bc 1000a5bd 1000a5ff 00a6f14c 00000038 tbb4malloc_bi!MemAllocA+0x46ef
00a6f0f0 1000a8fb 00a6f14c 10005df1 603bccd0 tbb4malloc_bi!MemAllocA+0x46ad
00a6f10c 00e3e41a 603bccd8 00a6f14c 0000002d tbb4malloc_bi!MemAllocA+0x49eb
00a6f128 00e3e8f7 00a6f14c 1119d000 00000000 arma3!opus_get_version_string+0xae3a
00a6f27c 10005e8d 9488ebc0 00000000 01c3fd92 arma3!opus_get_version_string+0xb317
00a6f288 01c3fd92 9488ebc0 158739e8 00a6f2d0 tbb4malloc_bi!MemFreeA+0x4d
00000000 00000000 00000000 00000000 00000000 arma3!simul::clouds::BaseCloudRenderer::FillIlluminationBlock+0x12942


STACK_COMMAND:  ~0s; .ecxr ; kb

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  arma3!simul::clouds::CloudGeometryHelper::SetDetailFadeStrength+4871a

FOLLOWUP_NAME:  MachineOwner

IMAGE_NAME:  arma3.exe

BUCKET_ID:  WRONG_SYMBOLS

FAILURE_BUCKET_ID:  SOFTWARE_NX_FAULT_NULL_c0000005_arma3.exe!simul::clouds::CloudGeometryHelper::SetDetailFadeStrength

WATSON_STAGEONE_URL:  http://watson.microsoft.com/StageOne/arma3_exe/1_58_135_689/5719dd3f/unknown/0_0_0_0/bbbbbbb4/c0000005/00000000.htm?Retriage=1

Followup: MachineOwner

Share this post


Link to post
Share on other sites

Happy to report that this has fixed many issues for my players.

Running a modded server (although players also had issue on vanilla) with game crashing on startup, joining server or short while after playing in the server. The usual crash message was Status Access Violation, however others had graphical glitches with disappearing vehicles and players, followed by lag and then a crash.

The 1.58 perf binary was able to fix everyone's issues (as long as they used no allocators) and also improved client fps, have not checked server read puts if there was any improvement there. Thanks so much for the update.

Further info on the issues, 1/4 of server population experienced issues of some sort, we believed MoCap Melee was causing it with the new weapon switching changes however after removing people still continued to have problems, some people were able to fix their games through using certain settings or allocators, however using the perf binary solved it for everyone!

  • Like 1

Share this post


Link to post
Share on other sites

@deltafiveone

please look into C:\Users\%username%\AppData\Local\Arma 3\

there should be .BIDMP, .MDMP and .RPT files at moment of crash (in rare cases the MDMP is missing)

please compress those into archive (7z, zip, rar) and upload to dropbox or google drive then PM me the URL , thanks

  • Like 1

Share this post


Link to post
Share on other sites

Hello guys! Please make sure you simply UNTICK the Malloc option in the launcher. More details below. Do not tick it to use tbb4malloc_bi, as some users have reported they still get the 1fps issue if they have it ticked even with the default memory allocator in the text box. Just UNTICK it.

 

 

FYI: everyone who has sudden fps/stability issues and use 3rd party allocator / system alocator or obsolete allocators, switch to default TBB4 alocator (none defined)
+
new performance binary 1.58.135689
https://forums.bistu...76#entry3012976

 

1.58.135689 profiling & performance v1 server and client, windows/linux
* more fixes of crashes, joining mp game and VON
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

 

To quickly DETAIL THE FIXES: For anyone who didn't see this post - It has worked for a lot of people so I will repost in threads where it may be of some use.

 

Dwarden, feel free to remove this if this is not what you want.

 

  • REMOVE ANY custom memory allocator (Untick the box in the launcher, or remove the '-malloc=' entry from your startup exe/shortcut/etc.)
  • REMOVE ANY custom memory allocator from 'STEAM LAUNCH PARAMETERS'. (Right click ArmA 3 in Steam Library > Properties > Set Launch Parameters)
  • REMOVE ANY custom memory allocator from 'CUSTOM ARMA LAUNCHERS'. (Arma3Sync, etc)
  • CONFIRM THERE ARE NO CUSTOM MEMORY ALLOCATORS (Open ArmA 3 Launcher, click 'Parameters' > Basic 'Tab' > If there is entry 'Command Line Parameters', check it doesn't have -malloc=etc). If it DOES have that entry, that means you have a memory allocator launch parameter being forced via some other method, such as a shortcut to the arma3.exe.
  • Download the 1.58.135689 v1 'arma3client_performance_158_135689.7z' file from the link. (OPTIONAL STEP, MAY NOT ACTUALLY CONTRIBUTE TO THE FIX.)
  • Backup your arma3.exe from your arma 3 installation directory
  • Delete the arma3.exe and then put the arma3client_performance executable in your arma 3 installation folder.
  • Rename the arma3client_performance executable you just placed in the directory to arma3.exe
  • Play the game! Be sure to THANK DWARDEN AND DEV TEAM FOR THE QUICK FIX/RESPONSE AND POST YOUR FEEDBACK HERE IN THE CORRECT THREAD IF THIS WORKED FOR YOU

Share this post


Link to post
Share on other sites

 

Hello guys! Please make sure you simply UNTICK the Malloc option in the launcher. More details below. Do not tick it to use tbb4malloc_bi, as some users have reported they still get the 1fps issue if they have it ticked even with the default memory allocator in the text box. Just UNTICK it.

 

 

 

To quickly DETAIL THE FIXES: For anyone who didn't see this post - It has worked for a lot of people so I will repost in threads where it may be of some use.

 

Dwarden, feel free to remove this if this is not what you want.

 

  • REMOVE ANY custom memory allocator (Untick the box in the launcher, or remove the '-malloc=' entry from your startup exe/shortcut/etc.)
  • REMOVE ANY custom memory allocator from 'STEAM LAUNCH PARAMETERS'. (Right click ArmA 3 in Steam Library > Properties > Set Launch Parameters)
  • REMOVE ANY custom memory allocator from 'CUSTOM ARMA LAUNCHERS'. (Arma3Sync, etc)
  • CONFIRM THERE ARE NO CUSTOM MEMORY ALLOCATORS (Open ArmA 3 Launcher, click 'Parameters' > Basic 'Tab' > If there is entry 'Command Line Parameters', check it doesn't have -malloc=etc). If it DOES have that entry, that means you have a memory allocator launch parameter being forced via some other method, such as a shortcut to the arma3.exe.
  • Download the 1.58.135689 v1 'arma3client_performance_158_135689.7z' file from the link. (OPTIONAL STEP, MAY NOT ACTUALLY CONTRIBUTE TO THE FIX.)
  • Backup your arma3.exe from your arma 3 installation directory
  • Delete the arma3.exe and then put the arma3client_performance executable in your arma 3 installation folder.
  • Rename the arma3client_performance executable you just placed in the directory to arma3.exe
  • Play the game! Be sure to THANK DWARDEN AND DEV TEAM FOR THE QUICK FIX/RESPONSE AND POST YOUR FEEDBACK HERE IN THE CORRECT THREAD IF THIS WORKED FOR YOU

 

 

Using default malloc did fix the slideshow issue. But the performance is at least 30% inferior when compared to 1.56 with default malloc.

 

With 1.56, I could play in HostileTakeover KOTH US #1 server without any issues, using tbbmalloc with large pages enabled. Now it is totally unplayable for me even with the so called "quick fix".

Share this post


Link to post
Share on other sites

Ensure you do not have large pages enabled. (Regedit: Image File Execution Options > Arma3.exe > UseLargePages 32-bit DWORD value to (0x000000) 0

 

NOTE: They are working on an actual fix. The 'FIX' I posted was simply intended to alleviate the LOD Degradation issue as a result of Dwarden working tirelessly to give users a chance to continue playing.

 

THE REAL HOTFIX will come, just sit tight!

Share this post


Link to post
Share on other sites

Ensure you do not have large pages enabled. (Regedit: Image File Execution Options > Arma3.exe > UseLargePages 32-bit DWORD value to (0x000000) 0

 

You mistook large pages with the GimmeMoarFrames tweak (The one you mentioned), which has been incompatible with arma3.exe since more than a year ago.

Share this post


Link to post
Share on other sites

@deltafiveone

please look into C:\Users\%username%\AppData\Local\Arma 3\

there should be .BIDMP, .MDMP and .RPT files at moment of crash (in rare cases the MDMP is missing)

please compress those into archive (7z, zip, rar) and upload to dropbox or google drive then PM me the URL , thanks

@ Dwarden, sent.  Thank you!

Share this post


Link to post
Share on other sites

The Dropbox page has been "temporarily disabled" because "the account's links are generating too much traffic" (Error 429).

Share this post


Link to post
Share on other sites

The Dropbox page has been "temporarily disabled" because "the account's links are generating too much traffic" (Error 429).

you can always use the steamclient to switch to profiling branch

(performance binaries are used by default so nothing to worry about)

for first time ever is the demand for performance binaries so big that my dropbox went to disabled ;(

  • Like 1

Share this post


Link to post
Share on other sites

you can always use the steamclient to switch to profiling branch

 

For a Linux server it'd be "app_update 233780 -beta profiling -validate" right?

Share this post


Link to post
Share on other sites
gg, dropbox

 

Error (429)

This account's links are generating too much traffic and have been temporarily disabled!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×