Jump to content
Dwarden

Arma 3 STABLE server 1.96 "performance binary" feedback

Recommended Posts

tl:dr; if you have windows 8, update to 10 and use system allocator. 

 

Or just use windows 7 and pray the GNU/Linux port gets more updates in the future...

Share this post


Link to post
Share on other sites

1.66.139519 new PROFILING branch with PERFORMANCE binaries, v0, server and client, windows/linux

+ sync with 1.66.stable (with 1.64.perf changes/features which didn't make it into 1.66.stable)

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

  • Like 1

Share this post


Link to post
Share on other sites

Hello everyone,

as I found out about the performance build, I instantly started downloading Arma 3 in steam to check it out.

I was kind of a hardcore Arma2/3 mods gamer and dont know why I didnt hear about this before.

 

I have just one little question. In the latest release there is no memory allocator included. Do I have to use the one from the 1.64 v13 version?

Share this post


Link to post
Share on other sites

those allocators are now part of stable release

Share this post


Link to post
Share on other sites

those allocators are now part of stable release

So performance branch will now be obsolete?

Share this post


Link to post
Share on other sites

So performance branch will now be obsolete?

There is already a 1.66 perf. build.

Share this post


Link to post
Share on other sites

 SomeOne?      I donnot see any .dll in the ARmA3 MainGame that says malloc.   I have the perf tbb4malloc_bi.dll in my MainGame because I put it there.  It still says 2017.   I still launch with  tbb4malloc_bi(default)  from launcher,  so,  I've not sat and removed above malloc, and check all files,

MayB I'm lazy  but  How did they write tbb4malloc into stable build?  What do they call it? Because my tbb4malloc shows no sign of having been updated with  main game.

Share this post


Link to post
Share on other sites

 SomeOne?      I donnot see any .dll in the ARmA3 MainGame that says malloc.   I have the perf tbb4malloc_bi.dll in my MainGame because I put it there.  It still says 2017.   I still launch with  tbb4malloc_bi(default)  from launcher,  so,  I've not sat and removed above malloc, and check all files,

MayB I'm lazy  but  How did they write tbb4malloc into stable build?  What do they call it? Because my tbb4malloc shows no sign of having been updated with  main game.

They are stored in "dll" folder in arma 3 root folder.

Share this post


Link to post
Share on other sites

1.66.139566 new PROFILING branch with PERFORMANCE binaries, v0, server and client, windows/linux

+ fix some of the issues with eventhandlers

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

  • Like 2

Share this post


Link to post
Share on other sites

1.66.139566 new PROFILING branch with PERFORMANCE binaries, v1, server and client, windows/linux
+ fix some of the issues with eventhandlers
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

  • Like 1

Share this post


Link to post
Share on other sites

1.66.139614 new PROFILING branch with PERFORMANCE binaries, v2, server and client, windows/linux
+ sync with 1.66 hotfix and some crashfixes
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

  • Like 1

Share this post


Link to post
Share on other sites

1.66.139630 new PROFILING branch with PERFORMANCE binaries, v3, server and client, windows/linux
+ more crashfixes
+ fixed stuck VON transmit in lobby
+ optimizations to reduce memory waste/leaks (scripting, functions etc.)
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

  • Like 1

Share this post


Link to post
Share on other sites

the increase to 3GB limit is back, hence -maxmem=3071 works in profiling and even stable
it's part of the new memory rework (related to 64bit cleanup of code/changes) so we re-enabled it
thus some feedback on that would be quite welcome too ...
(note: 3GB limit for maxmem is available only on 64bit OS, on 32bit OS it is still 2GB)

Share this post


Link to post
Share on other sites

1.66.139634 new PROFILING branch with PERFORMANCE binaries, v4, server and client, windows/linux
+ more optimizations to reduce memory waste/leaks (scripting, functions etc.)
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

  • Like 2

Share this post


Link to post
Share on other sites

Has tried on DEV - 3071Mb.
In the editor - Productivity excellent, FPS 70-80, places 40-50.
On servers couldn't check. From all available DEV only Westland. I am connected to the server - well. Loading of a mission - it is good. Loading of a task of a mission - a mistake.
Reports.

https://www.dropbox.com/s/ogpdib8uaxwv87h/ArmaReport_Log_20161213T053656_Lex.zip?dl=0

https://www.dropbox.com/s/528taq7bzeoj1b8/ArmaReport_Log_20161213T054013_Lex.zip?dl=0

https://www.dropbox.com/s/5vbiukb0g3y0z1t/ArmaReport_Log_20161213T055117_Lex.zip?dl=0

There was no time, to check a game more carefully.

P.S.

What happened? After the last update of SECREP #00010 BattlEye - long start of a game. From the moment to press in a launcher "to Play" - before start games are played by about one minute.

http://imgur.com/hiRr6Te

It occurs on DEV and 1.66

Share this post


Link to post
Share on other sites

1.66.139665 new PROFILING branch with PERFORMANCE binaries, v5, server and client, windows/linux
+ optimizations to reduce memory waste/leaks (scripting, functions, objects etc.)
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-34performance-binary34-feedback/?do=findComment&comment=3127855

Discord feedback https://discord.gg/0aWSevYPq5W2FeM6

  • Like 3

Share this post


Link to post
Share on other sites

Regarding -maxmem=3071 with 1.66 v3, v4, v5 client binary

 

I experienced "choppy" and plain unplayable performance in MP only on "BECTI" and "Invade and annex" servers.

 

It fixed itself after removing the parameter.

 

OS: Win10 64

System memory: 8GB

HDD + 25GB SSD cache

CPU: i7 4770

GPU: GTX1060 6GB

 

 

Share this post


Link to post
Share on other sites

@ Dwarden - I had been meaning to ask so here goes:

 

My specs Win 7 x64 Pro, 32 GB DDR3-2400 CL10 RAM, 4.5 GHZ Haswell OC'ed, AMD 6950 CFX unlocked, game and OS on SSD.

 

During 1.60 performance testing, I had good performance up to the 6th to 7th test. From 8th-9th patch and on, I started getting memory leak errors which would drop me down to less than 5 FPS, and all the models LOD down to the basic one (looked like OFP) but without textures then either lockup or crash out. Same for 1.66 RC.

 

Then I switched to Dev 1.67 and STILL have this problem in 32 bit, even with maxmem set to 3 GB.

 

I just switched to 64 bit and it seems better but wanted to ask if 1.67 DEV 32 bit will incorporate the memory leak fixes? or can I apply these patches to 1.67 dev or at least the memory allocator?

Share this post


Link to post
Share on other sites

got any/enabled swap file? where is it located (sdd or hdd) ...

the 3GB limit may put higher stress on the way memory as is freed by engine later

Share this post


Link to post
Share on other sites
12 minutes ago, dwarden said:

got any/enabled swap file? where is it located (sdd or hdd) ...

the 3GB limit may put higher stress on the way memory as is freed by engine later

 

Swapfile is enabled, auto, on c drive which is on SSD.

 

I will try to move it to my second SSD and see if that helps. might be fragmentation.

Share this post


Link to post
Share on other sites

1.66.139754 new PROFILING branch with PERFORMANCE binaries, v6, server and client, windows/linux
+ crash fixes

+ new server.cfg setting inside Mission Cycle: randomOrder=<Boolean>;
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288

Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

 

note: new server setting which allows missions from Missions class to be selected randomly (with equal probability),

only rule is that two successive missions are always different (with exeption of one mission in the list).

 


class Missions {
randomOrder = true;
class mission1
{
template = "mission1.VR";
};
class mission2
{
template = "mission2.VR";
};
};

  • Like 1

Share this post


Link to post
Share on other sites

I'm still unable to se larger maxmem parameter than 2GB. Any number i put there larger than 2Gigs will reset to max 2gb. Arrow on the right (increasing) is unreachable after puting 2GB

Share this post


Link to post
Share on other sites

seems like you have problem with arma 3 launcher, make sure you updated DEV branch ...

also remember you need to have 64bit OS and select 64bit build in arma 3 launcher (there is option for 32bit too)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×