Jump to content
Dwarden

Arma 3 STABLE server 1.96 "performance binary" feedback

Recommended Posts

So is it 3 or 4 months that the servers havent worked now ?

Since December 1st.

Share this post


Link to post
Share on other sites

v10 crash logs

https://www.dropbox.com/s/sofizei19t30dd0/crash_v10.7z?dl=0

 

Ignore animation crash, dwarden. Turns out a guy was using a menu hack to disable unit variables / modify them.

Will move onto v12 (already had a crash on v11) and test, then 13...

 

Is there any correlation among the remaining serves that are experiencing crashes? type of mod / functions used etc...?

Share this post


Link to post
Share on other sites

Same type of crashing on both vanilla and modded servers for me, stevo.

Share this post


Link to post
Share on other sites

Had a crush this night on v 13. I've noticed that it crashed when one specific animation 'amovpknlmrunsnonwnondbr' was streaming:

 1:52:21 Streaming anim a3\anims_f\data\anim\sdr\mov\knl\run\non\non\amovpknlmrunsnonwnondbr.rtm
 1:52:21 ARTM Pos 2620, Size 103
 1:52:21 Virtual memory total 4095 MB (4294836224 B)
 1:52:21 Virtual memory free 2068 MB (2168922112 B)
 1:52:21 Physical memory free 25374 MB (26606923776 B)
 1:52:21 Page file free 36895 MB (38688190464 B)
 1:52:21 Process working set 1368 MB (1434677248 B)
 1:52:21 Process page file used 1701 MB (1784549376 B)
 1:52:21 Longest free VM region: 2066571264 B
 1:52:21 VM busy 2125979648 B (reserved 172810240 B, committed 1953169408 B, mapped 52142080 B), free 2168856576 B
 1:52:21 Small mapped regions: 23, size 106496 B

No other instances of this animation seen in logs. The error was 'Out of memory'. Archive here:

https://www.dropbox.com/s/knt6cwucg50h515/logs.7z?dl=0

Share this post


Link to post
Share on other sites

@Avka, @kupferkarpfen, @lgstevo

I need MD5 or SHA-1 checksums of all files in your server with anims_f_*.pbo

or pack those files into 7z and upload to dropbox and send me url

 

MD5 checksums are:

anims_f_bootcamp.pbo 5baf5d8bd281d9b746d83ef21fb3db72
anims_f_data.pbo de42edfe70c1527d1c9b5fe914c1e5e8
anims_f_epa.pbo fa67a4b0dac2db28397a701179946b1f
anims_f_epc.pbo b6abda994f4ca2cc2dd48dcf80bcd145
anims_f_exp_a.pbo ab2ec9eefc1d3017568e74095891246c
 
Corrupted files would explain why only the HC crashes, but neither client or server. Will retry with a fresh installation and latest perf-binary.

Share this post


Link to post
Share on other sites

@dopefish thanks a lot, we will analyze that

Share this post


Link to post
Share on other sites

Is there any correlation among the remaining serves that are experiencing crashes? type of mod / functions used etc...?

 

I've been working with Ryan Zombies and have been testing the last few performance builds with just spawners churning out waves of AI.

 

45 mins to an hour is all the servers will stay up before the negative memory crash.  V11 went the longest, especially when using his module spawners instead of the game logic spawners.

 

There may be a clue there - the game logic spawners cause the fault state and memory bloat, substantially faster.

Share this post


Link to post
Share on other sites

What is message? All server how i see write in log this. A lot of times... 

2016/01/28, 16:58:51 Server: Object 23:32 not found (message Type_119)
2016/01/28, 16:58:51 Server: Object 51:1 not found (message Type_119)
2016/01/28, 16:58:51 Server: Object 40:9 not found (message Type_119)
2016/01/28, 16:58:51 Server: Object 40:7 not found (message Type_119)
2016/01/28, 16:58:51 Server: Object 6:4 not found (message Type_119)
2016/01/28, 16:58:51 Server: Object 22:24 not found (message Type_91)
2016/01/28, 16:58:51 Server: Object 22:21 not found (message Type_91)

After this:

Streaming anim ... anim 1

Streaming anim ... anim 2

Streaming anim ... anim 1

Streaming anim ... anim 1

Error decompressing LZO:  ... anim 1

 

After this and crash: 

ARTM Loaded 2740 -> 103 | 103
ARTM Loaded 3721 -> 103 | 103
ARTM Loaded 4702 -> 103 | 103
ARTM Loaded 5684 -> 103 | 103
ARTM Loaded 6667 -> 103 | 103
ARTM Loaded 7649 -> 103 | 103
ARTM Loaded 8630 -> 103 | 103

I think all problems with cyclical call animation in 1.54 version. Clien <-> Server

For life server this repair, medical, restrain and  etc. animation call in mission with function

Share this post


Link to post
Share on other sites

that logging is for us to nail it, ignore it...

Share this post


Link to post
Share on other sites

On our server, Altis Life  with 120+ Players on evening did run following:

Restart periods between 4 and 6 hours.

 

v12 no runtime crash, only crashes at startup.

v13 terrible crashes every 30 - 90 minutes and startup crashes.

v14 stable since release yesterday 16:00 o´clock

 

good work dwarden, good work (anyone working in background and i don´t know)

Share this post


Link to post
Share on other sites

V14 is running perfectly stable for more than 24 hours. I validated the server files using steamcmd yesterday, but there were no errors reported.

Share this post


Link to post
Share on other sites

Same type of crashing on both vanilla and modded servers for me, stevo.

I stand corrected again then ;)

Share this post


Link to post
Share on other sites

@dwarden with -nologs the Server is running longer without Crash.

Testing V15 now

Share this post


Link to post
Share on other sites

yes but we need those full crash logs, hence using -nologs negate the point ...

Share this post


Link to post
Share on other sites

 

v15 log, crash 5min ago but looks like not because of memory? Exception code: C0000005 ACCESS_VIOLATION at 6C08E9D3

 

I dont know, here are the files:

need more infos?

 

Need key to unlock zip dude.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×