Jump to content
Dwarden

Arma 3 STABLE server 1.94 "performance binary" feedback

Recommended Posts

1 hour ago, Dedmen said:

Your profiling log shows 26ms of AI calculation on the server though. For what seems to be 4 groups

https://gist.github.com/winseros/692cf3685b5b3733d976dcf6dab584a6#file-captureframe-6260-2018-09-24_21-50-01-log-L7417-L7429

That shouldn't be there if there was no AI on the server itself.

 

Well, that's are empty groups somehow getting created on the server. I suggest they're left after players join/left the server. One thing I can be sure in - noone of the mission scripts calls the createGroup command on the server machine.

Anyways, the situation doesn`t change if I issue "{deleteGroup _x} forEach (allGroups select {local _x})" on the server.

 

But it gives a very short but a very high fps boost after I exec the disableRemoteSensors command on the server. FPS gets to 20-40 from 10, but lasts minutes.

Share this post


Link to post
Share on other sites

@Dedmen I somehow solved my previous issues - reduced the number of AI's here and there. But now there is another kind of issue with the server.

It works with high FPS numbers about 30-50 for approximately 18 hours, but after that, fps suddenly drops to ridiculous numbers of 1-3 fps. And those numbers do not rise back even after the number of players and AI enemies decreases.

My checks at such moments show there are not more units/vehicles/groups than when FPS is high. Also, I don't see any leaked/dead units/groups/vehicles on any of the machines. 

 

Could you take a look at the snapshot and advice? It looks another way than the previous one.

 

By the way, I know at least one more PvE server except us, who runs completely another mission but suffers the same kinds of issues.

Share this post


Link to post
Share on other sites
On 11.10.2018 at 8:58 PM, winse said:

Could you take a look at the snapshot and advice? It looks another way than the previous one.

Environment Sounds.. 500 out of 511ms of the total frame. Can't tell you more than that tho

Share this post


Link to post
Share on other sites

@Dedmen thank you a lot. All I can say - I have the following at the mission start in the init.sqf:

enableEnvironment [hasInterface, hasInterface];

Have no other ideas of how to influence the environment the other way. Maybe, the dynamic weather (e.g. rain - it makes sounds) which is handled by the server causes that. Or there is another leak in the game code:dozingoff:

Would be awesome if some BIS guy came and helped us out, e.g. @Dwarden

Share this post


Link to post
Share on other sites

So, there is apparently environment sound(s) "bug/leak", similar to the "FPS drop and performance degradation caused by the direct speech channel", that was recently fixed.

This then also needs to be addressed before next patch.

 

Share this post


Link to post
Share on other sites
22 hours ago, Groove_C said:

similar to the "FPS drop and performance degradation caused by the direct speech channel", that was recently fixed.

What? That bug had nothing to do with direct speech channel.

And IMO it's really far fetched to speak from a vanilla memory leak when one guy with lots of env sounds comes along. There are many mods that could cause that.

Or do you have any more data that I don't know about?

Share this post


Link to post
Share on other sites

I just suppose that such low, single digits server fps could be env. sound (s) related.

 

If it is, then this should be solved by BIS.

 

No mods on the server - pure vanilla.

Share this post


Link to post
Share on other sites
On 10/14/2018 at 2:46 PM, Dedmen said:

leak when one guy with lots of env sounds comes along. There are many mods that could cause that.

@Dedmen we're talking about the dedicated server fps. And the snapshot I provided was taken on the server machine. As @Groove_C says, there are no mods there - a pure vanilla server instance running A3 profiling branch. 

That`s, why I'm very very confused by the words regarding environmental sounds. They make no sense to be played on a dedicated server. But if they really are, and if you're right in your suggestions regarding the profile provided, then we really need some official attention.

Share this post


Link to post
Share on other sites

Will there be a 1.88 profiling/performance branch? I've seen files for linux in your Dropbox but no windows server files.

Share this post


Link to post
Share on other sites

I changed my game to profiling branch but the functions diag_captureFrame and diag_captureSlowFrame are not working. It is like if they does not exists.

 

Edit: The executable profiling files are there but the launcher don't use it. Fixed, thanks!

Share this post


Link to post
Share on other sites

Is there ever going to be a performance stable build for the main branch?
The performance of ARMA is not up to standards of 2019 and this needs to be fixed.

We wont be waiting for you for 5 more years until arma4. By that time, someone else will do it better and faster.
You really need to talk to your team dwarden and your bosses as well because the shotty crap being dished out to us is being exposed for what it really is.

We support the development of arma, if our expectations are being met. The moment they are entirely ignored, you are out of a job, so are they.

If I dont see performance increases in Arma3 before Arma4 is even announced for a release date, we will be blogging about it from these gamer studios here in Los Angeles about why people need to stop buying games from developers who just cannot produce quality anymore.

Share this post


Link to post
Share on other sites

@Diveyez no bias towards BI or anything else. Im not sure if you know what Arma runs on.. its a i think 14 years old engine (RV) that isnt even technically able to run Arma 3 and somehow it runs (not even bad if knowing the quirksin scripting and server administration). So the solution would be a new engine. There already is one in development, its called Enfusion (new in-house Engine).

Pros:

-Better Performance

-Future Proof

-New technologies like DX12 / Vulkan

 

Cons:

-mod compatibility??? (thats what Arma lives from)

-new bugs and quirks ( this is present on any more compicated engine and Arma is heck of a lot more complicated than BF or CoD)

-new scripting language , so probably Missions will not be compatible...

 

So we have 2 options

A) take what we have . And we got way better performance wise since the Alpha. I personally get stable FPS from 40 to 80FPS depending on the server and mods. I run a Ryzen R7 2700X (all core 4.1GHz)

B) lose probably all our mods (many developers moved along, because they finished they work) and there is no one to update them (look what happened with APEX and the Map lighting).

 

there is even 1 option i like the most: Make Arma 4 with the new Engine and make it backwards compatible like Arma 3 to Arma 2, even with performance cost.

 

Thats a tough choice if you ask me, but as of what i play im ok with 40 to 80 fps (Arma is not that fast paced that you would need 200fps like in doom).

 

PS: regarding someone will do it better and faster... someone would need the knowhow that BIS has and i mean not BI but BIS, because BI could ask BIS for help in many situations. Additionaly if there would be someone we would already have a Arma 2 competitor, the only thing we have is Squad, having no mod support and no scripting language at all. So if there is someone out there we like to see what they offer.

Share this post


Link to post
Share on other sites

Ill fix all the mods I use and host those fixes privately for my people. That's never an issue.
Just give us the new new! Its 2019!

Share this post


Link to post
Share on other sites

Many servers do not use Mods and many servers use Mods.
I don't even know which ones anymore. But everyone suffers from the performance problems of a modern PC, server, and numerous other VR-based limitations. These restrictions force us to give up a lot in favor of performance. There are many maps and Mods that also cannot be used and developed in a limited VR space, without sacrificing performance. Any move to the new Enfusion may create a partial or 100% recycling situation for Mods. The state and number of problems and limitations in Arma3 does not please anyone, much less not stimulate the creation of new Mods, maps, missions, scenarios and so on.I hope the new Enfusion will be able to cause the same interest and incentive in the processing of existing and new Mods.

I think that the appearance of the unpredictable problems and limitations of the new Enfusion is most alarming for everyone. Let's hope good events.

Share this post


Link to post
Share on other sites

The problems in comlicated Engines always exist, just by beeing complicated. RV suffers from that Enfusion will too and other bigger complicated Engines will too. Its just a matter of time till they pop up.

Share this post


Link to post
Share on other sites
8 hours ago, TheMasterofBlubb said:

The problems in comlicated Engines always exist, just by beeing complicated. RV suffers from that Enfusion will too and other bigger complicated Engines will too. Its just a matter of time till they pop up.

I don’t mind if Enfusion shows us such effects. )))

1060247528_HD.gif.15a4eda78a7e62643e271e

  • Like 2

Share this post


Link to post
Share on other sites
5 hours ago, lex__1 said:

I don’t mind if Enfusion shows us such effects. )))

1060247528_HD.gif.15a4eda78a7e62643e271e

Enfusion will also introduce sloped stalinium armor 😉

Share this post


Link to post
Share on other sites

I have decided to discontinue any ongoing mod development projects until I see major performance updates or a new version of Arma all together. It is just not worth it. Literally a nightmare as a developer to hear back from everyone that their 2019 computer running an RTX2080 and an i9 cannot run arma at a frame rate higher than 20FPS when in battle with AI infantry as infantry themselves.

  • Like 2
  • Confused 2

Share this post


Link to post
Share on other sites

Interesting how come i had a MP server running modded liberation with ~700 active AI and 15 players. All running at 55 server fps and client side depending on the PC from 40 to 120fps?

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
54 minutes ago, Diveyez said:

I have decided to discontinue any ongoing mod development projects until I see major performance updates or a new version of Arma all together. It is just not worth it. Literally a nightmare as a developer to hear back from everyone that their 2019 computer running an RTX2080 and an i9 cannot run arma at a frame rate higher than 20FPS when in battle with AI infantry as infantry themselves.

 

Sounds like you have issues with your current PC setup. Perhaps head over to https://forums.bohemia.net/forums/forum/153-arma-3-troubleshooting/ to resolve them.

  • Haha 1

Share this post


Link to post
Share on other sites

1.90.145405 new PROFILING branch with PERFORMANCE binaries, v00, server and client, windows 32/64-bit, included linux 32-bit server

+ sync with 1.90.main branch

 

1.90.145416 new PROFILING branch with PERFORMANCE binaries, v01, server and client, windows 32/64-bit, included linux 32-bit server

+ fixed some issues with new caches

note: the cache is now generated at -profiles= directory into \DataCache\cache.ch

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMclient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-184-performance-binary-feedback/?do=getLastComment

 

Arma anything discord:  https://discord.gg/arma

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites

@Dwarden - Thank you, I will test it. Btw, Linux versions present on Dropbox but not uploaded on Google Drive.

 

Update for Linux Dedicated Server with a lot of mods: it works if you create "DataCache" folder manually.

 

How to check?

Simply start ./arma3server and you'll see repeated message like:

Waiting for '/root/.local/share/Arma 3/DataCache/cache_lock' to be available

It seems Dwarden moved cache.ch from Arma folder to user profile but forgot to create cache folder?

 

First run will be quite long (up to 5 mins) due to cache calculation for server and each headless client. 

 

Share this post


Link to post
Share on other sites

note: in the new profiling build the cache is now generated at -profiles= directory into \DataCache\cache.ch

also there will be another update to profiling tomorrow to fix another issue related to session lost

Share this post


Link to post
Share on other sites

1.90.145423 new PROFILING branch with PERFORMANCE binaries, v02, server and client, windows 32/64-bit, included linux 32-bit server

+ fixed more issues (e.g. session lost)

 

note:

for client since 145146 build the `cache.ch` now goes into

``C:\Users\%windowsusername%\AppData\Local\Arma 3\DataCache\``

unless defined -profiles= path

 

if defined then the `cache.ch` is now generated at `-profiles=` directory

into sub-folder `\DataCache\`

 

temporary workaround:

we found out that sometimes create `cache.ch` fails because of special character in windows username

use "-profiles=test" startup command-line to try run game

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMclient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-184-performance-binary-feedback/?do=getLastComment

 

Arma anything discord:  https://discord.gg/arma

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×