Jump to content
Dwarden

Arma 3 STABLE server 1.94 "performance binary" feedback

Recommended Posts

1.66.139938 new PROFILING branch with PERFORMANCE binaries, v9, server and client, windows/linux
+ fixed missing RPT-log header

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=findComment&comment=3139161

Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

 

 

@h0nkX... yes all incorporated features in past builds are existing in onward builds unless mentioned as reverted / removed ...

  • Like 3

Share this post


Link to post
Share on other sites

Steam client & Steamcmd both seems to be pulling 1.66.0.139586 for ArmA 3 Server (233780) profiling branch on three different servers for me. Mentioned this to you on Twitter a few weeks back, never seemed to be fixed... Anyone else having issues with it?

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, SSgt Hito said:

sorry, whats the difference between the profiling and the performance .EXE  for the client side ?.

 

Info is on Dwardens first post.

Share this post


Link to post
Share on other sites
6 hours ago, afevis said:

Steam client & Steamcmd both seems to be pulling 1.66.0.139586 for ArmA 3 Server (233780) profiling branch on three different servers for me. Mentioned this to you on Twitter a few weeks back, never seemed to be fixed... Anyone else having issues with it?

 

you must be doing something wrong on the commandline for SteamCMD ...

because i use that always and it works on Windows fine ... (it never worked for Linux, hence manual download of server binary is only way)

Share this post


Link to post
Share on other sites
8 hours ago, afevis said:

Steam client & Steamcmd both seems to be pulling 1.66.0.139586 for ArmA 3 Server (233780) profiling branch on three different servers for me. Mentioned this to you on Twitter a few weeks back, never seemed to be fixed... Anyone else having issues with it?

 

Same issue here, always pulls stable server exe via Steamcmd (not tried from client).

  • Like 1

Share this post


Link to post
Share on other sites
On 11/1/2017 at 4:07 PM, dwarden said:

1.66.139938 new PROFILING branch with PERFORMANCE binaries, v9, server and client, windows/linux
+ fixed missing RPT-log header

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=findComment&comment=3139161

Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

 

 

@h0nkX... yes all incorporated features in past builds are existing in onward builds unless mentioned as reverted / removed ...

Now HC works even with password :don12:

Share this post


Link to post
Share on other sites

@ramius86 v10 coming shortly ... i do wonder if it will work too ...

Share this post


Link to post
Share on other sites

v10 is out ... it should readd what was removed as part of v9 fix but this time not broken

Share this post


Link to post
Share on other sites
22 hours ago, cyruz said:

 

Same issue here, always pulls stable server exe via Steamcmd (not tried from client).

 

 

On 1/11/2017 at 6:15 PM, dwarden said:

 

you must be doing something wrong on the commandline for SteamCMD ...

because i use that always and it works on Windows fine ... (it never worked for Linux, hence manual download of server binary is only way)

 

Using it on Windows.

 

Steam client and SteamCMD both pull from the same place. If it's not working correctly on the steam client, SteamCMD will have the same issue. Can you verify that your SteamCMD is pulling the right version # w/ a validate switch? Or perhaps share your working SteamCMD line?

 

My steamcmd line is as follows;

D:\SteamCMD\steamcmd.exe +login ***** +force_install_dir D:\ArmA3\A3Master +"app_update 233780 -beta profiling -betapassword CautionSpecialProfilingAndTestingBranchArma3" validate +quit

I can pull the ArmA 3 client's profiling build fine with this line (switch out 233780 to 107410), ArmA 3 server always pulls the stable exe though. It's confirming the password for the branch as valid (if you remove it, you get a wrong branch password error), so I know it's switching to the profiling branch fine...

Share this post


Link to post
Share on other sites

hmm, I just tried and downloaded both client appid and server appid as 1.66.139968 ...

Share this post


Link to post
Share on other sites

Wouldn't be able to share your steamcmd command line, could you?

Share this post


Link to post
Share on other sites

same as yours ... 

Share this post


Link to post
Share on other sites
4 hours ago, dwarden said:

same as yours ... 

 

This smells like a Steam issue or something wonderful and it's impacting people selectively. I even added a line to delete the old arma3server.exe first to make sure it wasn't a permissions problem in Windows, still pulls the same stable binary.

Share this post


Link to post
Share on other sites

just make sure you

exit STEAMclient

run steamcmd via "run as administrator"

Share this post


Link to post
Share on other sites

1.66.139968 new PROFILING branch with PERFORMANCE binaries, v10, server and client, windows/linux
+ readded what was reverted in v9 w/o breaking anything this time
 
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server
 
BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=getLastComment
Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

 

  • Like 1

Share this post


Link to post
Share on other sites

latest official memory allocators are already included in stable and profiling branch so no need to use older ones ...

if there will be new then i will say

Share this post


Link to post
Share on other sites
12 hours ago, dwarden said:

same as yours ... 

Curious, are you using a BI dev flagged account as your login, or a regular steam account which purchased the game normally?

 

Checked my appmanifests for ArmA 3 server from both the steam client method and the steamCMD method, and neither are mounting depot 233784 (which is where the profiling build's changes are located.) I'd assume my account doesn't have access to it or something?

 

ArmA 3 client's appmanifest shows that it's mounting the profiling depot (249503) fine with both steamCMD & the steam client however.

 

Client's appmanifest; 

http://pastebin.com/pf8RfLDQ

 

Server's appmanifest;

http://pastebin.com/K30C2q2R

 

Can you check your appmanifest to see if it's mounting them?

Share this post


Link to post
Share on other sites

works at both DEV and non-dev accounts ...

Share this post


Link to post
Share on other sites

How does one switch between the PERF and PROF branches?

Because my Launcher clearly indicates that I'm on the Profiling branch thanks to the green band in the top left-hand corner marked "Profiling" in white text?

I looked in the Parameters tab but found no command to switch to PERF.

Share this post


Link to post
Share on other sites
56 minutes ago, domokun said:

How does one switch between the PERF and PROF branches?

Because my Launcher clearly indicates that I'm on the Profiling branch thanks to the green band in the top left-hand corner marked "Profiling" in white text?

I looked in the Parameters tab but found no command to switch to PERF.

The branch is called "Profiling" but the default exe is the performance binary. If you want to run the actual profiling, rename the "arma3profiling.exe" to "arma3.exe".

Share this post


Link to post
Share on other sites
34 minutes ago, Greenfist said:

The branch is called "Profiling" but the default exe is the performance binary. If you want to run the actual profiling, rename the "arma3profiling.exe" to "arma3.exe".

Thanks I though so but I wasn't sure.

Share this post


Link to post
Share on other sites

Yep, can confirm that steam client downloads stable exe on profiling branch for the server. I actually asked about this some months ago on discord and dwarden assured me that it should work fine.

I blamed steam_appid thing cause you have to change the id to 107410 on the server for it to allow connections or something like that, but it appears there's something else going on.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×