Jump to content
Dwarden

Arma 3 STABLE server 1.94 "performance binary" feedback

Recommended Posts

15 minutes ago, dwarden said:

@Getsuga_10Shou

yes, you need replace the older tbb4allocator.dll with the one on dropbox (or update the game to latest profiling via steamcmd or steamclient w/e method you are using)

 

 

thank you sir

Share this post


Link to post
Share on other sites

Disclaimer, I don't do benchmarks often, let me know if I've left out important data or if you want me to do any other testing!


Did 6 quick tests on v7 varying the combinations of -enableHT, -cpuCount, and -hugepages. I used the "Yet Anoher Arma Benchmark v0.98" mission from the workshop because that seems popular...?

Also used the following params for all tests: -skipIntro, -noSplash, -malloc=system (Win 10 x64)
Overall quality preset: Standard. Render distance set to 4000m, object set to 2000, shadow set to 100
Game was restarted before each test, no mods were used, system specs in my sig.

Table:

d50N1Vn.png

 

Also not pictured, I tried a 7th test using the same parameters as #6 except I changed -cpuCount to 12, averaged 39 FPS.

For comparison, I also switched back to the main branch (1.66.139586) for an 8th / 9th test and used all the same settings as above, no mods, except with only the following parameters: -skipIntro, -noSplash, -malloc=system. Averaged 38.9 FPS in YAAB.
I tried one last test for shits 'n giggles on the main branch, same settings as above except I also enabled -exThreads and checked off all 3 boxes for it. Averaged 40.6

 

 

Basically I saw a ~2FPS delta between any given test. And frankly, the performance might have been exactly the same and the small FPS differences could've just been random variation. Rather underwhelming results for all that work.

 

EDIT: Just read this "...isn't using hugepages yet either (only tbb4)" That completely flew over my head. Just redid a test with the same settings as # 6 from above except I changed to tbb4, I still only averaged 40.4 in YAAB... Still no change :/

Share this post


Link to post
Share on other sites

@cnutter (as explained in the wiki) when you use -cpuCount= it will 'disable' -enableHT so just one or the other ;)

Share this post


Link to post
Share on other sites
19 hours ago, dwarden said:

@agorapolis

try "-password=agora"

anyway I need someone else to confirm this (no mods) as I had no time to check it

and more likely it will not be fixed before January anyway (team needs to have some holiday time)

Same, tried even with quotes but always same error

Share this post


Link to post
Share on other sites

Hello @dwarden

You guys continue delivering or what?! I tested both CPUcore numbers and HugePages; with latest TBB4, performance is better than blub's xtbbmalloc with LargePages Enabled!

 

Here some details:

  • sandy bridge 2500k cpu @ 4.6ghz, 8gb ddr3 1660mhz ram
  • increased core numbers from 4 to 6 (solo) gives better fps than blub's xtbbmalloc with LargePages trick
  • using HugePages startup param (solo) wasn't that impressive, fell behind xtbbmalloc
  • Using core count trick with HugePages causing worse performance, two dont mix together well, must be related to my sandy bridge
  • Core count increase with this tbb4malloc is absolutely best I've seen yet.

keep doing what you doing! thanks!

Share this post


Link to post
Share on other sites

well -cpucount/-enableht shall not really 'fight' with -hugepages ...

that's related to memory allocation and actually freeing some l2/l3 cache and less tlb lookups because the memory is mapped in large blocks etc.

 

thus I would combine those @archibald tutter

-hugePages -cpuCount=5 -exThreads=7

Share this post


Link to post
Share on other sites

more findings on latest perf build @dwarden

  • hugepages and cpucount doesn't really "fight" against each other, my bad defining it that way. But compared to xtbbmalloc compiled by blub (based on "tbb44_20160526oss") both of this latest tweaks still falls short.
  • maybe on a i7 cpu with more native threads and L3 cache, mixing these two will give better results and that is way to go, because we had so much hegemony on l3 cache and clockspeeds because of policies the cartel (intel) since 2010. AMD coming up with new architecture, will make available 20MB L3 chips available for the half price in very near future. But like i said, my heavily overclocked intel 2500k didn't had the big improvement with this or at least didn't exceed blub's build.
  • I'd do tests on AMD build If i can, lets say 8 threads amd chips. Because even if you get bad performance with intels, it is okay IMO, as long as you manage to spread workload better to more threads and make use of L3 cache better. The cartel hegemony is about to end (I hope).
  • comparing xtbbmalloc and using your TBB4 build with corecount and hugepages tweak; I am getting greater high frames on my regular 90players infantry only KOTH server. Issue is minimum low framerates and that is I believe what you implemented is pure experimental and it will get better.

summing up, i think if you continue this direction you go you will succeed improving arma performance greatly. I saw better HIGH framerates (lets say, at base, in 90 player koth mission) but lowest minimums were still fell short from bb44_20160526oss build of blub (xtbbmalloc with LP trick).

 

happy xmas to all! shortest day passed, from now on dayz will only get longer, mind is gettin stronger!

peace!

Share this post


Link to post
Share on other sites

From a simple client perspective, v7 is not working all that well in neither configuration. I get a lot of stutters and loading pauses with and without -enableHT and -hugespages. and tbb4.

 

The best üerform,ance in MP and SP from for a client is still v6 with no VRam and maxmem parameter and system allocator

 

OS: Win10 64

System memory: 8GB

HDD + 25GB SSD cache

CPU: i7 4770

GPU: GTX1060 6GB

 

 

Share this post


Link to post
Share on other sites

V7 is good but I still have better FPS in YAAB with xtbbmalloc.

arma3_2016_12_23_00_15_16.png

arma3_2016_12_23_00_33_33.png

Intel Pentium G3258@4.4GHz

4x4GB DDR3 RAM@ 1886MHz

ATI R9 270@1050/1500 (Crimson ReLive Edition 16.12.1)

Win7 64bit

w/o page file

Share this post


Link to post
Share on other sites

is there any news on a fix for the '3 FPS bug' that has now made its way into main stream stable branch?

Share this post


Link to post
Share on other sites

The 3fps bug has been here for months now and the game is barely playable for me due to this, i can play for aprox 1hour and the 3fps bug sets in and restart of game is only solution. I am afraid we will not see any change to this until the 64-bit .exe hits stable branch. I have not seen any official news about when this will happen but hopefully on next update, the game is not really enjoyable as it is now thats for sure.

  • Like 1

Share this post


Link to post
Share on other sites

   Anyone using the 1.67 perf?  That's dev .exe right? The 64 bit main game?  ( the one that's  in the DropBox.)

Share this post


Link to post
Share on other sites

So now that were back from the Christmas / New Years hiatus does anyone know if the coming performance builds will continue to be released on 64 bit? Haven't been putting much playtime into the dev release because I don't feel like downloading the 5GB every time I switch between main branch and dev.

Share this post


Link to post
Share on other sites

Hi Guys,

 

Some questions ,

 

  • How can i downlaod latest TBB ?
  •  
  • What is executable Arma 64 bit ? Is it working as 64 bit after the latest update ?
  •  
  • How can ı see the latest update version is 1.66 or 1.67 ?
  •  
  • Finally What is -Hugepages what is the main purpose on the steam luncher ?

 

Thanks,

Share this post


Link to post
Share on other sites

there will be no 64-bit for 1.66 performance builds, it's too many changes (absurd amount of work needed to merge it all and test) ...

that's why 64-bit exists only for DEVELOPMENT branch

 

hugepages, read

in short, instead of 4kB blocks, the engine attempts use 2MB blocks and if needed some small ones (yet if it fails completely it still shall use only 4kB)

Share this post


Link to post
Share on other sites

1.66.139937 new PROFILING branch with PERFORMANCE binaries, v8, server and client, windows/linux
+ crashfix with lobby menu (may sort some trackir/freetrack crashes)
+ yet another memory leak squashed

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=findComment&comment=3138781

Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, dwarden said:

1.66.139937 new PROFILING branch with PERFORMANCE binaries, v8, server and client, windows/linux
+ crashfix with lobby menu (may sort some trackir/freetrack crashes)
+ yet another memory leak squashed

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=findComment&comment=3138781

Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

 

 

 

Headless client still got kicked with wrongpassword :down:

Share this post


Link to post
Share on other sites
2 minutes ago, ramius86 said:

Headless client still got kicked with wrongpassword :down:

which profiling build this started to happen ?

Share this post


Link to post
Share on other sites
2 minutes ago, dwarden said:

which profiling build this started to happen ?

6 or 7, more likely 7

Share this post


Link to post
Share on other sites
8 minutes ago, ramius86 said:

6 or 7, more likely 7

 

linux or windows?

Share this post


Link to post
Share on other sites
Just now, dwarden said:

 

linux or windows?

Windows, didn't test linux perf since a while

Share this post


Link to post
Share on other sites

Hmm, first time I started running an Exile server, (I'm such an idiot, should've done it sooner, especially since I started dev'ing games 12 years ago). Anyway, lot's of these scripts and addons are poorly written,quick OT throw in

 

What's more efficient:

        if(_side == "survivor") then 
        { 
            _group = createGroup SC_SurvivorSide; 
        } 
        else 
        {
            _group = createGroup SC_BanditSide;
        };

OR

        _group = createGroup SC_BanditSide;
        if(_side == "survivor") then 
        { 
            deleteGroup _group;
            _group = createGroup SC_SurvivorSide; 
        };    

Below is the excerpt from a popular Exile addon, it runs the if statement anyway, why create and delete the group.... that's just illogical. Ugh.

 

And FPS is an issue that is severely affected by what's going on the server. Maybe one statement like this ain't nothing, but through all the files inside the game, count 1 bad statement per file, that's a huge swing.

 

Anyway, rant over. My 2 questions are:

 

1. Running the A3DS on my old i7 machine, and I NEVER get more than 30% CPU usage, usually more around 25-26% in total. So essentially, the server is using 1 core, 2 threads total, is there any way to max the usuage?

 

2. If I start running 1.66 Perf 07 or 08 on the server, will clients running the now current A3 version (from Steam) will be able to connect? I believe this is 1.66.139586 ATM.

 

Share this post


Link to post
Share on other sites
18 hours ago, dwarden said:

1.66.139937 new PROFILING branch with PERFORMANCE binaries, v8, server and client, windows/linux
+ crashfix with lobby menu (may sort some trackir/freetrack crashes)
+ yet another memory leak squashed

 

Is -hugepages and all the stuff from perf7 supported in perf8 - is the allocator from perf7 workin with perf8?

 

Cheers

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×