Jump to content
Dwarden

Arma 3 STABLE server 1.94 "performance binary" feedback

Recommended Posts

10 minutes ago, dwarden said:

+ new server.cfg setting inside Mission Cycle: randomOrder=<Boolean>;

I wanted this setting for years!! thx))

Share this post


Link to post
Share on other sites
3 hours ago, Vasily.B said:

I'm still unable to se larger maxmem parameter than 2GB. Any number i put there larger than 2Gigs will reset to max 2gb. Arrow on the right (increasing) is unreachable after puting 2GB

 

 

 

    U can use the properties tab and enter startup param -maxmem=,  or In the launcher there is a 'startup parameters' option (check) where u create a folder od startup parameters in the main game directory.   There u can create a folder with a parameter file  maxmem=.  :don16:

Share this post


Link to post
Share on other sites
15 minutes ago, dvdbrewster said:

 

 

 

    U can use the properties tab and enter startup param -maxmem=,  or In the launcher there is a 'startup parameters' option (check) where u create a folder od startup parameters in the main game directory.   There u can create a folder with a parameter file  maxmem=.  :don16:

Do you think i dont know.... I just sayed i cannot put IN LAUNCHER any larger than 2 GB at maxmem parameter.

@dwarden i tough the 3GB limit is for stable :
 

Quote

However, although it is true the support for 64-bit has yet to hit our Main Branch, we decided to give you all at least something as a small appetizer. Starting with Update 1.66, when run on 64-bit Windows, 32-bit Arma 3 will be able to effectively work with more than just 2 GB of memory. The current limit has been increased to 3 GB. Magic, yay!

https://dev.arma3.com/post/oprep-64-bit-executables

Share this post


Link to post
Share on other sites
1 minute ago, Vasily.B said:

Do you think i dont know.... I just sayed i cannot put IN LAUNCHER any larger than 2 GB at maxmem parameter.

@dwarden i tough the 3GB limit is for stable :
 

https://dev.arma3.com/post/oprep-64-bit-executables

  No, that's not where it goes.. mine does same thing.  There is a different  box.

 

 

Share this post


Link to post
Share on other sites
23 minutes ago, dvdbrewster said:

  No, that's not where it goes.. mine does same thing.  There is a different  box.

 

 

I need a beer and double check it, its friday at least :D  I wasnt launching this game since...... i dont remeber. Will check it

JUST TRIED
and it doesnt work - arma will not utilize more than 2GB even with additional parameters txt file aquired in launcher.

Share this post


Link to post
Share on other sites
23 hours ago, Vasily.B said:

JUST TRIED
and it doesnt work - arma will not utilize more than 2GB even with additional parameters txt file aquired in launcher

 

 

Isnt ot supposed to be hpp  instead of .txt?

Share this post


Link to post
Share on other sites
22 minutes ago, dvdbrewster said:

 

 

Isnt ot supposed to be hpp  instead of .txt?

No, it can be txt, it allways could be txt.

Share this post


Link to post
Share on other sites

Since 1.66 the frame drop bug, where als the models and textures are broken, is back for me.

This is not my picture, but it looks the same as the probem i have: https://gyazo.com/da4eefcde24fb88cc496ff6296aaf963

I have tested with the profiling build yesterday and today without it. In both sessions the fps broke down after some time and i had to restart Arma.

Does someone else have this problem too, or knows how to fix this?

 

Share this post


Link to post
Share on other sites
12 hours ago, meiestrix said:

Since 1.66 the frame drop bug, where als the models and textures are broken, is back for me.

This is not my picture, but it looks the same as the probem i have: https://gyazo.com/da4eefcde24fb88cc496ff6296aaf963

I have tested with the profiling build yesterday and today without it. In both sessions the fps broke down after some time and i had to restart Arma.

Does someone else have this problem too, or knows how to fix this?

 

Did you tried different malloc? If you have Win 8/10 try system memory allocator, for me it works fine now.

Share this post


Link to post
Share on other sites

Yes i have Windows 10. The memory allocator is the default one i have not changed anything on the allocator.

Share this post


Link to post
Share on other sites
8 hours ago, meiestrix said:

Yes i have Windows 10. The memory allocator is the default one i have not changed anything on the allocator.

So try other allocator (you choose them fromg ame launcher in parameters tab. Default one should fix the issue, try also JE malloc.

Share this post


Link to post
Share on other sites

just to be clear, stop using any maxmem or maxvram, they not needed anymore ...

the option and max values are just in case ...

  • Like 1

Share this post


Link to post
Share on other sites
30 minutes ago, dwarden said:

just to be clear, stop using any maxmem or maxvram, they not needed anymore ...

the option and max values are just in case ...

I Figured that out myself and can corfirm this on the client user side. Game runs indeed best if you don't touch -maxmen and -maxvram anymore.

System memory allocator still seems the best and most stable for Win10.

Share this post


Link to post
Share on other sites

Afree best performance for now is not using any parameters, only Hyperthreading (if your CPU is able to use it). Performance is almost perfect since i disabled those params.
First time i was disapointed beacuse on my older PC those parameters was doing something, and on brand new pc performace was worse, even with my friend who have exacly same pc, game was runing like a charm. Everything changed when i disabled parameters. Now i can enjoy gameplay. :)

Share this post


Link to post
Share on other sites

What about setting for server?

Currently use tbbmalloc (cma) from 

 

 

And start param: 
 

-malloc=cma -enableHT -config=cfg\config.cfg -world=empty -servermod=@A3Log;@asm;@infiSTAR_A3; -nosplash -noSound -noPause -loadMissionToMemory -nologs -enableHT -autoinit

(Yup no log server side but... these spam make me fool ^^, already done topics about this)
Also no custom -cfg atm for for test

 

Also some tutorials tell to use
 

BIstudio.wiki a écrit :
profiling branch (special performance + profiling build) requires access code: CautionSpecialProfilingAndTestingBranchArma3


http://steamcommunity.com/sharedfiles/filedetails/?id=791321243

 


This profiling branch is good/same/worst than last dwarden binary build ?

Share this post


Link to post
Share on other sites

1.66.139792 new PROFILING branch with PERFORMANCE binaries, v7, server and client, windows/linux
+ fixed -enableHT startup commandline param, linux (major) windows (minor), bonus benefit to AMD or CPU with many core users
+ added support for Large / Huge Pages into allocator interface, included in default TBB4, https://en.wikipedia.org/wiki/Page_(computer_memory)#Huge_pages
+ new startup commandline -hugepages (both client/server)
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=findComment&comment=3130011Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

 

FIY: -enableHT is off by default (as it was until now) and -hugePages isn't available on linux yet

 

 

  • Like 1

Share this post


Link to post
Share on other sites

So this

31 minutes ago, dwarden said:

+ new startup commandline -hugepages (both client/server)

Will appear in launcher? I know its not right now, but will?

Share this post


Link to post
Share on other sites

launcher, next year more likely ... just add it manually for now ...

 

Share this post


Link to post
Share on other sites

now interesting for those who think about trying squeeze most performance

-hugePages , this could give you 1-15% performance boost (depending on cpu cache sizes and architecture, memory speeds and latencies etc.)

-enableHT, this now properly detects the amount of cores and types of cores (same goes for default w/o any commandline used)

 

yet, there is interesting 'tidbit, but please do not take it as 'definitive tweaking guide, it needs to be first tested' (and the result may vary vs cpu platforms/generations)

 

if you have overclocked CPU (let say at minimum 20-25% over the stock value)

then instead of -enableHT or -cpuCount=<nativecorecount>

try use -cpuCount=<NATIVEcorecount+HTcorecount+1> or -cpuCount=<NATIVEcorecount+HTcorecount+2>

so e.g. for 4.5GHz quadcore Intel i7 try -cpuCount=9 or -cpuCount=10

 

note: you may observe the effect of those Arma 3 startup commandline parameters on 'count' of threads the arma3.exe spawns

 

feel free to get back to me with some benchmark results comparing default (that means no -enableHT, no -cpuCount=<>) vs just -enableHT vs various -cpuCount= experiments

 

FIY: -enableHT is off by default (as it was until now) and -hugePages isn't available on linux yet and jemalloc isn't using hugepages yet either (only tbb4)

 

 

  • Like 4

Share this post


Link to post
Share on other sites

I just happen to have an i7 (albeit only a 2700k) overclocked from 3.5 to 4.8 (sometimes 5 if I fiddle with the voltages but it's sketchy)... I'll get on that cpucount thing later and report back ;), if the results look promising I might up my page file size as well. Do you think this will make the game more unstable / more likely to get memory errors like '3FPS'?

Share this post


Link to post
Share on other sites

hugepages are leak unrelated ... so if the leak still exists then the problem will happen sooner or later

 

Share this post


Link to post
Share on other sites

Sorry, noob question(s) inbound.

 

Do i need to update the allocators in the dll folder with the new ones with the support? 

 

Also should I do away with the maxMem and maxvram parameters that i have for the launcher?

 

thanks 

 

Share this post


Link to post
Share on other sites

@Dwarden i have same problem since V5 and V6/V7, commandline -password is broken... The server returns "invalid password"

My commandline : -connect=164.132.203.110 -port=2302 -password=agora -mod=@agorapolis -noLogs -nosplash -nopause The players must be connect manually With the V4 it works very well, but not since the V5 and V6/V7

Share this post


Link to post
Share on other sites

@agorapolis

try "-password=agora"

anyway I need someone else to confirm this (no mods) as I had no time to check it

and more likely it will not be fixed before January anyway (team needs to have some holiday time)

Share this post


Link to post
Share on other sites

@Getsuga_10Shou

yes, you need replace the older tbb4allocator.dll with the one on dropbox (or update the game to latest profiling via steamcmd or steamclient w/e method you are using)

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×