Jump to content
Dwarden

Arma 3 STABLE server 1.94 "performance binary" feedback

Recommended Posts

ideal server these days?

Arma 3 Server (separate data package)

+ ^ performance binary

+ fred41 allocator

+ uber cpu

+ worth to mention -nologs used in commandline for client, dedicated server and dedicated client (headless client) if you use it

Share this post


Link to post
Share on other sites

Is it possible to have this performance binary rolled out before Christmas, this makes game play so much smoother.

I have a 4770k and GTX 770 with 16GB 2400 Memory. Sa-matra's wasteland is my favorite mod but recently the getting these micro stutter that just make the not not enjoyable as before. I tested on the [PERF] Sa-matra's wasteland, it's so smooth even with high ping like 121 (Playing Czech server from Canada...). I am getting constant 60 FPS (my monitor refresh is at 60Hz). But when I go to other server, such as ws.arma.su US#1, it's not running [PERF], the experience is much worse. A lot of people are having the same issue with me, I know it's not my PC, because no matter how I adjust the settings, it still happens. The FPS is not stable, jumping up and down and produces screen tearing and micro stutter every other second.

Please.... please... release this performance binary~~~~~:(

Share this post


Link to post
Share on other sites

nope, only available per request on me ... most of team are on holidays until next year ...

Share this post


Link to post
Share on other sites

got a chance to get into our server, installed the new .exe right out the box we could all tell the server was running better frames. we (6 people) loaded up in vics and heli's and flew around an insurgency map to activate as many areas at once.. the server stayed around 30fps. Was nice. and our server is Ok, its not really BAD ASS or anything to write home about but it works for us.

I had set #monitor 60 so after an hour of playing i can say that the server was steady around 30 while we just tried to bog it down. It was not our usual style of game play we derp'd out. Thanks for the Ability to get in on testing. ON average our server used 1.2Gb of mem. out:1000-1200 in: 130 those are just the average of what i saw using #monitor.

Share this post


Link to post
Share on other sites

Here are 2 ASM screens i find pretty interesting. Perf server.exe used - mission Domi

Screen1 - all seems perfectly nice and dandy, 50 cps and no prob. The excact moment things start to go wrong are when first town capurred and 2nd target gets active. I checked the first target and it seems to be pretty neat cleaned up, no dead ai or wrecks to be seen.

Screen2 - same as above, just the performance hit between 2nd and 3rd town to capture. No need for more screens as performance take a dip every time a new target comes up untill its unplayable.

Screen1: https://dl.dropboxusercontent.com/u/95560311/Screenshot%202013-12-21%2018.19.48.png

Screen2: https://dl.dropboxusercontent.com/u/95560311/Screenshot%202013-12-21%2019.16.11.png

Share this post


Link to post
Share on other sites

@Dwarden

Hi,

I confirm the same symptoms on our Alive mission.

the perf version you've done is really great and seems to improve the framerate (around between 40 to 50fps instead of 30fps when in forests or wilderness).

But once objectives are in town the perfs are decreasing a lot and fps drop to 16 - 19 fps.

I'll try to deploy ASM to confirm that too and monitor evrything that is appening.

In your last post what do you mean for "+ uber cpu"?

bye

Share this post


Link to post
Share on other sites
Dorph;2583800']+ uber cpu just means - good/fast cpu

Thx I just saw my stupid question when google responded me... :j:

an Intel® 1x Xeon® E3 1220 should do it I think.

Share this post


Link to post
Share on other sites
Dorph;2583800']+ uber cpu just means - good/fast cpu

I got told off by a well known German scriptwriter for saying that... 'uber' doesnt exist its 'uberlagen' :P

Share this post


Link to post
Share on other sites
HUD... How many Guys do you have playing?

The 2 screenshots are with 15-20 players - i now rectricted server to 21players as more than that wil make it puke :(

Share this post


Link to post
Share on other sites
Dorph;2583702']Here are 2 ASM screens i find pretty interesting. Perf server.exe used - mission Domi

Screen1 - all seems perfectly nice and dandy' date=' 50 cps and no prob. The excact moment things start to go wrong are when first town capurred and 2nd target gets active. I checked the first target and it seems to be pretty neat cleaned up, no dead ai or wrecks to be seen.

Screen2 - same as above, just the performance hit between 2nd and 3rd town to capture. No need for more screens as performance take a dip every time a new target comes up untill its unplayable.

Screen1: [url']https://dl.dropboxusercontent.com/u/95560311/Screenshot%202013-12-21%2018.19.48.png[/url]

Screen2: https://dl.dropboxusercontent.com/u/95560311/Screenshot%202013-12-21%2019.16.11.png

Hi [HUD]Dorph,

your screenshots are showing an interesting and important issue, it seems.

Just two ASM related hints:

- since objectcounting is customizable, it would be helpfull to know, how OC0 and OC1 are defined in asm.ini for this session

- you could use the "timedivisor" feature to "compress" the whole scenario in one screenshot, for a better overview (popupmenu in value area, select: 2sec, 5sec or 10sec)

Thanks for sharing your screenshots :)

Greets,

Fred41

Share this post


Link to post
Share on other sites
Hi [HUD]Dorph,

your screenshots are showing an interesting and important issue, it seems.

Just two ASM related hints:

- since objectcounting is customizable, it would be helpfull to know, how OC0 and OC1 are defined in asm.ini for this session

- you could use the "timedivisor" feature to "compress" the whole scenario in one screenshot, for a better overview (popupmenu in value area, select: 2sec, 5sec or 10sec)

Thanks for sharing your screenshots :)

Greets,

Fred41

Hmm not sure what u mean fred - i havnt changed anything in the ASM.ini - so default i guess.

objectcountinterval0=30

objectcountinterval1=60

objectcountinterval2=0

objectcountcommand0=count entities ""All"";

objectcountcommand1=count vehicles;

objectcountcommand2=count allMissionObjects ""All"";

Edit: hehe didnt know about the menues, ill do a screenie of a largerpart of the session :)

Edited by [HUD]Dorph

Share this post


Link to post
Share on other sites
Dorph;2584141']Hmm not sure what u mean fred - i havnt changed anything in the ASM.ini - so default i guess.

... thats exactly what i meant.

Just asked, because this three object counting commands are customizable now and i was not sure, if you use defaults or your own .sqf commands here :)

Share this post


Link to post
Share on other sites

two new servers on 3.7GHz Xeon were added (2x80 players for starter)

37.59.21.108: 2302

37.59.21.108: 2402

Share this post


Link to post
Share on other sites

Joined one of them just there now. Jesus, you can see why people want to shut noobs up!

On the bright side, the server DID seem stable Dwarden.

Share this post


Link to post
Share on other sites

not sure and i would not count on slight chance of some tweaks to be backported ...

Share this post


Link to post
Share on other sites

Thx Dwarden for that Server files, we just tested it on "unplayable" coop mision with 40 ppl. Last try on "old server files' was 3 - 5 sFPS, with new binaries - 35 - 40.

Share this post


Link to post
Share on other sites

Just want to say that although the performance binary gave some xtra fps/cps situation are still far from ok. Performance still drops to unplayable (under 10cps) with as little as 25players. My current situation are that the fewer players the longer it takes til unplayable cps are reached. For now my server restricts to 20 players, and if we are lucky we can hold it playable for 4-6 maintargets (Domi). I do remember A2 going on for the full 21 maintargets with 30players before mission restart was needed :)

HC client have been used also but seems to have no effect on this issue.

Edited by [HUD]Dorph

Share this post


Link to post
Share on other sites

Hello,

we tested the "performance binary" on our Server. we can measure a massive increase of FPS specialy with high AI Missions. Very important and good is that the FPS will be recovered. in the past you have aprox 15 FPS on high level missions. later the AI where killed the FPS have not increased. now with the new binary the FPS recovers. This was a big Step in the right direction! Thank you BIS!

Share this post


Link to post
Share on other sites

Anyone know if these improvements also apply to AMD cpu's, like the 1100T hexacore ?

Share this post


Link to post
Share on other sites

if i got some time on thr weekend i can test this for you, but yes i am pretty sure it will work an all CPUs, it is an optimized binary, it will not depend on the CPU. But Remember, the Serverfile will not use more then 2 Cores.

Share this post


Link to post
Share on other sites

Dwarden (sorry if this has been answered before..)

The "revolutionary" .exe will make it to the upcoming "stable" patch or..new compatible ones will distributed (in the same way) when time comes?.. :/

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×