Jump to content
Dwarden

Arma 3 STABLE server 1.92 "performance binary" feedback

Recommended Posts

1.82.144658 new PROFILING branch with PERFORMANCE binaries, v00, server and client, windows 32/64-bit, linux 32-bit server

+ sync with 1.82.main branch for profiling branch / performance binaries

 

1.82.144667 new PROFILING branch with PERFORMANCE binaries, v01, server and client, windows 32/64-bit, linux 32-bit server

+ hotfix server crash at zeus gamemode

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMklient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-182-performance-binary-feedback/?do=getLastComment

Arma anything discord: https://discord.gg/arma

 

  • Like 5
  • Thanks 1

Share this post


Link to post
Share on other sites

Thank you for updating these!

 

Quick question:  Never noticed the "*_other_windows_libraries_binaries.7z" before.  Are these required now for use with the Prof/Perf Windows client binaries now, or what exactly are these files for?

 

Sorry if this has been answered already, did not see an explanation for these specific files and hadn't noticed them before in these branches.

Share this post


Link to post
Share on other sites

they just latest libs as in both stable/profiling branch via steam ... 

only in case someone has wrong ones

Share this post


Link to post
Share on other sites

1.82.144685 new PROFILING branch with PERFORMANCE binaries, v02, server and client, windows 32/64-bit, no linux 32-bit server atm.

+ crashfixes for issues with terrain loading in editor and several related to missiles

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMklient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-182-performance-binary-feedback/?do=getLastComment

Arma anything discord: https://discord.gg/arma

  • Like 2

Share this post


Link to post
Share on other sites

1.82.144709 new PROFILING branch with PERFORMANCE binaries, v03, server and client, windows 32/64-bit, included linux 32-bit server

+ fix for proximity explosions for guided missiles

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMklient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-182-performance-binary-feedback/?do=getLastComment

Arma anything discord: https://discord.gg/arma

  • Like 3

Share this post


Link to post
Share on other sites

update released as sync with 1.82.hotfix

only data changes

144709 and 144710 are identical

Share this post


Link to post
Share on other sites

I'm running the Linux dedicated server. launched through linuxgsm. Let me start this by saying that I've been succesfully managing this server for almost two years.

 

We sucesfully played on Monday of last week (5.7.2018). Since this new hotfix, joining the server will hang after role selection. You can hear the crickets/whatever other sounds, but the game is stuck on the map loading screen. This will happen on missions that worked last week. If I disable all my mods and select one of the vanilla MP missions, then it does work. In the ingame server browser, my server is displayed as running no expansions, not even the official dlc ones (karts, jets etc.). So this problem clearly has someting to do with the loading of mods. The patch notes make some allusion to this effect:

 

Quote

Known issue: Sometimes the add-ons are loaded from the wrong installation (e.g. main game)

Try adding -mod=curator;kart;heli;mark;expansion;jets;argo;orange;tacops;tank;dlcbundle;dlcbundle2 to your arma3server.exe shortcut

 

This suggested fix does not work however. I have verified game files through steam. What's strange is that in my experience, usally trying to start a missions without the correct mods loaded will just kick you back into the missions selection screen. 

 

EDIT: I fixed it. It was a broken mod that had to be reinstalled, most likely Enhanced Movement.

Edited by Ratlike
  • Confused 1

Share this post


Link to post
Share on other sites

1.82.144848 new PROFILING branch with PERFORMANCE binaries, v04, server and client, windows 32/64-bit, included linux 32-bit server

+ some crashfixes e.g. while disconnecting

+ AI no longer see thru fallen trees

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMklient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-182-performance-binary-feedback/?do=getLastComment

Arma anything discord: https://discord.gg/arma

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites
On 10-5-2018 at 10:06 PM, Dwarden said:

update released as sync with 1.82.hotfix

only data changes

144709 and 144710 are identical

 

I can't find the 144710 version to download and the Profiling Branch in Steam doesn't allow me to join servers that use the latest Arma 3 patch.

 

I have used the profiling branch (as client) for a long time and it makes a big difference for me when it comes to making the game playable (I play Exile mod mostly). I know it takes a bit of time after each Arma 3 update for the profiling branch to 'catch up', but this times things look different. Am I missing something?

 

EDIT: nevermind. Just tried it again and somehow it did work now. This post can be ignored.

Share this post


Link to post
Share on other sites
On 02/06/2018 at 7:23 PM, Dwarden said:

+ AI no longer see thru fallen trees

Halleluljah !!

Share this post


Link to post
Share on other sites
On 6/21/2018 at 3:22 PM, BrunkPL said:

Guys from bohemia please make linux 64bit binary ;(

 

it's on my TODO list , no ETA for now but i do hope sooner than later

  • Thanks 1

Share this post


Link to post
Share on other sites

1.82.144872 new PROFILING branch with PERFORMANCE binaries, v05, server and client, windows 32/64-bit, included linux 32-bit server

+ attempt to fix sound related performance issue e.g. from 

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMklient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-182-performance-binary-feedback/?do=getLastComment

Arma anything discord: https://discord.gg/arma

 

 

  • Like 8
  • Thanks 3

Share this post


Link to post
Share on other sites
On 6/22/2018 at 7:36 PM, Dwarden said:

+ attempt to fix sound related performance issue e.g. from 

 The last weekend have been playing with the performance build. Haven't faced the FPS issues. Suggest the fix rather works:)

Share this post


Link to post
Share on other sites

hey some reason i cant join a server with the perf build to try it out as battleye is not loading up with it, how do i add battle to the .exe because the perf and profile builds bypass the launcher 

Share this post


Link to post
Share on other sites
7 hours ago, sweepnclear said:

because the perf and profile builds bypass the launcher 

Not if you use the perf/prof steam branch. And even if you download the builds manually. Replace your arma3.exe by the perf/prof build and then run the game normally through the Launcher.

Share this post


Link to post
Share on other sites
5 minutes ago, churrofighter said:

Any chance of getting a performance binary for 1.84? 

It's already there. Dwarden added it just one day after the updated was released. On the Steam branch.

But why would you want the performance binary? Profiling I'd understand but there is no difference between release and perf.

Share this post


Link to post
Share on other sites

1.84.144930 new PROFILING branch with PERFORMANCE binaries, v00, server and client, windows 32/64-bit, included linux 32-bit server

+ sync with 1.84.main branch

 

1.84.144943 new PROFILING branch with PERFORMANCE binaries, v01, server and client, windows 32/64-bit, included linux 32-bit server

+ fixed command-line multiplication when using server.cfg setting missionsToServerRestart

+ some quality of life tweaks

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMklient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server

 

BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-184-performance-binary-feedback/?do=getLastComment

 

Arma anything discord:  https://discord.gg/arma

 

  • Like 2

Share this post


Link to post
Share on other sites

Hi folks. I'm trying to profile low FPS on the server. Here is what diag_captureFrameToFile outputs:

https://gist.github.com/winseros/692cf3685b5b3733d976dcf6dab584a6

The problem here - I can't see any particular spot of troubles - all the performance-eaters seem to be spread among several places, but without any visible peak.

 

Could you suggest what can be done to improve performance according to this snapshot?

 

Share this post


Link to post
Share on other sites
11 hours ago, winse said:

Hi folks. I'm trying to profile low FPS on the server. Here is what diag_captureFrameToFile outputs:

https://gist.github.com/winseros/692cf3685b5b3733d976dcf6dab584a6

The problem here - I can't see any particular spot of troubles - all the performance-eaters seem to be spread among several places, but without any visible peak.

 

Could you suggest what can be done to improve performance according to this snapshot?

 

Looks like you just have too many units running around. Maybe move them to a Headless Client.

Share this post


Link to post
Share on other sites
2 hours ago, Dedmen said:

Looks like you just have too many units running around. Maybe move them to a Headless Client.

Thanks for your reply. Actually, the setup we have now is the following:

-PVE mission

-25-30 players

-about 100 enemy AIs spread between 2 HCs

-about 25-30 friendly AI units controlled by players machines

-no AI units are controlled by the server itself

 

And what is interesting - both HCs, controlling AIs, have a pretty good performance with FPS in range of 20-40. But the server is not so happy. When the number of players grows to 18-20, the server's FPS starts degrading severely. 

 

And yes, when the number of enemy units goes down (drops from approx 100 to approx 50), the server FPS starts getting normal;

Share this post


Link to post
Share on other sites
16 minutes ago, winse said:

no AI units are controlled by the server itself

Your profiling log shows 26ms of AI calculation on the server though. For what seems to be 4 groups

https://gist.github.com/winseros/692cf3685b5b3733d976dcf6dab584a6#file-captureframe-6260-2018-09-24_21-50-01-log-L7417-L7429

That shouldn't be there if there was no AI on the server itself.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×