Jump to content
Dwarden

Arma 3 STABLE server 1.84 "performance binary" feedback

Recommended Posts

On 1/24/2017 at 7:41 AM, jagga99 said:

Guys, please help

 

I downloaded latest build of arma3.exe v16 1.66 binaries. Should I also download custom dll allocators?

Where I can find latest builds to test them? I found only custom allocators in folder called as v7 1.66

 

Please help to clarify this topic. Thanks.

That's the latest malloc in the profiling/performance builds.

Share this post


Link to post
Share on other sites

1.66.140166 new PROFILING branch with PERFORMANCE binaries, v13, server and client, windows/linux
+ fix for issues on Linux server with too many PBO (unable to connect to afterward)
+ multiple crash fixes
+ fixed sounds vanishing in SP while opening map
+ EnableEnvironment improvement (possible to disable ambient life and environmental sounds separately)
+ more tweaks related to previous fixes of detach/attachTo
 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server
 
BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=getLastComment
Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

  • Like 2

Share this post


Link to post
Share on other sites

How to let launcher to use the performance exe?
Is it simply download the performance exe and rename it to arma3battleye.exe to replace the original one?

 

Share this post


Link to post
Share on other sites

@Devastator_cm read the instruction in 1st post and no, you replace the arma3.exe (or arma3server.exe) ...

  • Like 1

Share this post


Link to post
Share on other sites
On 11.12.2013 at 9:00 PM, dwarden said:

NOTE: 1.66. PROF/PERF up! you don't need need new client on PERF/PROF server !

there is branch on steam you may use, but beware that sometimes data on my dropbox're newer due to manual build e.g. on weekend:

  Hide contents

special profiling Steam branch for Arma 3 following this wiki page :

https://community.bistudio.com/wiki/Arma_3_Steam_Branches.

In short :

- Right click on Arma 3 in your Steam Library, then Properties

- Select the tab BETAS

- Enter the code CautionSpecialProfilingAndTestingBranchArma3 then click CHECK CODE

- Finally, still in this BETAS tab, use the dropdown list to select the branch profiling - Performance Profiling Build

Servers (down, up only if needed):

  Hide contents

it's recommended to also use performance client on KOTH CHIMERA EU server(s)!

? servers now test run PERF/PROF branch as part of project "CHIMERA"

running special performance server binary ;) blazing fast FPS rumored ;)

(compatible with STABLE clients) enjoy and report

PERF = STABLE branch compatible, no debug layer, no #captureFrame nor diag_captureFrame

PROF = STABLE branch compatible, with debug layer, with #captureFrame / diag_captureFrame

possible server fps increases and clients may experience higher fps too

downloads

  Hide contents

PROF/PERF available here , client and server ,

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

note that above URLs for manual download might be overloaded by demand, in such case

you can always use the STEAMclient to switch to profiling branch

(performance binaries are used by default so nothing to worry about)


Actually I did check the first post. I cannot see here the instruction about which file need to be replaced with the new files..
But then *which is just now* I took a look again to your dropbox and there you have a how_to_readme.txt  :)))

Maybe you can put that info to first post?

 

Share this post


Link to post
Share on other sites

@dwarden

 

hey dwarden,

 

hope very much you guys have absolutly focus on solving the 3fps bug problem. this is really killing the game right now... :(

 

cheers,

yes

 

www.cdah-gaming.com

Share this post


Link to post
Share on other sites
On 28.1.2017 at 6:52 PM, dwarden said:

@Devastator_cm read the instruction in 1st post and no, you replace the arma3.exe (or arma3server.exe) ...


If I replace the arma3.exe instead of the battleye version, I cannot join to the server anymore. It says battleeye is not active bla bla bla

How will I use the performance exe in this case?
I can only use it when I play SP at the moment :/

Share this post


Link to post
Share on other sites

I think I am not explaining it clearly or I am confused totaly :/
I did it like you wrote. Did backup for arma3.exe and then copied client performance file and rename it to arma3.exe
Then I adjusted my shortcut which runs arma with required mods to following

"blablabla\arma3.exe" -mod=@ace;@CBA_A3;@JSRS4APEX;@DerSilvers_BSAE;@RHSAFRF;@RHSUSAF

when I try to join now to dedicated server I get error "BattleEye is not enabled. Restart the game and enable it? ".

When I press restart, it starts the game from beginning. 
Q1: Is this using now arma3.exe or arma3battleye.exe?

Q2: Can I not start the game with following  after I replace the arma3.exe? I assume it is the way but not sure anymore
"blablabla\arma3battleye.exe" -mod=@ace;@CBA_A3;@JSRS4APEX;@DerSilvers_BSAE;@RHSAFRF;@RHSUSAF

 

Share this post


Link to post
Share on other sites

If you want to join server which enabled BE you need to use in your shortcut or batch file  arma3battleye.exe.

2 hours ago, Devastator_cm said:

"blablabla\arma3battleye.exe" "-mod=@ace;@CBA_A3;@JSRS4APEX;@DerSilvers_BSAE;@RHSAFRF;@RHSUSAF"

Share this post


Link to post
Share on other sites

@dwarden, I am sure you are already aware of this / it's already been investigated, but I kept getting this 3FPS bug whenever I teleported anywhere in SP and sometimes randomly when I didn't. Looked into my virtual memory allocation and saw it was 4 GB. I've increased this now significantly (to 32 GB) and haven't any weird flickering objects / unrecoverable FPS drops since. Unfortunately I've already overwritten my last RPT when I had the bug but thought it was worth passing on regardless. Using the latest perf binaries. 

Share this post


Link to post
Share on other sites
37 minutes ago, Horus said:

If you want to join server which enabled BE you need to use in your shortcut or batch file  arma3battleye.exe.

 

But that was my point. If server uses BE, I cannot use then I cannot benefit from Dwarden's optimized code?
 

Share this post


Link to post
Share on other sites
16 minutes ago, Incontinentia said:

@dwarden, I am sure you are already aware of this / it's already been investigated, but I kept getting this 3FPS bug whenever I teleported anywhere in SP and sometimes randomly when I didn't. Looked into my virtual memory allocation and saw it was 4 GB. I've increased this now significantly (to 32 GB) and haven't any weird flickering objects / unrecoverable FPS drops since. Unfortunately I've already overwritten my last RPT when I had the bug but thought it was worth passing on regardless. Using the latest perf binaries. 

When you say virtual memory..do you mean in the launcher?

Share this post


Link to post
Share on other sites

No - I mean Windows 10 page file.... that said, I'll do more testing as I suspect it's going to hit me a little bit later on. 

Share this post


Link to post
Share on other sites

@Devastator_cm arma3battleye.exe is just BE launcher ... it always starts the arma3.exe ...

Share this post


Link to post
Share on other sites
28 minutes ago, Devastator_cm said:

 

But that was my point. If server uses BE, I cannot use then I cannot benefit from Dwarden's optimized code?
 

Every PRO/PRE build is compatibel with BE and any 1.66.xxxx server. Just start game with arma3battleye.exe, look in the bottom right corner and connect to your favorite server.

Share this post


Link to post
Share on other sites
17 minutes ago, Incontinentia said:

No - I mean Windows 10 page file.... that said, I'll do more testing as I suspect it's going to hit me a little bit later on. 

Ah i see.. Swtching to 64bit has for the most part fixed the 3 fps bug for me-but I do still get a fair amount of flashing foliage

  • Like 1

Share this post


Link to post
Share on other sites

Dwarden & Horus, thanks that was the answer I was looking for :))
Sorry that I was not that clear in my initial post

Share this post


Link to post
Share on other sites
19 hours ago, ineptaphid said:

Ah i see.. Swtching to 64bit has for the most part fixed the 3 fps bug for me-but I do still get a fair amount of flashing foliage

An old trick from Win Xp:

 

  1. Remove any automatically managed page file from all drives
  2. Set one with fixed value like 10 000 - 10 000 (I'm on 25 000 - 25 000 now), of course it's better to use it on an SSD or a unused drive (for bandwidth/latency optimum considering 4k R/W as the worst case)
  3. Apply and reboot.
Spoiler


Use MSI AFterburner to monitor your system over time. 10 Go of page file was indeed necessary while I'm playing Exile or Koth. Because Page file is the slowest memory it is why you don't want the file to be modified too much.
I hope that memory leak won't occur if the contenant is widly sized but I assume this is a personnal myth. Last time I've had a ML was when flares poops out of a flying target in Koth. Seems to be related to particules somhow. (happened before in Taru when lifting things)

I am convincing my teamates to check perfo builds as often as possible.

Share this post


Link to post
Share on other sites

Hi, I hope someone could help me understand Profiling or perf files, because I need to increase my A3 Performance for SP. 

First off, I don't play MP. I just play SP. I'm just trying to see if I could get above 50 FPS in City. I was just wondering if solo or SP player like me could benefit from it.?

-Game version is V.162

 

 

i7-6700HQ

16GB RAM

GTX 1060

Game runs on SSD

Share this post


Link to post
Share on other sites
On 31.1.2017 at 11:49 PM, Jomar Ancajas said:

Hi, I hope someone could help me understand Profiling or perf files, because I need to increase my A3 Performance for SP. 

First off, I don't play MP. I just play SP. I'm just trying to see if I could get above 50 FPS in City. I was just wondering if solo or SP player like me could benefit from it.?

-Game version is V.162

 

 

i7-6700HQ

16GB RAM

GTX 1060

Game runs on SSD

The "performance" binary is mainly for testing the new enhancements and command line parameters. You do not automatically get a better performance "fps" wise, The fps gain or loss beetwen builds is +/-5. The main goal in perf. binaries is fps stabilty right now, not more fps.

 

If you want more frames, you need to consider a hardware upgrade, just dropping in another .exe won't solve it, since those perf. binary changes make it into the dev and main branch updates sooner or later anyway.

Share this post


Link to post
Share on other sites
On 1/31/2017 at 11:49 PM, Jomar Ancajas said:

i7-6700HQ

16GB RAM

GTX 1060

Game runs on SSD

Beagle's right but unless I'm mistaken, you're running on a laptop right?

If so, then a CPU that runs at 2.6 GHz is going to badly bottleneck your GPU.

See for yourself here:

http://www.techspot.com/review/712-arma-3-benchmarks/page5.html

So either enjoy Arma at 50 fps (pretty good I think) or play Arma on a desktop machine with a fast CPU (at least 3 GHz, better +3.5, ideally 4+ GHz).

Share this post


Link to post
Share on other sites
On 12/19/2016 at 3:54 AM, dwarden said:

just to be clear, stop using any maxmem or maxvram, they not needed anymore ...

the option and max values are just in case ...

 

Coming back on that, there is a lot of performance guides/FPS shit that people say works, but could you as the actual game developer tell us what kind of config edits/different launch parameters actually have a chance of increasing FPS? It could help a lot of us with figuring out what does work and what doesn't, and leave players with low-mid PCs with their games fully working rather than completely broken from the 500 edits they decided to make to get 2 FPS extra.

 

Thanks!

Share this post


Link to post
Share on other sites

@laserhel50 those guides are outdated ... it's automated since 1.66 ... period

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×