Jump to content
Dwarden

Arma 3 STABLE server 1.84 "performance binary" feedback

Recommended Posts

So you want people to come and test the performance but don´t have any admins on when its EU primetime? Was one of the worst ARMA experiences I have had, felt like half the population was 14 year old trolls more prone to work against their team then with. If you have admins on I will try to get my group on again but not if its handled like this, I can take bugs and engine errors on test server´s but this was just to much.

Did not experience any performance raise client side it was still red chains and desync, the desync never peaked at max what I noticed but wandered around everytime I checked.

Get some admins at least on primetime and Ill be glad to join again.

Share this post


Link to post
Share on other sites
So you want people to come and test the performance but don´t have any admins on when its EU primetime? Was one of the worst ARMA experiences I have had, felt like half the population was 14 year old trolls more prone to work against their team then with. If you have admins on I will try to get my group on again but not if its handled like this, I can take bugs and engine errors on test server´s but this was just to much.

Did not experience any performance raise client side it was still red chains and desync, the desync never peaked at max what I noticed but wandered around everytime I checked.

Get some admins at least on primetime and Ill be glad to join again.

Or maybe an altis life test server should be created for kids? :j:

that should permits every servers admin to get a good public banlist once they are all connected :p

Share this post


Link to post
Share on other sites

quite some of the 'anti teamwork' behavior is atm caused by the mission

it needs proper scripting against deliberate team-killing and griefing (it's doable and afaik wip)

second you talk about trolls and need of admins but not mentioned what you mean by the offenses (cause I see no point to punish anything nonserious)

Share this post


Link to post
Share on other sites

http://www.reddit.com/r/arma/comments/2man1j/join_chimera_test_servers_engine_serverside/

https://www.dropbox.com/sh/582opsto4mmr8d8/AABSuQ8Jt5VlovUX86pi5iFRa

1.34 perf3/prof3 available (client isn't needed, optional as we fixed some crashes (for server but client can have same)) , compatible with stable 1.34

Share this post


Link to post
Share on other sites
http://www.reddit.com/r/arma/comments/2man1j/join_chimera_test_servers_engine_serverside/

https://www.dropbox.com/sh/582opsto4mmr8d8/AABSuQ8Jt5VlovUX86pi5iFRa

1.34 perf3/prof3 available (client isn't needed, optional as we fixed some crashes (for server but client can have same)) , compatible with stable 1.34

Thanks David. I'll try the server only and report back.

Share this post


Link to post
Share on other sites
http://www.reddit.com/r/arma/comments/2man1j/join_chimera_test_servers_engine_serverside/

https://www.dropbox.com/sh/582opsto4mmr8d8/AABSuQ8Jt5VlovUX86pi5iFRa

1.34 perf3/prof3 available (client isn't needed, optional as we fixed some crashes (for server but client can have same)) , compatible with stable 1.34

God damn. Good job!

Over 100 Player (Intel 4 Cores / 8 Threads) ~80% CPU utilization. :yay:

meh.ro8524.jpg

Edited by Sturmgewehr

Share this post


Link to post
Share on other sites
the built in anticheat is in wasteland is joke and will be phased out, same applies to KOTH

the server-sdeBE filters most of WST/Samatra servers use as base default were written by ... guess who ... me ;)

I don't give damn about client side scripts.txt BE filter cause that is performance hit, limited use, easy to get around

---------- Post added at 19:21 ---------- Previous post was at 19:20 ----------

atm. those 2 servers are active until they full then I add more:

94.23.112.9:2102

192.99.47.216:2102

Phased out in favour of what if you don't mind me asking? Just BE filters or another solution?

Share this post


Link to post
Share on other sites

Hello guys,

Tested today on server without AI tonight, and got +30/+40% server FPS with only this executable applied as modification. up to 90 people connected so far.

Thanks a lot Dwarden, nice job!

What would be the PCS impact of activating the profiling exe? In case you could use the result, I could help testing them, but I need to have an idea of impact before to choose the best time to test it :)

Edited by olivieridriss

Share this post


Link to post
Share on other sites
http://www.reddit.com/r/arma/comments/2man1j/join_chimera_test_servers_engine_serverside/

https://www.dropbox.com/sh/582opsto4mmr8d8/AABSuQ8Jt5VlovUX86pi5iFRa

1.34 perf3/prof3 available (client isn't needed, optional as we fixed some crashes (for server but client can have same)) , compatible with stable 1.34

Used your PERF3 (client and server .exe) today and got good results, 35-40 people for several hours and a BECTI amount of AI, server FPS tended to average a little higher than normal and overall the game felt like it was running a little better. It crashed once though, and crashes are rare on our server. Here's a snapshot of what I saw:

 
Mods: @task_force_radio
Distribution: 0
Version 1.34.128263
Fault time: 2014/11/16 18:14:56
Fault address:  5E2F21CB 01:001511CB C:\Program Files (x86)\Steam\SteamApps\common\Arma 3\PhysX3_x86.dll
file:     becti_0097_z1214_SS (__cur_mp)
world:    Altis
Prev. code bytes: 85 C0 74 1D 8B 50 40 F6 42 4C 01 75 14 8B 40 60
Fault code bytes: F6 40 2C 01 75 0B 51 50 57 E8 97 FF FF FF 83 C4

Registers:
EAX:00000000 EBX:532305A0
ECX:552DCF00 EDX:8DFD73E0
ESI:0C4C7F08 EDI:4A260D70
CS:EIP:0023:5E2F21CB
SS:ESP:002B:009BDD34  EBP:009BDD48
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00010246

Here are the files:

https://drive.google.com/file/d/0B70KE6LT-M_gQzJETHg0WkpQUm8/view?usp=sharing

Share this post


Link to post
Share on other sites

ignored physx86.dll crashes, that needs update of whole lib pack, it's wip

Share this post


Link to post
Share on other sites
http://www.reddit.com/r/arma/comments/2man1j/join_chimera_test_servers_engine_serverside/

https://www.dropbox.com/sh/582opsto4mmr8d8/AABSuQ8Jt5VlovUX86pi5iFRa

1.34 perf3/prof3 available (client isn't needed, optional as we fixed some crashes (for server but client can have same)) , compatible with stable 1.34

awesome, thanks for releasing!

updated our A3Wasteland stratis box with the performance binary :)

http://www.gametracker.com/server_info/7days.johanschaap.nl:2302/

b_560_95_1.png

Share this post


Link to post
Share on other sites

It seems that im using more CPU than the stable release with performance binary. Seeing an increase of ~10% cpu.

I used to get 80% cpu with 80 players, now im hitting 93-96%. I will keep testing.

Share this post


Link to post
Share on other sites

Can we use battleye with this? Just got the "da shit dis server b fucked" hack on my server.

Share this post


Link to post
Share on other sites

What i see with this new binary is that the server starts out with good fps and keeps running so for a while even with more AI. But after about 3 hours or so the fps gets more unstable.

Any one else who's running this server binary get this?

We're running the A3Wasteland v1.0b mission.

Without players:

FPS in first hour with almost no players on the server (look at the graph not the numbers):

LJPVKsr.png

After about 3 hours:

5aI4mla.png

Share this post


Link to post
Share on other sites

Hello,

I've noticed that if you have "EmptyDetectors" on client side, they are transfered to server during disconnection. I managed to get server FPS stable (almost only dependant on players/IA and what they do), and coming back to close than 47-48 when player counts gets below the "critical" level (depends on each mission/server/cfg), by only removing them.

Mods can also add Empty Detectors, and they seems to have an impact on "durability" of the "good FPS" time.

On default Wasteland, it seems there's only server side EmptyDetector trigges, but it could be worth checking the evolution of their count to ensure none are added on client side as well.

Share this post


Link to post
Share on other sites
Hello,

I've noticed that if you have "EmptyDetectors" on client side, they are transfered to server during disconnection. I managed to get server FPS stable (almost only dependant on players/IA and what they do), and coming back to close than 47-48 when player counts gets below the "critical" level (depends on each mission/server/cfg), by only removing them.

Mods can also add Empty Detectors, and they seems to have an impact on "durability" of the "good FPS" time.

On default Wasteland, it seems there's only server side EmptyDetector trigges, but it could be worth checking the evolution of their count to ensure none are added on client side as well.

Ok I would love to check this as I have some addons/scripts I added myself. How can I find these?

Share this post


Link to post
Share on other sites

Hello Loud,

Simply add this to a script that is ran pretty often on server side to start monitoring number of empty detectors:

diag_log format ["LOG - EmptyDetector: %1", count allMissionObjects "EmptyDetector"];

Even better, you could check for each of the items in the list the locality of objects (if they belong to cliens or server):

diag_log format ["LOG server local - EmptyDetector: %1", {local _x;} count allMissionObjects "EmptyDetector"];

Please pay attention in understanding what I stated earlier: in my case it has proven to be efficient to clean all non local Empty Detector (by cleaning mission code from Triggers and because it was feasible, and to clean the one brought by mods because I could not edit them and re-sign them).

But it depends on the mission and what your "EmptyDetector" are doing. sometimes it's just useless, sometimes it's useful. Just check your code ("grep" EmptyDetector), and see what it is doing. Optimization is about understand what your code does, when, how often.

And this is only one among many performance tweaks you can do code wise, maybe not the first one at all ;)

After a few days running between a few and up to 120 players, FPS seems stable with these Performance server EXE, without any server crash nor other issue specific to this build - players are quite happy here.

There's for sure still work to be done, but that's already a great achievement! (let's talk about something that works well for once ;))

I'm still wondering what the "Profiling" version could bring here, and I'm not really in the mood to test that and disappoint so many players without a clear idea of impact ;)

Share this post


Link to post
Share on other sites
What i see with this new binary is that the server starts out with good fps and keeps running so for a while even with more AI. But after about 3 hours or so the fps gets more unstable.

Any one else who's running this server binary get this?

We're running the A3Wasteland v1.0b mission.

Without players:

FPS in first hour with almost no players on the server (look at the graph not the numbers):

http://i.imgur.com/LJPVKsr.png

After about 3 hours:

http://i.imgur.com/5aI4mla.png

that's problem mainly of scripting in the mission

Share this post


Link to post
Share on other sites

Thanks olivieridriss I will try that. What to do if the log says EmptyDetectors found? How do I get rid of them?

Thanks Dwarden, looking into it :)

Share this post


Link to post
Share on other sites

olivieridriss : that profiling binaries are for logging and debugging, performance binaries are w/o debug layer ...

Share this post


Link to post
Share on other sites

That was crystal clear, I'm just wondering what could be the performance impact of using the profiling ones compared to the performance ones.

If you have no clue, then I'll test that right away on my dev server and invite ppl to see.

I was also looking for details about what is logged with profiling exe in addition to performance exe in case it could help optimize scripts in high load situations (without impacting players, that's why I was asking the previous question)

Share this post


Link to post
Share on other sites

as I said there is quite noticeable performance impact of the debugging / profiling and logging hence it's not recommended for genera public to run profiling binaries at all

---------- Post added at 23:10 ---------- Previous post was at 23:03 ----------

http://www.reddit.com/r/arma/comments/2mvwa0/call_to_arms_need_to_fill_two_mp_test_servers_111/

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×