Jump to content
dazhbog

Linux Dedicated Server feedback

Recommended Posts

Show me the full log again.

And try as:

apt-get install libusb-1.0:i386 libglib2.0-0:i386 libdbus-glib-1-2:i386

It helped me to Debian Wheezy :)

Edited by Huntsman

Share this post


Link to post
Share on other sites

share the 32bits libusb-1.0.so.0 and put it into the arma server home, could work too

Share this post


Link to post
Share on other sites

i cant believe it!!!!

working fine for MONTHS! and now i get this!!!!!

18:03:01 ManagerConfig()

18:03:07 Dedicated host created.

18:03:10 BattlEye Server: Initialized (v1.198)

18:03:10 Host identity created.

[s_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.

dlopen failed trying to load:

steamclient.so

with error:

libnm-glib.so.4: cannot open shared object file: No such file or directory

[s_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.

Arma 3 Console version 1.38 : port 2312

:(:(:(:(:(:(!!!!!!!!!

Share this post


Link to post
Share on other sites

copy steamclient.so from STEAMcmd

replace the one available with server

it solves quite some of Linux sever issues ...

note: nottestedbymyself

Share this post


Link to post
Share on other sites

This new update has seemingly made mods crash the server. Mission runs without mods, but when mods are added:

17:00:48 "WASTELAND SERVER - Server Compile Finished"

17:00:48 "[extDB] Startup..."

libgcc_s.so.1 must be installed for pthread_cancel to work

./start.sh: line 15: 22513 Aborted (core dumped) ./arma3server -bepath="$battleye" -cfg="/$networkConfig" -config="$serverConfig" -name="$profileName" -mod="$mods" -exThreads=1 -enableHT -bandwidthAlg=2 -loadMissionToMemory -autoInit -noTexHeaders -maxMem=2047 -world=stratis -port=2312 -noSound

All dependencies are there and linked correctly, including libgcc_s.so.1. These exact parameters worked fine on 1.36. When shutting down the server, same error (pthread_cancel) at the end pops up even when not running mods, but it doesn't crash through midway loading, like it does with mods.

Any way to revert back to 1.36?

Share this post


Link to post
Share on other sites

i think i fix it.

first i run: apt-get install libnm-glib4 and a new error appeared, something like "wrong ELF class"

then i run: apt-get install libusb-1.0:i386 libglib2.0-0:i386 libdbus-glib-1-2:i386 and the library libn-glib4 was removed.

and then apt-get install libnm-glib4:i386

now the server starts.

Share this post


Link to post
Share on other sites

won't reverting just create version mismatch errors for people trying to connect? we need BI to push out a hotfix

Share this post


Link to post
Share on other sites

server starting up with same error msg like in posts before, can't connect > kicked

copy steamclient.so from STEAMcmd

replace the one available with server

it solves quite some of Linux sever issues ...

note: nottestedbymyself

this fixed it for me

even mods are working etc...

Share this post


Link to post
Share on other sites
server starting up with same error msg like in posts before, can't connect > kicked

this fixed it for me

even mods are working etc...

Replacing the steamclient.so did fix the crashing and the pthread_cancel error coming up, however, even though the server is up, no one can connect, it just kicks anyone off the game with a "You were kicked off the game."

Share this post


Link to post
Share on other sites

However, can people actually connect to your server now???

Anyways, the included steamclient.so seems to be all screwed up, ALL these dependencies are really not needed...

        linux-gate.so.1 =>  (0xb774e000)
       libtier0_s.so => not found
       libvstdlib_s.so => not found
       librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb6618000)
       libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xb64e4000)
       libusb-1.0.so.0 => /lib/i386-linux-gnu/libusb-1.0.so.0 (0xb64cd000)
       libopenal.so.1 => /usr/lib/i386-linux-gnu/libopenal.so.1 (0xb6478000)
       libpulse.so.0 => /usr/lib/i386-linux-gnu/libpulse.so.0 (0xb6429000)
       libgobject-2.0.so.0 => /usr/lib/i386-linux-gnu/libgobject-2.0.so.0 (0xb63d6000)
       libglib-2.0.so.0 => /lib/i386-linux-gnu/libglib-2.0.so.0 (0xb62ca000)
       libdbus-glib-1.so.2 => /usr/lib/i386-linux-gnu/libdbus-glib-1.so.2 (0xb62a4000)
       libnm-glib.so.4 => not found
       libnm-util.so.2 => not found
       libudev.so.0 => not found
       libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xb625d000)
       libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb6258000)
       libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xb616f000)
       libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb6153000)
       /lib/ld-linux.so.2 (0xb774f000)
       libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb5fa3000)
       libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xb5f81000)
       libudev.so.1 => /lib/i386-linux-gnu/libudev.so.1 (0xb5f6e000)
       libjson-c.so.2 => /lib/i386-linux-gnu/libjson-c.so.2 (0xb5f63000)
       libpulsecommon-4.0.so => /usr/lib/i386-linux-gnu/pulseaudio/libpulsecommon-4.0.so (0xb5ef4000)
       libdbus-1.so.3 => /lib/i386-linux-gnu/libdbus-1.so.3 (0xb5ea8000)
       libffi.so.6 => /usr/lib/i386-linux-gnu/libffi.so.6 (0xb5ea1000)
       libpcre.so.3 => /lib/i386-linux-gnu/libpcre.so.3 (0xb5e63000)
       libgio-2.0.so.0 => /usr/lib/i386-linux-gnu/libgio-2.0.so.0 (0xb5ce2000)
       libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb5cc5000)
       libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xb5cc0000)
       libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xb5cb9000)
       libcgmanager.so.0 => /lib/i386-linux-gnu/libcgmanager.so.0 (0xb5c9b000)
       libnih.so.1 => /lib/i386-linux-gnu/libnih.so.1 (0xb5c82000)
       libnih-dbus.so.1 => /lib/i386-linux-gnu/libnih-dbus.so.1 (0xb5c78000)
       libwrap.so.0 => /lib/i386-linux-gnu/libwrap.so.0 (0xb5c6d000)
       libsndfile.so.1 => /usr/lib/i386-linux-gnu/libsndfile.so.1 (0xb5bfb000)
       libasyncns.so.0 => /usr/lib/i386-linux-gnu/libasyncns.so.0 (0xb5bf4000)
       libgmodule-2.0.so.0 => /usr/lib/i386-linux-gnu/libgmodule-2.0.so.0 (0xb5bef000)
       libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xb5bd5000)
       libselinux.so.1 => /lib/i386-linux-gnu/libselinux.so.1 (0xb5bb1000)
       libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xb5b99000)
       libnsl.so.1 => /lib/i386-linux-gnu/libnsl.so.1 (0xb5b80000)
       libFLAC.so.8 => /usr/lib/i386-linux-gnu/libFLAC.so.8 (0xb5b4c000)
       libvorbisenc.so.2 => /usr/lib/i386-linux-gnu/libvorbisenc.so.2 (0xb59d4000)
       libvorbis.so.0 => /usr/lib/i386-linux-gnu/libvorbis.so.0 (0xb59a7000)
       libogg.so.0 => /usr/lib/i386-linux-gnu/libogg.so.0 (0xb599e000)

Share this post


Link to post
Share on other sites

I'm trying to get a server that I did not setup myself running again. Same issue as everybody else here.

Where do I find the correct steamclient.so exactly and where do I copy it to?

~/steamcmd is an empty folder.

Any help is much appreciated.

Edited by BlueBär

Share this post


Link to post
Share on other sites
However, can people actually connect to your server now???

I could connect to my server now.

This whole thing took me way to long for a simple update -,-!

Share this post


Link to post
Share on other sites
I'm trying to get a server that I did not setup myself running again. Same issue as everybody else here.

Where do I find the correct steamclient.so exactly and where do I copy it to?

~/steamcmd is an empty folder.

Any help is much appreciated.

you got steamcmd on your server?

https://developer.valvesoftware.com/wiki/SteamCMD

install it, start it (read wiki)

go to /home/$user/Steam/linux32 > copy "steamclient.so" to your arma3_install_dir

Share this post


Link to post
Share on other sites

Finally got it working, by downloading and installing all these unneeded dependencies. Although, there was one specific one that was giving me trouble, since it does not exist any longer on newer distros, note this is for 32-bit distros, 64-bit distros will be slightly different but the idea behind it is the same:

Step 1,

ldd steamclient.so

and find all the missing dependencies

Step 2,

apt-get install libx11-6 libusb-1.0-0 libopenal-dev libglib2.0-0 libdbus-glib-1-2 libnm-glib-dev

add any additional dependencies you may be missing

Optional Step 3,

ln -s /lib/i386-linux-gnu/libudev.so.1 /lib/i386-linux-gnu/libudev.so.0

This is for newer distros, this was causing my server to crash, since it's a dependency dropped by newer distros. This line is for 32-bit distros, locate libudev.so.1 on your x64 and the link it the same way.

Hope this helps, albeit it's a bit more complicated.

Edited by DNice

Share this post


Link to post
Share on other sites
Step 2,
apt-get install libx11-6 libusb-1.0-0 libopenal-dev libglib2.0-0 libdbus-glib-1-2 libnm-glib-dev

add any additional dependencies you may be missing

On a x86_64 debian wheezy that would be

apt-get install libx11-6:i386 libusb-1.0-0:i386 libopenal1:i386 libglib2.0-0:i386 libdbus-glib-1-2:i386 libnm-glib4:i386

You might need to enable the i386 repository with:

dpkg --add-architecture i386 && apt-get update

Share this post


Link to post
Share on other sites

Server is back up and running fine with mods. We did exactly that, but apparently a second copy of the server was still running in the background so it didn't work at first. Thanks!

Share this post


Link to post
Share on other sites

In most cases, should be enough to do what I wrote earlier:

Im fix this problem.

You need to install additional libraries:

dpkg --add-architecture i386

apt-get update

apt-get install libusb-1.0:i386 libglib2.0-0:i386 libdbus-glib-1-2:i386 libnm-glib4:i386 libnm-glib4:i386

It's worth doing the first step.

If the problem remains, refer to the log and optionally install the libraries required by the server.

All this is 100% true for Debian. The server is tested and works without problems. Just do it and try to connect to the server.

Edited by Huntsman

Share this post


Link to post
Share on other sites

I'd recommend to simply replace the steamclient.so in your arma directory with the one from the linux32/-directory within your SteamCMD installation.

This (mine, includes details on above steamclient.so workaround) and this bug report have already been acknowledged/assigned, so there might be an official fix soon.

Regardless of that its quite embarassing to release a game update without properly testing the dedicated server first. Everyone with an eye patch and no hearing would have noticed this bug, if he'd tested the dedicated server binary on a real dedicated server.

Share this post


Link to post
Share on other sites
I'd recommend to simply replace the steamclient.so in your arma directory with the one from the linux32/-directory within your SteamCMD installation.

This (mine, includes details on above steamclient.so workaround) and this bug report have already been acknowledged/assigned, so there might be an official fix soon.

Pls do this as a workaround for now, proper fix is on the way.

Share this post


Link to post
Share on other sites
Pls do this as a workaround for now, proper fix is on the way.

Please stop breaking things, test before you release.

Share this post


Link to post
Share on other sites

Even the simplest form of regression testing like running linux dedicated server on a few common distro's would have stopped this bug from passing through. A friendly advice is that you take this under consideration to improve release quality.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×