Jump to content
wolffy.au

ALiVE - Advanced Light Infantry Virtual Environment

Recommended Posts

Anyone have a working mission where they have 3 AI commanders on field? One occupying one invasion and one assymetric? With a working reinforcement i simply can not get it to work.

+1 it would be kind of you guys...spent some hours trying to build a simple Template like this, fitting Stratis island...have tried various settings in the modules without obtaining a good result. have seen the wiki and understood the main things (module placements, synchronizations), tried SpyderBlack example missions (simple and very well done), but there are many things i can't set up nicely for now (i'll keep ChronicleDude's example)

-size of armies : virtual ai system (spawn at 1000/1500, between 15-30 active limiter), BLU_F (occupation ai commander, size of military placement? civilian placement? size?), IND_F (invasion commander spawning at a map corner with its own -blaclisted- taor, size of MP and/or CP?), OPF_F (asymetrical commander module in agia marina, linked to CP (size 30, place units?), MP (size 30, objectives only?), civilian CQB (5%chance, pair, dominant/static?), and IED)

-civilian placement/population : tried various settings regarding density (low or medium usually), active limiter set between 25 and 50, spawn at 700m...don't see many of them, and even less interacting with asymetric forces (never seen the events wiki talks about, except some roadblocks)...am i doing something wrong?

all this to say that some basic templates should be more than welcome, along with some advices (maybe in the wiki?) regarding the values needed in the modules to obtain good results on different islands (stratis/small islands, altis/big maps)

Please don't get me wrong, i really, really like your valuable work and the whole mod, which i consider as a must have for all those who don't have the knowledge or time to build proper missions. and i thank you for this.

Best regards, keep up the good work :)

Edited by Megiddo

Share this post


Link to post
Share on other sites

Does anyone else have lots of issues with the RHS factions and ALiVE?

I've had problems wherever the RHS factions are involved. Namely the logistics and Player task modules. For some reason the logistics module does not want to recognize the russian VDV as a OPFOR faction, and it refuses to let me use the module when i'm playing with a VDV group (Even though the AI Commander and his military placement modules are set to VDV and working just fine). I tried the same with MSV faction, and it recognized it as being on the OPFOR side, but not as being the MSV faction (It would only let me call in units if I set the Logistics module to "side" and not "faction"). I then tried the same with the US Army factions, and they all worked just fine. Very strange.

I then had similar problems with the task generator, which seemed to randomly select which side was the enemy and which one was friendly. Even though I had set up the enemy and friendly factions in the module, it would give me tasks targeting our own assets and troops, often in the same session as when it had given us a task correctly targeting the enemy faction. In one case, while testing out my VDV mission, it gave me an objective to "pick up troops" in the middle of our airbase. Upon arrival, I found a single US Army rifleman attempting to kill all the friendlies with a "pick up troops" marker over his head.

I'm not running anything else besides ALiVE, CBA, and RHS. I'm pretty sure I have everything updated as well. If anyone knows whats going on here, help would be appreciated.

Share this post


Link to post
Share on other sites
Anyone have a working mission where they have 3 AI commanders on field? One occupying one invasion and one assymetric? With a working reinforcement i simply can not get it to work.

I'll add it to my list of stuff to do if nobody else takes to it first. I always did want to create a template like that.

Edit: Check HH's post below

Edited by SpyderBlack723

Share this post


Link to post
Share on other sites

Anyone know how well a server runs when you'll having alive set up to run about 800 or more AI, with say 100-200 active at a time? Because I want to set up a mission thats meant to have a large military force active, with about 20-30 people having to complete objectives and such.

Just wondering how well that would run, since multiplayer runs not as smooth as singleplayer.

Share this post


Link to post
Share on other sites
Anyone have a working mission where they have 3 AI commanders on field? One occupying one invasion and one assymetric? With a working reinforcement i simply can not get it to work.

Yo!

So I just did an asymmetric threesome and it was working beautifully. Mind taking factions which have groups defined (at least under infantry).

So what I had was

MIL Placement OPF_F <sync> AI Commander Occupation OPF_F <sync> MIL Logistics (occupying Western Altis without NorthWestern part)

MIL Placement BLU_F <sync> AI Commander Invasion BLU_F <sync> MIL Logistics (Eastern Altis, invading OPF_F)

MIL Placement IND_F <sync> AI Commander Asymmetric IND_F <sync> CQB and IED module (NorthWestern Altis, invading OPF_F, hostile to all)

amb civs additionally, hostile to INDEP.

Working as intended, Reinforcements were requested and delivered after about half an hour beeing in the battle, asymmetric AI commander terrorized the shite out of the OPF held zones.

what is the issue specifically?

Share this post


Link to post
Share on other sites

Anyone been able to check into This Post? Just wondering if its a bug or if my design is incorrect? I tried to add it via bug tracker but having some issues getting the registration email... Thanks

---------- Post added at 14:16 ---------- Previous post was at 12:43 ----------

On another note, running into issues with ALIVE and latest update of IslaDuala3 map. I'm sure you probably aware and have to reindex maybe? Below are the errors and it goes on till it ends:

10:09:19 ALiVE [m_7|70] Module ALiVE_mil_placement INIT

10:09:19 Performance warning: Very large search for 204706 (>400 m)

..........................>>>>>>

10:09:25 Performance warning: Search for 2678: brg_umbrella_acacia_shrub2.p3d was very large (1360 m)

10:09:26 ALiVE [m_7|70] Module ALiVE_mil_placement INIT COMPLETE TIME: 6.54395

I set marker only for about 150x150 for the Mil Placement. THis is at the base on southwest side of map at the very bottom

EDIT:

Military Logistics module also affected and does the whole map?

Edited by JCae2798

Share this post


Link to post
Share on other sites
Yo!

So I just did an asymmetric threesome and it was working beautifully. Mind taking factions which have groups defined (at least under infantry).

So what I had was

MIL Placement OPF_F <sync> AI Commander Occupation OPF_F <sync> MIL Logistics (occupying Western Altis without NorthWestern part)

MIL Placement BLU_F <sync> AI Commander Invasion BLU_F <sync> MIL Logistics (Eastern Altis, invading OPF_F)

MIL Placement IND_F <sync> AI Commander Asymmetric IND_F <sync> CQB and IED module (NorthWestern Altis, invading OPF_F, hostile to all)

amb civs additionally, hostile to INDEP.

Working as intended, Reinforcements were requested and delivered after about half an hour beeing in the battle, asymmetric AI commander terrorized the shite out of the OPF held zones.

what is the issue specifically?

Yeah this is what i want, will try to recreate that exact setup just to see if i might have missed somthing! Thank you. will let you know what happens :P

Share this post


Link to post
Share on other sites

Is there a quick way to check how much is left in the reinforcment pool? Somtimes after the commander have gotten more units i get a popup says 980/1000 left is there a way to see this whenever i want?

PS:

Quote Originally Posted by ChronicleDude View Post

Anyone have a working mission where they have 3 AI commanders on field? One occupying one invasion and one assymetric? With a working reinforcement i simply can not get it to work.

Yo!

So I just did an asymmetric threesome and it was working beautifully. Mind taking factions which have groups defined (at least under infantry).

So what I had was

MIL Placement OPF_F <sync> AI Commander Occupation OPF_F <sync> MIL Logistics (occupying Western Altis without NorthWestern part)

MIL Placement BLU_F <sync> AI Commander Invasion BLU_F <sync> MIL Logistics (Eastern Altis, invading OPF_F)

MIL Placement IND_F <sync> AI Commander Asymmetric IND_F <sync> CQB and IED module (NorthWestern Altis, invading OPF_F, hostile to all)

amb civs additionally, hostile to INDEP.

Working as intended, Reinforcements were requested and delivered after about half an hour beeing in the battle, asymmetric AI commander terrorized the shite out of the OPF held zones.

what is the issue specifically?

It now works with vanilla and RHS! Thank you!:yay::yay::bounce3:

Edited by ChronicleDude

Share this post


Link to post
Share on other sites

hey guys, is there a way to only allow support modules (CAS for example) to go active on a trigger/code?

Share this post


Link to post
Share on other sites
Is there a quick way to check how much is left in the reinforcment pool? Somtimes after the commander have gotten more units i get a popup says 980/1000 left is there a way to see this whenever i want?

No. It's something we'd like to add though.

JCae2798 - you can start/stop modules on a trigger (see the wiki script snippets). It might work with Combat Support but I've never actually tried it.

Share this post


Link to post
Share on other sites

Not until the next release of ALiVE, which will be when it's ready :)

Share this post


Link to post
Share on other sites

I'm learning Alive right now. i'm using zeus to monitor things across the map,

- the alt+left click is not working anymore in editor why is that ? i need it as zeus POV will not pop virtualized unit i need to move my "player" instead.

- why i see sometime lonely soldiers , i don't understand why it's not at least, a 3 or 4 unit group. (i'm in range , as i set 3000meter range to cache unit , unit is 900meter away)

-i enabled debug nearly everywhere, but i don't see trooper waypoint/order. i can see vehicle patrol WP , but not trooper.

Edited by griffz

Share this post


Link to post
Share on other sites

@friznit, thanks, i'll give that a go and see how it works out and report back

@Griffz - Teleport needs to be enabled by ALIVE. Go into Admin Actions and enable teleport. Then all you need to do is click on map where and when you want to Teleport.

Share this post


Link to post
Share on other sites

@Griffz - Teleport needs to be enabled by ALIVE. Go into Admin Actions and enable teleport. Then all you need to do is click on map where and when you want to Teleport.

i'm previewing in editor. where is this admin action menu ?

Share this post


Link to post
Share on other sites

ok got it !

is there a way to define a minimum group size ? these lonely soldier are useless

Edited by griffz

Share this post


Link to post
Share on other sites
JCae2798 - you can start/stop modules on a trigger (see the wiki script snippets). It might work with Combat Support but I've never actually tried it.

Just wanted to report back. Tried the Pause module tip and no go. My guess is the module is not supported by the PAUSE scrip. I did see an error come up during mission startup as well. My guess is only the following modules are truly supported:

["ALIVE_SYS_PROFILE","ALIVE_MIL_OPCOM","ALIVE_AMB_CIV_POPULATION","ALIVE_MIL_LOGISTICS","ALIVE_SYS_AISKILL"] call ALiVE_fnc_pauseModule; unless this was meant to be used as an example.

Share this post


Link to post
Share on other sites

can we add more than 1 faction in the same placement module ? per exemple IND_F and BLU_G_F ?

Share this post


Link to post
Share on other sites
can we add more than 1 faction in the same placement module ? per exemple IND_F and BLU_G_F ?

No, it will error and default to CSAT

Share this post


Link to post
Share on other sites

okay, i'm discovering the 3 different AI commander entity . my IND commander send well 1 group to sabotage a CSAT mortar camp. that's great !

but , the team it use to do the dirty job isn't exactly appropriate . no weapons silencers, it's not a specops group. i assum there is no demo specialist either.

Where can i change that ? is there a way to do it ?

Ho and i forgot that ! : the designated sabotage team is moving in safe behavior . they walk. shouldn't they run , in frosty behavior ? it would achieve to goal faster. 2 time faster.

Edited by griffz

Share this post


Link to post
Share on other sites

http://forums.bistudio.com/showthread.php?169350-ALiVE-Advanced-Light-Infantry-Virtual-Environment&p=2969713&viewfull=1#post2969713

Hey guys about the above, has anyone been able to test and confirm its an issue on their end as well? Was hoping to use a mission with this setup and not sure what the problem is. I tried it on both my laptop and desktop with same result. Sorry dont mean to be annoying but trying to confirm its an issue with ALIVE and not my setup.

Just to add it seemed to work on a different map so not sure what the deal is.. :confused:

Share this post


Link to post
Share on other sites
http://forums.bistudio.com/showthread.php?169350-ALiVE-Advanced-Light-Infantry-Virtual-Environment&p=2969713&viewfull=1#post2969713

Hey guys about the above, has anyone been able to test and confirm its an issue on their end as well? Was hoping to use a mission with this setup and not sure what the problem is. I tried it on both my laptop and desktop with same result. Sorry dont mean to be annoying but trying to confirm its an issue with ALIVE and not my setup.

Just to add it seemed to work on a different map so not sure what the deal is.. :confused:

You could try loading the mission in the editor, while it is open, delete the mission.sqf from the mission folder. Then save the mission from in the editor. Reload with the new mission.sqm and see if it works.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×