Jump to content
wolffy.au

ALiVE - Advanced Light Infantry Virtual Environment

Recommended Posts

Can you try reversing the sync direction on the ML? I think I noticed something weird with this the other day, previously I was sure that the source and target of the sync line had no effect but now I'm not so certain, so can you do a test and see if drawing the sync lines in varied directions will change anything?

Created a simple test mission where its just 60 v 60 synced to one opcom invasion module. Tried syncing from opcom to ML still false, synced from ML to opcom, also false.

Share this post


Link to post
Share on other sites
Created a simple test mission where its just 60 v 60 synced to one opcom invasion module. Tried syncing from opcom to ML still false, synced from ML to opcom, also false.

Are you in the skype channel? If not can you pm me your skype name and I'll add you? If so, can you post in there and I will try to replicate?

Share this post


Link to post
Share on other sites

Thank you. Since those OPCOMs are no longer synced to both MP modules though, will they be able to attack the objectives in eachother's zones?

I thought you had to sync ALL MP's to each OPCOMs so they knew about each spawn zone.

Skype chat isn't launching for some reason.

Edited by I WUB PUGS
skype

Share this post


Link to post
Share on other sites

Ah yeah forgot that bit, just sync their own and the oppositions placement modules to the opcoms and it should be good to go. Check out the Valley of just pure death mission on the website which is the same idea. PM me your skype name and I can add you to the channel.

Share this post


Link to post
Share on other sites

I'll paste my question here again since I can't find an answer for it anywhere, and I'm kinda responsible for the mission making in our clan...

"If I don't want Alive to actually spawn units, just create missions, what do I do? I spawn my own units and create waypoints for them. Is it the military placement module that spawns enemies? It seems the whole map is FULL of spawned AI, even though I set it to only a 30 man pluton?"

Share this post


Link to post
Share on other sites
I'll paste my question here again since I can't find an answer for it anywhere, and I'm kinda responsible for the mission making in our clan...

"If I don't want Alive to actually spawn units, just create missions, what do I do? I spawn my own units and create waypoints for them. Is it the military placement module that spawns enemies? It seems the whole map is FULL of spawned AI, even though I set it to only a 30 man pluton?"

Read the manual before posting, please.

Share this post


Link to post
Share on other sites

I did, and it doesn't work..:cry2: Whatever I do, enemies keeps spawning after a while. What am I doing wrong?

Share this post


Link to post
Share on other sites

The problem here lies with the options I have on the profile system module, "Do nothing with synced units." is not needed as an option I don't think as it only confuses people. Do nothing with synced units at the moment just ignores anything you have synced and profiles everything on the map. So in your case if you don't want to profile anything on the map select "Only profile synced units".

@Delta99 - The individual's inability or lack of desire to read certainly isn't ARJay's fault, but understanding is in the hands of both readers and writers. There's a whole career field built around it, actually.

But aside from that; I used the option as it seemed most logical, and it didn't work. I had synced the vehicles to the profile module and set it to "Do nothing with synced units," but the module was still syncing them which caused the issues I described. Now that I have told it to profile only synced units without syncing anything to it, editor-placed vehicles function as intended. It works, but it seems kind of backwards considering the options given.

Regardless - thanks for the assistance. Everything is working now to the best of my knowledge.

Share this post


Link to post
Share on other sites
I did, and it doesn't work..:cry2: Whatever I do, enemies keeps spawning after a while. What am I doing wrong?

I'm not sure what you are trying to achieve? You have placed your own units and you want OPCOM to take control of them? Just place an OPCOM and it should pick up your editor placed units (as long as they are profiled). If you want to give OPCOM objectives with no units spawned select "Objectives Only" from the spawn units drop down on the placement modules.

---------- Post added at 18:10 ---------- Previous post was at 18:07 ----------

@Delta99 - The individual's inability or lack of desire to read certainly isn't ARJay's fault, but understanding is in the hands of both readers and writers. There's a whole career field built around it, actually.

But aside from that; I used the option as it seemed most logical, and it didn't work. I had synced the vehicles to the profile module and set it to "Do nothing with synced units," but the module was still syncing them which caused the issues I described. Now that I have told it to profile only synced units without syncing anything to it, editor-placed vehicles function as intended. It works, but it seems kind of backwards considering the options given.

Regardless - thanks for the assistance. Everything is working now to the best of my knowledge.

Thanks for bringing up your difficulties, this is exactly what an alpha release is for. As makers of the modules we know them back to front, so we are often not the best at spotting usability issues for learners. "Do nothing with synced units" is redundant as its the same as just placing the module down.

Share this post


Link to post
Share on other sites
I'm not sure what you are trying to achieve? You have placed your own units and you want OPCOM to take control of them? Just place an OPCOM and it should pick up your editor placed units (as long as they are profiled). If you want to give OPCOM objectives with no units spawned select "Objectives Only" from the spawn units drop down on the placement modules.

Thanks for your reply.

I don't want ALiVe to spawn any enemies from either side, I just want to use the unites I spawned via the editor- I also gave them waypoints, so I don't need OPCOM to do anything eiher. I just want a clean build, where I can use 200 spawned enemies I spawned myself, and be able to play it with the built in thing that makes it lag-free.

Do you see what I mean?

Share this post


Link to post
Share on other sites
Thanks for your reply.

I don't want ALiVe to spawn any enemies from either side, I just want to use the unites I spawned via the editor- I also gave them waypoints, so I don't need OPCOM to do anything eiher. I just want a clean build, where I can use 200 spawned enemies I spawned myself, and be able to play it with the built in thing that makes it lag-free.

Do you see what I mean?

So just place the profile system and you should be done, it will translate your waypoints into virtual ones (as long as they are only move and cycle waypoints) and handle caching of the units. What else did you want it to do?

Share this post


Link to post
Share on other sites
So just place the profile system and you should be done, it will translate your waypoints into virtual ones (as long as they are only move and cycle waypoints) and handle caching of the units. What else did you want it to do?

Thanks! But I need to put in "RequiresALiVe" aswell as the profile system, right?

I want to start with my own spawns and then learn more as I go along, I don't want the AI commander to spawn millions of bots everywhere at this point:)

Share this post


Link to post
Share on other sites
Thanks! But I need to put in "RequiresALiVe" aswell as the profile system, right?

I want to start with my own spawns and then learn more as I go along, I don't want the AI commander to spawn millions of bots everywhere at this point:)

Yep just place requires alive module and that should be fine.

Share this post


Link to post
Share on other sites
Yep just place requires alive module and that should be fine.

Scratch that. IT STILL Spawned enemies??? How??

Edited by Kardan

Share this post


Link to post
Share on other sites

Do not place any Placement modules (MP or CP) - only place Requires ALiVE and Profiles - nothing else. If enemies are still spawning, then it's not ALiVE doing it.

Share this post


Link to post
Share on other sites
Do not place any Placement modules (MP or CP) - only place Requires ALiVE and Profiles - nothing else. If enemies are still spawning, then it's not ALiVE doing it.

I only have Requires alive, admin module and profiles, that's it. Things are still spawning. Empty vehicles and "iranians"... This is so weird.. Must've spent 15 hours trying to solve this, at least!

Could MCC somehow screw it up?

Edited by Kardan

Share this post


Link to post
Share on other sites
Possibly. Try removing it but this is not ALiVE spawning anything.

I opened the sqm file and it has text about military placements in it, even though I don't have that module in the save?

I'm sorry for all these questions, but I'm so frustrated since I've spent so much time making a good mission.

Share this post


Link to post
Share on other sites
I opened the sqm file and it has text about military placements in it, even though I don't have that module in the save?

I'm sorry for all these questions, but I'm so frustrated since I've spent so much time making a good mission.

Can you join the skype channel if you want further assistance. You can PM me your skype name and I can add you too the alive channel

Share this post


Link to post
Share on other sites

Thank you, guys, this mod is amazing. I just spent an hour flying randomly over Altis, supporting friendly troops and performing randomly assigned missions. The feeling of a battlefield independent from you is great.

Kudos for your work.

Share this post


Link to post
Share on other sites
The transport combat support helicopters refuse to land on the USS Nimitz during a transport mission. Any ideas?

I have coded the SUP_TRANSPORT to be able to use the Nimitz as it's base by adding a spawn height option into the module, this works without issue and the transport Heli will RTB to the Nimitz and land.

However in the LAND Command I have coded it so that it does not land in the water, you are probably getting a sidechat message saying "Unable to Land at coordinates. Out". There is a check in the code to ensure that heli does not attempt to land on the water.

Unfortunately it looks like the deck of the Nimitz is not being recognised, but just the water it is sitting on top of, I'm afraid there is nothing I can do as this is the config of the Nimitz.

---------- Post added at 10:31 ---------- Previous post was at 10:20 ----------

Thank you, guys, this mod is amazing. I just spent an hour flying randomly over Altis, supporting friendly troops and performing randomly assigned missions. The feeling of a battlefield independent from you is great.

Kudos for your work.

Cheers for the comments DarkWanderer, Glad your enjoying it!

Edited by Gunny1979

Share this post


Link to post
Share on other sites
Can you join the skype channel if you want further assistance. You can PM me your skype name and I can add you too the alive channel

You have mail....or pm=)

Share this post


Link to post
Share on other sites

Could it be possible to make it so that enemies cannot come over the sea with cars and tanks? Now the virtual side allows them to move over the sea. If I go close and make them real, they will spawn to the closest land. I am mainly worried about the Pyrgos Gulf section. Trying to make it so that one side controls the other side and one the other and the choke point would be north of the airfield but enemies keep coming over the sea :( Maybe if someone would come over they sea, they would be boat atleast or helicopters.

Also this might be already too much to ask but would be it possible that the virtual AI would still go on the roads, or at least near the roads when they are not "fighting". During fightning or when getting near enemy lines, ofc spread out but when they are moving further away from enemy lines, make them go on the roads.

Edited by Hapexi

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×