Jump to content
wolffy.au

ALiVE - Advanced Light Infantry Virtual Environment

Recommended Posts

Hmm. Most likely I do something wrong, but...

Whatever settings I use, OPCOM modules for two sides and ML/MI modules won't start.

I have even drawn a pentagram:

https://dl.dropboxusercontent.com/u/57455736/pentagram.jpg

But still get an error:

https://dl.dropboxusercontent.com/u/57455736/error.png

Mission is here. Can anybody help me, please?

thanks comrade!

I will have a look at your mish in a few minutes after i finished my work!

latersh

Share this post


Link to post
Share on other sites
So what do I do to get DRIrregulars to work with ALiVE? Im such a noob about some of this stuff. Please take it from the top. :D

Okay so this is a bit of a workaround to get you working until the Independent fixes to ALiVE are made and/or drongo updates his mod. The changes will put drIrregulars onto the "East" faction.

(or you could cheat and just download my modified mod directory http://arma.quartermoa.com/mods/super_irregulars_20131213.zip :))

In the interest of sharing knowledge here are the full steps. Basically, what you're going to do is unpack the drirregulars PBO, unbin the config.bin file, edit config.cpp, re-bin it, then repack the pbo. You'll want to keep backup copies of drirregulars.pbo and config.bin. I'm still pretty new to this but since others have helped me it's only right I pay it forward. :)

You'll need to have on hand the "Arma 3 Tools" package that was recently released on Steam, and some way of unpacking and repacking PBO files (I use PBO Manager: http://www.armaholic.com/page.php?id=16369).

  1. Hop into your main Arma3 directory (Steam/SteamApps/common/Arma 3/)
  2. In another Explorer window navigate to (Steam/SteamApps/common/Arma 3 Tools/CfgConvert/)
  3. Go into @dr_irregulars/addons/
  4. Copy drirregulars.pbo aside (drirregulars.pbox). Right-click drirregulars.pbo and click "PBO Manager" -> "Extract to drirrgulars/". You should see a new directory be created named "drirregulars".
  5. Enter this new directory. One of the files you should see is config.bin. Copy it aside with a new name (config.binx)
  6. This step is important: Drag the config.bin ON TOP OF the BINtoCPP.bat in the CfgConvert directory. You should see a new file be created named config.cpp.
  7. Open config.cpp in a text editor.
  8. Globally search and replace instances of "side=2" with "side=0"
  9. Find where it says "INDEP" beneath the "class CfgGroups" directive and change "INDEP" to "East".
  10. Find the group named "driRifleSquad" (look for "class driRifleSquad). Add "side=0;" (without quotes) underneath the line that says 'faction="drIrregulars"'
  11. Do the same for the group named "driWeaponsTeam".
  12. Save and close the file.
  13. Drag the config.cpp file onto CfgConvert/CPPtoBIN.bat. This should overwrite the previous config.bin with your modified one.
  14. Go up one directory, right-click on the drirregulars directory (the one that was unpacked from the pbo), create PBO. This will overwrite drirregulars.pbo.

After that you should be good to go. Add "drIrregulars" to the Force Faction input field in the military [civilian] placement module, and away you go!

Edited by superfluid

Share this post


Link to post
Share on other sites

DarkWanderer, It looks like you have things synced that shouldn't be. Here is a kind of diagram to show what should be synced. This example would have OPCOM utilizing 3 MP (military placement modules) and 3 CP (civilian placement modules) I also have CQB synced to all three MP and one of the CP. ML (military logistics) is synced to OPCOM as well as MI (military intelligence)

CQB

/ \ \ \

MP CP MP MP

\ / / /

OPCOM

/ \ \ \

ML MI CP CP

EDIT: Thanks Superfluid im on it!

EDIT 2: I noticed the file is very small. Is there any way you could do me a solid and email the converted .pbo to me? I keep getting a unrelated .dll error because I have crappy Vista OS I would be grateful.

Edited by Redfield-77

Share this post


Link to post
Share on other sites

EDIT 2: I noticed the file is very small. Is there any way you could do me a solid and email the converted .pbo to me? I keep getting a unrelated .dll error because I have crappy Vista OS I would be grateful.

Redfield, I unpacked the zip file, you should be able to find the updated pbo here: http://arma.quartermoa.com/mods/%40dr_irregulars/addons/drirregulars.pbo

Share this post


Link to post
Share on other sites
DarkWanderer, It looks like you have things synced that shouldn't be. Here is a kind of diagram to show what should be synced. This example would have OPCOM utilizing 3 MP (military placement modules) and 3 CP (civilian placement modules) I also have CQB synced to all three MP and one of the CP. ML (military logistics) is synced to OPCOM as well as MI (military intelligence)

CQB

/ \ \ \

MP CP MP MP

\ / / /

OPCOM

/ \ \ \

ML MI CP CP

EDIT: Thanks Superfluid im on it!

The forums engine has broken the diagram a little bit, but NP, I've got it...

As it turns out, I shouldn't have synced the OPCOM to the Profile system module. Now it works - thanks a lot!

Share this post


Link to post
Share on other sites

EDIT: Solved, Thanks again Superfluid cheers!

One other question, Will they use the assets they came with ie: Technicals with pks etc...

Edited by Redfield-77

Share this post


Link to post
Share on other sites

Quick question. Does the logistics module in its present state create convoys for resupply/replacement? If not can you detail exactly what its current state is?

Share this post


Link to post
Share on other sites

I have placed a few Vehicles/Heli down and I am using our own cargo script and that goes into the Vehicles INITfor the addaction , but the Profile system seems to pick up theses empty vehicles and in doing so they lose their add action.

I have tried syncing them with the profile module and selecting the option to ignore any synced units but it still removes the add action

How do i get the Module to ignore pre placed vehicles ?

Share this post


Link to post
Share on other sites
Quick question. Does the logistics module in its present state create convoys for resupply/replacement? If not can you detail exactly what its current state is?

It just adds new units to the profile at the moment, no physical convoys are created in game yet.

Share this post


Link to post
Share on other sites

Wow, this is a great mod. Thank you for making it :)

Nice to see that its both SP and MP.

Share this post


Link to post
Share on other sites
I have placed a few Vehicles/Heli down and I am using our own cargo script and that goes into the Vehicles INITfor the addaction , but the Profile system seems to pick up theses empty vehicles and in doing so they lose their add action.

I have tried syncing them with the profile module and selecting the option to ignore any synced units but it still removes the add action

How do i get the Module to ignore pre placed vehicles ?

In the Profile module there is an option what to do with synced units, default to do nothing. The way I understand it, if you change this to only profile synced units, it would not profile anything you manually place in editor; or, if you only want some to escape profiling, sync them and tell it to ignore synced units. Not sure why it wouldn't be working for you... Have you tried the option to only profile synced units, and leave yours unsynced?

Share this post


Link to post
Share on other sites

Some more issues/queries:

1. AI spawned seems to ignore AI precision from the AI skills module. Using a radio trigger with "" shows them with aimingAccuracy of 0.5. Only the player's aimingAccuracy is actually set to what I set in the AI skill module.

2. After a while, intel seems to stop showing up on the map.

3. Hardly any tasks are given to the player. Only task I've seen so far is destroying the solar transformer at the same place. The TAOR marker is quite large covering 16 square kilometers with mostly ground terrain in the Kavala area.

4. After initialization, a "There are no profiles for faction(s) ["BLU_F"] assigned to OPCOM WEST!" message shows. Is this OK? I placed this module just to give the players task, and not control any friendly AI. Might be related to #3.

Share this post


Link to post
Share on other sites

Question regarding the ALiVE Combat Support module please...

I have a transport helicopter and a Combat Air Support helicopter on my map, each using a Combat Support module.

My question is... if either of the helicopters gets destroyed, how/when does the helicopter respawn?

Does ALiVE handle the respawn of those units and if so, when do they respawn?

Thanks in advance!

Z

Share this post


Link to post
Share on other sites

The logistics module keeps giving me a popup on load that says it isn't working because it isn't synced. I have an ML module synced to each of the 3 OPCOMS I have. That is all they are synced to. Should I be concerned? Are the ML modules working?

The mission doesn't appear to be affected since once the queue is done, the various units are given objectives and off they go. But the ML modules give me a popup saying they aren't synced.

Share this post


Link to post
Share on other sites
2. After a while, intel seems to stop showing up on the map.

3. Hardly any tasks are given to the player. Only task I've seen so far is destroying the solar transformer at the same place. The TAOR marker is quite large covering 16 square kilometers with mostly ground terrain in the Kavala area.

I am running vanilla ALiVE, so to speak - no other mods. And I have not noticed this whatsoever.

Please can you give the ALiVE version, other mods, .rpt and any other variables that may cause issues.

Share this post


Link to post
Share on other sites

Hey fellas, i'm having an issue getting uav's to work. I have them placed with cas synched to the cs module. Everything works fine in the editor and on non dedicated, but when on dedicated the uav's don't show up on map, i can control them through the pda but cannot take control with the uav terminal, any help appreciated.

Share this post


Link to post
Share on other sites

I don't believe the UAVs work in multiplayer as far as accessing them through the uav terminal. This is only for single player from what I recall.

The only uav that works in multiplayer is the little quad copter

Share this post


Link to post
Share on other sites

had a quick look at this with my mate yesterday and if i understand correctly the battle over the island is ongoing for as long as the server is up.

question (sorry can't read 50 pages of posts): is the battle over the island over at some point? is one faction actually conquering the whole island?

cheers

Share this post


Link to post
Share on other sites

Zlin/Skryboyd - CS units do not respawn at the moment. That part is still to come. We will need to look into the UAV in MP thing - may be a BIS 'feature' though. Please can you log a ticket on DH for that?

Blueskunk - the war will effectively end when one of the sides runs out of units and the whole island is occupied. If logistics is replacing units indefinitely then this may never happen of course. There's no scripted mission end though, that's up to the mission maker to add. Mission persistence is coming soon which will allow you to restart the server and continue from where you left off.

Share this post


Link to post
Share on other sites

OK, I will try load up an RPT after next game. Version is synced through PWS. Mods are @CBA_A3, @ALiVE, @STHUD_A3 and @IDF. All are the PWS version.

Though what about the AI skills issue? Has anyone else run into it?

Edited by galzohar

Share this post


Link to post
Share on other sites

I have a small problem. Whenever I start a game in a squad but not as its leader I'm unassigned from it. Is there a way to prevent this from happening.

EDIT: I also hope you guy will implement the new fog system for the dynamic weather :)

EDIT 2: Trying to spawn Arma 2 factions with AiA and US units spawn as hostile :confused: ( Didn't try other AiA factions yet but I presume its the same with them )

Edited by Denco

Share this post


Link to post
Share on other sites
I have a small problem. Whenever I start a game in a squad but not as its leader I'm unassigned from it. Is there a way to prevent this from happening.

EDIT: I also hope you guy will implement the new fog system for the dynamic weather :)

EDIT 2: Trying to spawn Arma 2 factions with AiA and US units spawn as hostile :confused: ( Didn't try other AiA factions yet but I presume its the same with them )

Ad. Squad - Your squad was virtualized by the profiler, but real players won't be virtual and thats where you got unassigned. Set the dropdown of SYS PROFILES module accordingly (f.e. "Only profile synced units") to solve your problem!

Ad. 1. - New fog system is already implemented in dynamic weather. In addition, there are several epic improvements for dynamic weather module by Jman inbound!

Ad. 2. - We tested with AiA and didnt see that, please open a ticket on the dev heaven tracker with a repro mission that only has ALiVE (incl. CBA) and AiA in!

latersh

HH

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×