Jump to content
wolffy.au

ALiVE - Advanced Light Infantry Virtual Environment

Recommended Posts

Ok, so you asked for me to test with just cba and alive. the tests were done and the verdicts are in... It is @ALiVE. or maybe its CBA_A3??? I DONNO

I just did 1hr of testing on just my client "didnt want to disturb the server yet."

I started off with just cba, alive, gl5, AIATp and caraboufronteer. This was because i first had to make a mission with out gl5 , so i had launch with it and remove all the modules to then bel able to launch the mission with out the mod. after removing gl5 and restarting with just AIATP, and caraboufronteer. I still had the same glitch.

so moving on.

I copied and pasted the same mission into stratis. then shut down arma and restarted it.

With Only "" @CBA_A3;@ALIVE; ""

Then went threw and made sure all the markers, boats, modules, were in good places. That way when the mission started the cas/transport vic's wouldnt spawn on rocks or in the ocean etc. Then tested it out..

I had some technical difficulties with drifting.. as the dropped vic's would drift out to the ocean. I finally had a winner, and I approached.

Mind you this was again with ONLY CBA_A3 and ALIVE... On stratis. So it could also be a glitch in cba? again i donno...

Edited by Lordprimate

Share this post


Link to post
Share on other sites
Ok, so you asked for me to test with just cba and alive. the tests were done and the verdicts are in... It is @ALiVE. or maybe its CBA_A3??? I DONNO

I just did 1hr of testing on just my client "didnt want to disturb the server yet."

I started off with just cba, alive, gl5, AIATp and caraboufronteer. This was because i first had to make a mission with out gl5 , so i had launch with it and remove all the modules to then bel able to launch the mission with out the mod. after removing gl5 and restarting with just AIATP, and caraboufronteer. I still had the same glitch.

so moving on.

I copied and pasted the same mission into stratis. then shut down arma and restarted it.

With Only "" @CBA_A3;@ALIVE; ""

Then went threw and made sure all the markers, boats, modules, were in good places. That way when the mission started the cas/transport vic's wouldnt spawn on rocks or in the ocean etc. Then tested it out..

I had some technical difficulties with drifting.. as the dropped vic's would drift out to the ocean. I finally had a winner, and I approached.

Mind you this was again with ONLY CBA_A3 and ALIVE... On stratis. So it could also be a glitch in cba? again i donno...

Sorry what is the actual issue here?

Please supply the mission you used, and the exact steps you did prior to this happening, I will constantly do it for 2hrs to see if I get a rocket fired vehicle!

What's the debug output?

Edited by Gunny1979

Share this post


Link to post
Share on other sites

Are you trying to say that VB-IEDs are seemingly being applied to civilian vehicles that are delivered by Player Combat Logistics. Is that correct?

Share this post


Link to post
Share on other sites
Are you trying to say that VB-IEDs are seemingly being applied to civilian vehicles that are delivered by Player Combat Logistics. Is that correct?

Long answer

first off the video description says a bit more. I am reporting the same issue as before vehicles called in as support explode when you approach them .. i can link you to the whole video *(Ill link it here in a few minutes when it uploads to youtube)*. if you were to watch it you will see several vehicles that i call in for support to drive around, blow up just like that, AND there is some more footage of the "rocket effect"(but that happens when im running aiaTP on Caribou). At the very beginning of the video you will see a charge floating in the air.. that is where a vic just was.. i had stupidly forgot to start OBS. that vic had just turned into a rocket and flew off leaving that charge behind(i called it a satchel). The main issue here is the exploding vehicles im calling in for support. the rocket issue is second on my list...

with that out of the way.. this is the ONLY glitch i am having with ALIVE.. I am not badmouthing ALIVE at all this is a GREAT MOD.. I am simply reporting a glitch..

yes its a video (a highlight of a longer video) that shows me running up to a vic i called in for support.. i shortened it for your sake. instead of watching a 48 min vid of me talkin to random people and carrying on you got the good stuff.. sorry, ill explain the scean. I just called for 3 vic's two of them landed in the ocean. this one didnt. I ran up to it to get in and drive away, thinking it was safe, as i just called for it... and >BOOM<

.. how is it im reporting a glitch and i am getting this much pushback for it... WOW... I even state in my earlier post it could be cba? in my extended video i even acknowledge the fact that the rocket problem isnt happening... but thats not what im reporting here its me calling for a vic and that very vic exploding in my face...

short answer : yes

ill do a video of alive running with all the debug stuff on. and i will also get you that mission file. you want the stratis version or the caribou version? ill just send both.

Edited by Lordprimate

Share this post


Link to post
Share on other sites

You're not getting pushback. We're as keen to resolve any issues as you are but I'm honestly struggling to reproduce it, so just trying to understand what steps you are taking. Without repro, we cannot begin to identify the root cause. I'm sure you understand.

I've just knocked up a quick ALiVE mission on Stratis - extreme IED threat, player combat logistics and all the other modules running as normal. I called in several vehicles of different types with different methods and it's all working fine - no random explosions. If you could send me a copy of your mission so I can pick it apart that would help. It could well be an edge case where a unique way of syncing modules is causing weird behaviour.

Share this post


Link to post
Share on other sites

Pm Sent. Your probably right, I just have a bad filter and write in stream of consciousness so i often dont get my point across as i intend to. And in the same respect i tend to read into things a bit. the mission is running very few scripts, VAS shk_pos for initial halo drop positions. i disabled the Loot spawning a long time ago that has not been an active part of the mission for a while (need to remove it) and some pictures. you have the files in your pm box. youll see there pretty simple, and it may very well be how i synced things. I dont know.

the first time the rocket thing happend was really funny, but, kinda freaked me out as i was pretty immersed at the time. i thought that even though i am running some mods. being only AI , and map mods i figured someone else had to have had the issue or would get a good laugh at it.

Share this post


Link to post
Share on other sites

Well after a good few hours of testing I think I can confirm your suspicion that there is a saboteur in the logistics chain. It only appears to happen to vehicles you request from a different faction that I can tell, as I have not been able to repro it when requesting BLU_F vehicles as a NATO Soldier, or when requesting Independent vehicles as FIA. While we dig around and try to find what's causing this, if you want an extreme IED threat I'd suggest restricting logistics to your faction only and maybe bring an Engineer along to be doubly safe!

I have created a ticket on DH and we'll have a root around to see if we can find a fix. http://dev.withsix.com/issues/76040

Edit: Tup's rewritten the VB-IED module to work around this issue. Will be in the next release.

Edited by friznit2

Share this post


Link to post
Share on other sites

I have quickly searched this thread and I could not find anything about this so my apologizes if it has been mentioned. Is there a way to save items (other than vehicles / boxes) spawned with Zeus?

I seem to recall that in ArmA2 with MSO there was a command you could run on things spawned by MCC to save them, is there anything like this for ALiVE?

Share this post


Link to post
Share on other sites

Please see the editor notes at the bottom of this Logistics Wiki article: http://alivemod.com/wiki/index.php/Logistics_Support

For AI groups spawned by Zeus, you need to manually profile them (Admin actions > Profile all non-profiled units). They will then get taken over by the AI Commander and treated like any other Profile for persistence purposes.

Share this post


Link to post
Share on other sites
Well after a good few hours of testing I think I can confirm your suspicion that there is a saboteur in the logistics chain.

That's not a bug, it's a feature. The Insugency is REAL.

Share this post


Link to post
Share on other sites

Hello All

My friends and I are having trouble with Alive on our dedicated server.

The first time we played it we messed about on CO12 Sabotage mission and blew up vehicles at base just to see how our new server run. Now every time we try and play the mission it restarts from that point and the vehicles remain blown up.

We have tried to delete the saved game files locally but it makes no difference, where are they stored ? are they stored locally or on the server ? i cannot find anythying on server.

We have done commands such as #restart but the mission always continues with blown up vehicles on spawn.

Is there a location on server where saved version of mission is located ? How to completley start fresh ?

Hope you understand.

Thank you

Share this post


Link to post
Share on other sites

If you are using the ALiVE database just rename your mission to start afresh

Share this post


Link to post
Share on other sites

Thank you for quick response.

I am not sure what you mean by alive database ?

We just have mod enabled locally and on server (@alive, @aliveserver)

We select mission in mission select screen but always starts from last location.

If we simply rename mission it will be like a new mission ? good idea, i try this.

Share this post


Link to post
Share on other sites

Assuming you're not running ALiVE Persistence or hooked up to the War Room, then you just need to restart the mission completely (#missions is your best bet).

If you've got your server set up with the War Room and ALiVE data, then persistence is working as intended across multiple sessions. To reset the mission in this case you need to change the filename of the pbo.

Incidentally, if you haven't registered your server on the War Room and are not using the ALiVE database, then you don't need to run @Aliveserver. But you should, full mission persistence and stats tracking is pretty cool!

Check out the wiki (linked in my sig) for more info.

Share this post


Link to post
Share on other sites
Assuming you're not running ALiVE Persistence or hooked up to the War Room, then you just need to restart the mission completely (#missions is your best bet).

If you've got your server set up with the War Room and ALiVE data, then persistence is working as intended across multiple sessions. To reset the mission in this case you need to change the filename of the pbo.

Hello. I do not think we are running Persistence or war room, i have no idea what either are. We just use mod in default state and want to try this co12 sabotage mission !

Thank you for help

Share this post


Link to post
Share on other sites

Not sure if this is a bug or something on my end but I had an issue with the auto generating tasks for Takistan (AIA)... First off... on this mission it was perfect because tasks generated 300-1000k from each other.. like a campaign witch is PERFECT.. well 3 objectives down and I get .. Destroy (lamp post on)... which yo can't really destroy but you can run over.. after that.. no more generated tasks... even though mission was complete. Note that I was not using any blufor factions.. Just opfor cqb + a few mil and civ placements. I really enjoy a insurgency style mission where you need to go though enemy territory to get to an objective.. and keep pressing on. It was a dream come true until that damn OBJ! Anyways thanks! Hope it gets sorted out as I can't choose to decline small tasks for this.

Share this post


Link to post
Share on other sites
Please see the editor notes at the bottom of this Logistics Wiki article: http://alivemod.com/wiki/index.php/Logistics_Support

For AI groups spawned by Zeus, you need to manually profile them (Admin actions > Profile all non-profiled units). They will then get taken over by the AI Commander and treated like any other Profile for persistence purposes.

The trouble with that command Friz is that ALiVE then profiles ALL units on the map, including hand placed Shilka's, Roof guns, all the base guards, and vehicles we've specifically set to NOT profile.....

Could you not set some sort of Radius selection to the command? It's a great feature, but not usable on any of the persistant missions we run as it's too indiscriminate.

Share this post


Link to post
Share on other sites

You could make a script using the profile func. You'd either need to grab all the units in a trigger area (if Zeus can place triggers) or get near groups/units to a map click radius. Func needs to run on the server locality: [false, arrayOfGroups, arrayOfVehicles] call ALIVE_fnc_createProfilesFromUnitsRuntime;

Jman's example of spawning a group and profiling it is on the wiki here, albeit that's not using Zeus but it's a similar concept (ish)

Share this post


Link to post
Share on other sites

I have some questions regarding the database/persistent feature.

What is the exact procedure from uploading a mission until finishing it? (Assuming database is connected and everything runs fine)

- First uploading

- Server starts before player join

- player join

- mission is played

- Game is over for this night

then?

Do I have to load a different mission? Stop server or what?

Can I leave the mission on the server running?

If I load the mission two hours (or days) later, will the mission continue where we left it?

What is saved? Will also the trigger, variable states etc. saved in the database?

Can I edit the mission file before continuing, add trigger, add scripts, units etc.?

Is there maybe a guide how that feature exactly works?

Share this post


Link to post
Share on other sites

All the details are, as always, on our wiki: http://alivemod.com/wiki/index.php/Persistence :)

In short - assuming the database is connected and the ALiVE modules are down - just play as normal. For best results, you should use ALiVE's Player/Server Save & Exit buttons when you leave, because the standard BIS methods (Abort button) don't work very well. You can do what you want after that - leave it running (OPCOM pauses if no players are around) or shut it down, edit the mission, add more toys and restart from where you left off.

Custom triggers and variables cannot be saved to the database yet (it's technically possible but we don't want to go there just yet).

Edited by friznit2

Share this post


Link to post
Share on other sites

Thanks for advice :-)

Can we have several missions running? How many missions are stored for one server/group at the same time?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×