Jump to content
sancron

XMedSys - Improved Medical System for A3

Recommended Posts

X39_MedSys_var_KnockOut_showAbortButton = 0;

X39_MedSys_var_Hearing_enable = 0;

X39_MedSys_var_DamageMultiplicator = 0.5;

X39_MedSys_var_KillUnitWhenMaxDamageReached = 1;

X39_MedSys_var_LifeTime = 300;

X39_MedSys_var_Display_TimeBeforeRespawnAvailable_NormalKnockout = 10;

this is my server config :(

here is my blurry screen :(

http://steamcommunity.com/sharedfiles/filedetails/?id=247319270

and here is normal screen

http://steamcommunity.com/sharedfiles/filedetails/?id=247319254

if you compare right corner the word private you can recognize much easier

It happen even i erase all server config words :(

Edited by kgino1045

Share this post


Link to post
Share on other sites

I dont think x-med is working for "Zeus"... at least not for me. I cant bleed out and also dont get the action-menu.

Share this post


Link to post
Share on other sites
I dont think x-med is working for "Zeus"... at least not for me. I cant bleed out and also dont get the action-menu.

why all you guys say "its not working" and not considder that you people simply failed to read the documents/check the demo mission first??

90% of those issues posted in this thread are created in the 8. layer of the OSI model ...

also

with no info

no support can be provided

"its not working" is NOT A USEFULL INFO!

its a state ... which is useless

or do you go to a mechanican and say "my car is not working"

NO

you say whats the fucking problem and provide him as many infos as possible to fix the fucking issue!

so dont wonder if you people dont get help in this thread if it has been posted 200 times in this thread, simply giving informations about a state

or something else like that

kindly regards

X39

Edited by X39

Share this post


Link to post
Share on other sites

@Kgino1045 : I have the same problem than you , if you find a solution please PM me thank you !

Share this post


Link to post
Share on other sites
X39_MedSys_var_KnockOut_showAbortButton = 0;

X39_MedSys_var_Hearing_enable = 0;

X39_MedSys_var_DamageMultiplicator = 0.5;

X39_MedSys_var_KillUnitWhenMaxDamageReached = 1;

X39_MedSys_var_LifeTime = 300;

X39_MedSys_var_Display_TimeBeforeRespawnAvailable_NormalKnockout = 10;

this is my server config :(

here is my blurry screen :(

http://steamcommunity.com/sharedfiles/filedetails/?id=247319270

and here is normal screen

http://steamcommunity.com/sharedfiles/filedetails/?id=247319254

if you compare right corner the word private you can recognize much easier

It happen even i erase all server config words :(

@Kgino1045 : I have the same problem than you , if you find a solution please PM me thank you !

+ all others i dont find on this page who got this problem with empty server config

check your god damned setup!

use the correct version at server + client

there is currently a bug inside which causes this which has to do with disabling morphine/pain effects

thats the only thing (but other mods which cause problems) that can create such a nice blurry screen

meaning either you got mods inside of you which are not compatible because they are using the same ppEffects layer like i do

or youre not got a 100% default setup and anywhere a variable that causes exactly that (see the comment more up)

it has been told about 1000000000000 times a few pages back

meaning a single search

yeah EVEN a fucking "lets check what other people wrote" would have solved your problems

Share this post


Link to post
Share on other sites
+ all others i dont find on this page who got this problem with empty server config

check your god damned setup!

use the correct version at server + client

there is currently a bug inside which causes this which has to do with disabling morphine/pain effects

thats the only thing (but other mods which cause problems) that can create such a nice blurry screen

meaning either you got mods inside of you which are not compatible because they are using the same ppEffects layer like i do

or youre not got a 100% default setup and anywhere a variable that causes exactly that (see the comment more up)

it has been told about 1000000000000 times a few pages back

meaning a single search

yeah EVEN a fucking "lets check what other people wrote" would have solved your problems

Chill bro I'll check it. i thought you might know something so i just ask. I'll let you know which addons is make this things. I assume it is happen because Blastcore

---------- Post added at 19:58 ---------- Previous post was at 19:24 ----------

Found it.

super_flash

The flash bang

http://www.armaholic.com/page.php?id=21139

This is the caused. after i removed, it just works fine

Edited by kgino1045

Share this post


Link to post
Share on other sites
why all you guys say "its not working" and not considder that you people simply failed to read the documents/check the demo mission first??

90% of those issues posted in this thread are created in the 8. layer of the OSI model ...

also

with no info

no support can be provided

"its not working" is NOT A USEFULL INFO!

its a state ... which is useless

or do you go to a mechanican and say "my car is not working"

NO

you say whats the fucking problem and provide him as many infos as possible to fix the fucking issue!

so dont wonder if you people dont get help in this thread if it has been posted 200 times in this thread, simply giving informations about a state

or something else like that

kindly regards

X39

Lol ok chill.

But it would be not that unusal if a mod dosent work with a brand new model added to arma. So I thought that xmed isnt up to date for that.

I mean I use x-med no for a good while and never had a problem but now, even if I place the models and stuff I just dont get any feedback(errors) and nothing is really working. ( I cant check others and I cant bleed out.)

So Iam just given you feedback with things that arent working.

So befor you enrage the next time, pls consider that not everyone has an idea which, zeus changed in terms of the mod and how I know what is broken (on my, or your side=

Telle me how I can debug it and I will.

Regards NIN3

Edit: I can understand that it´s fustrating to answer questions several times, but since this is a new model and noone posted about it yet in this Thread, it should be ok to simply ask about it.

Edited by NIN3

Share this post


Link to post
Share on other sites

For those having trouble getting it to work. The documentation says:

How To Install:

1. Move the "@XMedSys" folder to your ArmA 3 dir (or to the directory you move your mods to by default)

2. Move the "userconfig" folder to your ArmA 3 dir

3. Add "-mod=@XMedSys" to your launch parameters OR start the game and enable the mod at "Configuration>>Expansions"

4. Edit the userconfig to your needs (or leave it like it is shipped by default and assign the CustomKey 1 & 2)

5. Have fun

The first issue I had was that there was no "userconfig" folder. It seems the PWS version doesn't have it or at least didn't give it to me. You MUST have it!

Even if you do have it, you MUST edit the MedSys_ServerConfig.hpp file because it is empty. The file tells you where to get the example config from.

After that I was able to use the Insert and Delete keys to bring up the menus. Oh, note that I didn't have any med supplies be default. Make sure you grab them from the middle crate.

Share this post


Link to post
Share on other sites

G'day,

There appears to be an incompatibility between XMedSys (or XActionUI?) and SUPER_FLASH. If both mods are included then the whole screen except for a small area in the middle becomes blurred. I notice that if I do not include the SUPER_FLASH mod (I only have XMedSys) that the screen blurs for a second while it displays the droplet health indicator then becomes sharp/normal again.

Also, it seems my menus look different to the video. Is this expected? I couldn't see anything in the release notes about a change in style.

https://dl.dropboxusercontent.com/u/7598715/WithXMedSys.jpg (626 kB)

Here is what it looks like if I remove XMedSys or SUPER_FLASH.

https://dl.dropboxusercontent.com/u/7598715/WithoutXMedSys.jpg (798 kB)

Share this post


Link to post
Share on other sites
G'day,

There appears to be an incompatibility between XMedSys (or XActionUI?) and SUPER_FLASH. If both mods are included then the whole screen except for a small area in the middle becomes blurred. I notice that if I do not include the SUPER_FLASH mod (I only have XMedSys) that the screen blurs for a second while it displays the droplet health indicator then becomes sharp/normal again.

Also, it seems my menus look different to the video. Is this expected? I couldn't see anything in the release notes about a change in style.

https://dl.dropboxusercontent.com/u/7598715/WithXMedSys.jpg (626 kB)

Here is what it looks like if I remove XMedSys or SUPER_FLASH.

https://dl.dropboxusercontent.com/u/7598715/WithoutXMedSys.jpg (798 kB)

Chill bro I'll check it. i thought you might know something so i just ask. I'll let you know which addons is make this things. I assume it is happen because Blastcore

---------- Post added at 19:58 ---------- Previous post was at 19:24 ----------

Found it.

super_flash

The flash bang

http://www.armaholic.com/page.php?id=21139

This is the caused. after i removed, it just works fine

Um... hello?

Share this post


Link to post
Share on other sites
Um... hello?

Hi.

Maybe you have time to read through 96 pages to see if something might be there...

Normally we would have a Known Issues section that dealt with such things.

As a general note. I found a video of the first XActionUI test so I guess there is nothing wrong with my install when comparing to the demo video.

Share this post


Link to post
Share on other sites

Release 0.3.5

Download:

http://www.mediafire.com/download/ivg1grdnsx0xd4c/XMedSys_BETA_0.3.5.zip

Changelog:

0.3.5 BETA
* updated french language
* added russian language (thx to nkey)
* added polish language (thx to someone who gave me the stringtables a long time ago (totally forgot about that : / sry for that))
* added TFAR support !TFAR VERSION MIGHT NOT BEING RELEASED AT XMEDSYS 0.3.5 BETA RELEASE DATE! (another thx to nkey here :F)
* fixed: errorMessage when throwing light
* fixed: Serverconfig variables of the type BOOL are not transfered correctly from the serverconfig into ingame mechanics    [ http://feedback.vbundeswehr.de/view.php?id=52 ]
* fixed: X39_MedSys_var_Pain_AllowMorphineOverdoseEffect = false causes blur                                                [ http://feedback.vbundeswehr.de/view.php?id=53 ]
* fixed: X39_MedSys_var_Legs_AllowBrokenLegs = false; does not work                                                            [ http://feedback.vbundeswehr.de/view.php?id=56 ]
* fixed: Broken Limitation System after Respawn                                                                                [ http://feedback.vbundeswehr.de/view.php?id=58 ]
* fixed: Incorrect BIRD reaspawn handling                                                                                    [ http://feedback.vbundeswehr.de/view.php?id=64 ]
* fixed: Incorrect frag handing                                                                                                [ http://feedback.vbundeswehr.de/view.php?id=65 ]
* fixed: Buttons not works after CPR                                                                                        [ http://feedback.vbundeswehr.de/view.php?id=66 ]
* fixed: X39_MedSys_var_allowSpeedLimitations_forceWalkAtXDamage not works                                                    [ http://feedback.vbundeswehr.de/view.php?id=77 ]
* fixed: X39_MedSys_fnc_knockOutUnit function (timestamp)
* handled: Vanilla medikit still working - Removed FAK fix and removing all default medic items when unit gets initialized    [ http://feedback.vbundeswehr.de/view.php?id=61 ]
* handled: Way to disable drag\carry menu                                                                                    [ http://feedback.vbundeswehr.de/view.php?id=63 ]
* handled: Earplug not affect in-game volume                                                                                [ http://feedback.vbundeswehr.de/view.php?id=72 ]
* handled: Volume level attenuation is not natural                                                                            [ http://feedback.vbundeswehr.de/view.php?id=75 ]
* X39_MedSys_fnc_killUnit has a new parameter (see wiki)
* new variables:
   - X39_MedSys_var_Hearing_earplugManipulationValue                        (0.2)            //Controls how much the earplugs affecting the hearing ability of a unit
   - X39_MedSys_var_enableDrag                                                (true)            //Enables/Disables the drag option of the actionUi
   - X39_MedSys_var_enableCarry                                            (true)            //Enables/Disables the carry option of the actionUi
* new default values:
   - X39_MedSys_var_Legs_DamageMultiplicator                                (2        -->    0.2)
   - X39_MedSys_var_Generic_DamageBeforePermaKnockOut                        (5        -->    6)
   - X39_MedSys_var_Bleeding_StartBloodAtMinDamageValueX                    (0.1    -->    0.25)
   - X39_MedSys_var_Pain_minPainToMaxPain                                    (10        -->    15)
   - X39_MedSys_var_KnockOut_MinTimeBetweenTempKnockOuts                    (300    -->    30)

Highlights:

  • TFAR Support is included
  • vanilla FAKs and MEDIKITs are removed now upon spawn when XMedSys is initialized on a unit
  • some default setup balancing changes

Edited by X39

Share this post


Link to post
Share on other sites

Thank you very much for informing us about the new release :cool:

New version frontpaged on the Armaholic homepage.

news_download_a3_3.png

XMedSys v0.3.5 Beta

required_addons.png

XActionUI (included)

XLib (included)

================================================

We have also "connected" these pages to your account (X39) on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Ok.

I know I get all the hate from you guys but,

since the newest update it just wont work anymore.

2 days ago befor the release of the Arma-Update evrything worked fine.

Now the ui wont work anymore. I can only check my self... blabla...

You've heard that several times here, but we tested it with our missions we´ve made -- not working

We replaced the modules -- not working

Tested it in a clean new mission -- not working

Deledted the mod(user config) downlaoded it again -- not working

Its not only for me all the other guys which Iam playing with have the same problem.

I´ve read serveral sides in this thread and I know that similar questions have been asked, but this is a whole new case I assume.

Looking forward to the tfr-patch btw.

Regards NIN3.

Edit: I of course also updated the requierments (I dont think its needed but just in case)

Edit/Solved: Seems to be, that the limations dont work as befor. So I´ve deleted all the limitation and it works. (similiar thing happend to "GDent" 2 pages befor that, but I mean it worked 2 Days ago o.O)

Edited by NIN3

Share this post


Link to post
Share on other sites

I have a question. In how far wasn't TFAR not supported?

Does it mean, that when you are down you can't here radio talk or even normal talk anymore (like in arma 2 ACE->ACRE?)

Thanks for your great work!

Moony

Share this post


Link to post
Share on other sites
I have a question. In how far wasn't TFAR not supported?

Does it mean, that when you are down you can't here radio talk or even normal talk anymore (like in arma 2 ACE->ACRE?)

Thanks for your great work!

Moony

TFAR had/has not the ability to make things possible like in ArmA 2 using ACE+ACRE meaning that i had no option to add the functionallity to XMedSys

now i got the required docs from nkey so i included them into XMedSys so that it is comparable to ACE+ACRE

Share this post


Link to post
Share on other sites

Dude ! So cool you got help from nkey and other people.

We are using XmedSys almost every evening on 30/50 players coop, i try to report major bugs and things that make the mod hard to play, but we're using it with the VTS, so there might be some special issues due to (un)compatibility.

Keep on keeping on ;)

Share this post


Link to post
Share on other sites
TFAR had/has not the ability to make things possible like in ArmA 2 using ACE+ACRE meaning that i had no option to add the functionallity to XMedSys

now i got the required docs from nkey so i included them into XMedSys so that it is comparable to ACE+ACRE

Yes, but is required to release new version of TFAR to make everything worked.

Share this post


Link to post
Share on other sites
Yes, but is required to release new version of TFAR to make everything worked.

from changelog:

[color=#333333]* added TFAR support !TFAR VERSION MIGHT NOT BEING RELEASED AT XMEDSYS 0.3.5 BETA RELEASE DATE! (another thx to nkey here :F)
[/color]

^^

Share this post


Link to post
Share on other sites

Is it possible that in the future this addon will be automatically initialized to all units?Without manually writing initialization code for each unit

Share this post


Link to post
Share on other sites
Is it possible that in the future this addon will be automatically initialized to all units?Without manually writing initialization code for each unit

youre not supposed to initialize every player using the init line of all units

doing so WILL result in unexpected issues as its not the desired behaviour!

place down the module or use a scripted solution

Share this post


Link to post
Share on other sites
from changelog:

[color=#333333]* added TFAR support !TFAR VERSION MIGHT NOT BEING RELEASED AT XMEDSYS 0.3.5 BETA RELEASE DATE! (another thx to nkey here :F)
[/color]

^^

Sorry, I have reopened a lot of issues...

Share this post


Link to post
Share on other sites

dev request

to all groups using XMedSys currently which got a medic in their group

i please you guys to send me a document about how the entire medic job in the field works covering as much as possible (even if its not directly adabtable into the game)

for example:

when you need t o apply morphine?

what happens if someone takes morphine?

morphine overdose? what now?

.

.

.

(yeah ... i had no better examples currently :F)

the reason for this is because i started working on XMS2 ("X39s Medical System 2") to finally get rid of those bugs which are implementation based and be able to include new features which are not possible with the current implementation

thx for your help

X39

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×