Jump to content
nkey

Task Force Arrowhead Radio

Recommended Posts

How do you use the speakers on the radios?

Just enabled them on radio dialog to allow everyone near here the radio.

---------- Post added at 21:54 ---------- Previous post was at 21:53 ----------

Sorry mate i don't have a clue what this is. It may be something to do with my Turrets as 1 of the three gunners ive defined has the vehicle.

Check Dimitri_Harkov answer.

Share this post


Link to post
Share on other sites

Hey nkey...

Quick question..is there a way to setup a radio on the ground, or even any object for that matter and allow players to use it on a set frequency.

For example, I have a FOB with 4 towers. However only the Platoon and Squad Leaders have radios...what I would like, is for the guys who go on to Tower Guard to be able to use a radio object while in the tower and speak to Squad Leaders. However, not be able to put the radio in their inventory. Any way to do with with the speaker feature?

Share this post


Link to post
Share on other sites

Ive encountered an issue with enabling the mod on a dedicated server.

I am sure that its simply a matter of server settings, but would anyone be able to help out?

Issue is that the server is not starting the mod. All players have TFAR enabled, with the correct TS Plugin. Their clients work correctly on other servers, but not our own.

Any help would be appreciated as I am out of my depth currently and cannot think of anything else to try.

Share this post


Link to post
Share on other sites
Hey nkey...

Quick question..is there a way to setup a radio on the ground, or even any object for that matter and allow players to use it on a set frequency.

For example, I have a FOB with 4 towers. However only the Platoon and Squad Leaders have radios...what I would like, is for the guys who go on to Tower Guard to be able to use a radio object while in the tower and speak to Squad Leaders. However, not be able to put the radio in their inventory. Any way to do with with the speaker feature?

Currently not possible...

---------- Post added at 20:50 ---------- Previous post was at 20:49 ----------

Ive encountered an issue with enabling the mod on a dedicated server.

I am sure that its simply a matter of server settings, but would anyone be able to help out?

Issue is that the server is not starting the mod. All players have TFAR enabled, with the correct TS Plugin. Their clients work correctly on other servers, but not our own.

Any help would be appreciated as I am out of my depth currently and cannot think of anything else to try.

It happens sometime with TFAR or other mods. Try to remove some keys from server. Also, check thread - http://forums.bistudio.com/showthread.php?184644-Server-issue

Share this post


Link to post
Share on other sites

hey looks like TFAR isn´t working anymore since latest patch.

we are both on the same frequenz with the same radio. if we try to contact each other the indicator on the bottem right is shown but no voice is transmitted over the radio, not even the radio sounds. only thing that works is the talking option.

EDIT: nevermind---> user error

Edited by Gunny24

Share this post


Link to post
Share on other sites

THe Jurassic Arma (Raptor) keep make TFAR Crash.

dont work If we spawn raptor in game.

Share this post


Link to post
Share on other sites

The keybindings are broke will the new update. CBA its self is broke and quite a few RPT errors happen when you try to change keys.

Share this post


Link to post
Share on other sites

Hey all,

So I love TFAR and it's awesome! However, since the .97 update, I cannot open the SW radio menu at all (default key-bind is ctrl+p )

So far, I've tried the following:

  1. Completely removed old versions of TFAR
  2. Deleted old userconfig files from main Arma 3 directory
  3. Did a clean reinstall (of TFAR)
  4. Bound "Open SW Radio Menu" to other keys

Anybody having the same issue? I tried searching for it in this massive thread but I can't find a similar instance.

Other keybinds (like change speaking volume, all the numpad keys [to change channels], caps-lock etc.) are working fine.

Thanks!

Share this post


Link to post
Share on other sites
Hey all,

So I love TFAR and it's awesome! However, since the .97 update, I cannot open the SW radio menu at all (default key-bind is ctrl+p )

So far, I've tried the following:

  1. Completely removed old versions of TFAR
  2. Deleted old userconfig files from main Arma 3 directory
  3. Did a clean reinstall (of TFAR)
  4. Bound "Open SW Radio Menu" to other keys

Anybody having the same issue? I tried searching for it in this massive thread but I can't find a similar instance.

Other keybinds (like change speaking volume, all the numpad keys [to change channels], caps-lock etc.) are working fine.

Thanks!

Hm.. So, is it work for another keybind?

Share this post


Link to post
Share on other sites

Make sure your Teamspeak files are 'Installed in installation directory'. Most people who select the option to 'Install to User Own Files' experience all kinds of TFAR related issues within our community. Uninstall TS, reinstall and select 'Install in installation directory' (forgot the actual wording but whichever isnt the option with 'user own files' in it).

Share this post


Link to post
Share on other sites
Hey all,

So I love TFAR and it's awesome! However, since the .97 update, I cannot open the SW radio menu at all (default key-bind is ctrl+p )

So far, I've tried the following:

  1. Completely removed old versions of TFAR
  2. Deleted old userconfig files from main Arma 3 directory
  3. Did a clean reinstall (of TFAR)
  4. Bound "Open SW Radio Menu" to other keys

Anybody having the same issue? I tried searching for it in this massive thread but I can't find a similar instance.

Other keybinds (like change speaking volume, all the numpad keys [to change channels], caps-lock etc.) are working fine.

Thanks!

Hm.. So, is it work for another keybind?
Make sure your Teamspeak files are 'Installed in installation directory'. Most people who select the option to 'Install to User Own Files' experience all kinds of TFAR related issues within our community. Uninstall TS, reinstall and select 'Install in installation directory' (forgot the actual wording but whichever isnt the option with 'user own files' in it).

Hey,

So I figured out what was wrong...

There was a mismatch with TFAR and CBA versions.

I installed the latest version of CBA and all was well!

Thanks for responding!

Share this post


Link to post
Share on other sites
Could it be that the update broke radio syncing? It doesn't always seem to work anymore.

What are you mean about "syncing"?

Share this post


Link to post
Share on other sites
Well, making sure all radio's have the correct frequencies set using the module.

Should work... Could you provide mission file with issue?

Share this post


Link to post
Share on other sites

Since 0.9.7 we keep getting "Waiting for unique radio" and can't set up the frequencies.

Whenever someone changes the frequency on his personal radio, it will be changed for every player. Is there some setting that may cause this behaviour?

Share this post


Link to post
Share on other sites
Since 0.9.7 we keep getting "Waiting for unique radio" and can't set up the frequencies.

Whenever someone changes the frequency on his personal radio, it will be changed for every player. Is there some setting that may cause this behaviour?

probably issue with server side setup. check installation on server

Share this post


Link to post
Share on other sites

I already did a fresh installation of the server. So there are no settings that may cause this behaviour?

What shall I look for when getting the "unique radio" messages?

Edited by soapsurfer

Share this post


Link to post
Share on other sites
I already did a flash installation of the server. So there are no settings that may cause this behaviour?

What shall I look for when getting the "unique radio" messages?

Check server for RPT logs.

Share this post


Link to post
Share on other sites

Hi,

We sometimes use TFAR on the server but also sometimes wish to disable it. However we don't want to drive the players crazy by telling them to constantly enable or disable the mod.

Is it possible that when the mod is running it will just give a message when joining the server that the server is nor running TFAR (which is already done), but not continue to give errors throughout the game? Currently the "pipe error 6" won't go away even if the server isn't running TFAR. Basically, other than the warning message you get when joining, I don't think there should be any errors displayed whatsoever if the server is not running the mod.

Also, is there any API for doing simple things with scripting like changing channel / setting frequencies / changing encryption etc? That is, dynamically during a mission (for example, when a player picks a new loadout or joins a new squad or a new round starts) without requiring the player to do a lot of manual settings of the radio every time his gear/group changes or new round starts.

Edited by galzohar

Share this post


Link to post
Share on other sites
Hi,

We sometimes use TFAR on the server but also sometimes wish to disable it. However we don't want to drive the players crazy by telling them to constantly enable or disable the mod.

Is it possible that when the mod is running it will just give a message when joining the server that the server is nor running TFAR (which is already done), but not continue to give errors throughout the game? Currently the "pipe error 6" won't go away even if the server isn't running TFAR. Basically, other than the warning message you get when joining, I don't think there should be any errors displayed whatsoever if the server is not running the mod.

Also, is there any API for doing simple things with scripting like changing channel / setting frequencies / changing encryption etc? That is, dynamically during a mission (for example, when a player picks a new loadout or joins a new squad or a new round starts) without requiring the player to do a lot of manual settings of the radio every time his gear/group changes or new round starts.

API is here - https://github.com/michail-nikolaev/task-force-arma-3-radio/wiki

You can disable TFAR for clients by calling ["processPlayerPositionsHandler", "onEachFrame", "TFAR_fnc_processPlayerPositions"] call BIS_fnc_removeStackedEventHandler;

Share this post


Link to post
Share on other sites

There used to be a ''radio_keys.hpp'' file to edit your ptt or channel switch keys on the keyboard. has this been removed from the latest version?

as i its using the default key bindings again and i cant seem to change them, even if i use my old ''radio_keys.hpp'' file, it does not seem to be affective and the default key bindings conflict with all my other Arma 3 bindings.

Does anyone know what im doing wrong, or is there just no way of customising your ptt keys anymore??

***EDIT***

Sorry i just found out you can change them in game... my bad, will research more before i post in future :/

Edited by Susscon

Share this post


Link to post
Share on other sites

Would it be possible to send audio "over radios" in mission, from the server? I'd like to make a spooky mission and send stuff to radios when players get close to a radio station.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×