Jump to content
nkey

Task Force Arrowhead Radio

Recommended Posts

Thanks for informing us of the update :cool:

Updated version frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

nkey:

Quick question;

We're running 0.9.6 (yes, we're going to update soon ;]) and we've replaced the radio sounds to a custom set of sounds and distribute this to our players with Arma3Sync. We've verified so we place the files correctly within the A3S-repo and all the files we put in are installed as intended.

The custom sounds play just fine when using the radio yourself (local_start and _end.wav I assume), but when another player is talking no start or end sounds are played (remote_start and _end.wav, right?).

If I play the sounds with VLC the files are indeed the ones I want.

This is how the contents of all my directories in radio-sounds look like:

tfar_sounds.png

yep, local and remote sounds are identical.

Am I doing anything wrong? :)

Share this post


Link to post
Share on other sites

maybe you should check the bitrate of the original files and see if your files have the same

Share this post


Link to post
Share on other sites
nkey:

Quick question;

We're running 0.9.6 (yes, we're going to update soon ;]) and we've replaced the radio sounds to a custom set of sounds and distribute this to our players with Arma3Sync. We've verified so we place the files correctly within the A3S-repo and all the files we put in are installed as intended.

The custom sounds play just fine when using the radio yourself (local_start and _end.wav I assume), but when another player is talking no start or end sounds are played (remote_start and _end.wav, right?).

If I play the sounds with VLC the files are indeed the ones I want.

This is how the contents of all my directories in radio-sounds look like:

https://dl.dropboxusercontent.com/u/4170539/arma3/Phoenix/tfar_sounds.png

yep, local and remote sounds are identical.

Am I doing anything wrong? :)

Hello.

Check you files format (you may use Audacity), it should be 48000hz, 2 channels.

Share this post


Link to post
Share on other sites

Yeah, there are some differences. The original sounds are 48KHz/16bit (stereo) and my files are 44.1KHz/16bit (Stereo).

I'll try chaning to 48KHz and get back with results, thanks :)

Share this post


Link to post
Share on other sites

I have followed the directions and set this up the way I think. I am having two issues.

1. When I push Caps Lock in game it shows me Caps Lock On or Caps Lock Off

2. I have no sounds when I push to talk.

Any help would be greatly appreciated. Thanks.

Share this post


Link to post
Share on other sites
I have followed the directions and set this up the way I think. I am having two issues.

1. When I push Caps Lock in game it shows me Caps Lock On or Caps Lock Off

2. I have no sounds when I push to talk.

Any help would be greatly appreciated. Thanks.

Looks like something tricky with your keyboard. Do you test in editor (need to be in mission). Window mode or fullscreen?

Share this post


Link to post
Share on other sites
Looks like something tricky with your keyboard. Do you test in editor (need to be in mission). Window mode or fullscreen?

I am in a scenario and editor full screen.

Share this post


Link to post
Share on other sites
I am in a scenario and editor full screen.

Test in MP (create local server).

Share this post


Link to post
Share on other sites

Ok I figured out the Caps Lock thing..It was my bluetooth software displaying on screen. I still have no sounds when pushing to talk.

Edited by lunchbox35

Share this post


Link to post
Share on other sites
Ok I figured out the Caps Lock thing..It was my bluetooth software displaying on screen. I still have no sounds when pushing to talk.

Sound are played by TS, you need have TS with plugin started and running MP mission.

Share this post


Link to post
Share on other sites

How do I use the new microDAGR? How do I open it and use it? Couldn't find any key shortcuts for it on your homepage..

Share this post


Link to post
Share on other sites
It is probably you watch slot. If you have it and open rifleman radio - you will see also programmator.

Is that what you mean?

Share this post


Link to post
Share on other sites
How do I use the new microDAGR? How do I open it and use it? Couldn't find any key shortcuts for it on your homepage..

As far as I know, it will show up only when using the Rifleman Radio. Of course you need to have microDARG in your watch slot (inventory).

(Please somebody correct me if I'm wrong)

Share this post


Link to post
Share on other sites
Have you tried only with TFAR and CBA?

In terms of re-installing, I tried C-L-F as well, and that produced no results. What should I try uninstalling and reinstalling?.

Edited by SHOGUN-6

Share this post


Link to post
Share on other sites

Is it possible to add LR radios to civilian vehicles? I have a mission that kind of depends on it.

Having to resort to giving units backpacks could break the balance and would feel very unfitting.

Share this post


Link to post
Share on other sites

Hi. With the last update I cant seem to rebind my task force radio keys to what I like. I'm not sure if the location and file name has changed or what, but I really want to be able to change them. Default layout is rather terrible for me.

Share this post


Link to post
Share on other sites

Hello, I suspect I have an issue with TFAR.

I've installed version 0.9.6 and it works fine, but the direct speech sounds wrong. There is a 3D effect to it (if someone to my right speaks, his voice will come from the right speaker, etc.) however, it doesn't sound as if his voice comes from his in-game character.

For reference, this is exactly what my TFAR direct speech sounds like:

As you can hear, it has somewhat of a 3D effect, but it still sounds like regular teamspeak speech.

In

, it works as I think it should be working. The 3D effect is there and you can also hear the voice coming from each in-game character.

Is my TFAR not working correctly or is it just me?

Thanks in advance.

Share this post


Link to post
Share on other sites
Is it possible to add LR radios to civilian vehicles? I have a mission that kind of depends on it.

Having to resort to giving units backpacks could break the balance and would feel very unfitting.

https://github.com/michail-nikolaev/task-force-arma-3-radio/wiki/API:-Variables (search for tf_hasRadio)

---------- Post added at 05:07 ---------- Previous post was at 05:06 ----------

Hi. With the last update I cant seem to rebind my task force radio keys to what I like. I'm not sure if the location and file name has changed or what, but I really want to be able to change them. Default layout is rather terrible for me.

Check manual -

(at the end)

---------- Post added at 05:09 ---------- Previous post was at 05:07 ----------

Hello, I suspect I have an issue with TFAR.

I've installed version 0.9.6 and it works fine, but the direct speech sounds wrong. There is a 3D effect to it (if someone to my right speaks, his voice will come from the right speaker, etc.) however, it doesn't sound as if his voice comes from his in-game character.

For reference, this is exactly what my TFAR direct speech sounds like:

As you can hear, it has somewhat of a 3D effect, but it still sounds like regular teamspeak speech.

In

, it works as I think it should be working. The 3D effect is there and you can also hear the voice coming from each in-game character.

Is my TFAR not working correctly or is it just me?

Thanks in advance.

Try to switch to the first person and check if problem persists.

Share this post


Link to post
Share on other sites

New to TFR is there a list of what the settings in the Userconfig "task_force_radio", "radio_settings.hpp" can be set at, or what they do?

Share this post


Link to post
Share on other sites
Radio interference vehicle

if someone interested - script with radio interference vehicle - https://www.dropbox.com/s/vp7lg3b0tz0u2xj/interference.Stratis.zip?dl=0

Enabled in vehicle, engine should be on.

What does the script exactly do, I'm not sure to understand, does it reduce or extend radio power, or something else ?

BTW, do you think you could create a function that simulate relay antennas ? In ACRE for Arma 2 there was a function that could be added to an object's init and the object had the ability to retransmit communications from one frequence to an other in order to allow people to communicate at very long distances (without disabling terrain interferences).

Keep up the good work.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×